Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing unter Debian

Frage Linux Debian

Mitglied: samsx87

samsx87 (Level 1) - Jetzt verbinden

28.08.2007, aktualisiert 02.09.2007, 5195 Aufrufe, 5 Kommentare

Hallo zusammen

Ich habe ein Problem mit dem routing unter debian.
Mein Netzwerk sieht wie folgt aus:

WAN
|
|
Router 192.168.1.1
(Routet das 10.0.0.0 Netz nach 192.168.1.5) ------------------ Windows XP PC (192.168.1.2)
|
|
Netz 1:
Netmask: 192.168.1.0
Subnetzmask: 255.255.255.0
Standartgateway 192.168.1.1
|
|
eth0 (192.168.1.5)
Debian (welcher als Router fungieren soll)
eth1 (10.0.0.1)
|
|
Netz 2:
Netmask: 10.0.0.0
Subnetmask: 255.0.0.0
Stabdartgateway: 10.0.0.1
|
|
Windows 2003 Server (10.0.0.2)

Wie kann ich nun den Debian Rechner als Router (inkl. NAT) konfigurieren?

Das pingen von 192.168.1.2 nach 10.0.0.1 sowie umgekehrt funktioniert
Das pingen von 10.0.0.2 nach 10.0.0.1 funktioniert, jedoch NICHT umgekehrt
Das pingen von 10.0.0.2 nach 192.168.1.2 funktioniert in beide Richtungen NICHT

Die routing Tabelle auf dem Debian Rechner sieht wie folgt aus:

192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth1
default 192.168.1.1.loc 0.0.0.0 UG 0 0 0 eth0
Mitglied: Dani
28.08.2007 um 19:02 Uhr
Hallo samsx87,
also hier gibts n prima Tutorial von aqui dazu. Funktioniert sowohl unter Linux als auch unter Windows.


Grüße
Dani
Nächstes mal bitte die Suche benutzen!!
Bitte warten ..
Mitglied: samsx87
28.08.2007 um 20:47 Uhr
Vielen Dank für die Antwort!
Habe das Tutorial durchgelesen, jedoch bin ich immer noch gleich weit wie am Anfang

Kann mir jemand helfen?
Bitte warten ..
Mitglied: aqui
02.09.2007 um 16:25 Uhr
...Das pingen von 10.0.0.2 nach 10.0.0.1 funktioniert, jedoch NICHT umgekehr t

Das hat natürlich mit deinem Debian Router rein gar nichts zu tun, denn das ist mit Sicherheit eine Firewall Einstellung a.) unter Windows und/oder b.) unter Linux.
Lokale Firewalls musst du für ICMP Echo Packete (Ping) öffnen. Wie man das unter Windows macht ist einfach:
Eigenschaften LAN Verbindung -> Erweitert -> Windows Firewall Einstellungen -> Erweitert -> ICMP Einstellungen -> Hier den Haken setzen bei Eingehende Echoanforderungen zulassen !!!

Bei Linux dürfte es analog sein obwohl Ping dort in der Regel per Default geht.

Ggf. ist das das Problem aller deiner Ping Tests, deshalb macht es am meisten Sinn erstmal das funktionierende Routing des Routers zu verifizieren indem man die Interface des Routers pingt (Debian) aus dem jeweiligen anderen Netz und nicht gleich 2 Endgeräte mit unkalren Firewall Settings .
Also folgendes solltest du zuerst machen:
  • Ein Ping auf eth0 (192.168.1.5) aus dem 10er Netz
  • Ein Ping auf eth1 (10.0.0.1) aus dem 192.168.1er Netz
  • Ein Ping aus dem 10er Netz auf den DSL Router 192.168.1.1

Das muss auf alle Fälle beidseitig funktionieren und damit hätte man dann grundsätzlich das funktionierende Routen der Debian Maschine geprüft !!!

Wenn du dir das Tutorial durchgelesen hast wird dir nicht entgangen sein das du zwingend eine statische Route auf dem DSL Router benötigst die da lautet:
Zielnetz: 10.0.0.0, Maske: 255.0.0.0, Gateway: 192.168.1.5

Das ist zwingend erforderlich sonst kann der DSL Router keine Packete ins 10er Netz routen.

Das du natürlich den Debian Rechner in der sysconfig auf IP Forwarding gesetzt hast bzw. diesen Parameter aktiviert hast mit einem anschliessenden Reboot sei hier mal vorausgesetzt, denn sonst routet der Debian Rechner nicht !!!
Bitte warten ..
Mitglied: samsx87
02.09.2007 um 16:37 Uhr
Vielen Dank für deine Antwort!
Das Problem wart tatsächlich die Windows Firewall
Bitte warten ..
Mitglied: aqui
02.09.2007 um 16:39 Uhr
Ist es hier im Forum in 98% aller Fälle bei Verbindungsproblemen....du bist also in guter Gesellschaft
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Debian
Debian 8.6 Absichern? (11)

Frage von Motte990 zum Thema Debian ...

Netzwerke
gelöst FritzboxLAN2LAN mit dahinterliegendem Router: Nur One-Way-Routing möglich (13)

Frage von SnowCrush zum Thema Netzwerke ...

LAN, WAN, Wireless
Computer mit 2 Netzwerkkarten und routing von Red Pitaya ins Internet (9)

Frage von DH1KLM zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...