Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing Konfiguration

Frage Netzwerke Router & Routing

Mitglied: xmenchen

xmenchen (Level 1) - Jetzt verbinden

22.08.2007, aktualisiert 24.08.2007, 8658 Aufrufe, 12 Kommentare

Habe eine Aufgabe die ich leider mit meinem Wissen nicht ganz verstehe und nun etwas Hilfe benötige.

Anhand meiner Netzwerkskizze will ich alle Routen (also auch in die jeweiligen lokalen Netze) eintragen,die notwendig sind, damit alle angegebenen Teilnetze von allen Komponenten erreicht werden können.

9c03afa9998fa2c475a079364bfc08c7-netzwerk - Klicke auf das Bild, um es zu vergrößern

Wer kann mir Zeigen wie zB. für rechner 1 und zB. router3 die Konfiguration aussehen müsste.???

net-lab-ueb 01
Nr. Ziel Subnetmask Router Interface
1
2
3
4

net-lab-router 03
Nr. Ziel Subnetmask Router Interface
1
2
3
4
Mitglied: 51705
22.08.2007 um 18:26 Uhr
netz-lab-router-02:
172.16.100.0/24 -> kennt er
172.16.101.0/24 -> kennt er
172.16.102.0/24 -> 172.16.101.253
172.16.103.0/24 -> 172.16.101.253

netz-lab-router-03
172.16.100.0/24 -> 172.16.101.254
172.16.101.0/24 -> kennt er
172.16.102.0/24 -> kennt er
172.16.103.0/24 -> 172.16.102.254

netz-lab-router-04
172.16.100.0/24 -> 172.16.102.253
172.16.101.0/24 -> 172.16.102.253
172.16.102.0/24 -> kennt er
172.16.103.0/24 -> kennt er

Jeder PC muß einen Router aus dem lokalen Subnet als Default Gateway haben, dann klappt es.

;)
Bitte warten ..
Mitglied: xmenchen
22.08.2007 um 19:49 Uhr
Cool Danke.

D.h. die routingtabelle für den Rechner netz-lab-ueb-01 würde so aussehen:

172.16.100.0/24 kennt er
172.16.101.0/24 -> 172.16.100.254
172.16.102.0/24 -> 172.16.100.254
172.16.103.0/24 -> 172.16.100.254

korrekt ??

Also ganz einfach wenn ichs nun verstanden hab
Bitte warten ..
Mitglied: 51705
22.08.2007 um 19:58 Uhr
Cool Danke.

D.h. die routingtabelle für den Rechner
netz-lab-ueb-01 würde so aussehen:

172.16.100.0/24 kennt er
172.16.101.0/24 -> 172.16.100.254
172.16.102.0/24 -> 172.16.100.254
172.16.103.0/24 -> 172.16.100.254

korrekt ??


netz-lab-ueb-01 würde so aussehen:

172.16.100.0/24 kennt er
0.0.0.0 -> 172.16.100.254 (das ist die default Route ;)
Bitte warten ..
Mitglied: xmenchen
22.08.2007 um 20:15 Uhr
Hmm okay, sieht schöner aus, und wichtig wenn man ins Internet will,
aber sonst würde meins doch auch funzen wenns nur die 4 Teilnetze gibt oder etwa nicht?

Hab ja nicht gesagt das ich es 100% verstanden hab
Bitte warten ..
Mitglied: 51705
23.08.2007 um 11:47 Uhr
Du hast recht, würde auch funktionieren. Ist einfach mein Weg, das Routen den Routern zu überlassen...
Bitte warten ..
Mitglied: aqui
23.08.2007 um 16:23 Uhr
...und das ist natürlich auch der richtige Weg ! Niemals oder nur in sehr seltenen Ausnahmen werden Routern auf Endgeräten konfiguriert. Die Infrastruktur also das Netz soll routen und für die Wegefindung verandwortlich sein und niemals Endsysteme !

Also bekommen alle PCs (ueb-01 + ueb-02) im Subnetz 172.16.100./24 normal die 172.16.100.254 als Gateway eingetragen !

Analog alle PCs (ueb-09 bis ueb-11) im Subnetz 172.16.103./24 normal die 172.16.103.254 als Gateway eingetragen !

Ein Sonderfall sind die Netze 172.16.101.0/24 und 172.16.102.0/24 , da diese Netze parallel an 2 Routern angeschlossen sind !!
Du hast nun 2 Möglichkeiten auf den PCs Gateways einzutragen nämlich einmal mit der .253 und einmal mit der .254 Beides funktioniert natürlich !
Allerdings hat so ein Szenario ja meist einen Sinn das man den Anschluss dieser Netze eben redundant haben möchte als Hochverfügbarkeit, denn wenn die .253 einmal ausfällt können alle Geräte weiter über die .254 arbeiten.
Das geht aber natürlich nicht wenn du die .253 auf den PCs fest eingestellt hast ohne das du alle PCs umkonfigurieren musst...ist also Mist !
2. Variante ist du konfigurierst die Hälfte der PCs auf die .254 und die andere Hälfte auf die .253. Das hätte den Effekt das bei Ausfall eines Gateways (Routerinterfaces) wenigstens 50% der PC Endgeräte weiterarbeiten können. Ist aber auch nicht das Gelbe vom Ei denn meist ist nach Murphy der Rechner betroffen der der Wichtigste ist !

Dafür gibt es aber als Lösung das VRRP Protokoll (Virtual Router Redundancy Protocol) oder da du vermutlich nach den Bezeichnungen deiner Ethernet Interface Cisco Systeme einsetzt deren proprietäres HSRP (Hot Standby Router Protocol). Achtung HSRP ist nicht kompatibel mit NICHT Cisco Systemen dann solltest du also immer besser VRRP nehmen !!!
Damit nutzen die beiden Router .253 und .254 eine gemeinsame IP Adresse die dann im Fehlerfalle automatisch auf den jeweils anderen Router übergeht. Damit bist du dann vollends gesichert gegen einen Ausfall !!

Hier mal ein Beispiel für eine VRRP Konfig mit dem Subnetz 172.16.102.0/24

netz-lab-router-03
interface ethernet 0/0
ip address 172.16.102.253 255.255.255.0
vrrp 1 ip 172.16.102.252

netz-lab-router-04
interface ethernet 0/0
ip address 172.16.102.254 255.255.255.0
vrrp 1 ip 172.16.102.252

Die PCs zeigen dann mit dem Gateway natürlich dann auf die 172.16.102.252 denn das ist die virtuelle Adresse die die Interfeces teilen und die im Ausfall immer aktiv ist ! Analog machst du das mit dem 172.16.101.0/24er Netz bzw. den Interfaces dazu !

Die statischen Routen auf den Routern lauten dann folgendermaßen:

netz-lab-router-02
ip route 172.16.102.0 255.255.255.0 172.16.101.253
ip route 172.16.103.0 255.255.255.0 172.16.101.253

Alle anderen Netze sind lokal und die kennt er !

netz-lab-router-03
ip route 172.16.100.0 255.255.255.0 172.16.101.254
ip route 172.16.103.0 255.255.255.0 172.16.102.254

Alle anderen Netze sind lokal und die kennt er !

netz-lab-router-04
ip route 172.16.100.0 255.255.255.0 172.16.102.253
ip route 172.16.101.0 255.255.255.0 172.16.102.253

Alle anderen Netze sind lokal und die kennt er !

Spannend wäre ja auch mal eine dynamische Routingvariante mit z.B. OSPF. Das erspart dir dann die Eingabe der statischen Routen.
Die Konfig (für Cisco) dafür sieht so aus:

netz-lab-router-02
router ospf 1
network 172.16.100.0 0.0.0.255 area 0
network 172.16.101.0 0.0.0.255 area 0

netz-lab-router-03
router ospf 1
network 172.16.101.0 0.0.0.255 area 0
network 172.16.102.0 0.0.0.255 area 0

netz-lab-router-04
router ospf 1
network 172.16.102.0 0.0.0.255 area 0
network 172.16.103.0 0.0.0.255 area 0

Damit werden deine Routing Tabellen dynamisch aufgebaut und alle Netze machen sich bei allen Routern über OSPF bekannt.
Bitte warten ..
Mitglied: 51705
23.08.2007 um 16:48 Uhr
Ein Sonderfall sind die Netze
172.16.101.0/24 und 172.16.102.0/24 , da
diese Netze parallel an 2 Routern
angeschlossen sind !!
Du hast nun 2 Möglichkeiten auf den PCs
Gateways einzutragen nämlich einmal mit
der .253 und einmal mit der .254 Beides
funktioniert natürlich !
Allerdings hat so ein Szenario ja meist
einen Sinn das man den Anschluss dieser Netze
eben redundant haben möchte als
Hochverfügbarkeit, denn wenn die .253
einmal ausfällt können alle
Geräte weiter über die .254
arbeiten.
Das geht aber natürlich nicht wenn du
die .253 auf den PCs fest eingestellt hast
ohne das du alle PCs umkonfigurieren
musst...ist also Mist !
2. Variante ist du konfigurierst die
Hälfte der PCs auf die .254 und die
andere Hälfte auf die .253. Das
hätte den Effekt das bei Ausfall eines
Gateways (Routerinterfaces) wenigstens 50%
der PC Endgeräte weiterarbeiten
können. Ist aber auch nicht das Gelbe
vom Ei denn meist ist nach Murphy der Rechner
betroffen der der Wichtigste ist !

3. Variante
2 default Routen mit unterschiedlicher Metrik, da bleiben 100% am Netz
Bitte warten ..
Mitglied: aqui
23.08.2007 um 17:40 Uhr
Sicher machbar, aber dafür musst du wieder umständlich alle Endgeräte anfassen...Kommen die in andere Segmente muss das alles wieder entfernt werden.... keine wirklich gute Lösung !
Auch wenn du DHCP machst in den Segmenten geht es wieder gar nicht.
VRRP hat da schon seinen Sinn
Bitte warten ..
Mitglied: 51705
23.08.2007 um 17:44 Uhr
Gerade mit DHCP geht es prima, wo siehst du da ein Problem?
Bitte warten ..
Mitglied: aqui
23.08.2007 um 17:53 Uhr
Stimmt..statische Route hat Priorität vor der Default Route die ggf. per DHCP kommt...Denkfehler, sorry.
So oder so aber ein umständliche Lösung die in der Praxis meist nie verwendet wird, da abgesehen vom der umständlichen, starren und statischen Konfig der Endgeräte du meist Timeouts hast. Der Client muss das neue Gateway neu ARPen usw. VRRP oder HSRP hat aber einen sub second Failover und ist daher immer vorzuziehen.
OK, in Umfeldern wo das Mangels Feature Ausstattung von Routern oder Switches nicht umzusetzen ist, ist das sicher ein quick and dirty Workaround der auch klappt, keine Frage
Bitte warten ..
Mitglied: 51705
23.08.2007 um 19:32 Uhr
Um Router redundant zu betreiben ist VRRP die deutlich bessere Wahl (um das mal vorab, dir zustimmend, klar zu stellen).

Nur was willst du mit statischen Routen auf den Clients? Ein DHCP-Server kann doch einem DHCP-Client leicht mehrere Router als default Route 'mitgeben'. Da ist wirklich kein 'Turnschuh-Admin' notwendig. Auch in ARP kann ich kein Problem erkennen. Die Verzögerung durch das 'Bemerken' des fehlenden Gateways ist allerdings vorhanden.

Insgesamt stimme ich dir jedoch zu, die für den jeweiligen Fall entwickelte Technik vorzuziehen.

Grüße, Steffen
Bitte warten ..
Mitglied: aqui
24.08.2007 um 19:32 Uhr
Damit sollte xmenchens Routing Problem das eigentlich keins ist normalerweise geloest sein ! Bitte dann
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Endgerät Routing über Netzwerk und VPN ins Internet (2)

Frage von amuelkx zum Thema Router & Routing ...

Router & Routing
Routing zu IP-Telefonanlage im Netzwerk (8)

Frage von goldstein.marcel zum Thema Router & Routing ...

Windows 10
Keine gültige IP konfiguration (14)

Frage von TicTakTeo zum Thema Windows 10 ...

Netzwerkmanagement
gelöst VLAN Konfiguration-Verständis-Frage (Problem bei der korrekten Einrichtung - Cisco) (35)

Frage von Skyemugen zum Thema Netzwerkmanagement ...

Neue Wissensbeiträge
RedHat, CentOS, Fedora

Fedora, RedHat, Centos: DNS-Search Domain setzen

(13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...

Drucker und Scanner

Samsung SL-M4025ND, firmware update und (kompatible) Tonerkassetten

(1)

Erfahrungsbericht von markus-1969 zum Thema Drucker und Scanner ...

Heiß diskutierte Inhalte
Windows 10
Windows für Privatanwender "nicht mehr handhabbar" (35)

Frage von FA-jka zum Thema Windows 10 ...

LAN, WAN, Wireless
Komplett neues Netzwerk, Ubiquiti WLAN, Router, Switch (15)

Frage von Freak-On-Silicon zum Thema LAN, WAN, Wireless ...

Backup
Backup Wochen- Monats- Jahressicherung (13)

Frage von Meterpeter zum Thema Backup ...

RedHat, CentOS, Fedora
Fedora, RedHat, Centos: DNS-Search Domain setzen (13)

Tipp von Frank zum Thema RedHat, CentOS, Fedora ...