Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing über Layer 3 Switch

Frage Netzwerke Router & Routing

Mitglied: ozricXX

ozricXX (Level 1) - Jetzt verbinden

29.11.2012, aktualisiert 11:19 Uhr, 2518 Aufrufe, 6 Kommentare

Guten Tag,
ich habe da mal eine doofe Frage.

Ich fange langsam an VLANs aufzubauen, unser Netzwerk ist mit HP ProCurve J9147A Layer 3 Geräten vernetzt.

Nun möchte ich (z.B.), dass 10.5.0.0/24 10.0.0.0/16 erreicht und umgekehrt....reicht ein "ip route 10.5.0.0/24 10.0.0.0/16" oder muss noch ein "ip route 10.0.0.0/16 10.5.0.0/24" her?

Sicherlich eine blöde Frage, sind meine ersten Versuche in der Richtung.

Viele Grüße
Mitglied: Philipp711
29.11.2012, aktualisiert um 14:11 Uhr
Du musst beide Routen eingragen - zumindest war es bei unserem 3500yl so...

So siehts bei uns aus:

01.
 
02.
ProCurve-3500yl-48G# show ip route 
03.
 
04.
                                IP Route Entries 
05.
 
06.
  Destination        Gateway         VLAN Type      Sub-Type   Metric     Dist. 
07.
  ------------------ --------------- ---- --------- ---------- ---------- ----- 
08.
  0.0.0.0/0          10.112.38.3     1000 static               1          1 
09.
  10.112.38.0/24     Verwal          1000 connected            1          0 
10.
  172.16.2.0/24      Produkt         1002 connected            1          0 
11.
  127.0.0.0/8        reject               static               0          0 
12.
  127.0.0.1/32       lo0                  connected            1          0 
13.
 
14.
 
Bitte warten ..
Mitglied: ozricXX
29.11.2012 um 15:46 Uhr
Hm, ich kriege keinen Ping durch.

Ein Client im VLAN 1, 10.0.0.0/16 Netzwerk, ein Client per untagged Port in VLAN 200.

VLAN 1: CLient IP: 10.0.4.126/16 (DHCP) Switch IP: 10.0.1.5/16
VLAN 200: Client IP: 10.20.0.3 Switch IP: 10.20.0.1/24


Hier einmal ein "show ip"

Internet (IP) Service

IP Routing : Enabled


Default TTL : 64
Arp Age : 20
Domain Suffix :
DNS server :

VLAN | IP Config IP Address Subnet Mask Proxy ARP
-------------------- + ---------- --------------- --------------- ---------
DEFAULT_VLAN | Manual 10.0.1.5 255.255.0.0 No
Versatel | Disabled
WLAN | Disabled
test | Manual 10.20.0.1 255.255.255.0 No


Und ein "show ip route"




IP Route Entries

Destination Gateway VLAN Type Sub-Type Metric Dist.
------------------ --------------- ---- --------- ---------- ---------- -----
10.0.0.0/16 DEFAULT_VLAN 1 connected 1 0
10.20.0.0/24 test 200 connected 1 0
127.0.0.0/8 reject static 0 0
127.0.0.1/32 lo0 connected 1 0
156.153.78.192/27 connected 1 0




Und die Config:


; J9147A Configuration Editor; Created on release #W.15.08.0012
; Ver #02:11.05:16
hostname "Rack"
module 1 type j9147a
module 2 type j9008a
module 3 type j9008a
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-hdx sensitivity high
fault-finder duplex-mismatch-fdx sensitivity high
trunk 35-36 trk1 lacp
trunk 31,34 trk2 trunk
trunk 43-44 trk3 lacp
trunk 41,45-48 trk4 trunk
gvrp
stack commander "MDA"
stack auto-grab
stack member 1 mac-address 78e3b5-32e8c0
stack member 2 mac-address 78e3b5-327840
stack member 3 mac-address b499ba-81b300
stack member 4 mac-address 78acc0-173000
stack member 5 mac-address 78acc0-176500
ip default-gateway 10.0.1.1
ip route 10.20.0.0 255.255.255.0 vlan 1
interface 33
name "nas2"
exit
snmp-server community "public" operator
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
vlan 1
name "DEFAULT_VLAN"
no untagged 8,27
untagged 1-7,9-22,24-26,28-30,32-33,37-40,42,A1-A2,B1-B2,Trk1-Trk4
tagged 23
ip address 10.0.1.5 255.255.0.0
exit
vlan 50
name "Versatel"
untagged 27
tagged Trk2,Trk4
no ip address
exit
vlan 100
name "WLAN"
tagged 23-25,Trk4
no ip address
exit
vlan 200
name "test"
untagged 8
ip address 10.20.0.1 255.255.255.0
exit
no autorun
password manager
password operator
Bitte warten ..
Mitglied: Philipp711
29.11.2012, aktualisiert um 18:14 Uhr
Hast du bei den beiden Clients jeweils das Switch mit der anliegenden VLAN-ID als Standardgateway eingetragen?

Die Clients lassen Pings bei der internen FW durch?

Was sagt ein Tracert/Pathping zu einem der beiden Clients?
Bitte warten ..
Mitglied: ozricXX
29.11.2012 um 19:34 Uhr
Lag an einem falsch konfigurierten Gateway -_-

Mal eine andere Frage....wie müsste ich eine ROute konfigurieren, um einen Gateway (ins Internet) für ein gewisses VLAN zu definieren.
Also angenommen ich möchte z.B. Server in VLAN 300 durch Gateway X und Clients in VLAN 400 und 500 durch Gateway Y raus schicken.
Bitte warten ..
Mitglied: Philipp711
30.11.2012 um 08:15 Uhr
Soweit ich weiß wird das mit den reinen Routingmechanismen der Switche nicht zu machen sein, da du ja kein Quell-Netzwerk definierst.

Ich würde es mit ACLs in Verbindung mit Routingeinträgen versuchen.

1) Die Netzwerke so verbinden, dass jeder überall hin kann.
2) Danach mit ACLs reglementieren, dass VLAN300 !nur! zum GW-X und VLAN400+500 !nur! zum GW-Y darf.
Bitte warten ..
Mitglied: aqui
30.11.2012, aktualisiert um 15:33 Uhr
Vielleicht helfen dir diese beiden Tutorials zum weiteren Verständnis. Switchkonfig für die Praxis ist immer mit dabei:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
und
http://www.administrator.de/wissen/vlan-routing-über-802-1q-trunk- ...
Nochwas: Statische Routen auf dem Switch der diese VLANs routet sind natürlich Blödsinn !
Diese IP netze sind ja direkt an diesem L3 Switch dran folglich kennt er alle diese IP Netze so das statische Routen auf eben diese netze natürlich überflüssiger Unsinn sind !
Statische Routen benötigst du logischerweise nur zu IP Netzen die dort direkt nicht dran sind wie Internet Router usw.
Um das nur für einzelne VLANs zu machen musst du immer zwingend mit einer IP Accessliste auf dem Switch arbeiten, da die Routen generell für alle VLANs gelten wie oben schon richtig bemerkt.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Layer 3 Switch Routing nach Firewall
Frage von gansa28Router & Routing5 Kommentare

Hallo zusammen, ich habe hier zwei Nortel 4548GT als Stack mit 4 VLANs. Das ganze funktioniert auch soweit, leider ...

Router & Routing
Layer 2 oder Layer 3 Switch
Frage von coppercableRouter & Routing6 Kommentare

Moin, eine kleine Frage, weils mir einfach nicht klar wird: Wir bekommen mehrere Uplinks, die wir gerne an einen ...

Netzwerkmanagement
Empfehlung Layer 3 Switch
Frage von davidsonNetzwerkmanagement8 Kommentare

Hallo Frage Ist zustand bei Firma Hilfe :) 100 Users 25 Drucker 20 Server (wmware) 3 Esxi Host Die ...

Switche und Hubs
Layer 3 Switch
gelöst Frage von homermgSwitche und Hubs4 Kommentare

Hey Leute, ich versuche gerade rauszufinden ob HP 2810-48G auch Layer3 bzw. Routing unterstützt. hier unter Key features steht ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 5 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 6 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 8 StundenAdministrator.de Feedback9 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 13 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...