Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing Server 2008R2 mit zwei Netzwerkkarten

Frage Netzwerke Router & Routing

Mitglied: Mar-west

Mar-west (Level 1) - Jetzt verbinden

11.10.2011, aktualisiert 18.10.2012, 9991 Aufrufe, 9 Kommentare

Hallo Freunde,

Eines Vorweg, ich habe mir alle Themen zu diesem Thema durchgelesen

Folgende Szenario:

Server 2008R2

FritzBox IP: 192.168.2.2

Routing in der FB eingestellt auf 192.168.1.0 (NIC2 Netzwerk)
Maske: 255.255.255.0
Gateway: 192.168.2.1 (NIC1)

Nic1 (Intern):

IP: 192.168.2.1
mask 255.255.255.0
GW:192.168.2.2
DNS:192.168.1.1

Nic2 (Extern):

IP: 192.168.1.1
Mask: 255.255.255.0
GW: leer
DNS: leer

Server läuft als DNS, DHCP, DC

Habe im DHCP die Router ip 192.168.2.2 hinterlegt, auch habe ich dieses schon mit der NIC1 IP versucht.

DNS abfrage läuft.

Habe die Rolle Lan Routing Aktiviert und nichts weiter eingestellt.

Das Problem:

Die Clients stehen auf Automatisch zuweisen und bekommen daher die IP vom DHCP, was auf funktioniert.
Ich kann an den Clients den Server auf der 192.168.1.1 Anpingen aber nicht auf der 192.168.2.1 auch den Router auf der 2 ist nicht zu erreichen.

Die frage die sich mich stellt, wo habe ich etwas falsch gemacht?

Vom statischen Routen soll man ja die finger lassen, da der server ja alle IP Netzte kennt.
Daher das ich die exteren Nic nicht Pingen kann, kommt natürlich auch keine Inernetverbindung zustande.

Über Hilfe würde ich mich sehr freuen.

Danke
Mitglied: battl1984
11.10.2011 um 10:43 Uhr
Also wichtig ist das im DHCP eingestellt ist, dass die GW-IP für die Clients die 192.168.1.1 ist. Der Server sollte dann alles was da ankommt in das 2er-Netz routen und das GW 2.2 zum sufen nutzen.

eine statische route in derFB brauchst du dann gar nicht...
Bitte warten ..
Mitglied: Mar-west
11.10.2011 um 12:31 Uhr
Zitat von battl1984:
Also wichtig ist das im DHCP eingestellt ist, dass die GW-IP für die Clients die 192.168.1.1 ist. Der Server sollte dann
alles was da ankommt in das 2er-Netz routen und das GW 2.2 zum sufen nutzen.

eine statische route in derFB brauchst du dann gar nicht...

Ok! Das mit dem GW in den dhcp Einstellungen hört sich gut an! Werde ich ausprobieren. Nur das Routen in der FB nicht nötig ist, verstehe ich nicht so ganz, da in dem Tutorial extra darauf hingewiesen wird!

Werde auch das entfernen und sehen was passiert!
Bitte warten ..
Mitglied: battl1984
11.10.2011 um 12:43 Uhr
na ich bin der Meinung, dass das Server OS sich um das Routing kümmert. Es sendet die Anfragen aus dem 1er-Netz in das 2er-Netz und dessen Gateway ist die FB. Die leitet den Traffic dann ganz normal per NAT nach "draußen"

Das Routing passiert ja so zusagen schon "davor". Wenn dein Server nur eine NIC hätte würdest du ja in der FB auch kein Routing konfigurieren. Routing in der FB ist nur notwendig wenn du Traffic der von einer bestimmten IP kommt über ein anderes Gateway, als der FB selbst, senden willst
Bitte warten ..
Mitglied: battl1984
11.10.2011 um 12:59 Uhr
Zusatz:

Ich habe eben mal auf der AVM-Seite gestöbert und habe raus gefunden, dass die statischen Routen in der FB nur nötig sind, wenn du von "außen" via VPN auf dein 1er-Netz zugreifen willst. Dann brauchst du die Route.

Es kann also nicht schaden die statische Route drin zu lassen. Aber es hat keinen Einfluss auf deine Clients!
Bitte warten ..
Mitglied: aqui
11.10.2011, aktualisiert 18.10.2012
Das entsprechende Tutorial hier zu dem Thema hast du auch gelesen ??
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Dort steht alles was du zu diesem Thema wissen musst ?
Das man von statischen Routen die Finger lassen soll gilt nur für den Server, das ist richtig !
Nicht aber für den Router, denn der "kennt" das Netz was hinter dem Server liegt logischerweise nicht ! Das musst du ihm als zwangsweise angeben mit einer statischen Route. Ist auch so detailiert im o.a. Tutorial beschrieben !
Wenn du allerdings NAT/ICS (Adress Translation) auf dem Server machst entfällt das, da das ganze Netz hinter dem Server dann hinter der IP des Servers "versteckt" wird. So "sieht" der Router also kein 2tes IP netz mehr.
Allerdings blockt man sich dann auch den Zugriff aus dem erstewn Netz durch die NAT Firewall dann auf dem Server.
Auch das erklärt das Tutorial in verständlicher Weise....
Nebenbei: Deine Netz Bezeichnung ist irreführend. Extern ist ja logischerweise das Netz wo der Router angeschlossen ist also 192.168.2.0 /24 und "Intern" wäre dann das 192.168.1.0er Netz wo die Clients "intern" arbeiten.
Das ist aber eher ein kosmetisches Problem...
Erstmal solltest du sicher klären ob du den Server im NAT/ICS Betrieb mit Translation betreibst oder ohne. NAT heist bei Winblows irgendwie "Universal Firewall" oder irgend so ein andere verquarster Begriff.
Vermutlich hast du aber nur die logische Zuordnung von extern zu intern auf den NICs. bzw. Firewall falsch gemacht, denn funktionieren tut so ein simples Banalkonzept ja problemlos... ?!
Bitte warten ..
Mitglied: Mar-west
11.10.2011 um 15:19 Uhr
Zitat von aqui:
Das entsprechende Tutorial hier zu dem Thema hast du auch gelesen ??

Ja habe ich.

Nicht aber für den Router, denn der "kennt" das Netz was hinter dem Server liegt logischerweise nicht ! Das musst
du ihm als zwangsweise angeben mit einer statischen Route. Ist auch so detailiert im o.a. Tutorial beschrieben !

Dann habe ich das ja schon mal Richtig.

Wenn du allerdings NAT/ICS (Adress Translation) auf dem Server machst entfällt das, da das ganze Netz hinter dem Server dann
hinter der IP des Servers "versteckt" wird. So "sieht" der Router also kein 2tes IP netz mehr.
Allerdings blockt man sich dann auch den Zugriff aus dem erstewn Netz durch die NAT Firewall dann auf dem Server.
Auch das erklärt das Tutorial in verständlicher Weise....
Ich führe kein NAT/ICS durch, da der Router sowie ich das im Tutorial verstanden habe ja Routing kann.

Nebenbei: Deine Netz Bezeichnung ist irreführend. Extern ist ja logischerweise das Netz wo der Router angeschlossen ist also
192.168.2.0 /24 und "Intern" wäre dann das 192.168.1.0er Netz wo die Clients "intern" arbeiten.
Das ist aber eher ein kosmetisches Problem...

Ich weis

Erstmal solltest du sicher klären ob du den Server im NAT/ICS Betrieb mit Translation betreibst oder ohne.

Ich betreibe ihn Ohne NAT, einfaches LAN Routing aktiviert, so wie es in dem Tutorial steht.

denn funktionieren tut so ein simples Banalkonzept ja problemlos... ?!

Ich weiss, wenn ich den fehler finden würde
Bitte warten ..
Mitglied: Mar-west
11.10.2011 um 16:03 Uhr
Ich habe mir jetzt nochmal das TuT durchgesehen, und denke das mein fehler wirklich nur der Gaytway im DHCP war.
Ich habe schlichtweg die Falsche IP angegeben, nicht die vom Server sondern die von der NIC Extern.

Dumm halt.

Werde das nacher testen und dann bericht abgeben.
Bitte warten ..
Mitglied: Mar-west
11.10.2011 um 17:30 Uhr
So ihr Lieben,
es hat also wirklich an den falschen Gateway einstellungen gelegen!

Ich danke euch!
Bitte warten ..
Mitglied: battl1984
12.10.2011 um 08:23 Uhr
Dann bin ich ja froh, dass wir das in den Griff bekommen konnten!

Kein Thema!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Windows Server
Server 2008R2 IIS Zertifikatsproblem

Frage von Alchemy zum Thema Windows Server ...

Windows Server
BPA bei Windows Server 2008R2 Standard (15)

Frage von MiSt zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...