Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Netzwerke Router & Routing

Routing Win2000 und Teledat 630

Mitglied: Dreistein

Dreistein (Level 1) - Jetzt verbinden

30.08.2006, aktualisiert 13.01.2007, 4759 Aufrufe, 13 Kommentare

Guten Tag, ich wende mich mit folgendem Anliegen an die User des Forums:

Wir unterhalten hier ein kleines Netzwerk mit ca. 20 PC, weitgehend unter Win2000, mit einem Server (Win2000 Server) als Arbeitsgruppe. Aus bautechnischen Gründen besteht das Netz physikalisch aus 2 Abschnitten, 1 X BNC (192.168.1.0 mask 255.255.255.0) und 1 X 100 Mbit Ethernet (192.168.0.0 mask 255.255.255.0). Alle PC haben manuell zugewiesene IP-Adressen, je nach (physikalischer) Zugehörigkeit.

Im 192.168.1.0/24 befindet sich ein Router mit DSL-Modem, Telekom-Modell TeleDat 630, dem man gemäß Handbuch weder eine andere IP-Adresse (fest: 192.168.1.1) noch gar irgendwelche Routen beibringen kann.

Das Subnet 192.168.1.0/24 wird durch diesen Router mit Internetzugang "versorgt", indem als Standardgateway die 192.168.1.1 und als DNS – Server die 192.168.1.1 eingetragen ist; das funktioniert einwandfrei. Auf dem Server ist aktuell weder DNS noch Routing eingerichtet, IP-Forwarding allerdings eingeschaltet.

Der Server besitzt 2 Netzwerkkarten, 192.168.1.2 und 192.168.0.2. Innerhalb des jeweiligen Subnetzes können sich alle Rechner, (einschließlich Server) pingen, sehen, sharen (je nach Freigaben) etc.

Aber: Weder kann man von 192.168.0.0 nach 192.168.1.0 pingen (oder umgekehrt), noch gelingt von 192.168.0.0 aus eine Internetverbindung, wie auch.

Eigentlich dachte ich, dass man dies per Routing über den Server "hinkriegen" müsste, aber weder mir noch einem hochbezahlten "Netzwerktechniker" einer ortsansässigen Firma ist das gelungen. Der hat statt dessen zwar "notdürftig" Jana als Proxy und E-Mail-Forwarder installiert, aber das eigentliche Problem nicht gelöst.

Wir brauchen nun aus verschiedenen Gründen (Datev, Elster) für 192.168.0.0 "direkten" Internetzugang.

Bitte, bitte: Kann mir einer detailliert schreiben, was wo eingetragen werden muss (Gateway, Routes pp) (an Server und PC); ich krieg das einfach nicht gebacken.

Vielen Dank
Mitglied: theinzel
31.08.2006 um 08:41 Uhr
Alles wäre kein Problem wenn man am Teledat Router eine statische Route
setzen könnte.
Routing und RAS auf dem Server aktivieren um das Netz hinter dem Server
erreichbar zu machen und dem Netz über den Server das "Internet" zugänglich machen

Lösung:
Einen anderen Router kaufen.
Bitte warten ..
Mitglied: Dreistein
31.08.2006 um 08:49 Uhr
Danke für den Hinweis, so was ähnliches hatte ich befürchtet ....

Gibt es vielleicht auch dazu noch eine Empfehlung (Hersteller, Typ), muss ja nicht wirklich viel können, oder??

Theoretisch müsste man ja sogar das "integrierte Modem" weiter benutzen können, was aber wohl wirtschaftlich nicht sehr viel Sinn machen dürfte, oder?

Danke
Bitte warten ..
Mitglied: theinzel
31.08.2006 um 08:52 Uhr
Habe gute Ergebnissse mit LANCOM (etwas teuer) und auch mit BINTEC

Im grunde geht jeder Router der statisches Routing oder auch ein Routingprotokoll
versteht.
Bitte warten ..
Mitglied: Dreistein
31.08.2006 um 13:59 Uhr
Danke für´s Erste

Werde das wohl mal umsetzen müssen und hoffe, dass ich das dann hinkriege
Bitte warten ..
Mitglied: aqui
01.09.2006 um 18:12 Uhr
Das du über den Server nicht routen kannst ist klar, denn das hat Microsoft per default ausgeschaltet !!!
Mit einem kleinen Eingriff in die Registry ist das aber freigeschaltet:

www.microsoft.com/windows2000/de/server/help/default.asp?url=/windows2000/de/server/help/sag_TCPIP_pro_EnableForwarding.htm

Das löst dir wenigsten sofort dein Problem das du von Clients im einen nicht ins andere Segment pingen oder dich verbinden kannst !!!
Das wäre sowieso der erste Schritt um einen Verbindung zwischen den beiden Segmenten zu realisieren !!!

In der Tat ist aber der teleDat dein größtes Problem, da er weder alternative IPs noch statische Routen supported. Ein Riesenmanko, was andere Consumer Router wir Linksys WRT 54, Draytek, NetGear, D-Link, AVM Fritzbox etc. nicht haben und mit denen so eine Konstellation problemlos möglich ist !

Ein Blick in Attis Tutorial hier auf dem Server kann nicht schaden:

www.administrator.de/Zwei_Netze_%FCber_WLAN_miteinander_verbinden.html

Stell dir einfach vor das WLAN Segment ist dein 2tes Drahtsegment. Die Prozedur um das zum Laufen zu bringen ist ein und dieselbe...
(Routing solltest du immer dem Bridging vorziehen...)
Bitte warten ..
Mitglied: Dreistein
11.10.2006 um 11:43 Uhr
Problem gelöst!

@aqui:

Der Eintrag in der Registry war natürlich schon gesetzt.

Habe jetzt jetzt statische Routen auf den Arbeitsplätzen gesetzt und es funktioniert!

Waum das bei 200 (+x) Versuchen vorher nicht ging, weis ich nicht.

Konkret:
Netz 192.168.1.0:
add route -p 192.168.0.0 mask 255.255.255.0 192.168.0.2
Default Gateway 192.168.1.1 (Router)

Netz 192.168.0.0:
add route -p 192.168.1.0 mask 255.255.255.0 192.168.1.2
Default Gateway 192.168.0.2

Danke an Alle!
Bitte warten ..
Mitglied: aqui
13.10.2006 um 20:37 Uhr
Die Routen sind IP technischer Unsinn und das Problem liegt vermutlich noch woanders. (Am meisten natürlich an dem schwachen T-Com Router der eigentlich in einem professionellen Netzwerk wie deinem nichts zu suchen hat, sondern ausschliesslich für Heimnutzer gedacht ist !!)

Mit statischen Routen gibt man Netze bekannt die man direkt nicht erreichen kann und macht Clients ein Next Hop Gateway bekannt über das dieses Zielnetz ereichbar ist.
In deinem Szenario ist das aber komplett überflüssig, da der Server ja beide Netze kennt da sie an ihm selber direkt! angeschlossen sind. Statische Routen sind damit komplett überflüssig !
Wenn du dir die Route Syntax einmal ansiehst wird das auch transparent:

add route -p 192.168.0.0 mask 255.255.255.0 192.168.0.2

Die Route besagt das er Packete die an das Zielnetz 192.168.0.0 gerichtet sind über ein Gateway schicken soll mit der Adresse 192.168.0.2.
Er soll also Packete an ein Netz was er eigentlich kennt, denn da ist ja die Gateway Adresse drin, an das gleiche Netzwerk schicken.... eigentlich komplett unsinnig. Wahrscheinlich biegt aber diese unsinnige Route einen anderen Konfigfehler glatt.
Vermutlich liegt der Fehler in der Gateway Konfiguration der Clients ! Aber eben nicht nur, da ein sauberes Routing durch den fehlerhaften T-Com Router (fehlende statische Routen) überhaupt gar nicht möglich ist in dem o.a. Szenario !

Denken wir uns den Router mal weg und nehmen den Server mit den beiden Segmenten 192.168.1.0 und 192.168.2.0 dann MÜSSEN alle Clients im .0er Segment die Serveradresse des jeweiligen Segments als default Gateway haben !
(Im .1er Segment nicht unbedingt würde der T-Com Router statische Routen supporten wie andere Hersteller !)
Folglich also alle PCs im .0er Segment die 192.168.0.2 und die PCs im .1er Segment die 192.168.1.2. Damit MUSS erstmal eine Verbindung von Segment zu Segment mit allen Beteiligten PCs und Server einwandfrei funktionieren, sofern man die Registry bei 2K und XP richtig gepatcht hat.
Hängt man den Router mit der .1.1 ins .1er Segment MUSS der Server eine default Route auf den Router .1.1 haben. Jetzt wäre die IP Konfiguration sauber.

Das Problem ist aber in der Tat der Router dem man die Route auf das .0er Segment über den Server nicht beibringen kann, da er keine statischen Routen supportet.
Eigentlich ein Unding und so ein Heimuser Router gehört folglich nicht in so ein Netzwerk !
Die Problematik ist, das der Server durch seinen default Gateway Eintrag auf den Router natürlich auch alle Internet Packet aus dem .0er Segment gen Router forwardet und die auch über ihn in die große weite Internet Welt gehen aber wenn sie zurückkommen muss der Router ja wissen wo sein "next Hop" Gateway für das .0er Netz ist. Eignetlich ja der Server mit der .1.2er Adresse aber durch den fehlenden Routeeintrag verwirft er das Packet da er das Ziel nicht kennt und die User im .0er Segment sitzen im Dunkeln

Mit den Routen forwardest du nun jeweils Packete aus dem 0er ins 1er Segment und umgedreht. IP technisch ein großer Unsinn und verwunderlich das Windows sowas supportet ...no comment.
Das der Router dann auch noch .0er Packete auf dem .1er Segment forwardet obwohl er nichtmal statische Routen kennt verwundert umsomehr.
Aber egal....auch wenns falsch, krank und unsinnig ist Hauptsache es klappt
Als Dauerlösung würde ich das aber in einem Produktivnetz nicht belassen wollen....
Bitte warten ..
Mitglied: Dreistein
16.10.2006 um 07:41 Uhr
Ich stimme Dir in vollem Umfang zu; aber im Moment jedenfalls geht dat ...

Anderer Router ist fest in der Planung.

Danke für die Kommentare.
Bitte warten ..
Mitglied: sewoastl
04.01.2007 um 11:29 Uhr
Routing mit dem teledat 630 geht schon....Einfach per telnet auf deinen Router, und siehe da: auf einmal finden sich mehrere Einstellungen, die über das Web-Frontend nicht erreichbar sind

und dort gibts irgendwo einen Punkt, der sich "Static IP Routes" oder so nennt...
Bitte warten ..
Mitglied: Dreistein
05.01.2007 um 09:37 Uhr
Vielen Dank für den Hinweis, aber ...
mit Telnet kenne ich mich leider überhaupt nicht aus.
Gibt es dazu irgendwie eine verständliche Anleitung oder
Bitte: Könntest Du in kurzen worten eine solche geben?
Danke!
Bitte warten ..
Mitglied: aqui
05.01.2007 um 11:04 Uhr
Telnet ist ein einfaches Terminalprogramm gewissermaßen zu vergleichen mit der Eingabeaufforderung unter Windows. Damit erreichtst genau wie bei dieser ("DOS Fenster") die Systemkonsole des Routers.
Eine Telnet Anwendung ist in Windows direkt drin ! Um den Router zu erreichen kannst du direkt von der Eingabeaufforderung:
telnet 192.18.1.1
eingeben, wenn Letztere die IP des Routers sein sollte (sonst ggf. anpassen an deine IPs)

Wem das Windows Telnet zu doof und zu spartanisch ist der kann auf
Putty:
http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

oder TeraTerm:
http://hp.vector.co.jp/authors/VA002416/teraterm.html

ausweichen ! Die machen das gleiche nur schöner und können etwas mehr !
Bitte warten ..
Mitglied: Dreistein
10.01.2007 um 08:34 Uhr
Vielen Dank für den Hinweis.

Ich habe es tatsächlich hinbekommen, ist ja "sogar" menügeführt und funktioniert prima!

Warum wird so etwas nicht dokumentiert? Oder war/bin ich nur zu doof, das zu finden?

Jedenfalls, nochmals danke, das (mein) Problem ist jetz hoffentlich endgültig gelöst.
Bitte warten ..
Mitglied: aqui
13.01.2007 um 18:07 Uhr
Zu doof nicht...es ist wohl eher die schlechte Doku des 630...

Dann kannst du den Thread ja auch als "gelöst" markieren !!!
Bitte warten ..
Ähnliche Inhalte
Windows Mobile
Lumia 630 recovery nicht möglich
gelöst Frage von Mengi86Windows Mobile6 Kommentare

Hi, seit der Installation der letzten Windows 10 Preview auf meinem Lumia 630 geht gar nichts mehr. Zunächst hatte ...

Grafikkarten & Monitore
NVIDIA Geforce GT 630 geht nicht mehr
gelöst Frage von Motherboard33Grafikkarten & Monitore7 Kommentare

Moin, Ich habe mir vor kurzem eine NVIDIA Geforce GTx 960 gekauft und vorher hatte ich eine GT 630 ...

Router & Routing
Routing über OVPN
Frage von SPSmanRouter & Routing18 Kommentare

​Moin, Folgendes ist gegeben: Rechner A(VPN Server): - NIC mit IP 1.0 - VPN mit IP 2.0 Rechner B(VPN ...

Router & Routing
Routing mit "anderer" Rückroute
gelöst Frage von 127944Router & Routing21 Kommentare

Moimn zusammen, ich habe da mal eine theoretische Frage die ich lieber kläre, bevor ich meine neue Baustelle anfasse. ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 2 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 2 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 2 TagenSicherheit10 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
E-Mail
Erfahrungen mit hMailServer gesucht
Frage von it-fraggleE-Mail10 Kommentare

Hallo, meine neue Stelle möchte einen eigenen Mailserver. Ich als Linuxkind war direkt geistig mit Postfix dabei. Leider wollen ...

Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall9 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

Entwicklung
VBS: alle PDF-Dateien in einem Ordner gleichzeitig öffnen
gelöst Frage von JuweeeEntwicklung9 Kommentare

Hallo, ich habe in deiner Ordnerstruktur (.\Tagesberichte\xx.18\) mehrere dynamische PDF-Formulare (mit LCD erstellt). Die Berichtsformulare sind im Layout alle ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen8 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...