Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Kein Routing mit Win2k Server SP4 möglich

Frage Netzwerke Router & Routing

Mitglied: Regalwand

Regalwand (Level 1) - Jetzt verbinden

28.12.2006, aktualisiert 29.12.2006, 5334 Aufrufe, 26 Kommentare

Guten Tag, ich habe ein Problem mit einem Windows 2000 Server mit Sp4 und allen Updates bis 27.12.2006. Folgendes:

Es gibt zwei Netze 192.168.1.0 (Netz1) und 192.168.2.0 (Netz2). Beide sind über zwei netzwerkkarten (Karte 1 IP 192.168.1.200 und Karte 2 192.168.2.1 kein Gateway eingetragen) im Server angeschlossen. Clients aus den ersten kommen aber nicht in zweite und umgekehrt.
Routing und Ras-Dienst ist aktiviert und es sind folgende statischen Routen eingetragen:
Netz2 : Ziel *.1.0 Gateway 192.168.1.200
Netz1 : Ziel *.2.0 Gateway 192.168.2.1
Die Beiträge über Routing mit zwei Netzwerkkarten die hier gepostet sind haben leider nicht weiter geholfen.

Weiß jemand rat ?
Mitglied: Dani
28.12.2006 um 16:16 Uhr
Hi,
bei den jeweiligen Clients sind die Standardgatewaya richtig hinterlegt.


Gruß
Dani
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 16:18 Uhr
denke schon.

die Clients in Netz2 haben die *.2.1

und die Clients im Netz1 haben *.1.1 ( 1.1 ist ein Suse-Server der mit dem Internet verbunden ist)

..danke für die schnelle Antwort
Bitte warten ..
Mitglied: Dani
28.12.2006 um 16:27 Uhr
Hi,
jetzt versteh ich nur Bahnhof!! Ist *.1.1 nochmal ein Server?!
Netz1 muss als GW *.1.200 haben.

Mach doch mal ein "tracert" von einem Subnetz ins andere. Also Client1 (netza) nach Client7 (netzb). Ergebnis bitte posten!


Gruß
Dani
Bitte warten ..
Mitglied: aqui
28.12.2006 um 16:57 Uhr
Normalerweise muss bei 2k generell das Routing zwischen mehreren NICs explizit in der Registry erlaubt werden. Dafür gibt es auch einen entsprechenden Eintrag in der MS Knowledgebase:

http://www.microsoft.com/windows2000/de/server/help/default.asp?url=/wi ...

Ohne das ist ein Routing zwischen 2 NICs nicht möglich, da es per Default deaktiviert ist !

Ein Gateway Eintrag in den Adaptersettings und ebenso jegliche statische Routen im Server sind komplett überflüssig und sollten entfernt werden sofern Clients in den Segmenten nicht noch über evtl. vorhandene Router ins Internet oder andere IP Segmente gehen und das Routing ausschliesslich lokal am Server stattfindet !!!
Ist in einem Segment ein Router ins Internet reicht es vollkommen aus nur auf dieser NIC das Gateway zu konfigurieren und eine zusätzliche statische Router auf dem Router selber zu setzen !
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 17:51 Uhr
Danke, aber das war es auch nicht. Ich habe jetzt nur einen Rechner pro Subnetz und nur den ROuting-Dienst auf dem Win2k -Sewrver laufen, sonst nichts. Die Registrieänderung hat nicht geholfen.....
Bitte warten ..
Mitglied: aqui
28.12.2006 um 18:23 Uhr
Hast du danach einen Kaltstart gemacht sonst wirkt die nicht !!! Auch solltest du evtl. eingerichtete statische Routen mit -d unbedingt entfernen
Sollte es dennoch Probleme geben sind die in 99% aller Fälle durch die Firewall bedingt, denn das Routing funktioniert de facto problemlos !

Nur noch mal zur Erinnerung: Die IP Einstellungen müssen so aussehen:

Server NIC 1: 192.168.2.1, Maske 255.255.255.0 (Kein Gateway)
Server NIC 2: 192.168.1.200, Maske 255.255.255.0 (Kein Gateway)

Clients im Segment der NIC 1:
192.168.2.x, Maske 255.255.255.0, Gateway: 192.168.2.1

Clients im Segment der NIC 2:
192.168.1.x, Maske 255.255.255.0, Gateway: 192.168.1.200

Damit sollte ein Ping von Client zu Client und Server problemlos klappen (korrekte Firewall Einstellungen vorausgesetzt, ggf. FW temporär abschalten !)
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 19:04 Uhr
Jep, Vielen Dank!!!
Jetzt klappt es. Habe die routingtabelle gelöscht und es lief.
Nun habe ich allerdings das Problem das die clients aus beiden Netzen über die 192.168.1.1 ins Internet sollen.
Habe auf der NIC 192.168.1.200 das Gateway 192.168.1.1 eingetragen aber es funktioniert nicht.
Bitte warten ..
Mitglied: Dani
28.12.2006 um 19:11 Uhr
Hi,
und wo steht der *.1.1??


Gruß
Dani
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 19:15 Uhr
Das ist ein zweiter PDC unter linux wo das bereits ein bestehendes Netzwerk läuft (192.168.1.*) und dahinter hängt der Router fürs Internet.
Liebe Grüße von wo auch immer du dir so geduldig Zeit nimmst....
Bitte warten ..
Mitglied: Dani
28.12.2006 um 19:41 Uhr
Kannst du mal die Rountingtabelle vom dem Rechner mit den beiden NIC'S posten.

Befehl ist "route print". Danke..


Gruß
DAni
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 19:49 Uhr
So:
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x1000003 ...00 40 f4 ef 7a 89 ...... Realtek RTL8169/8110 Family Gigabit Ethernet NIC
0x1000004 ...00 40 f4 ef 83 c0 ...... Realtek RTL8169/8110 Family Gigabit Ethernet NIC
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.200 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.1.0 255.255.255.0 192.168.1.200 192.168.1.200 1
192.168.1.200 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.1.255 255.255.255.255 192.168.1.200 192.168.1.200 1
192.168.2.0 255.255.255.0 192.168.2.1 192.168.2.1 1
192.168.2.1 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.2.255 255.255.255.255 192.168.2.1 192.168.2.1 1
224.0.0.0 224.0.0.0 192.168.1.200 192.168.1.200 1
224.0.0.0 224.0.0.0 192.168.2.1 192.168.2.1 1
255.255.255.255 255.255.255.255 192.168.2.1 192.168.2.1 1

Standardgateway: 192.168.1.1
Ständige Routen:
Keine

.....ich hoffe das hilft dir...
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 19:51 Uhr
Sorry, ich hatte das gut leserlich formatiert, ist aber nicht so dargestellt worden, ich hoffe du blickst durch......

kann ich das anders Posten ?
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 19:59 Uhr
2. Versuch, als Tabelle....

Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x1000003 ...00 40 f4 ef 7a 89 ...... Realtek RTL8169/8110 Family Gigabit Ethernet NIC
0x1000004 ...00 40 f4 ef 83 c0 ...... Realtek RTL8169/8110 Family Gigabit Ethernet NIC
Aktive Routen:
|| Netzwerkziel || Netzwerkmaske || Gateway || Schnittstelle || Anzahl||
|| 0.0.0.0 || 0.0.0.0 || 192.168.1.1 || 192.168.1.200 || 1||
|| 127.0.0.0 || 255.0.0.0 || 127.0.0.1 || 127.0.0.1 || 1||
||192.168.1.0 || 255.255.255.0 ||192.168.1.200 || 192.168.1.200 || 1||
||192.168.1.200 ||255.255.255.255 || 127.0.0.1 || 127.0.0.1 || 1||
|| 192.168.1.255 ||255.255.255.255 || 192.168.1.200 ||192.168.1.200 || 1||
|| 192.168.2.0 || 255.255.255.0 || 192.168.2.1 || 192.168.2.1 || 1||
|| 192.168.2.1 ||255.255.255.255 || 127.0.0.1 || 127.0.0.1 || 1||
||192.168.2.255|| 255.255.255.255 || 192.168.2.1 || 192.168.2.1 || 1||
|| 224.0.0.0 || 224.0.0.0 || 192.168.1.200 || 192.168.1.200 || 1||
|| 224.0.0.0 || 224.0.0.0 || 192.168.2.1 || 192.168.2.1 || 1||
||255.255.255.255 || 255.255.255.255 || 192.168.2.1 || 192.168.2.1 || 1||
Standardgateway:....192.168.1.1
Ständige Routen:
Keine
Bitte warten ..
Mitglied: Dani
28.12.2006 um 19:59 Uhr
Hi,
hast du den Auszug jetzt mit dem Gatewayeintrag gemacht oder nicht. Wenn "mit", dann lösch ihn doch bitte mal und zeig mir dann die Routingtabelle!


Gruß
Dani
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 20:07 Uhr
das war mit 192.168.1.1 als Gateway....jetzt ohne


Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x1000003 ...00 40 f4 ef 7a 89 ...... Realtek RTL8169/8110 Family Gigabit Ethernet NIC
0x1000004 ...00 40 f4 ef 83 c0 ...... Realtek RTL8169/8110 Family Gigabit Ethernet NIC
Aktive Routen:
Netzwerkziel--- Netzwerkmaske ---------------- Gateway---------- Schnittstelle------ Anzahl
127.0.0.0 ----------- 255.0.0.0 ----------------- 127.0.0.1 ----------127.0.0.1----------- 1
192.168.1.0 ---- 255.255.255.0 ------- 192.168.1.200 ----- 192.168.1.200-------------1
192.168.1.200 ---- 255.255.255.255 ---- 127.0.0.1 --------- 127.0.0.1 ----------- 1
192.168.1.255 ---- 255.255.255.255 ---- 192.168.1.200 ---- 192.168.1.200---------- 1
192.168.2.0 ---- 255.255.255.0 ---- 192.168.2.1 ---- 192.168.2.1---- 1
192.168.2.1 ---- 255.255.255.255 ---- 127.0.0.1 ---- 127.0.0.1---- 1
192.168.2.255 ---- 255.255.255.255 ---- 192.168.2.1 ---- 192.168.2.1---- 1
224.0.0.0------------ 224.0.0.0---- ---- 192.168.1.200---- 192.168.1.200---- 1
224.0.0.0---- ------- 224.0.0.0---- ---- 192.168.2.1 ---- - 192.168.2.1---- 1
255.255.255.255---- 255.255.255.255 ---- 192.168.2.1---- 192.168.2.1---- 1
Ständige Routen:
Keine
Bitte warten ..
Mitglied: Dani
28.12.2006 um 20:12 Uhr
Hi,
füge mal folgende Route hinzu:
01.
route add 0.0.0.0 0.0.0.0 192.168.1.1
oder
01.
route add 0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.100
Gruß
Dani
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 20:33 Uhr
Ok

ich kann jetzt mit dem Client aus dem 1.0er Netz ins Internet.
Muss ich den eintrag jetzt noch für das 2.0 er Netz wiederholen ?

also route add 0.0.0.0 MASK 0.0.0.0 192.168.1.1 192.168.2.1 ??

Oder anders ?

Grüße

P.S. der Route ausdruck sieht genauso aus wie eben, außer als oberse zeile

Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.1.1 192.168.1.200 1
Bitte warten ..
Mitglied: Dani
28.12.2006 um 21:06 Uhr
Hi,
Route hast beim Server hinzugefügt?! JA- Gut.
Normal müsste Netz2 jetzt auch online kommen. Ansonsten kannst du mal die ROute
01.
route add 0.0.0.0 MASK 0.0.0.0 192.168.1.1 192.168.2.1
hinzufügen.


Gruß
Dani
Bitte warten ..
Mitglied: Dani
28.12.2006 um 21:06 Uhr
Hi,
Route hast beim Server hinzugefügt?! JA- Gut.
Normal müsste Netz2 jetzt auch online kommen. Ansonsten kannst du mal die ROute
01.
route add 0.0.0.0 MASK 0.0.0.0 192.168.1.1 192.168.2.1
hinzufügen.


Gruß
Dani
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 21:22 Uhr
Hallo,
wenn ich das eingebe

>route add 0.0.0.0 MASK 0.0.0.0 192.168.1.1 METRIC IF 192.168.2.1

kommt diese Fehlermeldung
Hinzufügen der Route fehlgeschlagen: Entweder ist der Schnittstellenindex ungültig oder das Gateway befindet sich nicht im gleichen Netzwerk wie die Schnittstelle. Überprüfen sie die IP-Adresstabelle für diesen Rechner.
Bitte warten ..
Mitglied: Dani
28.12.2006 um 21:40 Uhr
Hi,
dann probier mal vom Netz2 auf Netz1 zuzugreifen. WEnn das geht, dann probier mal ins Internet zukommen.
Falls dies nicht geht, mach aus dem Netz2 einen "tracert www.google.de" und poste das Ergebnis.


Gruß
Dani
Bitte warten ..
Mitglied: Regalwand
28.12.2006 um 21:45 Uhr
von Netz2 nach Netz1

0 192.168.2.18
1 192.168.2.1
2 192.168.1.8

von Netz2 nach www.google.de

Fehler : zielname konnte nicht aufgelöst werden...
..

...
Vielen Dank für die Hilfe. Mache jetzt Feierabend. Bin morgen wieder da, hoffe dann klappt es besser.

Schönen Abend
Bitte warten ..
Mitglied: Dani
28.12.2006 um 21:47 Uhr
Dann mach den "tracert" noch auf www.google vom Netz2 aus, bitte!


Gruß
Dani
Bitte warten ..
Mitglied: aqui
28.12.2006 um 21:51 Uhr
Nein bitte KEINE statische Default Route das ist Unsinn !! Die kannst du gleich wieder löschen...

Du solltest folgendermaßen vorgehen:

1.) Zustand wiederherstellen in dem alles lokal problemlos rennt.

2.) Auf der NIC2 am Server als Gateway die 192.168.1.1 eintragen (bitte nur hier !), ebenso diese Adresse als DNS Adresse (auch nur hier), da der Internet Router auch als DNS Proxy arbeitet. Im Segment der NIC1 (192.168.2.0) bleibt alles so wie es ist, allerdings MÜSSEN bei allen Clients hier statisch die 192.168.1.1 als DNS Adresse konfiguriert werden !

3.) Jetzt MUSS auf dem Router eine zusätzliche statische Route für das IP Segment NIC1 "hinter" dem Server eingetragen werden, denn sonst könnte der Router keine Packete dahin forwarden denn er "kennt" das Netzwerk ja nicht bzw. "weiß" nicht das dies hinter dem Server erreichbar ist.
Also Route Tabelle im Router suchen und folgende Route dort im Setup eingeben damit er es kennenlernt:

Zielnetz: 192.168.2.0 Maske: 255.255.255.0 Gateway: 192.168.1.200 (IP des Servers)

Alle Packete fürs .2er Netz werden dann an den Server mit der .1.200 geforwardet und der weiss natürlich wo das .2er Segment ist, denn es ist ja direkt an ihm angeschlossen !!

Noch ein paar Anmerkungen: Sollte der Router einen DHCP Server aktiv haben kannst du natürlich auch alle Clients in den TCP/IP Settings auf "Adresse automatisch beziehen" stellen. Der Weg ins Internet ist für sie derselbe es hätte aber den Vorteil das sie dann die gateway Adresse direkt vom Router bekommen und nicht erst den Server kontaktieren müssen (statisch steht deren Gateway ja noch auf der Serveradresse) Würde der Server mal ausfallen würden dann wenigstens diese Clients noch ins Internet kommen ohne den Server.
Das ist aber letztlich kosmetisch. Natürlich kannst du auch statisch die Routeradresse statt die des Servers eintragen wenn die staische Adressvergabe dir besser gefällt.
Wichtig ist noch das der Server unbedingt von der DHCP Adressvergabe ausgenommen wird also ein statische Adresse behält. Die darf sich keinesfalls ändern, da ja die statische Route des Internet Routers auf diese Adresse zeigt. Diese Adresse sollte sich auch keinesfalls in der DHCP Range des Routers befinden, damit nicht zufällig eine anderes Gerät diese Adresse dynamisch erhält. Packete würden dann vom Router ggf. im "IP Nirwana" landen !

Das Böseste was dir passieren kann, ist das du einen Billigstrouter vom billigen Jakob hast. Es gibt einige wenige Systeme die leider keine zusätzlichen statischen Routen in der Konfig supporten. Leider ein Unding aber ein paar Hersteller sparen auch noch daran oder wollen dich damit zwingen teurere Modelle zu kaufen.
Ist das der Fall hast du erstmal ein Problem aber mit NAT kann man auch das lösen.... Hoffen wir mal das du nicht so ein System hast...
Bitte warten ..
Mitglied: Regalwand
29.12.2006 um 10:15 Uhr
Vielen Dank, eure Anmerkungen haben sehr geholfen.
Der Fehler lag an der Firewall am Rechner 192.168.1.1

Ich werde das Forum weiter empfehlen

Grüße
Bitte warten ..
Mitglied: Dani
29.12.2006 um 10:49 Uhr
Hi,
ok...dann bitte den Thread schließen. Dazu oben auf editieren klicken und den entsprechenden Hacken setzen.


Gruß
Dani
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(7)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (17)

Frage von Unwichtig zum Thema Netzwerkmanagement ...