Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing auf Windows einrichten (VPN Routing)

Frage Netzwerke Router & Routing

Mitglied: Squirrel900

Squirrel900 (Level 1) - Jetzt verbinden

19.10.2010, aktualisiert 18.10.2012, 9224 Aufrufe, 5 Kommentare

Hallo Zusammen
Leider habe ich ein Problem, bei dem ich irgendwie hange.

Ich habe folgendes Netzwerk:

01.
    |station1----  
02.
    | 	nic1: 172.16.22.244/24 (Netzwerk) 
03.
T---|	nic2: 10.8.0.2/24 (OpenVPN) 
04.
05.
06.
|   |station2---- 
07.
L---|	nic1: 10.8.0.1/24 (OpenVPN) 
08.
    |   nic2: 172.16.10.244/24 (Netzwerk)	 
09.
T---|	nic3: 192.168.0.100/24 (kleines PAN) 
10.
11.
12.
|   |station3---- 
13.
L---|	nic: 192.168.0.50/24 (kleines PAN)
Auf "station1":
01.
route add 192.168.0.0 mask 255.255.255.0 10.8.0.1 metric 1 -p
Auf "station2":
01.
route add 10.8.0.0 mask 255.255.255.0 192.168.0.100 metric 1 -p
Ziel ist es: Von "station1" via VPN auf "Station3" z.B. zu pingen, wobei "station3" kein Computer ist.
01.
ping 192.168.0.50
Hat leider bis jetzt nicht funktioniert.
Mitglied: micneu
19.10.2010 um 15:59 Uhr
was ist denn dein standard gateway?
was ist als gateway in der station3?

in welchem netz ist dein gateway?

ein bistchen wenig informationen...
ich würde die netze entsprechen in euren router eintragen oder was auch immer euer std. gateway ist.

dann ist es so kommt ein packet für ein fremdes netzt wird euer gw gefragt und der kennt den weg

so hoffe das hilft ein wenig

Netz A 172.16.22.0/24
ziel gw
route 10.8.0.0/24 172.16.22.244
172.16.10.244/24 172.16.22.244
192.168.0.0/24 172.16.22.244

Netz B 172.16.10.0/24
ziel gw
route 10.8.0.0/24 172.16.10.244
172.16.22.0/24 172.16.10.244
192.168.0.0/24 172.16.10.244

Netz C 192.168.0.0/24 PAN
ziel gw
route 10.8.0.0/24 192.168.0.50
172.16.10.0/24 192.168.0.50
172.16.22.0/24 192.168.0.50
Bitte warten ..
Mitglied: aqui
20.10.2010, aktualisiert 18.10.2012
Statische Routen sind völliger Unsinn in diesem Netz, denn sie werden gar nicht benötigt ! Die Beschreibung ist in der Tat sehr rudimentär und es geht vermutlich darum das der OpenVPN Client "Station-1" mit aktivem OpenVPN Tunnel das Netzwerk 192.168.0.0 /24 auf Station 3 erreichen kann, richtig ?

Da der zentrale OpenVPN Server die "Station 2" ist reincht es hier in der OpenVPN Server Konfig nur die 2 lokalen Netze mit dem push Kommando zu propagieren an den Client !!
Also ein
push "route 172.16.10.0 255.255.255.0"
push "route 192.168.0.0 255.255.255.0"

In der Server.conf Datei löst dein Problem sofort ! Alle sinnlosen statischen Routen solltest du löschen, denn die verschlimmberssern dein Problem nur .
Paket Forwarding sollte auf Station2 natürlich aktiv sein !
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Wenn du bei aktivem OpenVPN Client dann einmal das Kommando route print auf deinem Client angibst in der Eingabeaufforderung siehst du das diese Routen an den OpenVPN Client propagiert werden via Tunnel Interface.
Alle Pakete in diese beiden Netze werden dann in den Tunnel geschickt und landen am Server "Station-2" wo sie dann sauber in die lokalen Netze weitergeleitet werden, denn Station-2 "kennt" ja alle diese Netze da sie dort direkt angeschlossen sind !
Einfach mal die OpenVPN Doku lesen...das hilft !
http://openvpn.net/index.php/open-source/documentation/howto.html
Weitere Infos zur Installation findest du auch hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Bitte warten ..
Mitglied: Squirrel900
20.10.2010 um 08:51 Uhr
Vielen Dank für eure Antworten =).

@micneu
Ein StandardGateway bez. Router wäre natürlich eine Lösung. Ist bei der Anzahl 192.168.0.0 Netze zu aufwändig.

@aqui
Diese Einträge bez. der Eintrag push "route 192.168.0.0 255.255.255.0" ist bereits vorhanden. Nach dem ich die statischen Routen gelöscht habe, kann ich jetzt auch nic3: 192.168.0.100 anpingen. Leider aber station3: 192.168.0.50 immer noch nicht.
Dieses 192.168.0.0 Netz, hat keinen Standart-Gateway sondern fixe IPs. Sollte doch aber wenn ich auf die nic3 komme, auch ohne Probleme auf station3 pingen können?
station2 ist ein Windows 2000 Rechner und TCP/IP-Weiterleitung ist aktiviert.
Bitte warten ..
Mitglied: aqui
20.10.2010 um 09:09 Uhr
Das ist auch ganz klar, denn vermutlich hast du die lokale Firewall an der .0.50 nicht angepasst. Die blockiert, wie bei Winblows üblich, ALLE Zugriffe aus Fremdnetzen und du kommst ja aus dem 10er Netz mit deinem VPN Client (siehe ipconfig am VPN Client !)
Folgende Punkte musst du dort machen:
  • Lokale Firewall anpassen und in den Berweiterten Bereicheinstellungen zu den Dieneten das Netzwerk 10.8.0.0 /24 erlauben oder mit Alle Computer inkl. Internet die globale Einstellung wählen !
  • ICMP Pakete erlauben (Ping). In den erweiterten Einstellungen der FW auf ICMP gehen und dort den Haken Auf Echo Pakete antworten setzen !!
  • Das default Gateway an "Station-3" muss auf die 192.168.0.100 zeigen !

Quercheck:
  • Kannst du von "Station-3" die OpenVPN TServer Tunnel IP 10.8.0.1 anpingen ??
  • Was sagt ein Traceroute (tracert) oder pathping von Station 1 an Station 3 und umgekehrt ?
Bitte warten ..
Mitglied: Squirrel900
20.10.2010 um 13:47 Uhr
"station3" ist zum Glück kein Windows System sondern eine SPS =).
Der default Gateway auf "station3", den habe ich vergessen. Jetzt klappt alles, vielen Dank.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Entwicklung
gelöst Mit Batch,VBS,Powershell Windows einrichten (1)

Frage von Justin98 zum Thema Entwicklung ...

Router & Routing
Routing Windows OpenVPN Server mit Teltonika RUT500 als Client (1)

Frage von ahenngee zum Thema Router & Routing ...

Router & Routing
InterVlan Routing mit Linksys LRT224 Dual WAN Gigabit VPN Router (1)

Frage von darkliving zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...