Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing auf Windows einrichten (VPN Routing)

Frage Netzwerke Router & Routing

Mitglied: Squirrel900

Squirrel900 (Level 1) - Jetzt verbinden

19.10.2010, aktualisiert 18.10.2012, 10134 Aufrufe, 5 Kommentare

Hallo Zusammen
Leider habe ich ein Problem, bei dem ich irgendwie hange.

Ich habe folgendes Netzwerk:

01.
    |station1----  
02.
    | 	nic1: 172.16.22.244/24 (Netzwerk) 
03.
T---|	nic2: 10.8.0.2/24 (OpenVPN) 
04.
05.
06.
|   |station2---- 
07.
L---|	nic1: 10.8.0.1/24 (OpenVPN) 
08.
    |   nic2: 172.16.10.244/24 (Netzwerk)	 
09.
T---|	nic3: 192.168.0.100/24 (kleines PAN) 
10.
11.
12.
|   |station3---- 
13.
L---|	nic: 192.168.0.50/24 (kleines PAN)
Auf "station1":
01.
route add 192.168.0.0 mask 255.255.255.0 10.8.0.1 metric 1 -p
Auf "station2":
01.
route add 10.8.0.0 mask 255.255.255.0 192.168.0.100 metric 1 -p
Ziel ist es: Von "station1" via VPN auf "Station3" z.B. zu pingen, wobei "station3" kein Computer ist.
01.
ping 192.168.0.50
Hat leider bis jetzt nicht funktioniert.
Mitglied: micneu
19.10.2010 um 15:59 Uhr
was ist denn dein standard gateway?
was ist als gateway in der station3?

in welchem netz ist dein gateway?

ein bistchen wenig informationen...
ich würde die netze entsprechen in euren router eintragen oder was auch immer euer std. gateway ist.

dann ist es so kommt ein packet für ein fremdes netzt wird euer gw gefragt und der kennt den weg

so hoffe das hilft ein wenig

Netz A 172.16.22.0/24
ziel gw
route 10.8.0.0/24 172.16.22.244
172.16.10.244/24 172.16.22.244
192.168.0.0/24 172.16.22.244

Netz B 172.16.10.0/24
ziel gw
route 10.8.0.0/24 172.16.10.244
172.16.22.0/24 172.16.10.244
192.168.0.0/24 172.16.10.244

Netz C 192.168.0.0/24 PAN
ziel gw
route 10.8.0.0/24 192.168.0.50
172.16.10.0/24 192.168.0.50
172.16.22.0/24 192.168.0.50
Bitte warten ..
Mitglied: aqui
20.10.2010, aktualisiert 18.10.2012
Statische Routen sind völliger Unsinn in diesem Netz, denn sie werden gar nicht benötigt ! Die Beschreibung ist in der Tat sehr rudimentär und es geht vermutlich darum das der OpenVPN Client "Station-1" mit aktivem OpenVPN Tunnel das Netzwerk 192.168.0.0 /24 auf Station 3 erreichen kann, richtig ?

Da der zentrale OpenVPN Server die "Station 2" ist reincht es hier in der OpenVPN Server Konfig nur die 2 lokalen Netze mit dem push Kommando zu propagieren an den Client !!
Also ein
push "route 172.16.10.0 255.255.255.0"
push "route 192.168.0.0 255.255.255.0"

In der Server.conf Datei löst dein Problem sofort ! Alle sinnlosen statischen Routen solltest du löschen, denn die verschlimmberssern dein Problem nur .
Paket Forwarding sollte auf Station2 natürlich aktiv sein !
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...

Wenn du bei aktivem OpenVPN Client dann einmal das Kommando route print auf deinem Client angibst in der Eingabeaufforderung siehst du das diese Routen an den OpenVPN Client propagiert werden via Tunnel Interface.
Alle Pakete in diese beiden Netze werden dann in den Tunnel geschickt und landen am Server "Station-2" wo sie dann sauber in die lokalen Netze weitergeleitet werden, denn Station-2 "kennt" ja alle diese Netze da sie dort direkt angeschlossen sind !
Einfach mal die OpenVPN Doku lesen...das hilft !
http://openvpn.net/index.php/open-source/documentation/howto.html
Weitere Infos zur Installation findest du auch hier:
http://www.administrator.de/wissen/openvpn-server-installieren-auf-dd-w ...
Bitte warten ..
Mitglied: Squirrel900
20.10.2010 um 08:51 Uhr
Vielen Dank für eure Antworten =).

@micneu
Ein StandardGateway bez. Router wäre natürlich eine Lösung. Ist bei der Anzahl 192.168.0.0 Netze zu aufwändig.

@aqui
Diese Einträge bez. der Eintrag push "route 192.168.0.0 255.255.255.0" ist bereits vorhanden. Nach dem ich die statischen Routen gelöscht habe, kann ich jetzt auch nic3: 192.168.0.100 anpingen. Leider aber station3: 192.168.0.50 immer noch nicht.
Dieses 192.168.0.0 Netz, hat keinen Standart-Gateway sondern fixe IPs. Sollte doch aber wenn ich auf die nic3 komme, auch ohne Probleme auf station3 pingen können?
station2 ist ein Windows 2000 Rechner und TCP/IP-Weiterleitung ist aktiviert.
Bitte warten ..
Mitglied: aqui
20.10.2010 um 09:09 Uhr
Das ist auch ganz klar, denn vermutlich hast du die lokale Firewall an der .0.50 nicht angepasst. Die blockiert, wie bei Winblows üblich, ALLE Zugriffe aus Fremdnetzen und du kommst ja aus dem 10er Netz mit deinem VPN Client (siehe ipconfig am VPN Client !)
Folgende Punkte musst du dort machen:
  • Lokale Firewall anpassen und in den Berweiterten Bereicheinstellungen zu den Dieneten das Netzwerk 10.8.0.0 /24 erlauben oder mit Alle Computer inkl. Internet die globale Einstellung wählen !
  • ICMP Pakete erlauben (Ping). In den erweiterten Einstellungen der FW auf ICMP gehen und dort den Haken Auf Echo Pakete antworten setzen !!
  • Das default Gateway an "Station-3" muss auf die 192.168.0.100 zeigen !

Quercheck:
  • Kannst du von "Station-3" die OpenVPN TServer Tunnel IP 10.8.0.1 anpingen ??
  • Was sagt ein Traceroute (tracert) oder pathping von Station 1 an Station 3 und umgekehrt ?
Bitte warten ..
Mitglied: Squirrel900
20.10.2010 um 13:47 Uhr
"station3" ist zum Glück kein Windows System sondern eine SPS =).
Der default Gateway auf "station3", den habe ich vergessen. Jetzt klappt alles, vielen Dank.
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Routing unter Windows 7 einrichten
Frage von DrJohnLoganRouter & Routing15 Kommentare

Moin, ich versuche seit einer ganzen Weile ein Routing einzurichten Als Router soll vorerst ein Windows 7-Rechner dienen, bevor ...

Xenserver
Ubuntu Routing einrichten auf einem XenServer
Frage von anutrofXenserver1 Kommentar

Guten Tag zusammen, ich habe folgendes SetUp: XenServer 1. pound (Ubuntu) (eth0 -> physische Netzwerkkarte, eth1 virtuelle Netzwerkkarte) 2. ...

Router & Routing
Lancom Routing VPN
Frage von mekmekRouter & Routing11 Kommentare

Hallo, wir haben momentan 2 Netze in unserer Zentrale (Netz A + Netz B). Unsere Standorte sind über eine ...

Router & Routing
PfSense Routing durch VPN-Tunnel
Tipp von FA-jkaRouter & Routing2 Kommentare

Ich hatte vorhin das Problem, dass eine pfSense keine Route auf einen OpenVPN-Client setzen kann. In der Sense war ...

Neue Wissensbeiträge
Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 StundeBatch & Shell1 Kommentar

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 3 StundenHumor (lol)5 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 19 StundenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 19 StundenSicherheit1 Kommentar

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Heiß diskutierte Inhalte
Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server17 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...

Linux
OpenSource Groupware
Frage von FA-jkaLinux13 Kommentare

Hallo, ich suche eine Groupware als Alternative zum Exchange. Wesentliche Aufgaben sind die Handhabung von E-Mails (persönliche und gemeinsam ...

Windows 10
Bitlocker nach Verschlüsselung nicht mehr aufrufbar!
gelöst Frage von alexlazaWindows 1013 Kommentare

Hallo, ich besitze ein HP ZBook 17 G4 mit einem Windows 10 Pro Betriebssystem. Bei diesem Problem handelt sich, ...