Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing mit Windows Server 2003

Frage Netzwerke

Mitglied: gido1337

gido1337 (Level 1) - Jetzt verbinden

26.07.2007, aktualisiert 18.10.2012, 3397 Aufrufe, 10 Kommentare

Problemchen mit den Routen von Server 2k3 und der Netzwerkonfiguration.

Hi, ich hab ihr ein Problem mit dem Serverrouting von Win Server 2k3 bzw. den Routen.
Auf dem folgendem Bild hab ich die Problematik und Fragestellung dargestellt. Ich hab schon so ziemlich alles versucht und gelesen, komme aber auf keinen grünen Zweig.

Bild: 5e89dd0355c12880fb29127d0c952ede-netzwerk - Klicke auf das Bild, um es zu vergrößern

Im Vorraus vielen Dank für gute Tips und oder/ Umsetzungen.

Freundliche Grüße

gido
Mitglied: aqui
26.07.2007 um 11:54 Uhr
Die Lösung dazu ist recht einfach:

Als Leitfaden hilft dir dies Tutorial:

http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...

Folgende Punkte musst du beachten:

  • Deine VMware Maschine mit XP rennt ja vermutlich auf dem Server und du hast dessen virtuelle NICs auch richtigerweise (hoffentlich ?!) in den Bridging Modus gesetzt, damit diese per Layer 2 Bridging in ein und demselben IP Netz ist wie der Server selber. VMware und ServerLAN sind virtuell also im selben IP Segment, was auch richtig ist. Wenn sie wieder Erwarten im NAT Modus (Adress Translation) arbeiten funktioniert das Design NICHT ! Der Modus der VMware NIC Karten ist also essentiell wichtig im Host System !!! Ein Ping innerhalb des LAN Segments zur VMware Maschine und vice versa sollte das einwandfrei verifizieren !!!

  • Der Server selber benötigt keinerlei Routing Einträge, denn er ist an beiden Netzen physisch selber angeschlossen, kennt also komplett die gesamte IP Topologie so das Routen hier vollkommen überflüssig sind !!

  • Einstellungen in der Vmware Maschine: IP Adresse: 192.168.168.22, Maske:255.255.255.0, Gateway: 192.168.168.249, DNS-Server: 192.168.0.254 (Der Router ist ja proxy DNS !)

  • Einstellungen der LAN Karte im Server: IP Adresse: 192.168.168.249, Maske:255.255.255.0, Gateway: leer lassen, DNS-Server: leer lassen

  • Einstellungen der WAN Karte im Server: IP Adresse: 192.168.0.54, Maske:255.255.255.0, Gateway: 192.168.0.254, DNS-Server: 192.168.0.254

  • * Einstellungen des Routers: IP Adresse: 192.168.0.254, Maske:255.255.255.0. Achtung: Der Router muss unbedingt eine zusätzliche statische Route konfiguriert haben wie es in dem o.a. Dokument/Tutorial genau beschrieben ist !!! Die Route im Websetup des Routers unter zusätzliche statische Routen etc. MUSS lauten: Zielnetz: 192.168.168.0, Maske: 255.255.255.0, Gateway: 192.168.0.54 !!! Ohne diese Route funktioniert dies Szenario nicht !!!

Alles andere findest du detailiert im o.a. Tutorial beschrieben.
Das der Server natürlich aktiviert sein muss für RAS/Routing sollte klar sein, denn sonst routet er nicht und nichts geht !!!
Bitte warten ..
Mitglied: gido1337
26.07.2007 um 12:11 Uhr
Super vielen Dank für die schnelle Antwort, also kann ich getrost auf meinem "Windows Server 2003 -Server" das Routing und Ras ausmachen und einfach auf meinem WAN Router die beschriebene Route hinzufügen ?, oder müsste das nicht auch funktionieren wenn ich die Route nur auf derm Server 2003-Server einrichte und es auf dem WAN Router außen vor lasse ?!

Zu den VM Karten, ich hab auf dem "Windows Server 2003 - Server" die LAN-Karte nicht im Bridge-Modus, stattdessen hab ich die virtuelle Karte auf der VM als "host-only" konfiguriert, d.h. die Karte ist im Netzwerk bekannt. Der Ping von Server-LAN-Karte zu den VM-LAN-Karte funktioniert, auch ohne die Bridgefunktion.

Ok, das blieb mir noch offen. Ich hoffe das ist verständlich genug ausgedrückt.

MfG

gido
Bitte warten ..
Mitglied: aqui
26.07.2007 um 12:16 Uhr
Nein, Routing und RAS darfst du NICHT deaktivieren !!! Denn es müssen ja noch Packete durch den Server durch. Er muss ja vom 192.168.0.0er Segment Packete in das 192.168.168.0er Segment forwarden. Das würde er nicht tun wenn RAS/Routing deaktiviert ist.
Dann sind die NICs lediglich 2 Zugangsinterface zum Server aber er würde keine Packete forwarden. Das muss also unbedingt aktiviert bleiben !!!

Mit dem Modus der NIC in der VMware ist ok. Sofern du von der VMware maschine die 192.168.168.249 und die 192.168.0.54 pingen kannst ist alles OK ! Ein ping auf diese beiden Adressen des Servers MUSS möglich sein um das Szeanrio zum Laufen zu bringen !!!
Bitte warten ..
Mitglied: gido1337
27.07.2007 um 15:24 Uhr
Echt super nice, Vielen Dank für deine Hilfe, dass hat mich ein gutes Stück nach vorne gebracht.
Ich konnte bis jetzt nicht mehr daran weiter machen, allerdings bleibt mir noch ein Frägchen offen:

Also hab alles soweit, kann die 2 Karten auf dem Server Pingen usw. allerdings hab ich die Route auf dem Router noch nicht eingetragen und ich brauch ja von der VM Zugang zum Inet-GW,damit das Netz darauf geht. Öffnet die besagte Route dann für die VM den I-Net Gateway ?

Mit freundlichen Grüßen

Gido
Bitte warten ..
Mitglied: aqui
28.07.2007, aktualisiert 18.10.2012
Ja ! Die Route ist essentiell wichtig, sonst funktioniert das gesamte Konstrukt nicht !!!

Ggf. hilft dieser Thread dir zusaetzlich, denn der beschreibt einen Packet Weg vom VM (Client) zum Router und vice versa. Damit wird die Funktion dieser Route transparent:

http://www.administrator.de/forum/internetrouter-nicht-erreichbar%2c-ab ...
Bitte warten ..
Mitglied: gido1337
30.07.2007 um 08:42 Uhr
Ok, wunderbar Verstanden hab ich das ganze, jetzt noch abschließend eine Frage, ist es nicht ein bischen unsicher wenn ich auf dem Internet Router, diese Route eintrage, als erste Schnittstelle zum Netz ?

Und nochmal vielen lieben Dank für deine sehr kompetene und nette Hilfe aqui !
Bitte warten ..
Mitglied: aqui
30.07.2007 um 18:41 Uhr
Nein, keineswegs ist das unsicher, denn der Router hat eine interne NAT Firewall. Die zu überwinden ist technisch nicht oder nur sehr schwer möglich (sofern du alles wasserdicht gemacht hast wie z.B. UPnP abgeschaltet etc.).
Außerdem benutzt du private IP Adressen nach RFC 1918 die im Internet nicht geroutet werden, diese tauschen also niemals öffentlich auf. Die Route wirkt einzig und allein NUR auf deine lokalen Netze !

Du kannst also davon ausgehen, das dein Netzwerk oder besser deine Netzwerke sicher sind was den Zugang von außen anbetrifft.

Wenns das war bitte
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Mitglied: gido1337
31.07.2007 um 09:12 Uhr
Ok mittlerweile stellt sich ein weiteres Problem heraus, es hat sich herausgestellt, dass der aktuelle Internetrouter nicht ausreichend ist für das anliegende WAN, Mein Chef hat kurzer Hand nen neuen Router gekauft der natürlich nicht routen kann. Jetzt sieht das Szenario wie folgt aus, dass ich eben 2 Router im Netzwerk hab:

Router 1: 192.168.0.254 (Internet)
Mask: .....


Router 2: 192.168.168.99 (LAN - Soll Routen für die VM um der VM I-Net zu ermöglichen )
--Nur mit diesem Router kann man Routen anlegen !!--



Client 1: Win 2k3 Server
Karte 1:
192.168.0.54
Mask .....
GW: Router 1
DNS Router 1
Karte 2:
192.168.168.249
Mask ....
GW: ---
DNS: ---



Client 2: WinXP Pro auf VM-Ware, installiert auf dem Client 1
VM NIC
192.168.168.22
Mask ....
GW: 192.168.0.254
DNS " . " ." ."

Das konkrete Problem: Nur auf Router 2 kann man eigene Routen anlegen. Der Rest müsste soweit klar sein, ist ja durch vorhergehendes selbsterklärend.

Kann man das irgendwie verwirklichen ?

Freundliche Grüße

gido1337
Bitte warten ..
Mitglied: aqui
01.08.2007 um 17:37 Uhr
Nein, das wird nicht gehen.
Was geht steht hier:
http://www.administrator.de/Kopplung_von_2_Routern_am_DSL_Port.html

Warum nur um alles in der Welt hat dein Chef dich nicht vorher gefragt ??? Scheinbar ist ihm ja seine Firmen EDV ziemlich egal und spielt in sener Wichtigkeit keine Rolle oder wieso informiert er sich nicht vorher...komischer Chef ?!

Ein neuer anständiger Router der problemlos statische Routen kann kostet 50 Euro. Es kann ja nicht sein das dein Chef das Projekt an sowas scheitern lässt...oder betreibt er eine Würstchenbude ???
Das erspart dir eine unendliche Frickelei und Fehlergefahr.
Leider schreibst du nicht welches Produkt er erworben hat (vermutlich D-L... ) Ggf. gibt es dafür ein alternatives Image das diese Standardfunktion dann unterstützt...
Bitte warten ..
Mitglied: gido1337
02.08.2007 um 14:09 Uhr
Ja mein Chef ist leider ein Kapitel für sich... ne Würstchenbude wäre wohl passend... nene der hat so ein total verschundenes Teil von T-Offline gekauft...Ok danke für die Hilfe ) echt super von dir... Mal sehen wie ich das umsetzen kann ;)
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Windows Server 2003 unter HyperV 2012 R2: Keine Maus (2)

Frage von StefanMUC zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2003 DNS Server - Ping auf Subdomain nicht möglich in windows 7 (15)

Frage von aif-get zum Thema Windows Server ...

Neue Wissensbeiträge
Administrator.de Feedback

Umgangsformen auf der Seite

(3)

Information von Frank zum Thema Administrator.de Feedback ...

Windows 10

Windows 8.x oder 10 Lizenz-Key aus dem ROM auslesen mit Linux

(10)

Tipp von Lochkartenstanzer zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Exchange Server
gelöst RU 17 Exchange 2010 . Erfahrungen? (11)

Frage von keine-ahnung zum Thema Exchange Server ...

Windows Server
Festplatten Ruhezustand Windows Server 2016 (10)

Frage von ahaeuser zum Thema Windows Server ...

Datenbanken
gelöst MySQL Zeiterfassungs-Problematik (wer ist eingecheckt) (9)

Frage von NativeMode zum Thema Datenbanken ...