Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing über Windows Server 2008 mit 2 unterschiedlichen IPs

Frage Netzwerke Router & Routing

Mitglied: mechatrox

mechatrox (Level 1) - Jetzt verbinden

24.07.2009, aktualisiert 18.10.2012, 9173 Aufrufe, 12 Kommentare

Hallo,
ich habe schon bei diversen Suchmaschinen geschaut, auch hier im Forum, aber leider nichts vergleichbares gefunden. Es geht um folgende Konsterlation:

Einer VM (auf einem ESXi) Windows 2008 Enterprise wurden 2 Netzwerkkarten zugeordnet mit folgenden Netzbereichen:

IP-Netzbereich 1
Eigene IP: 192.168.1.102
IP-Bereich: 192.168.1.0-255
Subnetz: 255.255.255.0
Gatw/Proxy/Firewall/Router/DHCP: 192.168.1.254
Windows Domäne: ja

IP-Netzbereich 2
Eigene IP: 192.168.100.192
IP-Bereich: 192.168.100.0-255
Subnetz: 255.255.255.0
DHCP/Gateway: 192.168.100.1
Windows Domäne: nein

Auf dem Server komme ich ohne Probleme ins 1er und ins 100er Netz.

Ich möchte aber von einem Rechner aus dem 1er Netz ins 100er Netz zugreifen und bekomme es nicht geregelt das Routing (oder was auch immer) richtig einzustellen.

Hier ist mein Problem:
Auf einem Rechner im 0er Netz habe ich die Route "route add 192.168.100.0 mask 255.255.255.0 192.168.1.102" eintragen
Wenn ich jetzt ein Traceroute auf ein Rechner im 100er Netz starte, dann komme ich zur IP 192.168.1.102 aber der Server möchte die Anfrage nicht weiterleiten.

Auf dem Server habe ich folgende Route(n) eingerichtet und erprobt:
"route 192.168.100.0 mask 255.255.255.0 192.168.1.254"
"route 192.168.100.0 mask 255.255.255.0 192.168.1.102"
"route 192.168.100.0 mask 255.255.255.0 192.168.100.192"
"route 192.168.100.0 mask 255.255.255.0 192.168.100.1"

aber leider führt keine zum Ziel.

Was mache ich falsch?

Vielen Dank im Voraus für eure Vorschläge!

Gruß

Peter
Mitglied: Stru4ok
24.07.2009 um 10:45 Uhr
Sers,

kann es sein das du die RAS-Weiterletung auf dem Server nicht eingerichtet hast?

Start->Programme->Verwaltung->Routing und RAS.

(Der dienst Windows-Firewall/Gemeine nutzung... muss deaktivert werden und starttyp auf deaktiviert gesetzt werden)

Bei der Konfiguration sollte die Option "Sichere Verbindung zwischen 2 privaten Netzwerken herstellen" vorhanden sein.
Bitte warten ..
Mitglied: mechatrox
24.07.2009 um 11:56 Uhr
Firewall ist deaktiviert!

wo finde ich dann die Option "Sichere Verbindung zwischen 2 privaten Netzwerken herstellen"?
Bitte warten ..
Mitglied: aqui
24.07.2009 um 12:14 Uhr
Hast du oben einen Dreckfuhler gemacht ??

Der Netzwerkbereich 1 und 2 ist in einem und denselben IP Netzwerk (192.168.1.0 /24) das geht natürlich nicht, denn damit ist ein Routing vollkommen unmöglich !

Vermutlich sollte wohl beim IP-Netzbereich 2 als Eigene IP: 192.168.100.192 stehen....richtig ??

Was meinst du mit dem 0er Netz ??? So ein Netz ist bei dir gar nicht existent !!
Du hast ja nur die 192.168.1.0 /24 und die 192.168.100.0 /24 als IP Netze also mit deiner Sprache dann gesprochen ein 1er Netz und ein 100er Net z !
Ein
0er// Netz hätte ja dann die 192.168.0.0 /24 die es aber nicht gibt, das ist also etwas verwirrend !

Generell muss KEIN Routing eingetragen werden, denn die beiden Adapter sind ja direkt am Server angeschlossen so das dieser die Netze kennt. Routing ist also Blödsinn da. Ebenso deine sinnlosen Routing Einträge und deshalb führen sie dich auch nicht zum Ziel !!

Relevant ist was du zum Server für einem Moduseingtragen hast. Dieser muss auch 2 physische Netzwerkkarten haben und dort muss ein Bridging im Netzmodus aktiviert sein.

Hast du nur einen Adapter kannd er Server dann nur NAT oder ein Hostmodus aktivieren. Bei NAT ist es klar das es nicht klappt, denn dann kannst du die NAT Firewall nicht überwinden. Im Host Modus müsste der Host dann selber ein Routing zwischen den Adaptern supporten, was er aber so nicht macht.
Du musst also schon etwas mehr Information liefern, sonst kann man dir nur mit Raten oder in die Kristallkugel sehen helfen
Bitte warten ..
Mitglied: mechatrox
24.07.2009 um 12:16 Uhr
ja Duckrfehler
192.168.100.192 ist die richtige IP

mit 0er Netz meine ich folgendes Netz: 192.168.1.xxx
hab mich wieder verschrieben sorry
Bitte warten ..
Mitglied: aqui
24.07.2009, aktualisiert 18.10.2012
OK, dann check was oben steht, damit sollte es dann problemlos laufen !!

Ggf. hilft dir noch dieses Tutorial was 2 Netzwerkkarten anbetrifft:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Bitte warten ..
Mitglied: mechatrox
24.07.2009 um 12:55 Uhr
gibt es eine Anleitung wie ich das Bridging aktiviere beim Windows Server 2008 Enterprise oder kannst du mir erläutern wie ich das mache?
danke
Bitte warten ..
Mitglied: aqui
24.07.2009 um 13:08 Uhr
Nein das Bridging bezog sich auf die VMWare !!! NICHT auf die VM selber. Da dort 2 Netzwerkkarten aktiv sind müssen die in 2 unterschiedlichen IP Segmenten arbeiten...das ist schon richtig.

Nur der VMware Host selber, die ESXi Maschine hat ja auch vermutlich 2 Netzwerkkarten die im Bereich NIC1: 192.168.1.0 und NIC2: 192.168.100.0 arbeiten.
D.h. die VM miss die virtuelle Karte VMnet mit der 192.168.1.0 auf die NIC1 bridgen und ebenso die VMnet2 auf die NIC2 mit der 192.168.100.0 bridgen.
Die Bridging Option stellst du in den VMware Host Settings ein !! Dort steht eine VMnet Verbindung in der Regel im Host Modus...das müsstest du ändern !!
Bitte warten ..
Mitglied: mechatrox
24.07.2009 um 13:56 Uhr
das geht leider nicht, weil im 1er Netz ein Domaincontroller läuft.
D.h. die einzige Möglichkeit die mir bleibt ist diese Route oder was auch immer über den einen Server zu bewerkstelligen der in beiden Netzen eingebunden ist.

Beide Netze besitzen jeweils einen DHCP
Bitte warten ..
Mitglied: aqui
24.07.2009 um 16:01 Uhr
Nur nochmal zum Verständnis bevor es wieder missverständlich wird...:
Ist der Win2008 Server der VmWare Host selber oder ist das ein VM auf dem Server ?
Bitte warten ..
Mitglied: mechatrox
24.07.2009 um 16:13 Uhr
der Win2008 Server ist eine VM auf einem ESXi mit keiner großen Bedeutung. Dieser soll nur für das Routing zuständig sein, falls es klappt.
Im 100er Netz sind nur SNOM Telefone, die über das 1er Netz via WebBrowser zugänglich sein sollen.
Im 1er Netz sind nur PCs, Server usw. anzufinden...
Domaincontroller, Firewall, DHCP usw. sind auf anderen Rechner verteilt die im 1er Netz sind.
Bitte warten ..
Mitglied: aqui
24.07.2009 um 16:41 Uhr
Ganz schöner Aufwand einen kompletten 2008er Server nur als dummen 2 Port Router laufen zu lassen. Das hätte auch ein 20 Euro Baumarkt Router geschafft aber warum einfach machen wenn es umständlich auch geht.

So sieht dein Szenario aus:

b8fd1b6ee3fbd893fec94a9c871a288d-vm_rou - Klicke auf das Bild, um es zu vergrößern

Es darf keine Routing zwischen den physischen NICs des ESXi geben ! Auf der VM muss Routing und RAS aktiviert sein und die ESXi muss Bridging machen zwischen den virtuellen und physischen NIC Pärchen.

So kommen die Telefone nur über den 2008er Router ins .1er Netz.

Klingt ziemelich "von hinten durch die Brust ins Auge..." das Konzept aber du hast da sicher deine Gründe ?!
Bitte warten ..
Mitglied: aqui
02.08.2009 um 15:24 Uhr
Wars das jetzt ??
Dann bitte auch:
http://www.administrator.de/index.php?faq=32
nicht vergessen !
Bitte warten ..
Ähnliche Inhalte
Windows Server
Windows Server 2008 - Routing und Ras
gelöst Frage von KlaraFallWindows Server7 Kommentare

Hallo alle zusammen, wir sind gerade dabei, den als VPN-Server genutzten Server 2003 durch einen Server 2008 zu ersetzen. ...

Windows Installation
RemoteDesktop Services - Verbindung zum Backend Server mit unterschiedlichen IPs
gelöst Frage von nutzloser-userWindows Installation4 Kommentare

Hi Community, ich suche nach einer Lösung für unser ERP-System. Ich möchte gerne die ERP Software auf einem Terminalserver ...

Server
Ping an eine Domain: Zwei unterschiedliche IPs
Frage von frilooServer2 Kommentare

Hallo, ich habe einen Server der auf Plesk läuft. Dort habe ich den A- und den MX-Record geändert. Mir ...

Virtualisierung
VirtualBox unterschiedliche IPs für Host und VM
Frage von deckard2019Virtualisierung5 Kommentare

Hallo, ich habe eine Frage bezüglich VirtualBox. Ich würde gerne Windows 10 in einer VM betreiben und überlege nun, ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 8 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 12 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware8 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...