Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing unter Xen - domUs können nicht kommunizieren

Frage Linux Linux Netzwerk

Mitglied: Enclave

Enclave (Level 2) - Jetzt verbinden

26.07.2010 um 17:47 Uhr, 4379 Aufrufe, 1 Kommentar

Hallo alle zusammen,

ich habe es nun endlich hinbekommen, dass Xen routing auf meinem Hetzner EQ 4 einzurichten. Es funktioniert auch alles soweit außer, dass die domUs untereinander nicht kommunzieren können:

dom0 => domU (PASSED)
Internet => domU (PASSED)

domU => dom0 (PASSED)
domU => Internet (PASSED)
domU => domU (FAILED)


Ich denke einfach mal ich muss auf der dom0 diverse Routen definieren nur wüsste ich nicht wirklich wie. Eigentlich gibt es aber auch schon routen:

01.
root@ppps-debian-02-d0:~# route -n 
02.
Kernel IP routing table 
03.
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 
04.
88.xx.xx.123   0.0.0.0         255.255.255.255 UH    0      0        0 vif2.0 
05.
88.xx.xx.122   0.0.0.0         255.255.255.255 UH    0      0        0 vif1.0 
06.
88.xx.xx.97    0.0.0.0         255.255.255.255 UH    0      0        0 eth0 
07.
78.xx.xx.162    0.0.0.0         255.255.255.255 UH    0      0        0 vif3.0 
08.
0.0.0.0         88.xx.xx.97    0.0.0.0         UG    0      0        0 eth0
Die interfaces auf dom0:
01.
root@ppps-debian-02-d0:~# cat /etc/network/interfaces 
02.
### Hetzner Online AG - installimage 
03.
# Loopback device: 
04.
auto lo 
05.
iface lo inet loopback 
06.
 
07.
# device: eth0 
08.
auto  eth0 
09.
iface eth0 inet static 
10.
  address   88.xx.xx.113 
11.
  netmask   255.255.255.255 
12.
  gateway   88.xx.xx.97 
13.
  pointopoint 88.xx.xx.97
Die interfaces auf einer domU:
01.
root@ppps-debian-02-d1:~# cat /etc/network/interfaces 
02.
# The loopback network interface 
03.
auto lo 
04.
iface lo inet loopback 
05.
 
06.
# The primary network interface 
07.
auto eth0 
08.
iface eth0 inet static 
09.
 address 88.xx.xx.122 
10.
 netmask 255.255.255.255 
11.
 gateway 88.xx.xx.113 
12.
 pointopoint 88.xx.xx.113 
13.
  
14.
  
15.
 # post-up  ethtool -K eth0 tx off 
16.
 
17.
18.
# The commented out line above will disable TCP checksumming which 
19.
# might resolve problems for some users.  It is disabled by default 
20.
#
Hat da jemand eine Idee, denn der interne Verkehr ist irgendwie sehr wichtig ?


Mfg

Enclave
Mitglied: Enclave
30.07.2010 um 13:13 Uhr
Das Problem war, dass Xen zusätzliche IPs nicht automatisch routed, also man muss sie manuell in der /etc/network/interfaces auf der dom0 hinzufügen:
01.
up route add -host 88.xx.xx.124 vif2.0
Desweiteren war durch die Umstellung auf Pointopoint-verbindungen die Subnetzmaske der zusätzlichen IPS falsch...


Mfg

Enclave
Bitte warten ..
Ähnliche Inhalte
Backup
gelöst XEN Server Backup (8)

Frage von certifiedit.net zum Thema Backup ...

Virtualisierung
gelöst Interne Netzwerke untereinander kommunizieren lassen (9)

Frage von chelewae zum Thema Virtualisierung ...

SAN, NAS, DAS
Xen und ESXi VMs auf einem NAS sichern? (10)

Frage von WinLiCLI zum Thema SAN, NAS, DAS ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 im Unternehmen? (26)

Frage von zorlayan zum Thema Windows 10 ...

LAN, WAN, Wireless
Ping u. DNS geht am Rechner nicht mehr (19)

Frage von Kuemmel zum Thema LAN, WAN, Wireless ...

Festplatten, SSD, Raid
Raid 1 2 SSD mit Windows Server 2016 (17)

Frage von jaywee zum Thema Festplatten, SSD, Raid ...

Voice over IP
Über Fritzfax over IP gehen nur einige Faxe (12)

Frage von shearer9 zum Thema Voice over IP ...