Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing zweier Subnetze mit Windows Server 2012 R2

Frage Microsoft Windows Netzwerk

Mitglied: DonMatze

DonMatze (Level 1) - Jetzt verbinden

05.09.2014 um 03:12 Uhr, 2451 Aufrufe, 12 Kommentare

Moin moin,

ich habe leider noch keine Antwort auf meine Frage gefunden, deswegen stelle ich sie mal. Mit der Kategorie bin ich mir nicht ganz sicher, zwei konnte ich leider nicht auswählen, da ich aber mit Microsofts Server rum hantiere, denke ich passt das hier schon.

Kernpunkt meiner (virtuellen-) Infrastruktur ist ein Windows Server 2012 R2 mit zwei Interfaces.
Die Subnetze sind 10.0.2.0/24 und 192.168.0.0/24. Die Interfaces haben die IP Adressen 10.0.2.15 ("ExternesNetz") und 192.168.0.1("InternesNetz").
An das 192er Subnetz ist der DHCP Service gebunden.
Unter der IP 10.0.2.2 befindet sich ein NAT Router, der am Internet hängt.

Nun habe ich die RAS Rolle installiert und dort LAN Routing aktiviert. Nun sollten eigentlich beide Subnetze mit einander kommunizieren können.
Ein Ping vom Client 192.168.0.51 an 10.0.2.15 funktioniert. Jedoch kann ich vom besagten Client den NAT Router (10.0.2.2) nicht anpingen. Ein Ping vom Server aus funktioniert.

Statische Routen führten mich nicht zum Erfolg.
Vom Interface "InternesNetz" wurde Folgende Route eingerichtet: Destination: 10.0.2.0, Netzwerkmaske: 255.255.255.0, Gateway: 10.0.2.15
Vom Interface "ExternesNetz" wurde Folgende Route eingerichtet: Destination: 192.168.0.0, Netzwerkmaske: 255.255.255.0, Gateway: 192.168.0.1

Ein Blick mit Wireshark unter die Haube brachte folgendes zu Tage. ARP vom Client (192.168.0.51) nach 10.0.2.2 funktioniert. Versucht 10.0.2.2 jedoch auf den ICMP Ping zu reagieren, lässt sich die IP Adresse des Clients nicht per ARP auflösen. Eine Antwort auf die ARP Anfrage bleibt aus.
Wireshark meldet dann natürlich die Warnung "no response found!".

Wenn ich LAN Routing verwerfe und stattdessen NAT Routing benutze, geht es in Richtung 10.0.2.2 und Internet funktioniert auch. Aber das ist nur unidirektional und es soll halt in beide Richtungen funktionieren.


Ich hoffe ihr könnt mir da weiter helfen.
Falls ihr noch mehr Infos braucht, meldet euch ruhig.


Viele Grüße
Matze
Mitglied: Dani
05.09.2014 um 08:01 Uhr
Guten Morgen Matze,
dazu hat Kollege @aqui eine ausgezeichnete Anleitung geschrieben.


Gruß,
Dani
Bitte warten ..
Mitglied: colinardo
LÖSUNG 05.09.2014, aktualisiert 09.09.2014
Hallo Matze,
kurz und knapp: die Routen auf dem Server kannst du alle in die Tonne kloppen, die braucht es nicht, da der Server ja beide Netze kennt. Du benötigst nur eine statische Route auf dem Gateway im 10.0.2.x Netz die für das 192.168.0.x Netz deinen Server als Gateway ausweist, wenn du kein NAT machen willst. Denn sonst finden die Pakete den Weg nicht zurück in dein Netz.

Grüße Uwe
Bitte warten ..
Mitglied: aqui
05.09.2014, aktualisiert um 09:41 Uhr
Halte dich an das o.a. genannte Forumstutorial, das beantwortet alle deine Fragen zu dem Thema:
http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Statische Routen sind NICHT erforderlich in so einem Design und auch kontraproduktiv !
Wie immer bei solchen Threads hier hast du vermutlich die statische Route auf dem NAT Router vergessen sofern du kein NAT am Server machst ?!


Wenns da denn war
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Mitglied: Dobby
05.09.2014 um 09:40 Uhr
Hallo,

ich würde entweder das Routing an dem Server selber aktivieren oder aber einfach einen
kleinen MikroTik Router davor setzen der das Routing übernimmt, fertig.


Gruß
Dobby
Bitte warten ..
Mitglied: Lochkartenstanzer
05.09.2014 um 10:25 Uhr
Zitat von DonMatze:

Ein Ping vom Client 192.168.0.51 an 10.0.2.15 funktioniert. Jedoch kann ich vom besagten Client den NAT Router (10.0.2.2) nicht
anpingen. Ein Ping vom Server aus funktioniert.

Wie die Kollegen schon sagten: Solange der NAT-Router nicht weiß, wo das andere Netz liegt, wird er die Pakete an seinen default-router schicken, der dann irgendwo im "Internet" liegt.

Statische Routen führten mich nicht zum Erfolg.

Die würden dich zum Erfolge führen, wenn Du diese auf dem richtigen Router, nämlich dem NAT-Router setzen würdest. Auf der Windowskiste brauchst Du keine statische Route, weil die ja beide Netze kennt.

Also: aquis Anleitung durchackern und alles wird gut.

lks
Bitte warten ..
Mitglied: DonMatze
05.09.2014 um 16:25 Uhr
Moin moin,

die ganze Infrastruktur existiert nur virtuell, 10.0.2.2 ist das Gateway von VirtualBox. Ich denke nicht, dass ich das konfigurieren kann.

Also bleibt nur die NAT Lösung über?
Die hatte ja zumindest funktioniert.


Vielen Dank für die ganzen Antworten!


Viele Grüße
Matze
Bitte warten ..
Mitglied: colinardo
05.09.2014, aktualisiert um 19:44 Uhr
mach uns doch mal eine Skizze deines Netzwerks, dann ist das ganze schnell abgehandelt.
Bitte warten ..
Mitglied: Dobby
05.09.2014 um 19:38 Uhr
Zitat von colinardo:

nach uns doch mal eine Skizze deines Netzwerks, dann ist das ganze schnell abgehandelt.
Das wäre mal etwas für den Anfang gewesen!

die ganze Infrastruktur existiert nur virtuell, 10.0.2.2 ist das Gateway von VirtualBox.
Na der kam ja früh rüber.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
05.09.2014 um 22:13 Uhr
Ich denke nicht, dass ich das konfigurieren kann.
Doch, auch virtuell ist das völlig frei konfigurierbar...auch ohne NAT. Im Hypervisort (Virtual Box) ist das immer der Bridge Mode.
Bitte warten ..
Mitglied: DonMatze
06.09.2014 um 00:41 Uhr
Moin,

vielen Dank für die hilfreichen Kommentare!
Das mit der virtuellen Infrastruktur habe ich verpeilt! Sorry dafür.

Ich wünsche euch erst mal ein schönes Wochenende, ich kümmere mich am Montag drum.


Viele Grüße
Matze
Bitte warten ..
Mitglied: aqui
06.09.2014 um 12:05 Uhr
Wenns das denn war bitte dann auch
http://www.administrator.de/faq/32
nicht vergessen !
Bitte warten ..
Mitglied: DonMatze
09.09.2014 um 15:59 Uhr
Moin moin,

ich werde noch einen virtuellen Router einbringen, den ich konfigurieren kann. Somit kann ich die statische Rückroute einrichten!

Vielen Dank für eure Hilfe und FAQ32 vergesse ich natürlich nicht ;).


Viele Grüße
Matze
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Routing und Ras bei Windows Server 2012 R2 (12)

Frage von BlacksGood zum Thema Windows Server ...

Windows Server
Windows Server 2012 R2 Benutzerkonto für Zugriff auf AD Benutzer (2)

Frage von JulianOhm zum Thema Windows Server ...

Hyper-V
Windows Server 2012 R2 NIC Teaming mit Lancom Switch (3)

Frage von onkel87 zum Thema Hyper-V ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...