Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

routing zwischen zwei teilnetzen möglich?

Frage Netzwerke Router & Routing

Mitglied: Ratzeck

Ratzeck (Level 1) - Jetzt verbinden

18.02.2009, aktualisiert 22:21 Uhr, 5840 Aufrufe, 14 Kommentare

Hallo,

ich habe vor mein LAN in nächster zeit ein wenig auszubauen. U.a. möchte ich eine verbindung zum LAN des Nachbarn auf der anderen straßenseite herstellen.



Ich stelle mir das so vor:

LAN1 (192.168.0.x) <---->ROUTER <------> Wlan AccessPoint1 <
>WlanBridge<
>Wlan AccessPoint2<----->LAN2 (192.168.1.x)



LAN1 stellt dabei mein Netzwerk da, LAN2 das des Nachbarn. Beide LANs sind autark und verfügen bereits über einen Router für die DSL-Verbindung (LAN1:VigorPro5500; LAN2:Fritz!box, weiß nicht genau welche, ca. 3Jahre alt).
Es soll also zwischen den zwei Teilnetzen über eine WLANBridge geroutet werden, so dass alle clients neben dem eigenen Teilnetz auch auf das jeweils andere zugreifen können, aber weiterhin die jeweils eigene Internetverbindung nutzen.

Ich habe noch einen älteren Netgear FVS124G router herumliegen. Wäre es möglich diesen als Router für die WLANBridge zu nutzen und welche Accesspoints sind dafür zu empfehlen?
Und ist mein Vorhaben so überhaupt möglich?


Danke im voraus für eure Antworten,
Grüße,
Ratzeck
Mitglied: schiffmeister
19.02.2009 um 16:03 Uhr
Hi,
sind
  1. Wlan AccessPoint1
  2. WlanBridge
  3. Wlan AccessPoint2
im Netz deines Nachbarn? Dann klappt das wohl locker.
Der Router hat auf deiner Seite eine IP aus LAN1 und auf der anderen Seite eine aus LAN2, genauso wie die das andere WLAN-Gedöns.
Die AccessPoints können ja nicht routen, da sie keine Router sind und nur ein Bein in einem bestimmten Netz haben können.

Im Prinzip kannst du jeden AP nehmen. Du musst nur ein paar Kleinigkeiten beim Einrichten beachten:
Ca. 6 Kanäle unterschied zwischen den Empfangsbereichen der AP's (Kanal 1 -> Kanal 7 -> Kanal 13)
Alle müssen die selbe SSID haben
Bitte warten ..
Mitglied: Ratzeck
19.02.2009 um 22:17 Uhr
Guten Abend,

Ich hab das ganze jetzt mal experimentell mit einem 3. Routern, also ohne wlan-Bridge, realisiert. So sieht's jetzt aus:

Router1/LAN1<---->Router2<---->Router3/LAN2

Router1/Lan1:
192.168.0.1/255.255.255.0

Router2:
am Lan-Interface mit LAN1 verbunden: 192.168.0.7/255.255.255.0

Am WAN1-Interface mit LAN2
verbunden:192.168.1.2/255.255.255.0/Gate:192.168.1.1

Router3/Lan2:
192.168.1.1/255.255.255.0

StaticRoutes:

Router1/2:
1 nach 3: Destination:192.168.1.0/255.255.255.0 Gate:192.168.0.7

Router2/3:
3 nach 1:
Destination:192.168.0.0/255.255.255.0 Gate:192.168.1.2


Geht aber trotzdem nicht. Was läuft falsch?
Bitte warten ..
Mitglied: schiffmeister
20.02.2009 um 08:12 Uhr
Also der Aufbau der Hardware liest sich für mich logisch, die Routen auch.

Sieht doch in etwa so aus wenn ich das richtig verstanden hab, oder:
http://img264.imageshack.us/my.php?image=netdiag1jk8.jpg

Kannst du auf den Router ein Ping absetzen, oder gibt das die Firmware der Router nicht her?
Denn ich denke mal, du kannst zur Zeit nicht zwischen den Clients pingen die am jeweiligen anderen Ende sind, gell?
Firewallregeln sind alle deaktiviert zum testen auf Router2?
Welche Router kannst du von einem Client aus LAN1 erreichen und welche Router kannst du aus LAN2 erreichen?
Bitte warten ..
Mitglied: aqui
20.02.2009 um 17:06 Uhr
Um zu routen musst du aber auch routen können über den WLAN Link !!

Du gibst oben aber an das du Accesspoints benutzt mit einer WLAN Bridge !!!

Wie du ja sicher selber weisst ist bridging einen Trennung der Netze auf dem OSI Layer 2 also den MAC Adressen.
Damit ist dann dein Konzept von oben natürlich Unsinn, denn dann müssen dein LAN und das des nachbarn in einem IP Segemnt liegen !!

Du musst also zwangsweise noch einen separten Router benutzen um die Netze zu trennen nach der WLAN Bridge.
Um den Aufwand in Grenzen zu halten kannst du einen WLAN Router mit Rchtantenne benutzen der WISP supportet und dich somit direkt im WLAN des nachbarn einzuklinken.

Das geht aber nur wenn du das WLAN des Nachbarn sehen kannst über die Richtantenne !
Router die WISP können sind z.B. diese hier:
http://www.21byte.de/pro-267c14/AP__Repeater/80211g_Multi-funktion_WLAN ...
http://www.alternate.de/html/product/Netzwerk_WLAN-Router/TP-LINK/TL-WR ..?
und andere...

Das wäre die einfachste Variante !

Die andere Möglichkeit ist die einen WLAN Bridge zu realisieren wie z.B. hier beschrieben:

http://www.dd-wrt.com/dd-wrtv2/downloads/Documentation/German_WLAN_HowT ...

und diese Bridge dann an einen WAN Port einen DSL Routers zu hängen der KEIN integriertes Modem hat also 2 RJ-45 Ports hat und sich am WAN/DSL Port auf eine statische IP Adresse konfigurieren lässt !!

Beide Lösungen könnten dann so aussehen:

6436f9f8104b7a22546ce73e478c6e1a-rifu-link3 - Klicke auf das Bild, um es zu vergrößern

Bei Richtantennen wirst du hier fündig:

http://www.wimo.de/wlan-richtantennen-aussen_d.html
http://www.wimo.de/wlan-richtantennen-innen_d.html

Was noch wichtig ist: Du musst auf den jeweiligen lokalen DSL Routern eine statische Route auf die jeweiligen Netze mit next Hop auf den Nachbarnetz Router eintragen, damit diese netze lokal geroutet werden und nicht ins Internet !
Das ist dir aber vermutlich selber klar !!??
Bitte warten ..
Mitglied: Ratzeck
20.02.2009 um 18:16 Uhr
Hallo,

danke erstmal für die Schemata!

@aqui
Es soll letztendlich so aussehen, wie dein zweites Schema, also mit Bridge.
Das ganze aus dem einfachen Grund, da ich das Wlan des Nachbarn nicht "sehen" kann, weil das Signal bei mir schon zu schwach ist. Deshalb haben wir uns gedacht eine Wlan-Richtantenne mit dazugehörigen Accesspoint auf seiner Gartenhütte zu befestigen und bei mir aufs Hausdach ebenfalls eine, auch mit Accesspoint. Die Entfernung würde dann nur ca. 20m betragen und die Antennen könnten sich direkt "sehen". Beide Accesspoints werden dann per Kabel ans jeweilige LAN gebunden, so wie es dein zweites Schema beschreibt.

Wie oben schon beschrieben:
LAN1 (192.168.0.x) <---->ROUTER <------> Wlan AccessPoint1 <
>WlanBridge<
>Wlan AccessPoint2<----->LAN2 (192.168.1.x)



Bei meinem Testaufbau habe ich wie gesagt 3 Router verbunden, weil die WLAN-Bridge noch nicht existiert:

Router1/LAN1<---->Router2<---->Router3/LAN2 (Genauer Aufbau: siehe oben)



Folgendes funktioniert/funktioniert nicht beim Pingtest:
(----> stellt ein Ping da)


Router1 (192.168.0.1) ----> Router2 (192.168.0.7) geht
Router2 (192.168.1.2) ----> Router3 (192.168.1.1) geht
Router1 (192.168.0.1) ----> Router3 (192.168.1.1) geht

Client 192.168.0.11 ----> Router2 (192.168.0.7) geht
Client 192.168.0.11 ----> Router2 (192.168.1.2) geht nicht
Client 192.168.0.11 ----> Router3 (192.168.1.1) geht nicht

Client 192.168.1.3 ----> Router2 (192.168.1.2) geht
Client 192.168.1.3 ----> Router2 (192.168.0.7) geht nicht
Client 192.168.1.3 ----> Router1 (192.168.0.1) geht nicht

Router 3 (192.168.1.1) kann leider nicht "pingen"...


Ich verstehe nicht, warum 192.168.0.11 nicht auf 192.168.1.1 zugreifen kann, obowhl der Router 192.168.0.1 das kann und die Routen deshalb scheinbar richtig funktionieren...
Woran kann das liegen?
Bitte warten ..
Mitglied: aqui
20.02.2009 um 18:40 Uhr
Das ist logisch das das nicht geht !! Ein Fakt das hier in Formumsbeiträgen sehr häufig übersehen wird !

Du hast vermutlich einen Router der NAT (Network Adress Translation) macht wie das so viele DSL Router machen !
http://de.wikipedia.org/wiki/Network_Address_Translation

Wenn du nun vom Netzwerk was am WAN/DSL Port angeschlossen ist irgendetwas im dahinterliegenden LAN pingen oder erreichen willst geht das natürlich nicht, denn das verhindert die NAT Firewall.
Ist ja auch so gewollt damit sie das Internet vom lokalen Benutzer LAN abschottet.
Das Problem ist hier:
http://www.heise.de/netze/DMZ-selbst-gebaut--/artikel/78397
im letzen Abschnitt des ASrtikels auch nochmal beschrieben, wenn auch in einem anderen (gewollten da DMZ) Umfeld !

Um das zu überwinden musst du mit Port Forwarding arbeiten, damit die NAT Firewall das alles durchlässt !!
Das ist aber für mehrere Systeme natürlich nicht möglich !!

Fazit: Du benötigst als Koppelrouter einen Router bei dem du die NAT Funktion ausschalten kannst und der dann NUR routet, sauber ohne NAT Firewall, die du ja nicht gebrauchen kannst, da sie dir deinen Traffic einseitig blockt !

Ein Linksys o.ä. mit DD-WRT Software oder auch andere supportet sowas z.B.
Auch ein PC mit 2 Netzwerkkarten wie hier beschrieben:
http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...
kann so einen einfachen IP Router realisieren !

Damit funktioniert das was du vorhast völlig ohne diese Probleme !
Bitte warten ..
Mitglied: Ratzeck
20.02.2009 um 20:33 Uhr
Hallo,

NAT ist aus... funktioniert aber trotzdem nicht!

Es ist nicht möglich von 192.168.0.11 auf 192.168.1.1 oder entsprechend umgekehrt von 192.168.1.3 auf 192.168.0.1 zu pingen.

Die Pings kommen aber scheinbar am Router2 an, weil die LAN1-LED entsprechend blinkt, wenn ich von 192.168.0.11 auf 192.168.1.1 pinge und die WAN1-LED wenn ich es andersrum von 192.168.1.3 auf 192.168.1.0 mache. Es findet aber anscheinend kein routing statt...

Richtig komisch ist aber folgendes: ich kann von 192.168.0.11 über den Browser das Web-Interface von 192.168.1.1 erreichen, mich aber nicht anmelden. Ich kann Anmeldename und Passwort eingaben und bestätigen, danach tut sich dann aber nichts mehr.

Bin langsam wirklich ratlos. Was läuft da falsch?
Bitte warten ..
Mitglied: aqui
20.02.2009 um 23:28 Uhr
So so...NAT ist aus ?! Bei welchem Router lässt sich das denn so ohne weiteres ausschalten...viele gibt es da nicht ???

OK, wenn du dir da sicher bist mit dem abgeschalteten NAT dann hast du mit an Sicherheit grenzender Wahrscheinlichkeit die statischen Routen auf den beiden lokalen DSL Routern vergessen !!!

f8cc57678d793aff1d5863f0b048ca66-nachbar - Klicke auf das Bild, um es zu vergrößern

Sind die nicht eingetragen auf den lokalen Verbindungs Router als Gateway, versuchen die DSL Router sie dann natürlich ins Internet zu routen und da versinken sie im Nirwana !!!
Siehe auch Paket Beschreibung hier:
http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...

Die Endgeräte haben ja immer die jeweiligen DSL Router als Gateway und logischerweise musst du DIESEN per statischer Route natürlich sagen das sie das Netzwerk des Nachbarn eben nicht ins Internet routen sondern an die jeweils lokale IP des "Verbindungsrouters".
Ansonsten gehen sie, ohne diese zusätzlichen Routen, ins Internet und verschwinden auf nimmerwiedersehen !
Bitte warten ..
Mitglied: Ratzeck
21.02.2009 um 00:03 Uhr
Schönen guten Abend,

ja NAT ist aus, bzw. "classical routing" ist aktiviert. Der Router ist ein Netgear FVS124g, der kann das. Ich denke mal, dass das genügen sollte, vorsichtshalber habe ich aber auch die Firewall entschärft.
Tut mir leid dich enttäuschen zu müssen, aber ich habe, wie gesagt die Routen auf Router1 und Router3 richtig gesetzt, denke ich...


Nochmal der Aufbau, wie oben gepostet:

Router1/LAN1<---->Router2<---->Router3/LAN2

Router1/Lan1:
192.168.0.1/255.255.255.0

Router2:
am Lan1-Interface mit LAN1 verbunden: 192.168.0.7/255.255.255.0

am WAN1-Interface mit LAN2 verbunden:192.168.1.2/255.255.255.0/Gateway:192.168.1.1

Router3/Lan2:
192.168.1.1/255.255.255.0



StaticRoutes:

Router1:
1 nach 3: Destination:192.168.1.0/255.255.255.0 Gateway:192.168.0.7

Router3:
3 nach 1:Destination:192.168.0.0/255.255.255.0 Gateway:192.168.1.2


Würde es Sinn ergeben die Routen im Router2, also dem Verbindungsrouter noch einmal gesondert einzutragen? Denke eigentlich nicht, aber Schaden kann es auch nicht, oder?

Router2 lässt es außerdem nicht zu, dass ich am WAN1-Port, an den Router3/Lan2 angeschlossen ist, KEIN Gateway eintrage. D.h. ich habe 192.168.1.1 (Router3) eingetragen. Kann das evt. das Problem sein? Glaub ich aber eigentlich auch nicht...
Bitte warten ..
Mitglied: aqui
21.02.2009 um 00:17 Uhr
Nein es macht absolut keinen Sinn die Routen im Verbindungsrouter einzutragen !!

Ist auch komplett sinnlos, denn der Router 2 kennt ja beide Netze da sie an ihm selber direkt angeschlossen sind.
Routen hier einzutragen ist also vollkommen unsinnig und schadet eher das es nützt, denn er routet ja nur zwischen dem 192.168.0er und 192.168.1er Netzwerk !

Das beantwortet natürlich auch deine letzte Frage. Eine Gateway Eintrag ist damit auch unsinning und überflüssig und muss auch unbedingt raus aus dem Verbindungsrouter... wie gesagt :
Der er routet ja nur zwischen dem 192.168.0er und 192.168.1er Netzwerk ! Andere netze braucht und soll er gar nicht kennen !


Damit MUSS es klappen...wie gesagt unter der Prämisse das NAT wirklich aus ist was bei NetGear mehr als fraglich ist....aber du bist dir da ja sicher.

Besser du misst mit einem Wireshark oder NetMonitor Sniffer mal nach !!! NetGear solltest du aus Prinzip nicht trauen...!

Abgesehen davon gibt es einen sehr einfachen Workaround das sicher zu testen !!!
Nimm testweise das Gateway der PCs beim Nachbar und dir mal direkt auf die Verbindungsrouter IP Adressen also die .0.7 und die .1.2. statt auf die lokalen DSL Router !

Damit ist dann ein Routing Problem vollkommen ausgeschlossen !
Du kannst zwar so nur die jeweils anderen Netze erreichen und nur aus Basis von IP Adressen (keine Namen verwenden da DNS so nicht klappt !) aber für einen Test der Verbindungsroute reicht das allemal !!

Nun sollte ein Ping von einem PC zum anderen PC (Achtung nur die mit dem umgestellten Gateway) einwandfrei klappen sofern die internen Firewalls der PC entsprechend angepasst sind (Jeweils anderes Netzwerk freigeben und ICMP Pakete (Ping) erlauben)
Alternativ kannst du testweise die Firewall temporär ganz ausschalten !!!

Dieser Test muss klappen und funktionieren sofern NAT und die Firewall am Verbindungsrouter wirklich deaktiviert sind !
Gleichzeitig verifiziert er dann , sollte es klappen, das der Verbindungsrouter so funktioniert wie er soll !

Funktioniert auch das nicht kannst du ein Quercheck mit einem PC und 2 Netzwerkkarten machen wie oben beschrieben:
http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...
damit gehts in jedem Falle, denn der PC routet nativ ohne NAT !
Ein gängiges Router Design das zigfach im Einsatz ist und getestet sicher funktioniert !

Wenn das auch nicht geht ist der NetGear wie vermutet der böse Buhmann der eben nicht NAT und Firewall deaktiviert hat !
Bitte warten ..
Mitglied: Ratzeck
21.02.2009 um 00:34 Uhr
Naja sicher bin ich mir nicht, ob der Netgear NAT wirklich deaktiviert hat...aber es gibt sonst keine Einstellmöglichkeiten...leider. Ich mag Netgear auch nicht, hab mir deshalb einen Draytek für mein LAN geholt, der Netgear ist sozusagen übrig geblieben, aber das nur am Rande bemerkt.

Die Fritzbox vom Nachbarn kann ich nicht nehmen, weil er sonst kein Netz hat. Ich werde morgen mal versuchen den Router3 anstatt dem Router2 als Verbindung zu nutzen...ist leider ein uralt-router und leider auch ein Netgear... aber mal sehen.

Danke dir vorerst mal für deine Unterstützung!
Bitte warten ..
Mitglied: aqui
21.02.2009 um 00:38 Uhr
Mach doch erstmal den Test mit der Gateway Umstellung der PCs in beiden Netzen !!!

Der beweist dir doch sofort obs klappt und wo der Fehler ist !!

Router 3 ist doch der Nachbarrouter...dann hat er doch kein Netz sagst du wenn du den nimmst...oder verwechselst du da was.. Na ja egal..uralt Router klingt nicht gut...da ist NAT meist nie abschaltbar.
Na ja... "Versuch macht kluch(g) !! "
Bitte warten ..
Mitglied: Ratzeck
21.02.2009 um 00:52 Uhr
Router3 soll mal der Nachbarrouter sein. Jetzt ist es zu Testzewcken ein alter von mir. Habe gerade drei Router im Zimmer rumliegen: Router1, Router2 und Router3. Zu Testzwecken so aufgebaut, wie es später mit dem Nachbarn und dessen Fritzbox mal sein soll.

sorry für eventuelles Missverständnis


Der Nachbar braucht seine Fritzbox, darum kann ich sie nicht einfach zu testzwecken nehmen.

außerdem geht das nicht, weil das gesamt-netz also LAN1<--->LAN2 noch nicht existiert. Die WLAN-Bridge fehlt ja noch. Ich wollte das ganze erstmal testen, indem ich ein Netz aus 3 Routern und entsprechenden Teilnetzen realisiere.


Außerdem muss ich im Router2 am WAN1-port ein gateway eintragen. Er erlaubt es mir nicht, dass dieses Feld leer bleibt, bzw. trägt er, wenn ich es leer lasse automatisch 192.168.0.1 ein, was ja keinen sinn ergibt. Darum wollte ich die Router2 und 3 austauschen.
Bitte warten ..
Mitglied: aqui
21.02.2009 um 01:21 Uhr
Ausserdem musst du natürlich am WAN Port des Verbindungsrouters auch PPPoE abschalten und auf statische IP setzen, was du vermutlich aber selber schon gemacht hast !?

Mit dem Gateway Eintrag ist komisch...setz das sonst auf seine eigene IP sofern die Konfig das annimmt ??!
Typisch unausgegorenes NetGear Geraffel....

Dein Weg ist aber richtig. Erstmal solltest du das wasserdicht testen und dann mit der WLAN Bridge umsetzen.
Generell ist das Design richtig und mit den richtigen Komponenten spielt das auch problemlos !!!
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Router & Routing
gelöst Routing zwischen zwei Netzen (31)

Frage von Xaero1982 zum Thema Router & Routing ...

Netzwerke
Routing zwischen 2 Fritzboxen langsam (2)

Frage von danielr1996 zum Thema Netzwerke ...

Netzwerke
gelöst FritzboxLAN2LAN mit dahinterliegendem Router: Nur One-Way-Routing möglich (13)

Frage von SnowCrush zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...