Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routingprobleme bei der Verbindung von zwei Subnetzen über Client-Konfiguration mit DD-WRT-Firmware

Frage Netzwerke Router & Routing

Mitglied: kasteng

kasteng (Level 1) - Jetzt verbinden

17.06.2009, aktualisiert 18.10.2012, 8881 Aufrufe, 4 Kommentare

Hallo zusammen,

ich bekomme einfach nicht hin, was ich möchte und bitte daher um Hilfe:

Ich habe einen Speedport Router, der die Verbindung ins Internet macht. Er ist über Kabel mit einem Linksys Router (Linksys1) gekoppelt, der als WLAN-AP konfiguriert ist. Der Speedport vergibt Adressen über DHCP im IP-Bereich 192.168.2.*. In diesem Netz steht auch noch ein Linux-Server auf dem OpenVPN läuft und dem ich Routen zuweisen könnte.

Ich möchte nun ein weiteres Subnetz 192.168.0.* über WLAN anschließen.

Dazu habe ich einen weiteren Linksys Router (Linksys2) mit der Firmware DD-WRT als Client konfiguriert. Die Clients aus dem 192.168.0.*-Subnetz hängen alle an einem Switch, den ich über die LAN-Buchse des Linksys2 verbunden habe. Es sollen die Rechner aus dem Subnetz 192.168.2.* auf die Clients aus 192.168.0.* zugreifen können.
Ich vermute, es herrscht ein Durcheinander bei meinen Routen. Da ich auch über VPN auf beide Netzwerke zugreifen möchte, habe ich auch dem Linuxserver Routen eingegeben und dort IP- Forwarding aktiviert.


Hier die Details:


DSL--Speedport -----(LAN 192.168.2.*) ----- AP Linksys1 ----(WLAN)----Client Linksys2 ------(LAN 192.168.0.*)-------clients



Linuxrechner 192.168.2.2 per LAN angeschlossen, mit nur einer Netzwerkkarte


Konfiguration Speedport W 500
IP 192.168.2.1
Subnetzmaske 255.255.255.0
DHCP-Server
Besonderheit: kann keine statischen Routen vergeben
Portweiterleitung für openvpn auf den Linuxserver

Standardgateway von allen LAN- und WLAN-Clients im 192.168.2.*-Subnetz


Konfiguration Linksys AP (Linksys1)
Original- Firmware 7.00.4
IP 192.168.2.222
Subnetzmaske 255.255.255.0
DHCP-Server aus
Bei Firewall ist nur Multicast filtern angeklickt
Modus Router
Routingtabelle (Ziel-LAN/Subnetzmaske/Gateway/Schnittstelle):
10.8.0.0/255.255.255.0/192.168.2.2/LAN&WLAN (für openVPN)
192.168.0.0/255.255.255.0/192.168.2.11/LAN&WLAN
192.168.2.0/255.255.255.0/192.168.2.222/LAN&WLAN


Konfiguration Linksys Client (Linksys2)
Modus Client
Firmware DD-WRTv23SP1micro
WAN:
WAN-IP 192.168.2.11
Subnetzmaske 255.255.255.0
Gateway 192.168.2.222
Static DNS 1 192.168.2.222
Static DNS 2 192.168.2.1
STP Disable
LAN:
IP: 192.168.0.11
Subnetzmaske 255.255.255.0
Gateway 0.0.0.0
Local DNS 0.0.0.0
DHCP-Server aus
Firewall disabled
Modus Router
Dynamic Routing both Interfaces
Routingtabelle (Ziel-LAN/Subnetzmaske/Gateway/Schnittstelle):
192.168.0.0/255.255.255.0/0.0.0.0/LAN&WLAN
192.168.0.0/255.255.255.0/192.168.0.11/LAN&WLAN
192.168.2.0/255.255.255.0/192.168.2.222/WAN
192.168.2.0/255.255.255.0/0.0.0.0/WAN
10.8.0.0/255.255.255.0/192.168.2.11/WAN
0.0.0.0/0.0.0.0/192.168.2.222/WAN

Konfiguration Linuxrechner:
Route (Ziel-LAN/Subnetzmaske/Gateway/Schnittstelle):
192.168.2.0/255.255.255.0/*/eth0
192.168.0.0/255.255.255.0/192.168.2.11/eth0
Standardgateway 192.168.2.1 (Speedport)

Stand der Dinge:

Von Linksys2 Webinterface (192.168.0.11 oder 192.168.2.11 ) aus kann ich alles im 192.168.2.*-Subnetz, die LAN und WAN-IP von Linksys2 und auch die Clients aus 192.168.0.* anpingen.
Von Linksys1 erreiche ich alles im 192.168.2.*-Subnetz und auch 192.168.2.11 und 192.168.0.11 von Linksys2 antwortet, aber NICHT die per Kabel an der LAN-Buchse hängenden Clients aus 192.168.0.* . Dasselbe Ergebnis vom Linuxrechner.

Was muß ich tun, damit die Clients aus dem 192.168.2.*-Subnetz die Clients aus dem 192.168.0.*-Subnetz erreichen können?

Ich hoffe, dass jemand durchblickt und mir Tipps geben kann…

Vielen Dank schonmal!

Kasteng
Mitglied: aqui
19.06.2009, aktualisiert 18.10.2012
Eigentlich ein banales und simples IP Design... OK, wenn man einmal deine Beschreibung sortiert dann müsste dein Netzwerk so aussehen:

6f218a240dda95a371e19644ffaf5bf4-wanlanrou - Klicke auf das Bild, um es zu vergrößern

Was auf den ersten Blick auffällt sind deine inkonsistenten Routen !!
Einmal routest du das Netz 10.8.0.0 an die 192.168.2.2 (OpenVPN vermutlich) und einmal an die 2.11 usw. usw.
Überflüssig sind auch die lokalen Hostrouten wo du ein Zielnetz auf sich selber (Host) routest was IP technisch natürlich Blödsinn ist....

Routen auf dem zum AP gemachten Linksys sind so oder so Unsinn, denn da reicht ein Default Gateway Eintrag.
Wie man den richtig konfiguriert kannst du hier im Tutorial nachlesen:

http://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...

Genau so musst du den auch anschliessen, Gateway Eintragen und die blödsinnigen Routen dort löschen !!

Es gibt zwei Knackpunkte in deinem Netz:
Der Speedport ist ein recht dummer und banaler Router der KEINE zusätzlichen statischen Routen supportet, was diesen Router für so ein Szenario schon gleich disqualifiziert !!!
Mit ein paar Klimmzügen die du unbedingt beachten musst sollte es aber dennoch klappen.
Folglich darf dieser Speedport Router niemals das Default Gateway im 192.168.2.0er Segment sein. Das ist auch logisch, da er nur ins Internet routen kann und niemals andere Segmente bedienen kann wie den 192.168.0.0er Netz !!
Du musst also ALLES auf den DD-WRT oder den OpenVPN umstellen und von diesen Geräten dann eine default Route auf den Speedport zeigen lassen.
Das ist ganz wichtig sonst bekommst du das nie zum Laufen !

2ter Knackpunkt ist der DD-WRT: Der darf nie im Modus Gateway arbeiten, denn dann macht er NAT am WAN Port ins 192.168.2.0er Netz aber das hast du vermutlich schon richtig bedacht ! Er muss hier im Modus Router betrieben werden, damit das NAT am WAN Port ausgeschaltet ist !!

Diese Grundvoraussetzungen musst du umsetzen !

Dann musst du lediglich als statische Route im DD-WRT das 10er Netz eintragen via VPN und als default Gateway die 192.168.2.1 und gut ist !
Andere Netze benötigt der DD-WRT nicht denn es ist alles an ihm selber direkt angeschlossen und er kennt dadurch diese Netze !!
Solch einen Blödsinn wie die Hostrouten im eigenen Netz ala 192.168.2.0/255.255.255.0/192.168.2.222/WAN sind unsinnig und die solltest du schnell löschen !

Das einzige ist eine zusätzliche Route des default Routers im 192.168.2.0er Segment sollte der default Router nicht der DD-WRT hier sein sondern der OpenVPN z.B.
Der braucht dann eine Route ala route add 192.168.0.0 mask 255.255.255.0 192.168.2.11 eingetragen !!
Der Speedport darf hier nicht als Gateway für die Endgeräte PC eingetragen werden, lediglich bei DD-WRT und OpenVPN als default Gateway !!!

Grundlagen zu solch einem Szenario sagt dir grundsätzlich auch dieses Tutorial:

http://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Bitte warten ..
Mitglied: kasteng
21.06.2009 um 23:15 Uhr
Hallo Aqui,

vielen Dank für Deine Tipps!

Was auf den ersten Blick auffällt sind deine inkonsistenten
Routen !!

ich habe bei den Routen aufgeräumt und nur die Route auf das 10 er Netz im DD-WRT und die Route auf das 192.168.0.0er Netz im Linuxrouter gelassen.


Es gibt zwei Knackpunkte in deinem Netz:

Du musst also ALLES auf den DD-WRT oder den OpenVPN umstellen und von
diesen Geräten dann eine default Route auf den Speedport zeigen
lassen.

Stimmt. Dem DD-WRT habe ich im WAN den Gateway 192.168.2.1 (statt 192.168.2.222) eingetragen . Wenn ich dann einen Client-Rechner im 192.168.0.0 er Netz an den DD-WRT anschließe mit Standardgateway 192.168.0.11, dann kann ich diesen Rechner vom 2 er Netz anpingen!

Mein Problem ist jetzt nur:

ich habe ein Elektrogerät mit Controller an einem Switch am DD-WRT hängen. Beide haben eine feste IP im 192.168.0.0er er Netz und Subnetzmaske 255.255.255.0. Ich kann auf diese Geräte nicht weiter zugreifen.
Diese beiden Geräte kann ich aus dem DD-WRT auf ihrer IP anpingen, aber nicht aus dem 192.168.2.0er Netz! Stecke ich einen Computer an denselben Switch an dem diese beiden Geräte hängen, kann ich diesen Rechner aus dem 192.168.2.0er Netz nur anpingen, wenn er den Standardgateway-Eintrag 192.168.0.11 hat, sonst nicht.

Was muß ich da noch machen oder ist mein ganzer Aufbau falsch?


2ter Knackpunkt ist der DD-WRT: Der darf nie im Modus Gateway
arbeiten, denn dann macht er NAT am WAN Port ins 192.168.2.0er Netz
aber das hast du vermutlich schon richtig bedacht ! Er muss hier im
Modus Router betrieben werden, damit das NAT am WAN Port
ausgeschaltet ist !!

Ja, ich habe ihn immer nur im Modus Router eingesetzt.

Das einzige ist eine zusätzliche Route des default Routers im
192.168.2.0er Segment sollte der default Router nicht der DD-WRT hier
sein sondern der OpenVPN z.B.
Der braucht dann eine Route ala route add 192.168.0.0 mask
255.255.255.0 192.168.2.11
eingetragen !!

Ich hatte zuerst den Clients im Netz 192.168.2.0 den Linuxserver 192.168.2.2 als Standardgateway eingetragen. Wenn ich dort aber openvpn mit Ethernet Bridging startete und versuchte, mit den Clients gleichzeitig ins Internet zu kommen (über den 192.168.2.1-Router) hatte ich Probleme. Deshalb habe ich den Clients im Netz 192.168.2.0 als Standardgateway 192.168.2.11 zugewiesen. Das scheint soweit auch zu laufen.

MFG,
kasteng
Bitte warten ..
Mitglied: aqui
22.06.2009 um 16:31 Uhr
Dein Elektrogerät hat schlicht und ergreifend die 192.168.0.11 NICHT als Gateway eingetragen !!
Das ist vermutlich das ganze Problem ?!
Pakete aus anderen Subnetzen kann es so nicht routen und ist damit nur isoliert in seinem .0.0er Subnetz zu erreichen !
Bitte warten ..
Mitglied: kasteng
23.06.2009 um 13:14 Uhr
Hm, das heißt, wenn das Gerät (ein Gewächshauscontroller, leider kann ich nicht an die IP-Einstellungen ran) keinen Gateway eingetragen hat, kann ich es mit dem Client Modus vergessen. Nur Client Bridge dürfte gehen, dann aber ist nach ersten Tests nur ein Client erreichbar...

Da aber das Routingproblem vom Anfang grundsätzlich gelöst ist, markiere ich das Thema als gelöst.

Vielen Dank nochmal an AQUI!


MFG,
kasteng
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
Dd-wrt Hotspot mit Radius Server und Traffic Volume Limit (19)

Frage von Kubus0815 zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
gelöst DD-WRT Zwei W-Lan Netzwerke (4)

Frage von schneerunzel zum Thema LAN, WAN, Wireless ...

Peripheriegeräte
WRT3200ACM: Linksys kündigt neuen OpenWRT- und DD-WRT-Router an

Link von runasservice zum Thema Peripheriegeräte ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...