Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

RPC über https - Mit Outlook von extern auf Exchange ohne VPN

Frage Microsoft Windows Server

Mitglied: r1chy2

r1chy2 (Level 1) - Jetzt verbinden

04.06.2010, aktualisiert 16:13 Uhr, 8531 Aufrufe

Mein Zeil war es, extern (also von überall auf der Welt) übers Internet mit einem Notebook und dem darauf installierten Outlook auf mein Exchange-Server zuzugreifen. Also RPC über https.
Das funktioniert aber leider nicht. Ich komm bis zur Benutzername/Kennwort-Eingabe aber dieses Fenster öffnet sich nach Eingabe immer wieder erneut.

Ich habe Exchange Server 2003 auf Windows Server 2003 R2 installiert (sämtliche SPs und Updates ebenfalls installiert). Dieser Computer heißt SERVER. Meine Domäne heißt FIRMA. Also vollständig: server.firma.local

Auf meinem Test-Client ist WIndows 7 und Outlook 2007 installiert (ebenfalls mit sämtlichen SPs und Updates).

Wenn ich den Test-Client am Netzwerk anschließe (er ist kein Domänenmitglied). Kann ich problemlos E-Mails empfangen/schicken und den Kalender synchronisieren.

Ebenfalls nutze ich vom Exchange das ActiveSync um die Mails/den Kalender mit meinem iPhone zu synchronisieren. Das funktioniert auch ohne Probleme.

OWA funktioniert ebenfalls, sowohl http (80) also auch https (443).

Der Exchange Server ist von extern über die URL mail.webdomain.com erreichbar.


Nun habe ich mir diese Anleitung (http://www.petri.co.il/how-can-i-configure-rpc-over-https-on-exchange-2 ...) hergenommen und zuerst in den Windows-Komponenten die Funktion RPC over HTTP Porxy aktiviert.
Danach bin ich in den IIS Manager und habe dort in den Einstellungen des Rpc-Ordners den anonymon Zugang deaktiviert, die Standartauthentifizierung in Klartext aktiviert und meinen Standartdomänennamen (firma.local) eingegeben.
Im Fenster Sichere Kommunikation habe ich 128-Bit SSL vorausgesetzt.
Anschließend habe in in der Registry folgende Parameter überprüft:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
Value name: Rpc/HTTP Port
Value type: REG_DWORD
Value data: 0x1771 (Decimal 6001)

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters
Value name: HTTP Port
Value type: REG_DWORD
Value data: 0x1772 (Decimal 6002)

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters
Value name: Rpc/HTTP NSPI Port
Value type: REG_DWORD
Value data: 0x1774 (Decimal 6004)

Bei dem Schlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc\RpcProxy habe ich den Wert bei ValidPorts wie folgt geändert:
server:6001-6002;server.firma.local:6001-6002;mail.webdomain.com:6001-6002;server:6004;server.firma.local:6004;mail.webdomain.com:6004

Dann bin ich in den Exchange System-Manager und habe dort bei meinem SERVER unter der Ersten administrativen Gruppe in Eigenschaften bei RPC-HTTP den Punkt RPC-HTTP-Back-End-Server ausgewählt.

Zu guter Letzt habe ich noch im IIS Manager ein SSL-Zertifikat von StartSSL installiert, das die Domain mail.webdomain.com validiert. Um evtl. CA-Probleme vorzubeugen, habe ich zusätzlich die CA- und Inter-CA-Zertifikate auf dem Server und CLient installiert (auch im MMC des Servers).


So jetzt habe ich meinen Client hergenommen und ihn mit einem USB-UMTS-Modem in das Internet eingewählt.
OWA und SSL-Domain sind erreichbar. Zertifikat wird angezeit und akzeptiert.

Jetzt öffne ich Outlook 2007 und richte ein E-Mail-Konto mit Exchange ein.
Microsoft Exchange-Server: server
Benutzername: Benutzer

Ich klicke weder auf Prüfen, noch auf Weiter, sondern zunächst auf Weitere EInstellungen.
Dort gehe ich auf Verbindungen und setze einen Haken bei Verbindung über HTTP herstellen.
In der Proxyeinstellungen trage ich die URL ein (https://mail.webdomain.com) und wähle unten die Standardauthentifizierung aus.
Haken sind bei Nur SSL verwenden und Bei langsamen Netzwerken zuerst Verbindung über HTTP dann über TCP/IP herstellen gesetzt.

Dann auf OK, Weiter und den Assistenten Fertig stellen (schließen).

Jetzt kommt das Fenster in dem ich Benutzername und Kennwort eingeben muss:
Verbindung mit server wird hergestellt
Benutzername: server\Benutzer
Kennwort:

Wenn ich da mein Benutzerkennwort eingebe und auf OK klicke, braucht es kurz, aber dann kommt das selbe Fenster wieder.
Ich habe es auch schon nur mit "Benutzer", mit "firma.local\Benutzer", "firma\Benutzer" und "server.firma.local\Benutzer" probiert. Immer erfolglos.

Auffällig ist, dass jedes Mal, wenn ich die Eingabe mit OK bestätige, die LAN-Port-LED am Exchange-Server blinkt. Also muss da doch irgendwas passieren.


Vielen Dank für eure Hilfe!


EDIT: Habe das Problem grad selber gefunden! Für diejenigen, die es wissen wollen: Im AD muss bei dem Benutzer muss bei RAS-Berechtigung der Zugriff gestattet werden!

Dennoch Danke und ein schönes Wochenende
Ähnliche Inhalte
Exchange Server
Exchange und Outlook 2016 extern
gelöst Frage von Florian86Exchange Server17 Kommentare

Hallo, wir haben einen Exchangeserver 2013. Hier komme ich von extern über die Weboberfläche ohne Problem rein. Nutze ich ...

Exchange Server
Exchange 2010 - alles funktioniert nur Outlook von extern nicht
gelöst Frage von RoSk3YExchange Server8 Kommentare

Hallo Leute! Ich hatte vor einigen Tagen ein Problem mit der Indizierung auf unserem Exchange 2010 (14.03.0123.004), nachdem ich ...

Exchange Server
RPC over HTTPS Einstellung wird nur unter Win 8.1 nicht gespeichert
gelöst Frage von PressmarExchange Server2 Kommentare

Hallo zusammen, wir haben hier einen kleinen Exchange Server 2010 mit aktuellen Update-Stand. Dieser funktioniert mit etlichen Windows 7 ...

Exchange Server
Outlook VPN Exchange
gelöst Frage von BergEnteExchange Server5 Kommentare

Hallo Forum, ein Windows 7 PC ist in einer Domain mit Exchnage verbunden. Sobald man ausser Haus über VPN ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 3 StundenVerschlüsselung & Zertifikate

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 14 StundenWindows 102 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 16 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 1 TagViren und Trojaner3 Kommentare

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen13 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...