Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

RPC over HTTP (SBS2003)

Frage Microsoft Exchange Server

Mitglied: phoenixz

phoenixz (Level 1) - Jetzt verbinden

22.06.2008, aktualisiert 23.06.2008, 9856 Aufrufe, 5 Kommentare

Hi

nach einem Frusttag gebe ich mich geschlagen...

Wie bereits im TItel erwähnt, versuche ich nun schon seit geraumiger Zeit das "Rpc over Http(s)" mit einem Exchange 2003 Server hinzubekommen.

Die Ausgangslage:
SBS 2003 SP2
Exchange 2003 SP1

Ser Server (SBS) wurde installiert als:
Vollständiger DNS-Name der Domäne: corp.local
NetBIOS-Domänenname: SBS-SERVER
Computername: SBS-Server.Corp.local
Netbios über TCP/IP deaktiviert

RPC over HTTP habe ich mit den folgenden Anleitungen eingestellt:
1.) http://www.msexchangefaq.de/clients/rpchttp.htm
2.) http://www.petri.co.il/configure_rpc_over_https_on_a_single_server.htm

Auf dem Client läuft WinXP SP2 samt Outlook 2007.
Der SBS-Server ist aus Testzwecken in der Firewall in der DMZ eingetragen, damit von dieser keine Probleme ausgehen.

Die Outlook-Konfiguration sieht so aus:
Microsoft Exchange Server: sbs-server
Benutzername: user
Exchange Proxyeinstellungen: https://sbs-server.domain.de
Standardauthentifizierung

Wenn ich nun auf dem Client Outlook starte, erhalte ich nach der Eingabe des Logins (Benutzername: CORP\user; Kennwort: user) die Meldung "Es steht keine Verbindung mit Microsoft Exchange zur Verfügung. Outlook muss im Onlinemodus verbunden sein...". Anschließend wird Outlook geschlossen.

https://sbs-server.domain.de/remote funktioniert problemlos
https://sbs-server.domain.de/rpc führt zum Anmeldebildschirm, eine Anmeldung ist allerdings aus mir unbekannten Gründen nicht möglich.

Alle User sind in der Sicherheitsgruppe "Remote Web Workplace User" eingetragen.

Was läuft schief? Hat jemand eine Idee?

Danke vorab und herzliche Grüße aus dem Rheinland
Pino
Mitglied: filippg
22.06.2008 um 21:34 Uhr
Hallo,

RPC-over-https funktioniert afaik nur wenn das Zertifikat auch gültig ist/der Client ihm vertraut. Ist das bei dir der Fall Versuch als Benutzername mal den UPN (meist user@domain.net). Lösche in der Systemsteuerung bei Benutzerkonten die gespeicherten Kennwörter.

Gruß

Filipp
Bitte warten ..
Mitglied: GuentherH
23.06.2008 um 00:05 Uhr
Hallo.

a) konfiguriere RPC over HTTPS über den Assistenten für den Internetzugang
b) das Zertifikat muss in deinem Fall auf sbs-server.domain.de lauten
c) importiere am Client das Zertifikat in die vertrauenswürdigen Stammzerifikatsstelle
d) test den Zugriff über OWA mit https://sbs-server.domain.de/exchange - es darf kein Zertifkatsfehler auftreten
e) wenn obiges klappt, dann klappt es auch mit RPC over HTTPS

LG Günther
Bitte warten ..
Mitglied: phoenixz
23.06.2008 um 00:21 Uhr
Hallo,

zunächst einmal danke für die Antworten. Werde morgen früh ausprobieren, ob's wirklich am Zertifikat liegt.

Eigentlich glaube ich das nicht so ganz, weil ich genau dieses Zertifikat (sbs-server.domain.de) bereits erstellt und in den Internet Explorer des Clients importiert habe.

Außerdem müsste ich doch gemäß der folgenden Anleitung

http://technet.microsoft.com/en-us/library/bb124604%28EXCHG.65%29.aspx

die Zertifikatsabfrage deaktiviert haben.

Wie lässt sich denn eigentlich über den Assistenten für den Internetzugang das RPC over HTTPS konfigurieren? Der Wizard fragt doch diesbzgl. nur das Zertifikat ab. Oder verwechsele ich jetzt da was?

Liebe Grüße
Pino
Bitte warten ..
Mitglied: GuentherH
23.06.2008 um 08:52 Uhr
Hallo

Wie lässt sich denn eigentlich über den Assistenten für den Internetzugang das RPC over HTTPS konfigurieren?

- Assistent ausführen
- im Auswahlfenster "Webdienstekonfiguration" Checkbox für Outlook über das Internet aktivieren
- Zertifkat gegebenfalls erstellen/korrigieren
- Assistentent fertigstellen
- fertig

LG Günther
Bitte warten ..
Mitglied: phoenixz
23.06.2008 um 09:52 Uhr
Hallo,

seltsamerweise funktioniert RPC jetzt, nachdem ich das Zertifikat auf dem Client gelöscht und neu eingespielt habe. Seltsam deshalb, weil ich doch über die Server-Registry die Zertifikatsabfrage deaktiviert haben müsste.

Interessant ist auch, dass weiterhin eine Anmeldung über

https://sbs-server.domain.de/rpc

nicht möglich ist (Anmeldebildschirm erscheint). Ich gehe doch mal davon aus, dass als Benutzername "CORP\user" eingetragen werden muss?!?

OWA funktioniert übrigens absolut problemlos.

LG
Pino
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Voice over IP
Fax over IP Einrichtung Gateway Call Manager (1)

Frage von mellon zum Thema Voice over IP ...

Netzwerke
VPN DHCP IPSec im Vergleich zu L2TP over IPSec (1)

Frage von TomJones zum Thema Netzwerke ...

Windows Server
RPC Server ändern (2)

Frage von DerNeueITler zum Thema Windows Server ...

Netzwerke
Sophos L2TP over IPSec Nutzer

Frage von Dome1988 zum Thema Netzwerke ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...