Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Runlevel einstellen

Frage Linux Linux Netzwerk

Mitglied: tetikmux

tetikmux (Level 1) - Jetzt verbinden

26.06.2010 um 20:37 Uhr, 3098 Aufrufe, 6 Kommentare

Hallo

habe 4 Mounts erstellt die auch funktionieren. Aber beim herunterfahren des PC (PC im WLAN betrieb) dauert es eine halbe Ewigkeit bis er heruntergefahren ist. liegt wohl am runlevel wegen den umount. Meine frage ist wie kann ich nun mein Runlevel so einstellen das mein WLAN nicht als erstes abgeschaltet wird sondern erst später wenn er nicht mehr benötigt wird? Mit eth0 gibt es keine Probleme. Habe Ubuntu 10.04
Mitglied: perseues
26.06.2010 um 21:15 Uhr
Hallo,

also bei den init Skripten kannst Du die Reihenfolge durch die Nummer, die auf das S (für Start) oder K (für Kill) folgt festlegen (genaugenommen sind es Links). Diese findet Du im Ordner /etc/rc.d/ bzw. /etc/init.d/ in dem Ordner des entsprechenden Runlevels rc0.d, rc1.d, rc2.d ... . Mit 10.04 ist die Umstellung auf Upstart weiter fortgeschritten und meines Wissens werden die Verzeichnisse schon darüber eingehängt, andere Dienste aber noch über die Initscripte gestartet. Versuch einfach mal, ob es reicht, wenn Du Dein Wlan eine höhere Ausführungsnummer gibst.


Grüße perseues
Bitte warten ..
Mitglied: tetikmux
26.06.2010 um 23:05 Uhr
ich habe in der rc0 nun die
lrwxrwxrwx 1 root root 22 2010-06-03 19:29 S16wpa-ifupdown -> ../init.d/wpa-ifupdown
auf
lrwxrwxrwx 1 root root 22 2010-06-03 19:29 S36wpa-ifupdown -> ../init.d/wpa-ifupdown

geändert

funktioniert trotzdem nicht

war sonst nichts mit wlan ähnliches drin
Bitte warten ..
Mitglied: perseues
26.06.2010 um 23:37 Uhr
ändere den Link mit "k" für kill. Dieser ist für das Runterfahren. "S" steht für Start.
Bitte warten ..
Mitglied: dog
27.06.2010 um 01:01 Uhr
Und jetzt nochmal am Beispiel:

S99programm und K01programm startet das Programm als Letztes beim Hochfahren und beendet es beim Herunterfahren als Erstes.
Bitte warten ..
Mitglied: tetikmux
27.06.2010 um 23:01 Uhr
Wichtige Ergänzung LAN bleibt als Dienst bis der kill befehl kommt.
WLAN schaltet sich sofort ab sobald der PC sich abmeldet bzw herunterfährt.
Deswegen keine Probleme mit LAN mit dem umounten.

Trotz alle dem habe ich immer noch keine Lösung.

schaut mal bei euch wann bzw. wo euer WLAN gekillt wird?
Bitte warten ..
Mitglied: perseues
28.06.2010 um 16:52 Uhr
also ich habe auf dem Notebook nicht Ubuntu sondern Debian und bei mir reicht der Eintrag in /etc/network/interfaces

01.
auto lo 
02.
iface lo inet loopback 
03.
auto wlan0 
04.
iface wlan0 inet dhcp 
05.
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
um das Wlan bei Systemstart mitzustarten. Ich habe also keine Scripte in rc.d

siehe auch : wiki.ubuntuusers.de/wlan/wpa_supplicant
Bitte warten ..
Ähnliche Inhalte
E-Mail
gelöst SPF richtig Einstellen (3)

Frage von MS6800 zum Thema E-Mail ...

Windows Netzwerk
gelöst Cipher Suite Einstellen (2)

Frage von Patrick-IT zum Thema Windows Netzwerk ...

Batch & Shell
Powershell Mikrofon aktivieren und Pegel einstellen (1)

Frage von Marabunta zum Thema Batch & Shell ...

Windows Server
Server 2012 Festplatte dauereinsatz Einstellen (5)

Frage von Stefan2402 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...