Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Runlevel einstellen

Frage Linux Linux Netzwerk

Mitglied: tetikmux

tetikmux (Level 1) - Jetzt verbinden

26.06.2010 um 20:37 Uhr, 3119 Aufrufe, 6 Kommentare

Hallo

habe 4 Mounts erstellt die auch funktionieren. Aber beim herunterfahren des PC (PC im WLAN betrieb) dauert es eine halbe Ewigkeit bis er heruntergefahren ist. liegt wohl am runlevel wegen den umount. Meine frage ist wie kann ich nun mein Runlevel so einstellen das mein WLAN nicht als erstes abgeschaltet wird sondern erst später wenn er nicht mehr benötigt wird? Mit eth0 gibt es keine Probleme. Habe Ubuntu 10.04
Mitglied: perseues
26.06.2010 um 21:15 Uhr
Hallo,

also bei den init Skripten kannst Du die Reihenfolge durch die Nummer, die auf das S (für Start) oder K (für Kill) folgt festlegen (genaugenommen sind es Links). Diese findet Du im Ordner /etc/rc.d/ bzw. /etc/init.d/ in dem Ordner des entsprechenden Runlevels rc0.d, rc1.d, rc2.d ... . Mit 10.04 ist die Umstellung auf Upstart weiter fortgeschritten und meines Wissens werden die Verzeichnisse schon darüber eingehängt, andere Dienste aber noch über die Initscripte gestartet. Versuch einfach mal, ob es reicht, wenn Du Dein Wlan eine höhere Ausführungsnummer gibst.


Grüße perseues
Bitte warten ..
Mitglied: tetikmux
26.06.2010 um 23:05 Uhr
ich habe in der rc0 nun die
lrwxrwxrwx 1 root root 22 2010-06-03 19:29 S16wpa-ifupdown -> ../init.d/wpa-ifupdown
auf
lrwxrwxrwx 1 root root 22 2010-06-03 19:29 S36wpa-ifupdown -> ../init.d/wpa-ifupdown

geändert

funktioniert trotzdem nicht

war sonst nichts mit wlan ähnliches drin
Bitte warten ..
Mitglied: perseues
26.06.2010 um 23:37 Uhr
ändere den Link mit "k" für kill. Dieser ist für das Runterfahren. "S" steht für Start.
Bitte warten ..
Mitglied: dog
27.06.2010 um 01:01 Uhr
Und jetzt nochmal am Beispiel:

S99programm und K01programm startet das Programm als Letztes beim Hochfahren und beendet es beim Herunterfahren als Erstes.
Bitte warten ..
Mitglied: tetikmux
27.06.2010 um 23:01 Uhr
Wichtige Ergänzung LAN bleibt als Dienst bis der kill befehl kommt.
WLAN schaltet sich sofort ab sobald der PC sich abmeldet bzw herunterfährt.
Deswegen keine Probleme mit LAN mit dem umounten.

Trotz alle dem habe ich immer noch keine Lösung.

schaut mal bei euch wann bzw. wo euer WLAN gekillt wird?
Bitte warten ..
Mitglied: perseues
28.06.2010 um 16:52 Uhr
also ich habe auf dem Notebook nicht Ubuntu sondern Debian und bei mir reicht der Eintrag in /etc/network/interfaces

01.
auto lo 
02.
iface lo inet loopback 
03.
auto wlan0 
04.
iface wlan0 inet dhcp 
05.
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
um das Wlan bei Systemstart mitzustarten. Ich habe also keine Scripte in rc.d

siehe auch : wiki.ubuntuusers.de/wlan/wpa_supplicant
Bitte warten ..
Ähnliche Inhalte
Apache Server
Korrektes Einstellen von Loadbalancing modjk
gelöst Frage von batman00Apache Server1 Kommentar

Hallo und guten Morgen. Ich doktor hier schon seit einiger Zeit rum, bekomme es aber nicht, dass mein Loadbalancer ...

Samba
Benutzerrechte auf Samba Freigabe einstellen!
Frage von mike7050Samba1 Kommentar

Hallo, ich habe einen Ubuntu 14.04 LTS Rechner der als File Server fungiert! Des Weiteren sind einige Windows Pc ...

Windows Netzwerk
Cipher Suite Einstellen
gelöst Frage von Patrick-ITWindows Netzwerk2 Kommentare

Hallo zusammen Ich würde gerne, dass der Netzwerkverkehr im Windows 10 nur über diese 3 Verfahren (Cipher Suite) verschlüsselt ...

Netzwerkprotokolle
IPv6 in Router einstellen
Frage von fundave3Netzwerkprotokolle11 Kommentare

Guten Tag zusammen. Ich habe mal eine Verständnis Frage. Ich habe einen Router wo eine statische IPv4 eingerichtet ist. ...

Neue Wissensbeiträge
Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 10 StundenMac OS X1 Kommentar

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser erreichbar sind. Leider fehlt ...

Datenschutz

Weitere Informationen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 17 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 19 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Microsoft Office

Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei

Anleitung von SarekHL vor 22 StundenMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1018 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...