Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Samba 3.0.22 PDC -> Kubuntu -> fstab -> readonly beim chmod; kein kopieren von XP

Frage Linux Ubuntu

Mitglied: 44888

44888 (Level 1)

08.03.2007, aktualisiert 23:52 Uhr, 4350 Aufrufe, 3 Kommentare

Hi Folks,

bin neu hier, da ich mit meinem Samba PDC und ext3 Raid1 nicht weiter komme.

Erst mal die Hardware:
MSI KT6Delta
AMD Athlon 2500+
Highpoint 370 IDE Raid
1GB RAM
NEC 2500

Auf der Kiste habe ich folgende Raid verbünde:
Anschluß 0 Highpoint: 2x Samsung 200GB IDE RAID1
Anschluß 1 Highpoint: 2x Samsung 160GB IDE RAID1
S-ATA Raid onboard (Silicon): 2x Samsung 400GB Raid1

Installiert ist Kubuntu Edgy 6.10 mit allen Updates, dmraid und samba Version 3.0.22. Die Raid1 Verbünde werden astrein erkannt.

Nun zu meinem genauen Prob:
Habe auf einer 500GB S-ATA Platte alle Daten des Raid 160GB und 200GB (war vorher 2003 Server) gesichert, bevor sie nach der Kubuntu Installation (auf einer separaten IDE 40GB Systemplatte) mit dmraid (/dev/mapper/hpt37_xxxx) und einem ext3 System und versehen wurden. Alle Einträge in der fstab scheinen korrekt. Wird alles richtig gemountet.

Nach einrichten der RAID1 Verbünde wurden die Daten der 500GB Platte mit einem temp eingebauten S-ATA Controller unter der shell mit cp wieder auf Ihren Raid1 VErbünden kopiert.

Samba installiert, PDC eingerichtet, User angelegt und die Shares in die smb.conf eingetragen.

Die XP SP2 Rechner lassen sich ohne Probs in die Domäne heben. Meine Domänen Admin Rechte ziehen auch. Alle Maschinen Accounts werden erstellt, Logon Script läuft und ich kann auf die Shares der Raid´s zugreifen.

ABER JETZT:

Will ich einen Ordner vom XP Client auf den Server schieben, Abbruch: Sehen Sie nach, ob Ihr Datenträger nicht voll oder schreibgeschützt ist ?

Hmmm..ok..was solls, zum testen mal alles auf:

chmod -R 0777 /pfad/zum/raid1

Samba restart. Hmpf...immer noch das selbe Prob ???

ok... chown -R root:users /pfad/zum/raid1

Samba restart....*heul*

Ok....ran an die Logs:

Keine großen Fehler zu erkennen....hmmm...naja, is net die englische Art, aber reboot tut ab und zu gut !

reboot.......

Immer noch das selbe Prob.....

Naja, mal die fstab angesehen....scheint ok, rw drin, kein acl ???

*5 Minuten Grübel*

Naja, machste nochmal ein chmod -R 0777 /pfad/zum/raid1

*glotz*was muss ich sehen.... ?? Das chmod kann nicht ausgeführt werden, da der Datenträger als read-only eingebunden ist, obwohl nichts in der fstab, mtab und den shares darauf hindeutet, nur lesen zu dürfen.

Nun stehe ich da ich armer Tor....heute Nacht bis 2 Uhr gekämpft, ohne Erfolg.

Bitte um Hilfe im Forum

P.S: Gebe nicht schnell auf, aber stehe wieder kurz vor w2k Server install ! Wäre schade, da Kubuntu sau schnell zu sein scheint ! Vorallem im GBIT Lan.
Mitglied: 25746
08.03.2007 um 20:32 Uhr
Keiner eine Idee ???

Habe jetzt mal nachgesehen. System bleibt seit heute abend Hängen auf /dev/mapper/hpt370x_xxx.

unexpected Consistency.

Lasse gerade fsck laufen. Da wird doch wohl eine PLatte nicht am sterben sein ?

i_blocks und i_size hat er 2 gefunden und 3 Illegal Blocks und 2 Multiply-claimed blocks...hmmm...was geht´n mit dem Raid Verbund ab ?

Einer eine Idee ??
Bitte warten ..
Mitglied: 25746
08.03.2007 um 21:08 Uhr
So, fsck hat den fehler anscheinedn bereinigt, scheinen defekte blöcke und sektoren zu sein.

Nun hab ich aber das Prob mit den Verzeichnis Unix Rechten.

Setze ich ein chmod -R 0770 auf mein raid160, zugriff verweigert, mit 0775 kann ich wenigstens auf mein Netzlaufwerk zugreifen und, klar, wie solls anders sein, mit 0777 kann ich alles, Warum ???


Hier mal meine smb.conf:

-----------------------------CODE-------------------------------------
[global]

## Server Identifikation - so meldet sich der Server im Netzwerk
netbios name = coruscant
server string = PDC (%h)
workgroup = domäne

## Welche Netzwerkkarte soll von Samba benutzt werden?
interfaces = eth0

## Sicherheits- und Passwort-Einstellungen
security = user
encrypt passwords = true
username map = /etc/samba/smbusers
passdb backend = smbpasswd ;optional „tdbsm“
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
add machine script = useradd -d /dev/null -g clientpc -s /bin/false %u
password level = 5
hosts allow = 127., 192.168.10.

## Domain-Einstellungen
local master = yes
preferred master = yes
os level = 200
domain master = yes
domain logons = yes
logon path =
logon script = logon.cmd ; .cmd, da w2k und XP konform; funktionierte nicht mit .bat !; %u.cmd ist für jeden user ein eigenes scipt !!!)
logon drive =
admin users = @sambadmins

## DNS-Einstellungen
wins support = yes
name resolve order = wins lmhosts host bcast

## Log-Einstellungen
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d

## Diverse Einstellungen
socket options = TCP_NODELAY
read raw = yes
write raw = yes
dead time = 15
remote announce = 192.168.10.255
remote browse sync = 192.168.10.255

## Drucker mit einbinden von CUPS
load printers = yes
printing = cups
printcap name = cups
cups options = raw

## Samba ist Zeitserver
time server = yes



#
Share Definitions


[netlogon]
comment = Network Logon Service
path = /home/netlogon/%u
guest ok = yes
writable = no
share modes = no

[printers]
comment = Alle Drucker
path = /var/spool/samba
browsable = no
public = yes
guest ok = yes
writeable = no
printable = yes

[print$]
comment = Printer Driver
path = /etc/samba/drivers
browsable = yes
guest ok = yes
readonly = yes
writelist = root

[raid160]
comment = Raid 160 System
path = /media/raid160
browsable = no
read only = no
valid users = @sambadmins,imperial
write list = imperial

--------------------------------------------------------------CODE---------------------------------------------------------------------------------------------------------------------------------------------------------------

imperial ist Domain Admin, geht auch mit den Rechten, nur eben nicht mit Zugriff auf raid160 bei Unix Rechten von 0770 ????

Keine , wirklich keine ne Idee ????
Bitte warten ..
Mitglied: 25746
08.03.2007 um 23:52 Uhr
naja, tolles Adminforum, werde mich aus dem Forum wieder abmelden, Sorry...was ne Reaktionszeit...egal...

Hab nu 2 3Ware Escalade 6200 Raid Controller eingebaut für die ATA Raid1 Verbünde. Wir sofort als /dev/sdX erkannt, ohne dmraid und den schmodder, brauche ich nur noch für den s-ata silicon Raid1.

Rockt nu wie lotte. Scheinen mehrere Sachen zusammen probs gemacht zu haben, angefangen von billig Controller wie Dawi HPT, über dmraid und dann noch den chmod kram.

Nur die Controller getauscht und es läuft mit 0770, als obs nix anderes gewesen wäre, von wegen Platte platt.

Cya im nächsten Forum

romeo310
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Bibliotheken & Toolkits
SVN Tortoise: sqlite S8: attempt to write a readonly database (5)

Frage von diwaffm zum Thema Bibliotheken & Toolkits ...

Windows Server
gelöst Neuer PDC - Exchange Server anpassungen? (6)

Frage von adrian138 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
RODC über VPN - Verbindung weg (10)

Frage von stefan2k1 zum Thema Windows Server ...