Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Samba 3.5 winbind Namensauflösung

Frage Linux Samba

Mitglied: Chonta

Chonta (Level 3) - Jetzt verbinden

05.06.2012, aktualisiert 17:36 Uhr, 7199 Aufrufe, 4 Kommentare

Produktivsystem Debian 6
Samba 3.5
mit
security = ADS
idmap backend = idmap_rid:DOMAIN=0-10000000000
idmap uid = 100000-1000000000
idmap gid = 100000-1000000000

Hallo,

das System wurde von einem alten Samba mit LDAP auf ein neues System mit ADS gebracht.
wibinfo -t ist ok
wbinfo -u ist ok
wbinfo -g ist ok
wbinfo -n löst auch die richtige sid auf

Bei einem ls -la steh tder benutzername nicht mehr a nur noch die gemapte uid (aber nicht bei allen Benutzern)

Einige Benutzer werden warum auch immer nicht mehr gefunden. Über wbinfo -u kann ich die Benutzer finden und auch ihre gemapte UID ist in Ordnung, aber wenn ich ein chaown benutzername machen möchte, oder der Benutzer auf Freigebn zugreifen möchte, dann geht das nicht.

Ein wbinfo -i gibt Could not get info for user zurück, aber der Benutzer wird angezeigt über wbinfo -u.
Es sind auch nicht alle Benutzer betroffen und man kann aich nicht sagen neue Benutzer gehen alte nicht.

Auf einem Testsystem kann ich nach wievor alle Benutzer verwenden.

Gruß

Chonta

PS: an einem laufendne nscd lag es nicht (keiner installiert)

nach einem neustart des dienstes ging wbinfo -i wieder und die ls -la Anzeige war dann auch wieder in Ordnung.
Die Frage ist nur, wieso das Problem heute einfach aufgetreten ist und am Linuxsystem wurde nichts verändert.
Mitglied: Alchimedes
05.06.2012 um 21:16 Uhr
Hallo Chonta,

Hab hier nen Verstaendnisproblem...

1) Du schreibst:
"Die Frage ist nur, wieso das Problem heute einfach aufgetreten ist und am Linuxsystem wurde nichts verändert."

Antwort: es wurde was veraendert!

"das System wurde von einem alten Samba mit LDAP auf ein neues System mit ADS gebracht."

2) Dann haust Du nen unwichtigen Teil der smb.conf raus... was soll das?

3) Wenn das Testsystem lief wieso wurde das dann nicht scharf geschaltet?

4) Dein ls -la haste wo am start gehabt?

5) nscd ( Name Service Caching Daemon ) nicht installiert... beim ads... ne ist richtig...

6) Du schreibst "nach einem neustart des dienstes"... welchen dienst? smbd? nmbd?



Tante Google haette Dir geholfen:
http://wiki.samba.org/index.php/Samba_&_Active_Directory
http://www.awerner.homeip.net/doku.php?id=it-artikel:nscd-oder-warum-ne ... nicht-sofort-sichtbar-sind

Sorry wenn das hier ungemütlich herüberkommt, aber als Linuxer solltest Du doch Probleme definiert auf'n prompt bringen.
Oder wolltest Du hier nur mit Halbwissen glänzen?

Gruss
Bitte warten ..
Mitglied: Chonta
06.06.2012, aktualisiert um 08:40 Uhr
Hallo,

das Systen wurde vor knap einem Monat schon umgestellt und bisher lief alles bis auf einen Fall wo sich der winbindd aufgehangen hatte und neu gestartet werden musste normal.

Meine Vermutung war, das die hohen UID-Nummern evtl. Probleme bereiten deswegen hatte ich das gepostet.
Am System wurde auch nichts verändert. Das alte System war ein Debian 4.0 mit einer unvorteilhaften Partitionierung. Das System wurde von Grundauf neu installiert. (Freigaben eingerichtet Rechte an den Daten neugemacht und mit dem AD abgeglichen...) Vorb wurden die Sambaeinstellungen in einer VM getestet.

ls -la wurde auf dem Server gemacht der die Namen nicht richtig auflösen konnte.
Der winbind wurde neu gestartet und dann konntne die Benutzer mit wbinfo -i auch wieder sofort richtig zugeordnet werden.
Warum auch immer ich konnte mit wbinfo das AD abfragen aber die Zuordnung auf dem Linux ging nicht...

Ein ps aux |grep nscd bringt nichts ausser dem grep selber, also läuft da diese Version nicht.
In einigen Samba-Ratgebern wird gerade bei dem Problem, das chown benutzername oder ein wbinfo -i nicht geht empfohlen den nscd abzustellen, deswegen hatte ich das nocheinmal erwähnt.

Gruß

Chonta

PS: wegen dem ungemütlich rüberkommen, lkein Problem hast ja auch Recht aber ich bin kein reiner Linuxer bin mehr MS mit wachsendem Linuxanteil
Bitte warten ..
Mitglied: blauschleiche
06.06.2012 um 12:01 Uhr
Hast du in deinem System Log Meldungen wie:
winbindd[4368]: winbindd: Exceeding 200 client connections, no idle connection found
Bitte warten ..
Mitglied: Chonta
06.06.2012, aktualisiert um 17:18 Uhr
Hallo,

nicht diese Meldung aber folgende.

could not find idmap alloc module idmap_rid:DOMAIN=0-1000000000
Diese Meldung kommt auch wenn die Zugriffe ohne Probleme funktionieren.

Gruß

Chonta

Nachtrag ganze Meldung.

[2012/06/06 12:38:20.453115, 0] winbindd/idmap.c:149(smb_register_idmap)
Idmap module rid already registered!
[2012/06/06 12:38:20.453244, 0] lib/module.c:69(do_smb_load_module)
Module '/usr/lib/samba/idmap/rid.so' initialization failed: NT_STATUS_OBJECT_NAME_COLLISION
[2012/06/06 12:38:20.453388, 1] winbindd/idmap.c:590(idmap_alloc_init)
could not find idmap alloc module idmap_rid:DOMAIN=0-10000000000

Und hier die smb.conf:

[global]

workgroup = DOMAIN
realm = domain.local
security = ADS
winbind refresh tickets = Yes
idmap backend = idmap_rid:DOMAIN=0-10000000000
idmap uid = 100000-1000000000
idmap gid = 100000-1000000000
template shell = /bin/false
winbind use default domain = Yes
winbind nested groups = Yes
winbind expand groups = 10
client use spnego = yes
encrypt passwords = yes
follow symlinks = yes
unix extensions = no

[freigabe]
comment = freigabe
path = /freigabe
read only = no
guest ok = no
nt acl support = no
valid users = @"DOMAIN\ADGRUPPE"
create mask = 0660
directory mask = 0770
create mode = 0660
directory mode = 0770
store dos attributes = Yes



[%U]
path = /data/samba/home/%U
comment = Test
browseable = yes
writable = yes
nt acl support = no
valid users = %U
create mask = 0640
create mode = 0640

[public]
path = /data/samba/public
browseable = yes
writable = yes
nt acl support = no
valid users = @"DOMAIN\ADGRUPPE"
create mask = 0660
create mode = 0660
directory mode = 0770
directory mask = 0770
force group = ADGRUPPE
guest ok = no
unix extensions = no
wide links = yes
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Win Server 2012R2 bzw 2016 als Backupdomaincontroller in einer Samba 3 Domäne

Frage von Franz-Josef-II zum Thema Windows Server ...

Netzwerkprotokolle
Herausfinden, welches Protokoll zur Namensauflösung verwendet wird (4)

Frage von manotada zum Thema Netzwerkprotokolle ...

Windows 10
gelöst Windows 10 SAMBA Share in Empfangsrichtung langsam (7)

Frage von Estrichleger zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...