Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Samba 3.6.9 - force user wirkungslos

Frage Linux RedHat, CentOS, Fedora

Mitglied: melmax

melmax (Level 1) - Jetzt verbinden

06.03.2014, aktualisiert 18.03.2014, 1684 Aufrufe, 6 Kommentare, 1 Danke

Hallo Linux Admins,

ich steh hier vor einem sehr großen Problem. Unser ERP System wurde von RedHat 5.2 auf RedHat 6.4 migriert.
Hier läuft ein Samba Server in der Version 3.6.9. Seit der Umstellung wird die Einstellung "force user" ignoriert.
Dateien die neu angelegt werden bekommen den User "nobody" zugewiesen, obwohl unter force user ein anderer Benutzer angegeben wurde.
Am alten Server (Samba 3.0.25) funktioniert die Einstellung ohne Probleme.

Die Lösung unseres ERP Supports wäre ein Update auf Samba 4.0.0rc4, allerdings sträuben sich die Haare beim Gedanken an einen Release Canditate am Produktivsystem.

Gibt's hier Erfahrungen/Lösungsansätze/Ideen zu diesem Problem?

Vielen Dank & Beste Grüße
Melmax
Mitglied: it-frosch
LÖSUNG 06.03.2014, aktualisiert 18.03.2014
Hallo Melmax,

das https://bbs.archlinux.org/viewtopic.php?id=160161 sollte dir helfen.

Lies unten auch den Bug Report.
Sollte in Version 3.6.15 gefixt sein.

grüße vom it-frosch
Bitte warten ..
Mitglied: mrtux
06.03.2014, aktualisiert um 13:08 Uhr
Hi!

Zitat von melmax:
Gedanken an einen Release Canditate am Produktivsystem.

Wieso eine Release Candiate? Warum probierst Du nicht die aktuelle Stable Release 4.1.5 oder zumindest die Stable, die der oben genannte RC am nächsten kommt. Aber Vorsicht es hat grundsätzlich einige grosse Veränderungen in der Config und der Userverwaltung zwischen Samba 3.x und 4.x gegeben, ich würde empfehlen unbedingt das Changelogs bzw, die Release Infos studieren.

Du solltest aber grundsätzlich erst mal alles in einer VM genau austesten bevor Du so eine (oder besser jede grössere) Veränderung auf ein Produktivsystem loslässt. Samba (und eigentlich alles unter Linux) steht unter ständiger Weiterentwicklung, deshalb bist Du grundsätzlich nie sicher vor Problemen, besonders bei einem Update der gesamten Distribution.

mrtux
Bitte warten ..
Mitglied: melmax
06.03.2014 um 14:24 Uhr
Zitat von it-frosch:
das https://bbs.archlinux.org/viewtopic.php?id=160161 sollte dir helfen.

Lies unten auch den Bug Report.
Sollte in Version 3.6.15 gefixt sein.

Danke it-frosch

das klingt schon mal verlockend, jetzt muss ich nur noch rausfinden wie ich die 3.6.15 auf meinen RedHat Server bekomme.

Über yum bekomme ich nur die 3.6.9 oder die 4.0.0

Hast du hier eine Idee?

Vielen Dank!
Melmax
Bitte warten ..
Mitglied: it-frosch
LÖSUNG 10.03.2014, aktualisiert 18.03.2014
Hallo melmax,

wie wär es denn damit?

http://www.samba.org/samba/history/


grüße vom it-frosch
Bitte warten ..
Mitglied: mrtux
LÖSUNG 10.03.2014, aktualisiert 18.03.2014
Hi!

Zitat von melmax:
Über yum bekomme ich nur die 3.6.9 oder die 4.0.0

Mit dem Paketmanager kannst Du nur fertige Binary-Pakete, von der Distribution angebotene Quellpakete oder evt. vorhandenen Backports (z.B. von einer Usercommunity) installieren.

Wenn es keinen Backport gibt, musst Du logischerweise und wohl oder übel fehlende Pakete selber aus den Quellen bauen. Ich denke der Kollege it-frosch meinte genau das. Was ich dir übrigens ja in meinem ersten Post ebenfalls schon vorgeschlagen hatte, was Du wohl nicht verstanden hast. Mit "probieren" war "aus den Quellen bauen" gemeint...

mrtux
Bitte warten ..
Mitglied: melmax
12.03.2014 um 07:54 Uhr
Danke euch beiden, ich hab mir die rpms der 3.6.22 runtergeladen und werd sie am WE einspielen.

Lg
melmax
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Samba
gelöst RedHat Samba User-Zugriffe loggen (6)

Frage von Akrosh zum Thema Samba ...

Windows Server
User-ID zu Application Crash

Frage von pablovic zum Thema Windows Server ...

Router & Routing
Radius für 15 User direkt über Mikrotik- oder Ubiquiti-Router (4)

Frage von Muesliriegel zum Thema Router & Routing ...

Windows 8
gelöst Active Directory Default User.v2 Profile - Windows 8.1 Apps Error (4)

Frage von adm2015 zum Thema Windows 8 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...