Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SAMBA Freigabe unter XP reagiert unterschiedlich, brauche Hlife!

Frage Linux Samba

Mitglied: Chris07

Chris07 (Level 1) - Jetzt verbinden

13.06.2007, aktualisiert 10.07.2007, 5518 Aufrufe, 14 Kommentare

Tach auch!

Ich hab da ein kleines Problem, vielleicht könnt ihr mir helfen?
Habe leider keinen Beitrag gefunden, der mir weiterhilft.

Zur info:
(Suse Linux 10, SAMBA 3)
Ich möchte mit XP auf eine SAMBA-Freigabe zugreifen.
SAMBA ist fertig konfiguriert, Benutzer, Gruppen und Rechte sind eingestellt.
Als Beispiel möchte ich hier den Benutzer "ABC" verwenden, der über WEBMIN
auf dem SAMBA-Server eingerichtet wurde.
SAMBA ist im Freigabemodus (share).
Der Benutzer "ABC" gehört zur Gruppe "Users" und braucht kein Kennwort beim Zugriff angeben.

Jetzt zu meinem eigentlichen Problem:

Ich habe unter XP einen Benutzer angelegt -> "ABC".

Ich melde mich unter XP als "ABC" an. (Arbeitsgruppe, keine Domäne)
Wenn ich über "Start" -> "Ausführen" -> die IP-Adresse des LinuxServersFreigabe öffne, dann bin ich mit den Rechten des Benutzers "ABC" in der Gruppe "Users" auf dem freigegebenen Ordner, also alles so wie ich es haben will!!!

ABER,

Wenn ich über Netzlaufwerk-Verbinden (oder per Hand über NET USE) gehe, kann ich machen was ich will, ich werde immer mit den Rechten von "guest" in der Gruppe "guests" verbunden!?!

Ich kann als Benutzernamen angeben was ich will, es scheint mir so, als wäre ich immer als "guest" verbunden, wenn ich ein Netzlaufwerk erstelle.


Kann mir jemand sagen, warum es einerseits geht und mit Netzlaufwerk nicht?


gruß

Christian
Mitglied: 39916
13.06.2007 um 10:11 Uhr
Hi Christian,

sieht nach einem Fehler in der smb.conf aus. Stelle mal auf

security = user

und / oder poste Deine smb.conf

Gruß,

Martin
Bitte warten ..
Mitglied: Chris07
13.06.2007 um 11:56 Uhr
Hi Martin,

alles klar, ich musste in den Benutzermodus wechseln.


Trotzdem merkwürdig, das es bei Windows da anscheinend Unterschiede gibt.


Danke trotzdem!
Bitte warten ..
Mitglied: Schwedenbitter
05.07.2007 um 10:03 Uhr
Hallo,

ich bin völliger Neuling was Linux betrifft. Ich benutze openSUSE 10.2 und bin bereits froh, den Samba Server überhaupt zum Laufen bekommen zu haben. Ich versuche schon seit 2 Tagen mit einem Windows XP Rechner auf entsprechende Freigaben zuzugreifen; leider ohne Erfolg. Ich sehe noch nicht einmal den Linux Rechner im Netzwerk-Browser von Windows XP. Ich vermute, der Teufel steckt irgendwo im Detail.
Ich schaffe es wenigstens, den Rechner über seine IP anzupingen. Leider habe ich noch nicht rausbekommen, wie man ihn auch über seinen Namen anpingen kann.

Kann mir jemand eine Art Schritt-für-Schritt-Anleitung (mit Link) empfehlen, in der das erklärt wird?
Bitte warten ..
Mitglied: 39916
05.07.2007 um 10:32 Uhr
Hi,

versuche mal über \\IP-Adresse-Server\ die Shares zu erreichen. Sind die Arbeitsgruppen identisch?

Gruß,

Martin
Bitte warten ..
Mitglied: Schwedenbitter
05.07.2007 um 13:16 Uhr
Hallo,

Danke erstmal für die Tipps. Die Arbeitsgruppen sind identisch.

Den ersten Tip verstehe ich nicht vollständig.
Ich habe bereits versucht, über net use z: \\192.168.*.*\Freigabename eine Laufwerksverbindung mit Windows XP herzustellen. Das hat nicht funktioniert. Falls der Tip so gemeint ist, dass ich einfach im Explorer mal \\192.168.*.*\ eingeben soll, werde ich das gleich heute abend probieren. Auf die Idee das so zu versuchen hätte ich Trottel ja auch selbst kommen können.

Gruß

Alex
Bitte warten ..
Mitglied: Schwedenbitter
07.07.2007 um 22:08 Uhr
..., dass ich einfach im Explorer mal \\192.168.*.*\ eingeben soll ...
Das hat prima funktioniert. Danke!

Ich kann jetzt zumindest die Freigaben sehen. Allerdings habe ich noch immer keinen Schimmer, wie ich an die ran komme. Wenn ich auf eine Freigabe in Windows XP klicke, verlangt er von mir einen Benutzernamen nebst Passwort. Ich habe bereits mehrere Benutzer angelegt und diese Daten jeweils in die Eingabe-Maske eingegeben; aber es funktioniert nicht.
Was muss ich machen?

Ich würde mir gern selber helfen, weil nur dadurch das Verständnis (auch für Linux) besser wird. Deshalb wiederhole ich meine Frage, ob mir jemand eine Art Schritt-für-Schritt-Anleitung (mit Link) empfehlen kann? In der über 700 Seiten langen Dokumentation zu openSUSE habe ich nichts gefunden. Möglicherweise liegt es aber nur daran, dass ich nicht weiß wo bzw. worunter ich suchen muss.
Bitte warten ..
Mitglied: 39916
08.07.2007 um 10:13 Uhr
Hhm, scheint mir, als würden die Benutzer auf Samba-Ebene nicht existieren.

Hast Du sie angelegt? Zeig mal Deine smb.conf.

Gruß,

Martin
Bitte warten ..
Mitglied: Schwedenbitter
08.07.2007 um 11:58 Uhr
[global]
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain master = No
netbios name = ***

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = Home Directories
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
create mask = 0640
directory mask = 0750
valid users = %S

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[doc]
path = /home/admin/Documents/
comment = Das ist ein Test
inherit acls = yes
read only = No

[TEST]
path = /home/admin/Test/
guest ok = yes
read only = no


Die letzte Freigabe funktioniert. Ich brauche nicht einmal einen Benutzernamen oder ein Passwort einzugeben. Obwohl ich das sicherer fände.
Ich habe dieses Ergebnis aber erst erzielt, nachdem ich im Kontextmenü des Ordners unter Berechtigungen bei allen alles zugelassen habe.
Bitte warten ..
Mitglied: 39916
08.07.2007 um 12:31 Uhr
Die letzte Freigabe funktioniert. Ich
brauche nicht einmal einen Benutzernamen oder
ein Passwort einzugeben. Obwohl ich das
sicherer fände.
Ich habe dieses Ergebnis aber erst erzielt,
nachdem ich im Kontextmenü des Ordners
unter Berechtigungen bei
allen alles zugelassen habe.

Das heißt, du hast die conf mit Webmin erstellt? Exisitieren die Benutzer auf Samba-Ebene? Wenn Du ein Passwort willst, dann musst Du im Global-Abschnitt security = user setzen.
Bitte warten ..
Mitglied: Schwedenbitter
08.07.2007 um 15:46 Uhr
Das heißt, du hast die conf mit Webmin erstellt?

Ja. Ich hatte zunächst versucht, die conf mittels Texteditor zu bearbeiten, so wie es in der Anleitung steht. Allerdings habe ich keinen Zugriff bekommen; warum auch immer.

Exisitieren die Benutzer auf Samba-Ebene?

Genau hier fehlt mir das Verständnis.

Wenn Du ein Passwort willst, dann musst Du im Global-Abschnitt security = user setzen.

Das ist - jedenfalls bei mir - standardmäßig schon der Fall. Jedenfalls steht es so im jeweiligen Menüpunkt von Webmin. Warum es in der Datei dann nicht mehr auftaucht, ist auch mir schleierhaft.
Bitte warten ..
Mitglied: 39916
08.07.2007 um 17:14 Uhr
smbpasswd -a benutzer - erzeugt den Benutzer auf Samba-Ebene.

guest ok = no - kein Gast, als nur mit Benutzer und Passwort
Bitte warten ..
Mitglied: Schwedenbitter
09.07.2007 um 21:14 Uhr
Danke für den Tip!
Aber egal was ich auch probiere, ich bekomme immer eine Fehlermeldung wie z.B. diese hier:

Failed to open /etc/samba/secrets.tdb
Failed to open /etc/samba/secrets.tdb
Failed to open /etc/samba/secrets.tdb
pdb_generate_sam_sid: Failed to store generated machine SID.
PANIC (pid 3996): Could not generate a machine SID

BACKTRACE: 6 stack frames:
#0 smbpasswd(log_stack_trace+0x2d) [0x800c870d]
#1 smbpasswd(smb_panic+0x5d) [0x800c883d]
#2 smbpasswd(get_global_sam_sid+0x1ed) [0x800424ed]
#3 smbpasswd(main+0x5bf) [0x80030bcf]
#4 /lib/libc.so.6(__libc_start_main+0xdc) [0xb7cbcf9c]
#5 smbpasswd [0x80030101]
Abgebrochen

Was mache ich verkehrt?

P.S. Ich suche immer noch nach einer idiotensicheren Anleitung für mein Problem.
Bitte warten ..
Mitglied: chfr77
14.07.2014 um 09:43 Uhr
Zitat von Schwedenbitter:
Aber egal was ich auch probiere, ich bekomme immer eine Fehlermeldung wie z.B. diese hier:
> Failed to open /etc/samba/secrets.tdb
> Failed to open /etc/samba/secrets.tdb
> Failed to open /etc/samba/secrets.tdb


Falls hier jemand wegen dieser Meldung durch eine Suchmaschine gelandet ist, folgende Lösungsansätze helfen oft:

- Dateirechte dieser Datei korrigieren
- Domänenmitgliedschaft erneuern (leave / join)
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Samba
Freigabe per Samba (3)

Frage von haashaasp zum Thema Samba ...

Ubuntu
Freigabe auf Fileserver - nach Neustart kein Zugriff!

Frage von mike7050 zum Thema Ubuntu ...

Windows 10
Brauche Hilfe bei BlueScreen Auswertung! (10)

Frage von SgtBurner zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...