Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Samba Option Admin users zeigt seltsames verhalten

Frage Linux Samba

Mitglied: pc-nico

pc-nico (Level 1) - Jetzt verbinden

12.07.2007 um 11:16 Uhr, 5148 Aufrufe

hallo,

ich habe ein problem mit der option Admin Users....

verwende Samba, Nutzerverwaltung winbindd mit W2K Domain

hier mal die config der freigabe:

[test]
valid users = DOMAIN+test
create mask = 0660
force create mode = 0660
directory mask = 0770
force directory mode = 0770
read only = no
admin users = DOMAIN+test2
path = /test


mit dem Nutzer [B]test[/B] kann ich auf die Freigabe zu greifen.
Wenn er Dateien anlegt, gehören diese im Dateisystem ihm. Also alles IO.

Nun sollte eigentlich der Nutzer [B]test2[/B] auch auf diese Freigabe zugreifen können, da er ja [I]admin user[/I] ist. Kann er aber nicht.
Wenn ich den Nutzer zusätzlich in valid users aufnehmen, kann er zugreifen.
Legt er dann eine Datei an, so gehört sie root. Also greift die Einstellung Admin Users, die ja bewirkt, das diese Nutzer mit Root-Rechten in der Freigabe arbeiten.

Nun aber die Frage warum der Admin user nicht auf die Freigabe zugreifen kann, wenn er nicht in valid users steht? Laut Literatur ist der Eintrag unter valid users für den Admin user nicht nötig...
Ähnliche Inhalte
CPU, RAM, Mainboards
gelöst Seltsames Verhalten vom Netzteil (14)

Frage von FFSephiroth zum Thema CPU, RAM, Mainboards ...

Windows 10
Win10-Server2008 Offlinedateien seltsames Verhalten

Frage von Elgered zum Thema Windows 10 ...

Switche und Hubs
gelöst Seltsames Verhalten der NIC bzw. des Switches seit W10 1607 Update (11)

Frage von Augenadler zum Thema Switche und Hubs ...

Viren und Trojaner
gelöst Seltsames Verhalten! Virus? Plinker! (14)

Frage von achim222 zum Thema Viren und Trojaner ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
gelöst Festplattenverschlüsselung im Ausland (13)

Frage von Nicolaas zum Thema Verschlüsselung & Zertifikate ...

Windows Server
gelöst Microsoft-Lizenz CALs und passendes Server-Betriebssystem (13)

Frage von planetIT2016 zum Thema Windows Server ...

Batch & Shell
HTML in Batch und Powershell (12)

Frage von michi-ffm zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Fehlerhafte Blöcke im RAID 10 (12)

Frage von Kojak-LE zum Thema Festplatten, SSD, Raid ...