Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Samba ist tot und DBUS hat ein Problem

Frage Linux Samba

Mitglied: 43292

43292 (Level 1)

14.11.2011, aktualisiert 15:31 Uhr, 4949 Aufrufe, 9 Kommentare

Hallo mit'nander,

ich bräuchte mal wieder eure Hilfe, und zwar geht es um Samba. Angefangen hat alles mit einem Rechte-Problem. Es hätte eigentlich eine Freigabe funktionieren sollen, die aber trotzdem nicht ging. Man hatte keine Schreibberechtigung, trotz zehnmaliger Überprüfung des Shares. Wie auch immer, dachten wir, dass evtl. daß das Linux-Passwort nicht mit dem Samba-Passwort gesyncht wäre. Wir hatten am Server unter root-Login das Kommando "smbpasswd" abgesetzt, daraufhin 2x unser root-Passwort eingegeben. Wir dachten mit dem smbpasswd würde man synchen können, worin wir natürlich zu voreilig waren. Samba war daraufhin nicht mehr erreichbar. Wir haben mit /etc/inet.d/samba restart versucht das ganze zu starten, aber irgendwie war Samba komplett verschwunden nachdem wir mal apt-get update und apt-get install samba probierten kamen lauter dpkg Fehler testparm zeigt keine Fehler.

sambaserv:/etc/samba# apt-get install samba
Reading package lists... Done
Building dependency tree
Reading state information... Done
samba is already the newest version.
The following packages were automatically installed and are no longer required:
libfam0 xfsprogs fam xfsdump libdm0
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 49 not upgraded.
5 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up dbus (1.2.1-5+lenny1) ...
The system user `messagebus' already exists. Exiting.
chown: invalid group: `messagebus:messagebus'
dpkg: error processing dbus (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of avahi-daemon:
avahi-daemon depends on dbus (>= 0.60); however:
Package dbus is not configured yet.
dpkg: error processing avahi-daemon (--configure):
dependency problems - leaving unconfigured
usw...

sambaserv:/etc/samba# dpkg-reconfigure dbus
/usr/sbin/dpkg-reconfigure: dbus is broken or not fully installed

Smbd und Nmbd laufen auf dem Server, auch mit "smbclient -L" kann ich die Freigaben sehen. Das Problem ist, dass ich von keinem Client aus mehr anmelden kann. Ich gebe zwar das richtige Passwort ein, aber ich kann wohl nicht mehr authentifiziert werden. Irgendwie werden wohl die Clients nicht mehr authentifiziert? Auf dem Server sehe ich ganz unten in der /var/log/samba/log.pc1 folgende Meldungen:

[2011/11/14 10:24:02, 0] rpc_server/srv_netlog_nt.c:get_md4pw(322)
get_md4pw: Workstation PC1$: account is not a trust account
[2011/11/14 10:24:02, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(502)
_netr_ServerAuthenticate2: failed to get machine password for account PC1$: NT_STATUS_NO_TRUST_SAM_ACCOUNT
[2011/11/14 10:24:02, 0] rpc_server/srv_netlog_nt.c:get_md4pw(322)
get_md4pw: Workstation PC1$: account is not a trust account
[2011/11/14 10:24:02, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(502)
_netr_ServerAuthenticate2: failed to get machine password for account PC1$: NT_STATUS_NO_TRUST_SAM_ACCOUNT

Bin für jeden Tip sehr dankbar.
Mitglied: sebfoe
14.11.2011 um 12:15 Uhr
Hast du mal probiert über

dpkg-reconfigure samba

das Paket neu zu konfigurieren?
Bitte warten ..
Mitglied: 43292
14.11.2011 um 12:21 Uhr
Nein. Aber ich habe vorhin gesehen, dass die Fehlermeldung ausgegeben wurde, dass der User messagebus bereits existiere. Ich hab in der /etc/passwd einfach die Zeile des Users "messagebus" mit # auskommentiert und dann konnte ich auch problemlos apt-get update, apt-get autoremove, apt-get install samba und apt-get install dbus durchführen. Jetzt gibt es einen neuen messagebus-User in der /etc/passwd.

Allerdings habe ich immer noch das Problem, dass irgendwas mit der Authentifizierung nicht mehr klappt. Ich kann mit den Clients nicht mehr anmelden. Die Vertrauensstellung ist irgendwie hinüber. Sobald ich mich mit dem Client überhaupt am Domaincontroller anmelde (und mein SAMBA fungiert ja auch als PDC) erhalte ich die FEhlermeldung

"Die Vertrauensstellung zwischen dieser Arbeitsstation und der primären Domäne konnte nicht hergestellt werden."

Kann ich irgendwie automatisch die Synchronisation wieder herstellen?

Das Logfile /var/log/samba/log.pc3 sagt zum Beispiel folgendes:

[2011/11/14 11:22:35, 0] rpc_server/srv_netlog_nt.c:get_md4pw(322)
get_md4pw: Workstation PC3$: account is not a trust account
[2011/11/14 11:22:35, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(502)
_netr_ServerAuthenticate2: failed to get machine password for account PC3$: NT_STATUS_NO_TRUST_SAM_ACCOUNT
[2011/11/14 11:25:39, 0] rpc_server/srv_netlog_nt.c:get_md4pw(322)
get_md4pw: Workstation PC3$: account is not a trust account
[2011/11/14 11:25:39, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(502)
_netr_ServerAuthenticate2: failed to get machine password for account PC3$: NT_STATUS_NO_TRUST_SAM_ACCOUNT
[2011/11/14 11:25:39, 0] rpc_server/srv_netlog_nt.c:get_md4pw(322)
get_md4pw: Workstation PC3$: account is not a trust account
[2011/11/14 11:25:39, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(502)
_netr_ServerAuthenticate2: failed to get machine password for account PC3$: NT_STATUS_NO_TRUST_SAM_ACCOUNT
[2011/11/14 11:30:22, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(520)
_netr_ServerAuthenticate2: netlogon_creds_server_check failed. Rejecting auth request from client PC3 machine account PC3$
[2011/11/14 11:30:22, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(520)
_netr_ServerAuthenticate2: netlogon_creds_server_check failed. Rejecting auth request from client PC3 machine account PC3$
[2011/11/14 11:31:25, 0] rpc_server/srv_netlog_nt.c:_netr_ServerAuthenticate2(520)
Bitte warten ..
Mitglied: 16568
14.11.2011 um 13:00 Uhr
Du brauchst tatsächlich DRINGEND Hilfe...

klick


Lonesome Walker
Bitte warten ..
Mitglied: 43292
14.11.2011 um 14:12 Uhr
Vielen vielen herzlichen Dank für die hilfreiche Lektüre.
Bitte warten ..
Mitglied: 43292
14.11.2011 um 15:11 Uhr
Ich habe in /var/log/apt/term.log gesehen, dass anscheinend durch das Update die database upgedatet wurde. So hat's also angefangen:

Log started: 2011-11-14 09:55:52
(Reading database ... 36277 files and directories currently installed.)
Removing sernet-samba ...
Stopping Samba daemons: nmbd smbd.
Removing sernet-samba-common ...
Removing sernet-libwbclient0 ...
Processing triggers for man-db ...
Selecting previously deselected package libwbclient0.
(Reading database ... 35952 files and directories currently installed.)
Unpacking libwbclient0 (from .../libwbclient0_2%3a3.2.5-4lenny15_i386.deb) ...
Selecting previously deselected package samba-common.
Unpacking samba-common (from .../samba-common_2%3a3.2.5-4lenny15_i386.deb) ...
Selecting previously deselected package smbclient.
Unpacking smbclient (from .../smbclient_2%3a3.2.5-4lenny15_i386.deb) ...
Selecting previously deselected package libpam-smbpass.
Unpacking libpam-smbpass (from .../libpam-smbpass_2%3a3.2.5-4lenny15_i386.deb) ...
Processing triggers for man-db ...
Setting up dbus (1.2.1-5+lenny1) ...
The system user `messagebus' already exists. Exiting.
chown: invalid group: `messagebus:messagebus'

Die Frage ist, ob mein Samba dadurch auch upgedatet wurde. Laut smbstatus werkelt version 3.2.5. Laut der Kompatibilitätsliste hier http://wiki.samba.org/index.php/Windows7 sollte meine Version also keine Probleme bereiten. Was sollte ich denn nun tun, um meine Authentifizierung wieder herzustellen? Sollte ich Samba komplett neu installieren, und wenn ja wie und in welcher Version, damit auch Win7-Clients funktionieren? Hab nämlich in Erinnerung, dass nicht alle Samba-Versionen mit Win7 kompatibel sind. Die Registry-Einträge auf den Win7-Clients sind natürlich überall aktiv. Bis heute funktionierte ja auch alles einwandfrei Kann ich irgendwie herausfinden welche Samba-Version zuvor installiert war, so dass ich irgendwie downgraden kann?
Bitte warten ..
Mitglied: 16568
14.11.2011 um 15:24 Uhr
Ich sag's ungern nochmal:

KLICK MICH! und dann TU WAS!


Lonesome Walker
Bitte warten ..
Mitglied: 43292
14.11.2011 um 15:32 Uhr
Wenn du damit meinst, dass in meinem Ursprungspost das "Hallo" fehlte, dann habe ich das jetzt hiermit nachgeholt. Ich mache das in all meinen Beiträgen wie unschwer zu erkennen ist. Ich habe wahrscheinlich heute morgen vor dem Schock, dass Samba komplett stehengeblieben ist, das Hallo total vergessen. Das soll nicht heißen, dass ich keinen Respekt den Forumsmitgliedern erweise oder unfreundlich bin. Wer meine Beiträge kennt, der weiß dass ich mich immer freundlich melde und auch eine Begrüßung einfüge. Du könntest mir mit diesem Hinweis einfach eine freundliche PN schicken, dann wüßte ich sofort was du meinst. Aber das so rauszuschreien und so hinzustellen ist meiner Ansicht nach nicht die feine Art. Wenn du schon auf Netiquetten verlinkst, dann solltest du dich selber mal an die Nase fassen:

GROSSCHREIBUNG wird in einem Forum genau wie in einer E-Mail als lautes Schreien interpretiert und dem entsprechend als unhöflich empfunden.

Ich hoffe weiterhin auf konstruktive Beiträge zum aktuellen Problem und bedanke mich für jegliche Hilfestellung dazu.

Eine schöne Woche allerseits.
Bitte warten ..
Mitglied: mrtux
15.11.2011 um 11:27 Uhr
Hi !

Zitat von 43292:
> Unpacking libwbclient0 (from .../libwbclient0_2%3a3.2.5-4lenny15_i386.deb) ...

Auch wenn das jetzt mit deinem Problem weniger zu tun hat, frage ich mich gerade, wieso Ihr überhaupt noch Lenny einsetzt, denn der Support läuft in Kürze (am 6. Februar 2012 genau) aus. Dann gibt es dafür keine Updates mehr, meines Wissens auch keine Sicherheitsupdates, daher das Upgrade nicht mehr auf die "lange Bank" schieben....

Die Meldung über den User messagebus sagt noch lange nichts darüber, ob der Daemon ein Problem hat. Hast Du mal geschaut ob der Daemon läuft? Ich tippe aber bei deinen Problemen darauf, dass die tdb's von Samba hinüber sind oder überschrieben wurden. Hast Du keine Datensicherung davon? Die macht man normalerweise bevor man so unbedarft mit smbpasswd und anderen (Konfig-) Tools von Samba herum experimentiert. Die Files liegen bei Debian per default unter /var/lib/samba. Ich sichere immer, zusätzlich zu einem regelmässigen, automatischen Backup per Cronjob, vor jeder Änderung an der Konfig, alle zu einem Paket gehörenden (Konfig-) Files, also z.B. auch die unter /var...

...und vertrage dich gut mit LW, der ist langjähriger Debian Berater (und darf sich sogar offiziell so nennen), wenn einer Ahnung von Debian hat, dann er!

mrtux
Bitte warten ..
Mitglied: 43292
15.11.2011 um 12:27 Uhr
Hallo mrtux,

ich hatte mir das gestern Abend auch noch gedacht, und damit angefangen Squeeze zu installieren. Der Server steht auch soweit, siehe meinen anderen Thread zur BIND9-Frage ich werde Samba also auch auf den neuen Server umziehen. Backups sind da, ist kein Problem. Werde Samba jetzt neu aufsetzen, bzw. eins zu eins übernehmen, nur eben auf dem neuen Squeeze-Server.

Ich habe mich nicht gestritten mit LW, sondern nur auf seinen Doppelangriff freundlich und aussagekräftig reagiert. Ich bin nicht der Typ von Streitereien, falls das also so rüberkam dann tuts mir leid. Es ist nicht meine Intension zu streiten. Ich bin in einer Gemeinde, in der Frage gestellt werden, und auch geholfen wird. Das weiss ich zu schätzen. Und ich respektiere jeden einzelnen hier, unabhängig davon ob er aktiv an Hilfestellung teilnimmt, oder passiv mitliest. Fachliche Stellenwerte geben aber trotzdem keinem das Recht, auf diese Art zu agieren (meine Meinung).

Nix für ungut, eine schöne Woche allerseits.
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Samba
Samba 4.4.3 mit Spotlight - tracker dbus error (1)

Frage von xfiles zum Thema Samba ...

Exchange Server
Problem mit POP3-Abruf eines Exchange-2013-Postfachs

Frage von YotYot zum Thema Exchange Server ...

Multimedia & Zubehör
gelöst BENQ Beamer Fernbedingung Frequenz Problem (4)

Frage von xbast1x zum Thema Multimedia & Zubehör ...

Windows Server
Google Chrome Web Store Problem auf Terminal Farm

Frage von dakoerry zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...