Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Samba - Win, kein ping !

Frage Linux Samba

Mitglied: pytisso

pytisso (Level 1) - Jetzt verbinden

02.11.2008, aktualisiert 03.11.2008, 5114 Aufrufe, 4 Kommentare

Nach längerem googeln immer noch nicht schlau.

Konstellation:
WIN xp prof Rechner bt10 + win2k Rechner pc29 im LAN:
Drucker + Dateifreigabe o.k. im LAN, pc29 erkennt bt10 und wird von bt10 erkannt, Daten schreiben auf jeweils anderem Rechner ok, "ping bt10" bzw. "ping pc29" vom jeweils anderen Rechner ok
Internet-Zugang über Kabel-Deutschland -> Motorola-Modem -> Router.

Backup-/Datei-Server pc17 im LAN:
debian linux sarge, samba v3.0.14a-3 (ct server v1.03)
smb.conf:
workgroup = WORKGROUP
security = user
....
wins support, wins server auskommentiert

user gerd existiert auf allen 3 rechnern
pc17 wird als pc17 von bt10 + pc29 erkannt, beide können auf pc17 schreiben
"testparm smb.conf" meldet keine Fehler

Problem:
von pc17 aus:
Eingabe: "ping bt10" bzw. "ping pc29": Rechner wird nicht erkannt,
Ausgabe:
PING bt10 (67.63.55.1) 56(84) bytes of data
64 bytes from 67.63.55.1: tcmp_seq=1 ttl=243 time=115 ms
für pc29 entsprechende Ausgabe.

"smbclient -L //b10" ergibt:
timeout connecting to 67.63.55.1:445
timeout connecting to 67.63.55.1:139
Error connecting to 67.63.55.1 (Operation already in progress)
Connection to bt10 failed
Ausgabe pc27 entsprechend, ebenso wenn ich den Router vom WAN abklemme.
(Was ist das überhaupt für eine Adresse? Warum antwortet der Rechner überhaupt auf einen vollkommen unzulässigen Namen ? Er antwortet auch auf z.B. "ping aaa" )

"nmblookup bt10" ergibt:
querying bt10 on 192.168.1.255
192.168.1.33 bt10<00>
bei pc29 entsprechend, ebenso wenn ich den Router vom WAN abklemme.

ping zur IP Adresse "ping 192.168.1.33" ist ok

wenn ich den router vom WAN abklemme kommt folgende Meldung bei Eingabe von "ping bt10":
ping: unknown host bt10
ebenso pc29

Samba log.nmbd, log.bt10:
keine Einträge bei den vergeblichen ping-Versuchen von pc17 aus.

So, wie ich das verstanden habe, fungieren doch die einzelnen Win-Rechner als Server für ihre Namen? Jedenfalls geben sie ja offenbar ihre Namen bekannt. Sonst könnten ja auch die win-Rechner sich nicht untereinander erkennen über ihr NetBIOS (over TCPIP). Es laufen jedenfalls die beiden Dienste "TCP/IP-NetBIOS-Hilfsprogramm" + "Server" auf bt10. Ein Abschalten der XP-Firewall brachte auch nichts.

Bis vor ca. 2 Wochen hat auch alles funktioniert, weiss leider nicht, wo ich was geändert hätte.
Und was ich bis jetzt gelesen habe, ist es auch nicht notwendig, dafür extra einen server aufzusetzen.

Wofür ich das brauche: Der Server benötigt die NetBIOS-Namen, da er automatische Backups ziehen soll (rsync+backuppc). Zuteilung der IP-Adressen der anderen beiden Rechner geschieht durch DHCP-Server des Routers. Alle Rechner werden täglich neu gestartet und wieder heruntergefahren. Ab und an wird noch ein Laptop drangehängt. Da soll auch mal irgenwann Datensicherung laufen.

Braucht Ihr noch Infos?
Was kann ich denn da machen (ratlos) ? Wo soll ich suchen ? Für jeden Hinweis dankbar.

Danke schon mal

pytisso
Mitglied: theton
03.11.2008 um 08:10 Uhr
Linux-Rechner hatten schon immer Probleme mit der Namenszuordnung via NetBIOS. Eine einfache Lösung ist das Zuordnen der im Netzwerk vorhandenen Rechner über die /etc/hosts. Alternativ muss ein DNS-Server verwendet werden, der die Namenszuordnung übernimmt.
Bitte warten ..
Mitglied: aqui
03.11.2008 um 11:59 Uhr
Es ist nicht wirklich ein Problem sondern ein Fehler in der Konfig wie oben richtig bemerkt !
Man muss ihnen die Namen nur bekannt geben, da diese automatische Masterbrowser Funktion in CIFS Netzen eben immer etwas länger dauert.
Du solltest den os-level Wert in der smb.conf entsprechend hochsetzen, das der Samba Server immer Masterbrowser im Netz wird, dann hast du keine Probleme mehr.
Sind die Namen nicht in der /etc/hosts fragt Samba immer den Nameserver und da hast du sicher den proxy DNS deines Routers konfiguriert oder den deines Providers !?
Das der natürlich keine lokalen Rechner mit RFC 1918 Adressen findet liegt auf der Hand und ist logisch !!! Deshalb auch der statische Eintrag in die /etc/hosts für alle lokalen Komponenten das das eben nicht passiert wenn du keinen lokalen DNS betreiben willst. (Musst du auch nicht bei den 3 Komponenten !)

Das sieht dann so aus in der /etc/smb.conf:

server string = Linux Samba Server
netbios name = SERVER
local master = yes
preferred master = yes
os level = 65

Die /etc/hosts Datei solltest du auch anpassen wie hier:
01.
# Do not remove the following line, or various programs 
02.
# that require network functionality will fail. 
03.
127.0.0.1               localhost.localdomain localhost 
04.
192.168.1.200           server.pytisso.local server pc17 
05.
192.168.1.33            bt10.pytisso.local bt10 
06.
192.168.1.29            pc29.pytisso.local pc29
So klappts dann auch immer mit den Namen beim Ping usw.
Siehe Infos hier:
http://www.linux-praxis.de/linux3/samba6.html

Damit sollte es problemlos klappen !
Bitte warten ..
Mitglied: theton
03.11.2008 um 12:11 Uhr
Du bestätigst meine Aussage (halt nur etwas ausführlicher) und tust sie als Unsinn ab? Ich hab doch geschrieben, dass eine Anpassung der /etc/hosts oder ein DNS für die interne Namensauflösung notwendig ist. Genau die von dir beschriebene Notwendigkeit der Anpassung der /etc/hosts meinte ich mit "Problemen" und habe darauf ja auch hingewiesen. Eine automatische Namenserkennung via NetBIOS (und somit Samba) ohne Zuhilfenahme der IP-Zuweisung via hosts-Datei oder DNS funktioniert eben nicht so einfach mit Samba unter Linux. Unter Windows ist eine solche Anpassung der Hosts-Datei oder ein zusätzlicher DNS unnötig, da es dort rein über NetBIOS gelöst wird.
Bitte warten ..
Mitglied: pytisso
03.11.2008 um 21:40 Uhr
Danke theton + aqui für die schnelle Antwort.

Master browser war mir kein Begriff. Muß mal nachlesen, was der im Unterschied zu WINS-Server macht.

Werde smb.conf entsprechend Vorschlag abändern und testen. Damit pc17 nicht andere DNS-Server (wie meinen router) abfragt bzw. damit diese niedrigere Priorität haben.

Wenn ich richtig verstanden habe, benötigt samba trotzdem noch zusätzlich eine eindeutige Zuordnung der NetBIOS-Namen zu den IP-Adsressen, sei es mit /etc/hosts oder DNS-Server.
Warum?
Ist die NetBIOS-Namens-Auflösung in samba noch nicht richtig implementiert (hatte sowas in einem alten Beitrag irgenwo mal gelesen, dachte, es sei inzwischen besser, zumal es ja bei mir ein paar Monate problemlos klappte)? Sollte ich die neueste samba version installieren?
Was mich irritiert: nmblookup erkennt doch richtig die Zuordnung von NetBIOS-Name zu IP-Adresse.

Sonst werde ich halt allen Rechnern eine fixe LAN-Adresse verpassen und in die /etc/hosts mit den entsprechenden Namen eintragen.
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
Win Server 2012R2 bzw 2016 als Backupdomaincontroller in einer Samba 3 Domäne

Frage von Franz-Josef-II zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Installation
gelöst 1:1 Kopie einer bootfähigen CF-Card mit Win embedded (7)

Frage von ben1310 zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (13)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...