Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Samba3 als PDC Windows XP als Clients geht nicht.

Frage Linux Samba

Mitglied: crashi09

crashi09 (Level 1) - Jetzt verbinden

03.08.2006, aktualisiert 18.10.2012, 6638 Aufrufe, 15 Kommentare

Habe folgendes Problem,

Wir haben bei einem Kunden einen Linux PDC Laufen
Debian 3.0 Sarge
Samba Version 3.014

smb.conf

Nach einem Update von der 2 Version auf die 3 geht die Benutzeranmeldung nicht mehr

Global parameters
[global]
panic action = /usr/share/samba/panic-action %d
workgroup = xx
netbios name = Test
server string = %h server (Samba %v)
encrypt passwords = true
os level = 33
security = user
browsable = no
domain master = yes
domain logons = yes
local master = yes
admin users = @s-admin, root
null passwords = no
smb passwd file = /etc/smbpasswd
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
passwd chat debug = Yes
log level = 3
syslog = 1
log file = /var/log/samba/log.%m
max log size = 1000
add user script = /usr/sbin/useradd -d /dev/null -s /bin/false -M %u
add machine script = /usr/sbin/useradd -s /bin/false/ -d /var/libnobody %u
logon script = %U\logon.bat
logon path = \\\\%N\Profiles\%U
logon drive = y:
passdb backend = tdbsam, guest
preferred master = yes
  1. dns proxy = No
wins support = yes
create mask = 0774
directory mask = 0775
hosts allow = 192.168.xx.0/255.255.255.0 192.168.xx.22 127.0.0.1

Ales freigaben können mit den Angelegten USer Account geöffnet werden, auch die ZUgriff auf die Verzeichniss greifen.
Nur wenn ich einen WinXP in die Domäne integriert habe kann sich keine User anmelden.
Es heist er findet das Servergespeicherte Profil nicht und das lokale auch nicht. Diese Fehlermeldung taucht nur beim den Benutzer auf die vor dem Update auf dem Server angelgt wurden. Habe auch neue Testuser angelegt, wenn ich mich mit diesen anmlde heist es, das er die Domäne nicht finden kann und der Domänen Controller nicht zur Verfügung steht.
Habe auch schon unter den
Sicherheitseinstellungen –> Lokale Richtlinien –> Sicherheitsoptionen Domänenmitglied: Daten des sicheren Kanals digital verschlüsseln oder signieren (immer) deaktiviert aber die Meldung bleibt die selbe. Bin hier fast am Verzweifeln. bitte um Hilfe.

Danke schonmal.

crashi09
Mitglied: Maggus
03.08.2006 um 13:20 Uhr
Hi,

haste mal versucht, die Client-Accounts (Maschinen-Accounts) zu löschen und neu anzulegen.
Kann sein, dass der Client den Server nicht mehr findet, weil die SID anhand der Client den Server identifiziert nicht mehr passt.

Mit freundlichen Grüßen
Maggus
Bitte warten ..
Mitglied: crashi09
03.08.2006 um 13:41 Uhr
Hallo,

erstmal danke für die schnelle Antwort

Wie mach ich den das?

Ich habe die Accounts aus der passwd und smbpasswd mal entfernt, geht das so?

Oder gibts es dafür ein script.

Sonst stimmt die Konfig? den bei der 3er mussten ja noch einige einträge mehr gemacht werden.

Gruß,

Crashi09
Bitte warten ..
Mitglied: Maggus
03.08.2006 um 14:02 Uhr
Hi,

vielleicht hilft Dir dieser Link weiter:

www.samba.org/samba/docs/man/Samba-HOWTO-Collection/

Mit freundlichen Grüßen
Maggus
Bitte warten ..
Mitglied: crashi09
03.08.2006 um 14:24 Uhr
Hallöle,

Nach dieser Anleitung habe ich die Einstellung gemacht.
Aber ich bekomme immer noch den Fehler.

Gruß,
Crashi09
Bitte warten ..
Mitglied: Maggus
03.08.2006 um 14:31 Uhr
Dann versuch mal mit userdel und smbuserdel den Maschinenaccount zu löschen und
dann wie in der o.g. Anleitung mit useradd und smbuseradd neu anzulegen.

Ansonsten versuch mal diese Anleitung:
www.xs4all.nl/~bruijn9/docs/sambapdc/sambapdc.pdf

Mit freundlichen Grüßen
Maggus
Bitte warten ..
Mitglied: crashi09
04.08.2006 um 13:13 Uhr
Hallo Leute,

Habe jetzt folgendes Problem, wenn ich den Rechner (WINXP) in die Domäne aufnehmen will. Bekomme ich die Meldung:

Beim dem Verwsuch der Domäne xx beizutrten ist ein Fehler aufgetreten.
Die Domäne ist nicht verfügbar oder falsch geschrieben.

Aber ich kann alle Namen überall hin auflösen. vom XP zum Samba vom Samba zum XP.

Hat vieleciht jemand noch eine Idee was ich da falsch mache.

Ich krieg die Krise

Danke schonmal
Bitte warten ..
Mitglied: Maggus
04.08.2006 um 13:53 Uhr
Hi,

haste bei deinem XP-Client in der Registry den Wert RequireSignOrSeal auf "0" gesetzt?

WinXP benötigt aktzeptiert normalerweise nur verschlüsselte oder signierte Pakete.

Den Schlüssel findest Du in der Registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters\requiresignorseal

Mit freundlichen Grüßen
Maggus
Bitte warten ..
Mitglied: crashi09
04.08.2006 um 16:09 Uhr
Hallo,

Ja den Schlüssel habe ich gesetzt. Ohne Erfolg.
Ich bekomme immer den Fehler das er die Domäne nicht findet.

Aber eine Frage habe ich noch.
Ich habe keinen Wins bei mir im Netz. den sollte eigentlich auch der PDC machen wie kann ich das realiesieren.

Gruß

Crashi09
Bitte warten ..
Mitglied: Maggus
07.08.2006 um 09:55 Uhr
Hi,

Du hasst ja eigentlich in Deiner Config bereits "WINS SUPPORT = YES" gesetzt. Daher müsste es eigentlich gehen. Ich glaube das bei der Aktualisierung etwas schief gelaufen
ist. Ist zwar nicht die schönste Lösung, aber unter Linux haben wir bei manchen Problemen
den jeweiligen Dienst komplett gelöscht und neu installiert. Ich meine also das Du vieleicht Deinen Samba komplett deinstallierst und kein Aktualisierung machst sondern neu Installation. Da es eigentlich laut Deinen Angaben mit den Einstellungen gehen müsste. Haßt ja anscheinend alles beachtet. Und selbst wenn WINS nicht geht, müsste eine Domain-Anmeldung gehen.

->Aber bevor Du das machst schliessen wir lieber noch ein paar Dinge aus. Was hasst Du denn für Meldungen in der "MESSAGES"? Findest Du unter /var/log/messages.

->Läuft Dein DNS-Server einwandfrei? Weil ohne WINS brauchst Du einen funktionierenden BIND. Versuch mal von Deinem Windows Client aus, die lokalen IP-Adressen und Namen aufzulösen. Kannst Du mit "nslookup" vom "cmd-prompt" aus testen.

Mit freundlichen Grüßen
Maggus
Bitte warten ..
Mitglied: Maik87
07.08.2006 um 13:33 Uhr
hast du nach dem editieren dem samba neugestartet??

rcsmb restart

oder die smb.conf mal auf fehler überprüft??

testparm
Bitte warten ..
Mitglied: crashi09
07.08.2006 um 15:02 Uhr
Hallo


Ja der Sambadienst wurde auch schonm neu gestartet.


Aber leider ohne erfolg. Ich glaube ja langsam das es an dem Windowsrechner liegt.
Bitte warten ..
Mitglied: Maik87
08.08.2006 um 09:26 Uhr
Ich habe selbst als Projekt einen Susu Linux 10.1 also Samba 3 als PDC aufgesetzt. Es läft auch alles wunderbar, bis auf ein RIESEN Problem:

Wenn ich mich ein zweites mal mit einem Profil einloggen will, tritt folgender Fehler auf:

Die Datei \\130.0.0.3\profiles\Anwendungsdaten\Microsoft\Internet Explorer\brndlog.txt konnte nicht nach C:\Dokumente und Einstellungen\hartwig.XXX\Anwendungsdaten\Microsoft\Internet Explorer\brndlog.txt kopiert werden. Mögliche Fehlerursachen sind Netzwerkprobleme oder nicht ausreichende Sicherheitsrechte. Wenden Sie sich an den Netzwerkadministrator, wenn das Problem weiterhin besteht.


Details - Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.



Es kann auch jede andere Datei sein, also je Versuch macht eine andere Datei diesen Ärger.
Bitte warten ..
Mitglied: Maggus
08.08.2006 um 09:54 Uhr
Hi,

ich denke mal das Ihr alle Windows XP Rechner nutzt.

Bei Windows XP muss ein Benutzer-Profil eines Domain-Users entweder dem User selber gehören (also er muss Besitzer sein) oder die Gruppe der Administratoren.

Überprüft mal die Sicherheitseinstellungen auf euren Linux-Servern. Die Benutzer habt Ihr ja auch auf dem Linux-Server eingerichtet, sowohl mit useradd als auch im Samba. Gebt den Usern selbst und dem root Vollzugriff. Des Weiteren könnt Ihr im Samba eine Funktion einschalten, woraus der Samba aus Administrator immer root macht. D.h. wenn Ihr von euren Windows-PCs aus mit dem Administrator-Account zugreift, sendet euer Windows ja standartmässig Administrator als Benutzer und das jew. Passwort. Samba kennt ja eigentlich nur root als admin. Mit o.g. Funktion wandelt er das jetzt aber automatisch in Administrator.

Die Dokumentation von samba.org steht das o.g. drin.

Mit freundlichen Grüßen
Maggus
Bitte warten ..
Mitglied: Maik87
08.08.2006, aktualisiert 18.10.2012
Ich habe auf dem Homeverzeichnis chmod 777 oder was meinst du?

Ich habe selbst einen Threath geöffnet:


http://www.administrator.de/forum/profilprobleme-bei-pdc-suse-linux-10. ...

vielleicht kannst mir da helfen!!
Bitte warten ..
Mitglied: crashi09
18.08.2006 um 09:57 Uhr
Hallo Leute,

Habe den Fehler gefunden. Es lag an den Zugriffrechten auf die Profilverzeichnisse.
Samba2 hat wohl andere Vorraussetungen als Samba3.

Danke für eure Mühe und Hilfe
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Windows 10
Windows 10 Clients laden Updates nicht von WSUS Server (7)

Frage von Alternativende zum Thema Windows 10 ...

Windows XP
Kann man noch neue Notebooks für Windows XP kaufen ? (9)

Frage von DieterJansen zum Thema Windows XP ...

Windows Netzwerk
SMBv2 in Windows 7 - Windows XP - Windows Server 2003 Domäne deaktivieren (4)

Frage von Mario.Steinberg zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...