Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Samba4 + winbindd 4.2 Homedir nicht richtig aufgelößt

Frage Linux Samba

Mitglied: Chonta

Chonta (Level 3) - Jetzt verbinden

28.03.2014 um 10:46 Uhr, 3014 Aufrufe, 6 Kommentare

Hallo,

ich habe Samba4 aus den Sourcen als Memberserver installiert (version 4.2)
Soweit ist auch alles ok, die Anmeldung am AD geht.

Das Problem ist, das ein wbinfo -i benutzername für das Homeverzeichniss

/home/%D/%U

ausgibt.
Eigendlich sollte bei %D der Netbiosname der Domäne stehen und vor allem bei %U der Benutzername.
Für den Zugriff auf Freigaben nicht weiter wild, aber wenn ich will, dass die Sambauser auch an dem Rechner anmelden können, ist das ein Problem.

PAM wurde soweit konfiguriert, das bei einer Anmeldung auch automatisch das Homeverzeichniss angelegt wird, das Proble ist halt das es dann für jeden User /home/%D/%U wäre.

Wenn jemand ne Idee hat, wie ich winbindd/smbd dazu bringen kann mit %U den richtigen User zu verknüpfen wäre das super.
Beim einrichten der [%U] Freigabe wird wenn der User auf den Server schaut die richtige Freigabe angezeigt.

Gruß

Chonta
Mitglied: DanielZ87
28.03.2014, aktualisiert um 11:41 Uhr
Ich bin jetzt nicht unbedingt der Experte aber vlt. Hilft dir das weiter (ich habe es auf einem OMV NAS angewendet).

edit /etc/nsswitch.conf
passwd: compat winbind
shadow: compat
group: compat winbind

root:/# ldconfig

create the file /usr/share/pam-configs/my_mkhomedir with the following content



Name: Activate mkhomedir
Default: yes
Priority: 900
Session-Type: Additional
Session:
required pam_mkhomedir.so umask=0077 skel=/etc/skel



Create the file /usr/share/pam-configs/umask with the following


Name: Activate umask
Default: yes
Priority: 800
Session-Type: Additional
Session:
optional pam_umask.so umask=0077



mkdir /home/DOMAIN
chmod 0755 /home/DOMAIN
chown root:domain\ users DOMAIN


gruß Daniel
Bitte warten ..
Mitglied: Chonta
28.03.2014, aktualisiert um 11:49 Uhr
Hallo,

die /etc/nsswitch ist shcon so, sonst würde ja nix gehen

Die Domänenuser sind auch im System drin, ich kann Dateirechte an Domänenbenutzer und User vergeben wie ich will.
Die Anmeldung am Linux geht auch wunderbar, nur lösßt winbind die Variablen %U und %D nicht richtig auf.

smbd macht es, weil die Freigaben mit %U werden richtig angelegt und ein root preexec script was verzeichnisse für %U anlegt legt diese auch an.

Hier das Script. geht jemand auf die [%U] Freigabe und der Ordner existiert nicht wird dieser angelegt.

01.
path=/data/profile/ 
02.
 
03.
if [ ! -e $path$1 ]; then 
04.
mkdir  $path$1; 
05.
chown -R $1:root $path$1; 
06.
chmod o-rwx; fi
Mein Problem derzeit ist rein die Auflösung des Homdir wo %U bei windbind %U bleibt und nicht als Benutzername angezeigt wird.

Gruß

Chonta

Nachtrag: Smbd und winbindd sind Version 4.2.0pre1-GIT-2e2137f
Bitte warten ..
Mitglied: DanielZ87
28.03.2014 um 11:54 Uhr
Zitat von Chonta:

Hallo,

die /etc/nsswitch ist shcon so, sonst würde ja nix gehen

Die Domänenuser sind auch im System drin, ich kann Dateirechte an Domänenbenutzer und User vergeben wie ich will.
Die Anmeldung am Linux geht auch wunderbar, nur lösßt winbind die Variablen %U und %D nicht richtig auf.

smbd macht es, weil die Freigaben mit %U werden richtig angelegt und ein root preexec script was verzeichnisse für %U anlegt
legt diese auch an.

Hier das Script. geht jemand auf die [%U] Freigabe und der Ordner existiert nicht wird dieser angelegt.

01.
> path=/data/profile/ 
02.
>  
03.
> if [ ! -e $path$1 ]; then 
04.
> mkdir  $path$1; 
05.
> chown -R $1:root $path$1; 
06.
> chmod o-rwx; fi 
07.
> 
Mein Problem derzeit ist rein die Auflösung des Homdir wo %U bei windbind %U bleibt und nicht als Benutzername angezeigt
wird.

Gruß

Chonta

Nachtrag: Smbd und winbindd sind Version 4.2.0pre1-GIT-2e2137f

Hmm, probiere mal


/etc/nsswitch.conf
hosts: files wins dns


/etc/samba/smb.conf
name resolve order = host wins bcast lmhosts

Gruß, Daniel
Bitte warten ..
Mitglied: Chonta
28.03.2014, aktualisiert um 12:19 Uhr
Hallo,

hilft beides nicht.

Gruß

Chonta

Mit Version: Version 4.2.0pre1-GIT-0dd648a ist es das selbe.

https://bugzilla.samba.org/show_bug.cgi?id=9839
Scheint ein Bug zu sein der alt ist, aber immer noch nicht gelößt ist..........
Bitte warten ..
Mitglied: DanielZ87
28.03.2014 um 12:51 Uhr
Zitat von Chonta:

Hallo,

hilft beides nicht.

Gruß

Chonta

Mit Version: Version 4.2.0pre1-GIT-0dd648a ist es das selbe.

https://bugzilla.samba.org/show_bug.cgi?id=9839
Scheint ein Bug zu sein der alt ist, aber immer noch nicht gelößt ist..........

Ok, schade dann kann ich leider nicht helfen.

gruß Daniel
Bitte warten ..
Mitglied: Chonta
28.03.2014, aktualisiert um 16:21 Uhr
Schade das ich nicht genug Ahnung vom programieren habe.
Hoffentlich reichen die bald nen Patch nach.

Hat jemand einen smbd4 +winbind4 an nem prä 2003 AD laufen wo das Problem nicht ist?
Meine smb.conf ist so.

01.
[global] 
02.
 
03.
#####neu 
04.
bind interfaces only = yes 
05.
interfaces = IP/Netz 
06.
workgroup = DOMÄNE 
07.
realm = DOMÄNE.LOCAL 
08.
security = ADS 
09.
winbind refresh tickets = Yes 
10.
#winbind separator = \ 
11.
idmap config * : backend = rid 
12.
idmap config * : range = 100000-1000000000 
13.
idmap config * : base_rid = 0 
14.
 
15.
template shell = /bin/bash 
16.
winbind use default domain = Yes 
17.
winbind enum users = Yes 
18.
winbind enum groups = Yes 
19.
winbind nested groups = Yes 
20.
winbind expand groups = 10 
21.
client use spnego = yes 
22.
encrypt passwords = true 
23.
nt acl support = yes 
24.
follow symlinks = yes 
25.
wide links = yes 
26.
unix extensions = no 
27.
#printing = cups 
28.
#printcap name = cups 
29.
#load printers = yes 
30.
smb ports = 445 
31.
max protocol = SMB3 
32.
vfs objects = btrfs 
33.
server services = +smb -s3fs
winbind nss info = rfc2307

Kann ich zwar setzen, aber danach geht die winbindauflösung nicht mehr.
Theoretisch soll dadurch der Pfad der im AD angegeben ist als homedir angegeben werden.
Ich kann das aber wegen fehlendem konformen AD nicht verifizieren
Also wenn das einer am laufen hat wäre die Info super.


Gruß

Chonta
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
Windows Server 2016 VPN richtig konfigurieren (1)

Frage von junior zum Thema Windows Server ...

Outlook & Mail
gelöst Kompletter Export von Postfach in Outlook. wie mache ich es richtig? (30)

Frage von fireskyer zum Thema Outlook & Mail ...

LAN, WAN, Wireless
gelöst Netzwerkstecker richtig verkabelt? (4)

Frage von billy01 zum Thema LAN, WAN, Wireless ...

E-Mail
gelöst SPF richtig Einstellen (3)

Frage von MS6800 zum Thema E-Mail ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...