Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SAN-Begrifflichkeiten (Luns, Tags) wegen Performanceproblemen

Frage Hardware SAN, NAS, DAS

Mitglied: Addl123

Addl123 (Level 1) - Jetzt verbinden

30.09.2012 um 11:12 Uhr, 3454 Aufrufe, 7 Kommentare

Einen schönen Sonntagvormittag wünsche ich!

Um das vorweg zu nehmen: Ich habe mich an Tante Google versucht, und außerdem habe ich einen externen Dienstleister mit der Sache befragt. Zufriedenstellend ist die Informationsausbeute aber nicht gerade.

Wir haben hier ein EonStor S12E-G1133-2 mit 12 HDDs über iSCSI an 2 ESX (5.1)-Server angebunden. Hier gibt es 1x RAID10 (4x147GB; 15.000 U/min), 1xRAID6 (6x147GB; 15.000 U/min) und 1xRAID1 (2x2TB, 7.200 U/min).

Auf dem RAID10 läuft eine Exchange-Server-DB, und ein Paar SQL-Datenbanken. Die SQL-DBs sind nicht besonders anspruchsvoll. Auf dem RAID6 laufen virtualisierte Windows Server, auf dem RAID1 werden Dokumente u.Ä. bereit gestellt.

Dies wurde von dem zum Problem befragten Dienstleister in 2009 konfiguriert.


Das Problem, das hier auftritt ist folgendes:

Die Performance bei Backups (Über BackupExec 2012) ist oft sehr schlecht (Beim RAID10 fast immer) (also weniger als 100MB/min), wobei es auch mal Zeiten gibt, wo es mit 3000MB oder mehr läuft. Außerdem habe ich bei Betrachtung der Leistungsdaten in vSphere öfter mal Ausschläge in den Zugriffszeiten der HDDs. Der Durchschnitt ist z.B. 3-10 ms, die Ausschläge sind dann so zw. 1000-10000 ms.

In der Vergangenheit ist der Controller 2 mal komplett hängen geblieben, möglicherweise wegen Überlastung (?).

Alle FW-Updates sind gemacht.

Meine Frage:

In den Einstellungen der EonStor gibt es folgende Parameter:

Host Side Parameters:
1) Maximum Queued I/O Count: 1024 (Möglich: Auto,1,2,4,8,16,32,64,128,256,512,1024)
2) Luns per Host SCSI ID: 8 (Möglich: 1,2,4,8,16,32)
3) Max Number of Concurrent Host-LUN Connection: 4 (Möglich: 1,2,4,8,16,32,64,128,256,512,1024)
4) Number of Tags Reserved for each Host-LUN Connection: 4 (Möglich: 1,2,4,8,16,32,64,128,256)

Drive Side Parameters:
5) Disk Access Delay Time(sec): 75 (Möglich: 5,10,15,20,25,30,35,40,45,50,55,60,65,70,75)
6) Drive I/O Timeout(sec): 30 (Möglich: 7,0.5,1,2,4,6,8,10,15,20,30)
7) Maximum Tag Count: 4 (Möglich: Disable,1,2,4,8,16,32,64,128)

Ergeben diese Werte für unsere Konfiguration Sinn? Hier geht es mir hauptsächlich um 2,3,4 und 7. Macht das so Sinn, oder könnte man das noch besser einstellen?

Vielen Dank schon mal für alle Antworten.
Mitglied: wiesi200
30.09.2012 um 14:54 Uhr
Also mit diesen Einstellung glaub ich wirst du nicht weiter Kommen.

Ist das denn schon seit 2009 so?
Wie ist denn die Verkabelung? Läuft das netzwerk separieret oder kann da ws stören?
Bitte warten ..
Mitglied: 60730
30.09.2012, aktualisiert um 20:44 Uhr
Moin,

Wer sichert denn und von wo nach wo?
Schau mal, ob du nicht an veeam trial kommen kannst.
Das tut es, ist aber nix fuer die kleine portokasse.

Die verwendung von iscsi laesst aber vermuten, das es "billig" sein muss?

Ps nein, der hersteller deines san sagt mir nix, aber was sagt der ?
Bitte warten ..
Mitglied: wiesi200
30.09.2012 um 20:58 Uhr
Zitat von 60730:
Ps nein, der hersteller deines san sagt mir nix, aber was sagt der ?

Der Hersteller Ansicht sagt mir schon was, wie ich mein SAN ausgesucht hab sind die Unterlagen auf den blos nicht Stapel gelandet.

Irgendwie hatte es den Fass mich nicht an charm auf mich.
Bitte warten ..
Mitglied: Addl123
30.09.2012 um 21:11 Uhr
Zitat von wiesi200:
Ist das denn schon seit 2009 so?
Wie ist denn die Verkabelung? Läuft das netzwerk separieret oder kann da ws stören?

Hallo,

ich kam 03/2011. Bis da gab es keine Vollbackups, nur die SQL-DBs und die Exchange-DB wurden ab und an gesichert. Damals habe ich das mit BE2010R3 angefangen. Das lief mal so, mal so (Also, die Probleme traten ab und zu auf).

Der Grund warum ich denke es iegt an der Storage (hätte ich wohl erwähnen sollen):

Wir hatten damals bei der Umstellung auf ESX 5 (von 4.0) riesen Probleme mit der Storage. Im Prinzip ist der Controller dauernd hängen geblieben. Ein Firmware Update hat das Problem behoben, seitdem ist alles OK, bis auf 2x hängen bleiben. Kurz danach haben wir das neue Backupprogramm eingeführt

Netzwerkprobleme würde ich ausschließen wollen. Es könnte zwar rein theoretisch etwas stören, aber ich habe auf den Switchen nie Paketverluste o.Ä. Ich kann über SMB mit fast 1Gbit übertragen, und das durchgehend. Auch wenn ich z.B. die VMs direkt aus dem vSphere Client auf den Backupserver kopiere geht das mit min. 500Mbit (oder mehr).

Auch wird manchmal die Sicherung des Exchangeservers abgebrochen - Fehler ist "I/O Error". Das lässt sich aber nicht an den Zugriffszeiten ablesen, und auch sonst nirgends kann ich den Fehler nachvollziehen, scheint wohl am ehesten der Controller der Storage zu sein. Die anderen Server laufen i.d.R. tapfer durch, wenn auch langsam.
Bitte warten ..
Mitglied: Addl123
30.09.2012 um 21:16 Uhr
Zitat von 60730:
Moin,

Wer sichert denn und von wo nach wo?

BackupExec 2012 sichert als Agent in den VMs auf physichen Backupserver. Das Sichern über Auswahl der VMs im ESX direkt geht meistens schneller.

Schau mal, ob du nicht an veeam trial kommen kannst.
Das tut es, ist aber nix fuer die kleine portokasse.

BackupExec ist jetzt im Normalfall auch nicht gerade günstig (Wir haben es nur sehr günstig bekommen), ich werde das aber vllt. mal nächstes WE mit der trial versuchen.

Die verwendung von iscsi laesst aber vermuten, das es "billig" sein muss?

Ja, definitiv. Was wäre denn "teuer"?

Ps nein, der hersteller deines san sagt mir nix, aber was sagt der ?

Also, die Manual sagt gar nix zu den Parametern nach denen ich gefragt habe. Beim Hersteller direkt habe ich nch nicht gefragt, ich dachte hierbei handelt es sich um Dinge, die man aus der Praxis besser kennt wie ein SupportMA, der das aus einem Datenblatt abliest. Aber ich denke ih werde mal fragen.
Bitte warten ..
Mitglied: wiesi200
30.09.2012 um 21:19 Uhr
Versuchs einfach mal mit Veeam Backup. Ist ein gutes Program und du kannst dann die Bckupsoftware ausschließen denn eigentlich waehr's jetzt mal naheliegend wenn die Probleme nach dem Wechsel massiv geworden sind.
Bitte warten ..
Mitglied: wiesi200
30.09.2012 um 21:22 Uhr
Zitat von Addl123:
Ja, definitiv. Was wäre denn "teuer"?

Sagen wir nicht teuer sonder sein Geld Wert. NetApp oder EMC mit einer Fiberchannel Anbindung.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Erkennung und -Abwehr
Hackers are holding San Francisco s light-rail system for ransom

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

SAN, NAS, DAS
gelöst SAN-Storage - Empfehlung von Erfahrenen (13)

Frage von Estefania zum Thema SAN, NAS, DAS ...

Vmware
gelöst VMWare 6 konsolidierung 2ter Platte auf SAN funktioniert nicht (2)

Frage von DirkGrote zum Thema Vmware ...

Monitoring
gelöst Wireshark: Anzeige von VLAN-Tags (2)

Frage von honeybee zum Thema Monitoring ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...