Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SAN Zugriffe über HBA FC Controller auf RAID5 gebremst

Frage Hardware Festplatten, SSD, Raid

Mitglied: 43292

43292 (Level 1)

02.12.2011, aktualisiert 10:44 Uhr, 3305 Aufrufe, 1 Kommentar

Hallo liebe Community,

momentan führe ich einige Tests an meiner SAN durch und so richtig schlau werde ich noch nicht draus. Ich möchte euch mal mein Setup vorstellen und meine Testergebnisse zeigen:

Dell PowerEdge 2950 Server mit 2x Quadcore-CPU Xeon 2,66GHz und 32GB ECC-RAM. Seine 8 lokalen Festplatten sind über den Perc 5/i Integrated Controller zu RAID5 gebildet mit zwei Hotspares. Read Cache ist aus, und Write Back Cache ist EIN und Stripesize von 64K. Das Array bietet 330GB an Speicherplatz. In dem Server ist noch eine QLogic HBA Karte verbaut, und zwar die QLE2462. Über den Port gehe ich mit 2GBit-FC-Verbindung raus zur SAN.

Die SAN ist eine IBM DS400: darin werkeln 12 Festplatten , 2 davon sind wieder als Hotspares definiert, also zehn verfügbar für die Erstellung der Arrays. Ich habe davon ein Test-Array1 RAID5 gebildet mit 280GB. Dieses Test-Array habe ich abwechselnd zwischen meinen Tests mit 16K, 64K, 256K und 512K Stripesizes immer neu gebildet (musste warten bis das Syncen abgeschlossen ist, damit ich die Cache Einstellungen auch anschliessend verändern konnte). So konnte ich die diversen Stripesizes und Cachevarianten testen und protokollieren. Das array1 besteht also aus 3 Festplatten. Ich habe die restlichen 7 Festplatten zu einem array2 gebildet, ebenfalls als RAID5 und dieses habe ich mit 512k stripesize festgelegt, damit ich es immer als Referenz verwenden kann.

Auf dem Dell-Server ist Xenserver 6.0 installiert. Als Test-VM habe ich mal eine Windows XP VM mit SP3 (32bit) hergezogen und mit dem ATTO Disk Bechmark Tool gemessen. Bei all den Tests ist mir aufgefallen, dass ich die bestmöglichste Schreib-/Leseperformance erreichte, wenn der Write-Cache aktiviert, und der Lese-Cache deaktiviert war.

Die Testergebnisse:

wenn die VM auf dem lokalen RAID5 mit der 64k-Stripesize des Dell-Servers ausgeführt wurde, waren selbstverständlich die höchsten Schreib- und Leseraten erzielbar. Die waren so gut, dass sie mich sogar selbst positiv überrascht haben. ist das normal, dass soviel dabei rauskommt ??? ich meine das ist schon heftig auf einer anderen Test-VM mit Win7 64bit war das ganze sogar einen Tick besser wie zu sehen ist...

WinXP 32bit Test-VM --> http://www.abload.de/img/victoriassecret_lokal0icr1.jpg
Win7 64bit Test-VM --> http://www.abload.de/img/atto_benchmark_win7_68ldlp.jpg


Dann habe ich auf der SAN getestet, da ich hier nicht so tolle Performance erzielen kann. Die besten Schreib-/Leseraten auf dem SAN-Testarray erreichte ich bei einer Stripesize von entweder 256K oder 512K. Die Ergebnisse sind hier zu sehen:

WinXP 32bit-Test-VM auf dem SAN-Testarray2 bei 512K Stripesize, Schreibcache=ON, Readcache=OFF --> http://www.abload.de/img/victoriassecret_800gbl8c2n.jpg
WinXP 32bit-Test-VM auf dem SAN-Testarray1 bei 256K Stripesize, Schreibcache=ON, Readcache=OFF --> http://www.abload.de/img/victoriassecret_280gbm9clv.jpg


Zusammenfassung:

Die schnellsten Zugriffe waren auf dem lokalen RAID5 möglich. Auf der SAN waren meine maximal erzielten Geschwindigkeiten ca. 72MB/sec write und 87MB/sec read.


Jetzt verstehe ich noch nicht, warum ich nicht auf über 100MB/sec auf der SAN komme. Ich meine ich hab doch eine 2GBit-FC-Verbindung zur SAN, das entspräche also 125MB/sec. Das ist natürlich ein Brutto-Wert, wenn ich also noch 10% davon abziehe, dann müssten doch die 100MB/erreichbar sein, oder nicht? Ist evtl. meine HBA-Karte falsch konfiguriert? Oder liegts doch an der SAN? Ich meine beim Array1 sind zwar nur 3 Festplatten als RAID5 aktiv, aber auf dem Array2 waren es ja 7 Platten. Da gings aber auch nicht schneller. Wo habe ich einen Flaschenhals?

Wiki meint zum RAID-Artikel irgendwo beim Abschnitt der RAID5-Performance folgendes:

" [...], dass bei RAID 5 möglichst ein Verhältnis von zwei, vier oder auch acht Platten für Nutzdaten plus einer Platte für Paritätsdaten eingehalten werden sollte. Daher haben RAID-5-Systeme mit 3, 5 oder 9 Platten ein besonders günstiges Performanceverhalten."

Könnte mein Performanceproblem also hier liegen? Mein Testarray1 hat ja momentan 3 Nutzplatten, und das Testarray2 hat 7 Nutzplatten.

Ich bin über Anregungen und Aufklärungen sehr dankbar.
Mitglied: 43292
09.12.2011 um 10:30 Uhr
Rege Teilnahme, WoW Problem ist gelöst. Für alle Interessierten, die ähnliche Probleme haben sollte hier meine Lösung --> Es lag definitiv an der SAN. Neue Firmware eingespielt, HDD Firmware Upgrades durchgeführt, Arrays neu gebildet, und da sieht's schon vieeel besser aus. Problem gelöst.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Festplatten, SSD, Raid
12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer (2)

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

SAN, NAS, DAS
gelöst NAS RAID5 - RAID0 und Backup (7)

Frage von easy4breezy zum Thema SAN, NAS, DAS ...

Erkennung und -Abwehr
Hackers are holding San Francisco s light-rail system for ransom

Link von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Festplatten, SSD, Raid
gelöst Defekten 3Ware Controller Tauschen (5)

Frage von Koseb586 zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...