Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SBS 2003 SP1: NT-backup-probleme

Frage Microsoft Windows Server

Mitglied: Roland33

Roland33 (Level 1) - Jetzt verbinden

29.04.2006, aktualisiert 05.05.2006, 16012 Aufrufe, 10 Kommentare

hi liebe leute,

ist mein erstes posting und hoffe, dass ihr mir weiterhelfen könnt.

mein kunde (und somit ich) hat folgendes problem: system mit SBS 2003 SP1. datensicherung soll via ntbackup erfolgen (diesen punkt nicht hinterfragen, weil ich selbst bin ein fan von vernünftiger backup-software)...

ntbackup funktioniert einigermassen. beim sichern des folgendes ordners bzw. datei bricht ntbackup ab: c:\windows\repair\system. ebenso erfolgt ein abbruch, wenn ich den systemstate sichern möchte (ebenfalls bei der datei system).

die dazugehörige fehlermeldung:
Fehler: Das Gerät hat einen Fehler auf eine Anforderung an "Daten auf das Medium schreiben." gemeldet.
Fehlermeldung: Unbekannter Fehler.
Möglicherweise ist ein Hardware- oder Medienfehler aufgetreten.
ich hoffe sehr, dass jemand weiss, wie man dieses problem lösen kann, weil ich darüber schon einige zeit verzweifle.

herzlichen dank u. schönes WE
lg
roland
Mitglied: VoSp
29.04.2006 um 19:12 Uhr
Hallo Roland33,

worauf wird denn gesichert? Ich denke Du hast schon verschiedene Medien ausprobiert?

Gibts ne Fehlermeldung im Ereignissprotokoll?

Die datei System gehört zur Registry, wenn Die nicht mitgesichert werden kann deutet das schon auf ein Problem hin.

Ich weiss gar nicht ob das neue NT Backup schon Shodw Copy unterstützt , wenn ja beim backup mal einschalten.

Jetzt doch noch zu NT Backup:
Rechne dem Kunden mal vor was 1-2 Wochen Ausfall seines Server für Ihn bedeutet!! Und so lange braucht er mindestens um alle seine Daten wieder hinzubekommen. (Bei einem sehr kleinen Unternehmen!). Bei grösseren UNternemen bedeutet ein Desaster ohne Backup meistens das aus für die Firma. Deshalb wir ja auch so viel Geld für Business continuity ausgegeben! Da sollten die ? für nen vernünftiges Backup auf Magnetbänder schon drin stecken. Und mach Dir nix vor, wenn da mal ein Problem ist und DU bekommst das mit NT Backup nicht wiederhergestellt, wen der Kunden dann wohl verantwortlich macht!

Bis dann

VoSp
Bitte warten ..
Mitglied: Roland33
30.04.2006 um 08:35 Uhr
guten morgen VoSp!

gesichert wird auf ein wechselfestplatten-system - am medium liegts sicher nicht, weil das problem immer auftritt.

fehlermeldungen im eventlog beschränken sich auf 8001 und 8019: fehler sind aufgetreten - wirf einen blick ins datensicherungsprotokoll...

shadow copy wird unterstützt und funktioniert auch in ca. 95%. in ca. 5% scheitert die sicherung daran, dass die kopie nicht erfolgreich erstellt werden kann.

die geschichte mit einem prof. backup ist mir wohl bewusst. der kunde hat x-mal ein mail bekommen mit einem entsprechenden hinweis. da die sicherung von exchange und files anstandslos funktioniert, empfinde ich es auch nicht als soooo dramatisch.

meines wissens liegt ja im ordner windows\repair lediglich eine kopie der registry & co. ich versteh daher überhaupt nicht, weshalb da irgendwas in use sein sollte.

wenn du dazu eine idee hättest, wär das echt super
lg
roland
Bitte warten ..
Mitglied: stani
01.05.2006 um 18:41 Uhr
Hallo Roland,
es wäre sinnvoll, mal zu wissen, wie genau du dein Backup startest. Mit einer Batch-Datei oder VBScript? Wie sieht die bks-Datei aus? Denn abhängig davon kannst du das repair-Verzeichnis links liegen lassen, also ausschließen.

Ansonsten versuch mal, den Inhalt von repair in einen anderen Ordner zu verschieben und schau, was dann passiert.

Das mit Systemstate ist eigenartig. Tritt das schon immer auf? Hast du schon mal chkdsk /f /v /r übers Systemlaufwerk laufen lassen? Gibt es noch andere Fehler oder Warnungen im Ereignisprotokoll?

Hast du %windir%\system32\config vom Virenscan ausgeschlossen (absolut wichtig, sonst können komische Fehler und Systemschäden auftreten!)?

Denn eigentlich ist es für's System kein Problem, die Registrierung zu sichern, wenn noch Handles drauf offen sind. Schließlich ist es ja eine Datenbank und im laufenden Betrieb greift immer irgendwas auf den system-hive zu.

Und nochmal zu ntbackup:
Finde ich in kleinen Umgebungen absolut optimal. Ich habe schon mit ArcServe und mit TapeWare gearbeitet, und finde die total schrecklich. Außer man hat vielleicht ne ganze Serverfarm mit mehreren Exchange-Organisationen oder mit einer riesigen Tape-Library mit Barcode und allerhand Schnickschnack zu zähmen. Aber bei einfachen Jobs wirst du mit diesen Programmen weich im Hirn.
Meine Kunden haben alle 1-3 Server mit Exchange und Terminalserverbenutzern. Die Sicherung geschieht auf DDS4/DDS5, täglich, vollständig, 14-Tage-Taperotation, Batch-gesteuert mit ntbackup. Ein MA wechselt jeden Morgen das Tape, prüft im auf dem Server freigegebenen Ordner das Backup-Protokoll und unterschreibt in einer Liste. Datenintegrität und Wiederherstellung werden von mir getestet, wenn die Leute bei mir einen Wartungsvertrag haben.

Alles in allem: ntbackup ist mindestens 1000x besser als sein Ruf. Man hat halt nicht so viele bunte Bildchen wie bei ArcServe. Dafür mußt du Exchange-Plugins und anderen Krempel nicht extra kaufen. Wenn man weiß, wie man das Ding per Batch-Datei steuert und wie die Wechselmedienverwaltung tickt, ist es das beste Backup-Programm, mit dem ich bisher gearbeitet habe.

Wofür der Kunde wirklich Geld ausgeben sollte, ist mind. ein DDS-Laufwerk. Dann mußt du nur noch einem MA einbläuen, jeden Morgen das Tape zu wechseln, Protokoll zu sichten und irgendwo zu unterschreiben, daß er das auch gemacht hat. Schon hast du 14 Tage zurück immer vollständige Backups. Natürlich von Zeit zu Zeit Integritätstests nicht vergessen!

Gruß stani
Bitte warten ..
Mitglied: carg
03.05.2006 um 17:15 Uhr
Mal bei MS die Fehlernummer nachgeschaut die im Eventlog seht?

http://support.microsoft.com/default.aspx?scid=kb;en-us;817688

Könnte es das sein?

Gruß
Bitte warten ..
Mitglied: Roland33
04.05.2006 um 10:33 Uhr
hallo,

herzlichen dank für eure mühe. ich versuche, noch weitere infos zu posten:

fall a) ich sichere direkt mit ntbackup => die sicherung schaffts nicht, über das repair-verzeichnis zu kommen. kopieren kann ich den inhalt des verzeichnisses ohne probleme. die sicherung bricht ab mit folgenden einträgen im eventlog:

fehler 8001 (ntbackup): Ende der Sicherung von C:, es wurden Warnungen oder Fehler gefunden.

fehler 8019 (ntbackup): Vorgang beenden: Es wurden Warnungen oder Fehler gefunden. Weitere Informationen finden sie im Sicherungsbericht.


fall b) ich sichere mit der sbs-sicherung, die ja auch irgendwie ntbackup verwendet. die sicherung bleibt genauso auf dem repair-ordner stecken, liefert aber folg. fehlermeldungen:
+8001 s.o.
+8019 s.o.
+warnung 1524 (userenv): Die Klassenregistrierungsdatei kann nicht entladen werden, da sie weiterhin von anderen Anwendungen bzw. Diensten verwendet wird. Die Datei wird entladen, wenn sie nicht mehr verwendet wird.
+warnung 1517 (userenv): Die Registrierung des Benutzers "KUNSTFORUM-WIEN\SBS Backup User" wurde gespeichert, obwohl eine Anwendung oder ein Dienst auf die Registrierung während der Abmeldung zugegriffen hat. Der von der Registrierung des Benutzers verwendete Speicher wurde nicht freigegeben. Der Upload der Registrierung wird durchgeführt, wenn diese nicht mehr verwendet wird.
Dies wird oft durch Dienste verursacht, die unter einem Benutzerkonto ausgeführt werden. Versuchen Sie diese so zu Konfigurieren, dass sie unter den Konten "Lokaler Dienst" oder "Netzwerkdienst" ausgeführt werden.

fehler 5634 (SBS-server, SBS-sicherung): Mindestens eine Komponente der Small Business Server-Sicherung ist fehlgeschlagen. Klicken Sie zum Anzeigen weiterer Informationen auf "Sicherung in der Serververwaltung erstellen", um die Protokolldateien anzuzeigen.


wenn ich das repair-verzeichnis ausschliesse hab ich das gleiche problem beim systemstate, weil dabei ja schliesslich auch auf diese dateien zugegriffen wird.

da ich bisher nicht mit sbs-sicherung gesichert hab, sind diese warnungen (1524 und 1517) erstmals aufgetreten. kann mir diesbezüglich jemand einen tipp geben.

danke im voraus
lg
roland
Bitte warten ..
Mitglied: carg
04.05.2006 um 11:34 Uhr
Hmmm.
wie wäre es denn damit:
http://support.microsoft.com/default.aspx?scid=kb;en-us;820272

Gruß Patrick
Bitte warten ..
Mitglied: Roland33
04.05.2006 um 11:39 Uhr
hallo patrick,

danke für den link, das problem ist es aber sicher nicht, weil ich gegenwärtig nur damit beschäftig bin, c: und systemstate rüberzusichern. den information-store hab ich grad mal deaktiviert.
lg
roland
Bitte warten ..
Mitglied: carg
04.05.2006 um 11:56 Uhr
Ok,

was steht denn für info im sicherungsprotokoll? Kommen da Fehlermeldungen?

Gruß Patrick
Bitte warten ..
Mitglied: Roland33
04.05.2006 um 11:58 Uhr
fehlermeldungen kommen nur jene, die ich im posting von 10:33 beschrieben hab - das ist der hässlich formatierte text, den ich irgendwie nicht anders hinbekommen hab...
Bitte warten ..
Mitglied: stani
05.05.2006 um 10:50 Uhr
Gehe folgende Schritte durch:

1. unbedingt 1517 und 1524 von userenv beseitigen:
a) %windir%\system32\config vom Virenscan ausschließen (Subfolders natürlich auch)
b) alle unnötigen Hintergrundtools aus den Autostarts entfernen (z.B. in HKLM\Software\Microsoft\Windows\Current Version\Run)
c) überprüfen, ob Dienste unter Benutzernamen ausgeführt werden, wenn ja, dann ändern: als local service oder network service ausführen
d) uphclean von Microsoft installieren und eventlog nach Meldungen von uphclean checken

2. überprüfe, ob in Deiner Sicherung "JET SERVERNAME\Microsoft Information Store\Recovery Storage Group\ " mit gesichert wird. Beim Backup mit ntbackup siehst Du das in der Auswahl, wenn Du das Backup über die SBS-Konsole startest, findest Du irgendwo eine script.bks, die die Sicherungsauswahl enthält und die Du im ntbackup öffnen und ändern kannst. Diesen Eintrag dann unbedingt entfernen.

Wenn Du diesmal wieder kein Feedback gibst, mache ich mir nicht mehr die Mühe, hier zu posten.

Ich kann Dir das Problem auch für meinen Standardsatz (20?/15min netto) lösen. Einfach Mail an info@caskan.com.

Gruß stani
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst Serverumzug SBS 2003 nach 2012R2 ohne Active Directory (2)

Frage von step777 zum Thema Windows Server ...

Windows 10
gelöst Backup Probleme unter Windows 10 mit Dateiversionsverlauf (2)

Frage von SHeart0523 zum Thema Windows 10 ...

Exchange Server
gelöst SBS 2003 und Multisendcon: Mailversand an t-online Adressen funktioniert nicht (11)

Frage von danieluk15 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...