Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SBS 2008 Exchange 2007 nach verschieben der Exchange Datenbank probleme mit dem Pfad

Frage Microsoft Exchange Server

Mitglied: mm4711

mm4711 (Level 1) - Jetzt verbinden

01.04.2011 um 15:54 Uhr, 7914 Aufrufe, 5 Kommentare

Habe ein mittelgroßes Problem mit unserem Exchnage 2007 SP3 nach einer Datenbankverschiebe Aktion

Hallo zusammen,

ich bin neu hier und habe bisher immer Lösungen für das ein oder andere Problem finden können. Doch dieses ist glaube ich schon etwas besonders.

Wir sind ein kleines IT- Unternehmen und haben noch nicht viel Erfahrung mit dem Exchange 2007 gemacht da wir bisher Lotus Notes nutzten. Alles funktionierte prima, bis wir unsere Exchangedatenbank auf die größere Partition D verschieben wollten. Wir nutzen hier einen SBS 2008 Standart mit Exchange 2007 mit nachinstalliertem SP3. Wie es beschrieben wurde haben wir den Assistenten aus der SBS Console genutzt und auch schön brav das Backup von Windows laufen lassen bevor er umzog.

Doch leider wie so oft bei Windows stürtze mitten in der Umzugsaktion der Assistent ab und nichts ging mehr. "Super", dachte ich und hab ja zum Glück das Backup.
Alles wunderbar; von DVD gestartet und das Backup von der externen HD wieder zurück. 3 Stunden gezittert, und alles lief wieder wie gehabt. EMails und Sharepoint lief wieder...

Und nun kommts:
Komischerweise liefen dann unsere BackupExec Sicherungen nicht mehr sauber durch und meldeten einen Fehler in der Exchangedatenbank.

Ein Extrahieren der Mailbox-Nachrichten aus dem Exchange-Backup ist nicht möglich.


Also, ich in die Exchangeverwaltung und sah das die Datenbank auf D:\ lag wo sie eigentlich nicht mehr sein sollte. Vor dem Backup lag dieses ja auf C:\
Das beste ist, gehe ich über dem Explorer auf den Pfad "D:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb" gibt es den nicht. Denn die Datenbank liegt, wie es auch sein soll, auf "C:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb"

Dann stimmt der Pfad in der Verwaltungskonsole ja garnicht...

Versuche ich jetzt den Verschiebeprozess über die Exchangekonsole zu starten kommt folgende Fehlermeldung:
*
Zusammenfassung: 1 Element(e). Erfolgreich: 0, Fehler: 1.
Verstrichene Zeit: 00:00:00

Mailbox Database
Fehler

Fehler:
Die Quelldatei 'D:\Program Files\Microsoft\Exchange Server\Mailbox\First Storage Group\Mailbox Database.edb' kann auf Server 'TDSBS' nicht gefunden werden. Führen Sie die Konfigurationsänderung mithilfe von '-ConfigurationOnly' aus.

Ausführungsversuch eines Exchange-Verwaltungsshellbefehls:
move-DatabasePath -Identity 'TDSBS\First Storage Group\Mailbox Database' -EdbFilePath 'D:\Exchange Database\Mailbox Database.edb'

Verstrichene Zeit: 00:00:00
*

Was nun?
Das -ConfigurationOnly klappt auch nicht, oder ich mach was falsch.
Wie sage ich der Verwaltungskonsole das die DB nicht auf "D:\" sonder auf "C:\" liegt?

Danke für jeden Tipp der Hilft.
Mitglied: mm4711
01.04.2011 um 16:16 Uhr
Nee, das hilft leider nicht weiter. Bekomme dann noch immer die Fehlermeldung das der Quellpfad nicht lesbar wäre oder exestiert.
Bitte warten ..
Mitglied: mm4711
04.04.2011 um 16:16 Uhr
Also, ich hab jetzt noch mal gekuckt.

Das Problem tauchte wärend dem Verschieben auf. Er hat wohl irgendwie einen Teil des Vorgangs durchgeführt und irgend wo den falschen Pfad hinterlegt. Nur weis ich nicht wo um Exchange den richtigen Pfad mit zu teilen.

Was ebenfalls nicht klappt ist der eseutil Befehl um die Datenbank in einzelne PST zu exportieren. Dann könnte ich zumindest die Daten sichern.

Ebenfalls probiert habe ich eine neue Speichergruppe zu ertsellen und die User dort hinein zu legen. Die Datenbank bekomme ich auch nicht bereitgestellt.
Bitte warten ..
Mitglied: GuentherH
04.04.2011 um 18:10 Uhr
Hallo.

Schau dir das einmal an. Ist zwar für Exchange 2010, sollte aber für Exchange 2007 gleich sein - http://technet.microsoft.com/en-us/library/gg680330.aspx

LG Günther
Bitte warten ..
Mitglied: mm4711
05.04.2011 um 11:59 Uhr
Super Danke

muste zwar das gleiche für 2007 raussuchen, aber jetzt hab ich wenigstens die Datenbank wieder breitgestellt und online, aber die Benutzeremailkonten sind weg.

Jedenfalls zeigt er mir jetzt keine Postfächer unter "Empfängerkonfiguration/Postfäch" an.
Wie bekomme ich den nun die Postfächer wieder hin mit den Konten?
Bitte warten ..
Ähnliche Inhalte
Exchange Server
SBS 2008 mit Exchange (6)

Frage von MrChiacomo zum Thema Exchange Server ...

Exchange Server
Exchange 2007 Datenbank restore ohne Exchange zu verändern - SBS2008

Frage von pitamerica zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 (SBS 2008) - Eingetragene Termine von Outlook Clients verschwinden (4)

Frage von fr4nkd zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2007 User Mailbox neu auf dem Server Datenbank aufsetzen (9)

Frage von Jacksoney zum Thema Exchange Server ...

Neue Wissensbeiträge
Windows Installation

Unorthodoxer Weg, um an einen Offline-Installer für Adobe Flash zu kommen

(14)

Tipp von beidermachtvongreyscull zum Thema Windows Installation ...

Datenschutz

Gefährdeter Datenschutz: Firefox löscht lokale Datenbanken nicht

(1)

Information von BassFishFox zum Thema Datenschutz ...

Firewall

PfSense OpenVPN beschleunigen

Tipp von Dobby zum Thema Firewall ...

Heiß diskutierte Inhalte
Utilities
CCleaner 5.33 mit Malware infiziert (27)

Information von SeaStorm zum Thema Utilities ...

Windows Systemdateien
Windows bootet nicht mehr Fehlermeldung 0xc0000098 (19)

Frage von franzgoerlich zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
gelöst 802.1X-Authentifizierung (16)

Frage von Alex29 zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Dateien mit Intelligenz per GPO ins Programmverzeichnis (14)

Frage von erwin.t zum Thema Windows Netzwerk ...