Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wie kann ich im sbs 2008 von pop3 auf smtp umstellen

Frage Microsoft Exchange Server

Mitglied: sbs-user

sbs-user (Level 1) - Jetzt verbinden

24.01.2011 um 16:39 Uhr, 8746 Aufrufe, 10 Kommentare

Windows SBS 2008 ist auf Mail-Abholung mit pop 3 eingestellt. Bei zwei Postfächern gibt es Fehlermeldungen, eines davon - meines - bekommt seit zwei Tagen keine Mails mehr weitergeleitet. Die liegen beim Provider im webmail. Die Ereignisse, Win SBS 2008, zeigen jede Menge Fehlermeldungen (Zitat unten). Andere, weniger benutzte Postfächer funktionieren klaglos mit POP3 für den Eingang. Die Ausgänge sind smtp über smarthost.
Mein Ziel: 1. Problem mit den Posteingang über POP3 lösen, d. h. die mails alle reinbekommen, 2. eventuell umstellen auf Posteingang über smtp. Ich weiß aber nicht wie das geht, wo stelle ich das ein?

Muster der Fehlermeldung im Ereinigsprotokoll:

Die TCP/IP-Verbindung mit dem Server "localhost" wurde bei dem Versuch beendet, auf das Postfach "postfach@firma.com" zuzugreifen. Die Gründe hierfür können Serverprobleme, Netzwerkprobleme, ein längerer Inaktivitätszeitraum, ein Verbindungszeitlimit oder falsche Verbindungseinstellungen sein.

Muster einer vorangegangenen Fehlermeldung im Ereinigsprotokoll:

Aufgrund von vorübergehenden oder unbekannten Fehlern konnte mindestens eine Nachricht (2) nicht an "postfach@firma.com" auf dem SMTP-Server "localhost" zugestellt werden. Die Nachrichten verbleiben auf dem POP3-Server. Wenn diese Fehler weiterhin auftreten, können Sie entweder die Verbindung zum POP3-Konto herstellen und die Nachrichten manuell abrufen oder löschen, oder Sie können das Problem beheben, das die Fehler verursacht. Weitere Informationen finden Sie in der Protokolldatei unter "C:\Program Files\Windows Small Business Server\Logs\pop3connector\pop3service.log".

Zum Umstieg auf smtp statt pop3: Das war für mich beim SBS 2003 kein Problem, aber beim sbs 2008 finde ich nichts, wo ich das einstellen kann.

Bitte um Hilfe dazu, danke vorab (es ist mir ziemlich dringend)..
Mitglied: MiniStrator
24.01.2011 um 18:50 Uhr
Öhm....

pop3 ist zum Mail abholen beim provider (oder meinetwegen auch intern vom Exchange, wäre aber ungewöhnlich)
smtp ist zum Mail senden übern provider (oder meinetwegen auch intern zum Exchange, wäre aber auch ungewöhnlich). Oder euer Exchange nimmt per SMTP Mails vom Internet entgegen, aber ihr habt ja Webmail, also nicht.

Wie 'umstellen'? Versteh ich nicht.

Habt ihr von 2k3 auf 2k8 migriert und seit dem gehts nimmer?
Vielleicht stimmt ja auch nur mit dem Outlook was nicht?
Benutzt ihr überhaupt Outlook?

Lass mal die operative Hektik weg und poste genauere Infos, es wird dir sicherlich geholfen
Und grüße das nächste mal, so viel Zeit muss sein

Gruß, MiniStrator
Bitte warten ..
Mitglied: sbs-user
24.01.2011 um 19:16 Uhr
Hallo MiniStrator,

Danke für den Kommentar und "Herzliche Grüße" - soviel Zeit haben wir hier immer!

Zum Thema: sbs08 ist eine Neuinstallation vom Sommer 10. Vom Start weg wurde eingestellt, dass die emails mit pop3 vom Provider abgeholt werden. Mit ein wenig google findet jeder zahlreiche Kommentare, die das als nicht sinnvoll darstellen. Wir sind eine 5-pc-company, also war das Anlegender Postfächer auf der provider-hp nicht so ein Problem und alles hat bislang funktioniert.

Wir verwenden client-seitig win 7 prof und office 2010.

Die Bindung zum provider geht über eine Standleitung 2048 up und down.

Jetzt bekomme ich zwar mails in das allgemeine postfach office@firma.com, nicht jedoch in meines, sbs-user@firma.com. Seit zwei Tagen nimmt der Exchange das nicht mehr an, Fehlermeldung wie zitiert.

Auf Basis von Google habe ich gefunden: Exchange Konsole, Server-Konfiguration, Hub-Transport, Empfangsconnector. Der ist aktiviert (Default Servername), ebenso der Dienst IMAP. POP3-Dienst ist weiterhin aktiviert. Irgendwo hab ich gegooglet, man soll das ein paar Tage parallel laufen lassen und erst dann den POP3-Dienst beenden.

Diese Konfiguration funktioniert leider noch nicht. Ich habe auf der hp des Providers als kurzfristige Notlösung eine Weiterleitung meines Postfachs an ein funktionierendes gesetzt.

Ich wäre auch einverstanden, wenn des mit dem POP-Dienst wieder klaglos funktioniert - nur versteh ich die Wurzel des Problems so ganz und gar nicht. Ich bin auch kein sbs/exchange-Spezialist.

Nachdem die Statistik von administrator.de schon über 30 LeserInnen zeigt, wünsche ich euch allen einen stesslosen, sorgenfreien Abend ;)

sbs-user
Bitte warten ..
Mitglied: GuentherH
24.01.2011 um 19:56 Uhr
Hallo.

Wenn der SBS 2008 korrekt, d.h. mit den entsprechenden Assistenten konfiguriert wurde, dann musst du hier gar nichts mehr ändern.

Passe die Einstellungen deiner Firewall an, teste dann von externe und trage bei deinem Domainhoster den passenden MX-Record ein.

LG Günther
Bitte warten ..
Mitglied: MiniStrator
24.01.2011 um 20:50 Uhr
Hi sbs-user,

ich schliess mich hier mal GuentherH an. Wenn ihr ein 2Mbit SDSL habt bekommt ihr sicherlich auch eine feste IP und einen mx-record von eurem Provider. Den Exchange dann direkt verdrahtet, dann kommen eure Mails auch direkt nach Hause und müssen nicht erst beim Provider warten bis ihr sie abholt. *g* Ggfs. könnt ihr dann auch ohne dyndns OWA betreiben.

Kann das Problem evtl was mit einer zu großen Mail und einem Timeout oder irgendwelchen Beschränkungen zu tun haben? Wurde der Server mal rebootet?

Gruß, MiniStrator
Bitte warten ..
Mitglied: sbs-user
24.01.2011 um 21:14 Uhr
Hallo Günther, hallo MiniStrator,

Danke für die Beiträge.

-> Assistenten: Ich mache grundsätzliches alles mit den Assistenten, Eigentore gab's da früher schon genug. Nur manchmal muß man eben doch direkt hinein, Exchange Konsole z. B., aber da halt ich mich im Zaum ;)

->IP's: Wir haben genug feste ip's, auch mit den mx soweit mir bekannt kein Problem. Mit den aktuellen mx-records lief es ja wochen- oder monatelang tadellos.

-> Mailgröße, Timeout: Mailgrößen sind standardmäßig auf ca. 10 MB, hab's mal auf 15 erhöht, was eher unnötig ist auch in der Grafik. Es werden dann und wann emailings versandt, personalisiert, html, da geh'n dann schon so 3 bis 3 1/2-tausend hinaus. Das hat bislang nicht auffällig gestört. Ich habe auch die (vielleicht schlechte) Gewohntheit, Unmengen älterer Dateien (mails) am Exchange im Öffentlichen liegen zu lassen... es ist einfach total praktisch, ganz rasch sehen zu können, was man vor zwei, drei Jahren in einem bestimmten biz-Bereich gemacht hat. Da wir aber eine 5-PC-Comp. sind, nehme ich diese Datenbelastung nicht als ursächlich für das Problem an: Was täte eine Firma mit 50, 100 usern?

-> Reboot: Ja, heute zweimal. Das Ergebnis in den Fehlermeldungen war, das nach dem booting diese Meldung kam:

Die TCP/IP-Verbindung mit dem Server "localhost" wurde bei dem Versuch beendet, auf das Postfach "postfach@firma.com" zuzugreifen. Die Gründe hierfür können Serverprobleme, Netzwerkprobleme, ein längerer Inaktivitätszeitraum, ein Verbindungszeitlimit oder falsche Verbindungseinstellungen sein.

... Im Gegensatz zu der eingangs bereits zitierten, vorangegangenen Meldung.

Wiederum Dank vorweg für Hilfe und guten Rat!

Grüße, sbs-user
Bitte warten ..
Mitglied: MiniStrator
24.01.2011 um 23:38 Uhr
Hi sbs-user,

das hört sich sehr quer an...

Mit mx-record meinen wir (@GuentherH wenns nicht so ist schreien ) einen mx auf mail.euredomain.com mit einem entsprechendem HOST(a) Eintrag a la 'mail -> eine.eurer.festen.ips'
(Evtl mit Prio 10 und mit 20 noch mal auf den Mailserver des Providers, falls eure Leitung mal abraucht). Dann würdet ihr Mails direkt zugestellt bekommen so lange alles funktioniert, und wenn was klemmt landen sie beim Provider. Oder das mit dem Provider ganz lassen, gewöhnlich werden Mails eh 48h 'behalten' und versucht zugestellt zu werden.

Hast du zu den Fehlern bessere Details? Sowas wie 'ExchangeTransport 4711', also Quelle und Nr. ? Wäre evtl hilfreich.

Muss etz aber schlafen, werde mich also erst morgen abend wieder melden falls es bis dahin nicht schon gelöst ist...

Gruß MiniStrator
Bitte warten ..
Mitglied: goscho
25.01.2011 um 10:29 Uhr
Morgen

ich möchte mich GüntherH und MiniStrator anschließen, habe aber noch einen Hinweis:

Wenn ihr die Mails bisher beim Provider per POP 'abgeholt' habt, habt ihr wahrscheinlich auch den AV/Antispam-Schutz des Providers eingesetzt. Das fällt beim direkten Empfang mit dem Exchange flach.
Hier bist du in der Pflicht, entweder vor den Exchange einen SMTP-Mailscanner zu setzen oder ein Produkt, welches direkt den Exchange-Server sichert. Anti-Spam nicht vergessen, sonst werden deine Mitarbeiter schnell ungehalten, ob der Flut an ungewollten Mails.
Bitte warten ..
Mitglied: sbs-user
25.01.2011 um 16:27 Uhr
Guten Tag,

@goscho: Ja, haben wir providerseitig genutzt. Das war mein strategischer Vorteil der pop-Lösung gegenüber der für Laien aufwändigeren smtp-Variante. Ich möchte klarerweise auch nicht zur Spamschleuder mutieren.

@MiniStrator: Bei uns ist alles unverändert, da ich mich den ganzen Tag um das normale Geschäftsleben kümmern muß.Gibt es für das Abschalten vom POP3 und das Aktivieren des Mailempfangs mit smtp tatsächlich keinen Assistenten im sbs08? Das heißt also alles selber einstellen in der Exchange Konsole?

Um die von dir gestellten Fragen kann ich mich erst ein wenig später kümmern, bitte um Verständnis.

Grüße an alle und Dank!

sbs-user
Bitte warten ..
Mitglied: goscho
25.01.2011 um 17:39 Uhr
Zitat von sbs-user:
Guten Tag,

@goscho: Ja, haben wir providerseitig genutzt. Das war mein strategischer Vorteil der pop-Lösung gegenüber der für
Laien aufwändigeren smtp-Variante. Ich möchte klarerweise auch nicht zur Spamschleuder mutieren.
Hi SBS-user,
so aufwändig ist diese Geschichte überhaupt nicht.
Wenn du hier nachliest, ist es sehr schnell und einfach eingerichtet.
Als Exchange-Viren-/Spamschutz kann ich dir Symantec Mailsecurity für Exchange empfehlen. Wenn du dort Premium Antispam mit lizenziert hast, bist du auf der sicheren Seite. Die Konfiguration ist sehr einfach.
Bitte warten ..
Mitglied: sbs-user
26.01.2011 um 18:17 Uhr
Guten Abend,

Danke @goscho für den link.

Ich habe jetzt folgende, aktuell funktionierende Lösung gemacht:
- MX Records bei meinem provider umgestellt auf McAfee Secure Messaging Service. Die MX zeigen jetzt auf:
meinefirma.com IN 100 MX meinefirma.com.etcetc.psmtp.com
usw bis IN 400.
Die emails sind sofort wieder angekommen. Auf dem alten Weg über POP3 war mein und nur mein Postfach bis zu dieser Umstellung blockert, d. h. wie oben beschrieben wurde nichts weitergeleitet, Ursache weiterhin unbekannt.
Ich habs im sbs08 in der Ex.Konsole einen Empfangs-Connector angelegt, da der standardmäßige Connector Default SERVERNAME meiner Einschätzung nacht nicht für diese Aufgabe eingerichtet ist. Mein Connector smtp emfpangsconnector ist ganz simpel:
- Port 25
- alles empfangen von 0.0.0.0 bis 255.255.255.255
- Authentifizierung: TLS (und sonst nichts)
- Berechtigungsgruppen: Anonyme Benutzer
Der POP3-Dienst am sbs ist weiterhin aktiv.
Ehrlich, ich hoffe mit dieser eigenschaftslosen Konfiguration keinen gröberen Schaden anzurichten da oben in die clouds ;)
Mehr kann ich bis zum Wochenende nicht tun, da wir gerade eine Messe haben und ich mich mit Priorität darum kümmern muß. Wir sind schließlich der Veranstalter.
Sollte ich irgendwo Mist gebaut haben mit dieser Lösung, dann bitte ich um einen unzweideutigen Aufschrei ;)
Nochmals Danke für die Hilfen,
sbs-user
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...