Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SBS 2008 Zertfikatprobleme IIS Exchange

Frage Microsoft Exchange Server

Mitglied: onkel87

onkel87 (Level 1) - Jetzt verbinden

23.01.2010 um 15:47 Uhr, 12651 Aufrufe, 8 Kommentare

Eine Kunde von uns hat einen SBS 2008 neu bekommen, soweit so gut.

Er hat:

- MS SBS 2008 64bit
- 2x Client XP Pro mit Outlook 2003
- 1x Client XP Pro mit Outlook 2007

er bekommt immer eine Fehlermeldung am Outlook 2007 PC das dass Zertifikat einen Falschen Name hätte,
egal wie ich es ändere auf servername etc. die meldung kommt immer wieder.

Alle Clients sind der Domäne und könne arbeiten nur diese Meldung kommt immer.

Sobald ich aber das Zertifikat im IIS unter SBS Web Applications auf domain-srv-01-ca ändere ist der fehler weg aber dafür geht das owa nicht
mehr, ändere ich es auf remote.kundendomain.de geht das OWA und der fehler kommt wieder.

Kann ich dem IIS nicht wie bei 2003 sbs sagen nehme das Zertfiikat für Web Applications und für OWA das andere?

Auch das mit dem remote.domäne.de blicke ich nicht seit 2008.
Kann mir jemand helfen?

Der Kunden hat:
kundendomain.de -> für website (provider)
name@kundendomain.de -> mail (provider per MX an de server)
eine Öffentliche feste IP von seinem CompanyConnect.

was soll ich jetzt mit dem remote.kundendomain.de?

Falls ich noch Infos brauch schreiben, bin dankbar um jede Antwort.
Mitglied: GuentherH
23.01.2010 um 18:37 Uhr
Hallo.

Lies dir einmal diesen Artikel durch - http://blogs.technet.com/sbs/archive/2010/01/05/troubleshooting-certifi ...

LG Günther
Bitte warten ..
Mitglied: ollembyssan
23.01.2010 um 22:50 Uhr
Hallo onkel87,

Exchange erstellt, sowohl beim SBS 2008 als auch bei seperater Installation von Exchange 2007/Exchange 2010
ein selbstsigniertes Zertifikat. Zudem findest du im IIS vom SBS 2008 noch weitere Zertifikate,
unteranderem das der installierten Zertifizierungsstelle etc.

Um es trivial zu erklären:

Outlook 2007 versucht anhand von "Autodiscover-Einträgen" den Weg zum Exchange 2007/Exchange 2010 zu finden.
Passt das Zertifikat nicht zum "Namen" auf welchen das Zertifikat ausgestellt worden ist,
kommt eben genau diese Fehlermeldung, die du selbst erhältst!

Dies sollte dir auch erkläten, warum dein Outlook 2003 Client diese Fehlermeldung nicht erhält,
da er nicht versucht anhand von "Autodiscover-Einträgen" den Weg zum Exchange zu finden!

Da sich deine Clients in der Domäne befinden, vertrauen sie bereits der Zertifizierungsstelle,
welche während der SBS 2008 Installation erstellt worden ist!
Das heißt, wegen der Vertrauensstellung musst du dir keine weiteren Gedanken machen!

Jetzt zur Problemlösung:

Zunächst wählst du im IIS das selbstsignierte Exchange Zertifikat aus,
wobei das Zertifikat auf den FQDN des Servers ausgestellt sein sollte z.B.
"server.domain.local"

Starte bitte die Exchange-Shell und gib folgende Befehle einzeln hintereinander ein,
wobei du jeden Punkt mit "Enter" bestätigst!

Bitte ersetze "server.domain.tld" durch den FQDN (z.B. server.domain.local)
deines Server

Bitte ersetze bei "Identity" -> "SERVERNAME" durch den einfachen Namen des Server!


• Set-Autodiscovervirtualdirectory –InternalURL https://server.domain.tld/autodiscover/autodiscover.xml
Identity: SERVERNAME\Autodiscover (Default Web Site)

• Set-Autodiscovervirtualdirectory –externalURL https://server.domain.tld/autodiscover/autodiscover.xml
Identity: SERVERNAME\Autodiscover (Default Web Site)

• Set-Clientaccessserver –AutodiscoverServiceInternalUri
https://server.domain.tld/autodiscover/autodiscover.xml
Identity: SERVERNAME

• Set-WebServicesVirtualDirectory
-WebsiteName "EWS (Default Web Site)"
-InternalURL https://server.domain.tld/EWS/Exchange.asmx

• Set-OWAVirtualDirectory
-identity OWA (Default Web Site)
-InternalURL https://server.domain.tld/owa

Nun erstellst du noch im DNS-Manager einen "SRV-Eintrag":

Du öffnest die DNS-Server Verwaltung,
wechselst zur Forward-Lookupzone deiner Domäne z.B. "domain.local" und erstellst mit einem Rechtsklick
-> "Weitere neue Einträge" einen neuen SRV-Eintrag wie folgt:

http://www.msxfaq.de/e2007/autodiscover08.gif

-> anstatt owa.netatwork.de wählst du den FQDN deines Servers z.B. "server.domain.local"

Starte danach den DNS-Server neu.


Gruß,

Ole
Bitte warten ..
Mitglied: onkel87
24.01.2010 um 13:58 Uhr
Das werd ich gleich morgen versuche - vielen Dank!
Bitte warten ..
Mitglied: onkel87
25.01.2010 um 08:53 Uhr
statt (Default Web Site) muss ich da nicht bei SBS: SBS Web Applications eingeben?
Bitte warten ..
Mitglied: onkel87
25.01.2010 um 09:39 Uhr
• Set-WebServicesVirtualDirectory
-WebsiteName "EWS (Default Web Site)"
-InternalURL https://server.domain.tld/EWS/Exchange.asm ...

• Set-OWAVirtualDirectory
-identity OWA (Default Web Site)
-InternalURL https://server.domain.tld/owa

diese 2 wollen nicht bei:
Set-WebServicesVirtualDirectory
kommt erst idententy. wenn ich dann -WebsiteName "EWS (Default Web Site)" eingebe kommt keine aufforderung mehr.
geb ich alles am stück ein kommen fehlermeldungen das es die befehle nicht gibt.
Bitte warten ..
Mitglied: ollembyssan
25.01.2010 um 10:24 Uhr
Hallo onkel87,

richtig, anstatt (Default Web Site) musst du SBS Web Applications eingeben!

Die Einträge der Identity, internalUrl, externalUrl etc. pp. kannst du auch mit Befehlen wie: " Get-WebServicesVirtualdirectory | fl " oder " Get-OWAVirtualDirectory | fl " oder " Get-WebServicesVirtualDirectory | fl " testen.

Bei " Set-WebservicesVirtualdirectory " gibst du folgendes ein:

Set-WebServicesVirtualDirectory -internalUrl https://server.domain.tld/EWS/exchange.asmx

=> danach kommt die Abfrage der "Identity"

dort bitte folgendes eingeben, wobei "SERVER" dem einfachen Servernamen entspricht:

=> Identity: SERVER\EWS (SBS Web Applications)

Gruß,
Ole
Bitte warten ..
Mitglied: kivircikali
02.02.2010 um 09:30 Uhr
Hallo,

Ich habe auch das gleiche Problem und komme nicht weiter. Danke für deinen tipp aber es hat bei mir nichts gebracht, jetzt geht nicht einmal OWA und Abwesenheitsassistent. Mit Site Bindung konnte ich OWA noc starten aber Abwesenheitsassisten geht immernoch nicht und anschliessend kommt eine Fehlermeldung "Ihre Abwesenheitseinstellungen können nicht angezeigt werden, da der Server zurzeit nicht verfügbar ist. Versuchen Sie es später erneut. Hat da jemand eine gute tipp??

Danke vielmaaal für die Bemühungen und Rückmeldungen.

MFG
K.ALI
Bitte warten ..
Mitglied: onkel87
24.02.2010 um 21:41 Uhr
hi ich habe soeben mir auch eine sbs 2008 aufgesetzt, nun hatte ich das gleiche Problem wieder, allerdings ging es nicht mit der Fehlermeldung weg.

Was mich wundert wenn ich Outlook 2007 starte am Client kommt folgende Meldung:

autodiscover.ÖFFENTLICHEDOMAIN.de
-> Zertfikat anzeigen: *.PROVIDER.de

Wie kann ich das ändern?

Vielen Dank für eure Infos....
Bitte warten ..
Ähnliche Inhalte
Exchange Server
SBS 2008 mit Exchange
Frage von MrChiacomoExchange Server6 Kommentare

Hallo zusammen, ich habe einen SBS2008 mir Exchange auf dem gleichen Rechner. Ich möchte dies nun ändern und den ...

Windows Server
SBS 2008 und 2011 IIS Logs und Speicherplatz
Frage von steftsWindows Server1 Kommentar

Guten Morgen, Wir betreiben bei uns in der Firma einen SBS 2011. Neulich ist uns bei uns (und auch ...

Exchange Server
Exchange 2007 auf SBS 2008: Topologieproblem
Frage von diwaffmExchange Server18 Kommentare

Hi Leute, wir haben hier einen SBS 2008, der seit ca. 4 Jahren läuft. Darauf einen Exchange 2007, der ...

Windows Server
SBS 2008 Exchange Store verschieben
Frage von MazenauerWindows Server2 Kommentare

Guten Tag zusammen, Ich habe bei einem meiner Kunden das Problem, dass mein Vorgänger die Exchange Daten auf dem ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 6 StundenWindows 101 Kommentar

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 7 StundenSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 22 StundenInternet3 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 1 TagDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement21 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

TK-Netze & Geräte
VPN-fähige IP-Telefone
Frage von the-buccaneerTK-Netze & Geräte16 Kommentare

Hi! Weiss noch jemand ein VPN-fähiges IP-Telefon mit dem man z.B. einen Heimarbeitsplatz gesichert anbinden könnte? Habe nur einen ...

Windows Server
Anmeldung direkt am DC nicht möglich
Frage von ThomasGrWindows Server16 Kommentare

Hallo, ich habe bei unserem Server 2016 Standard ein Problem. Keine Ahnung wie das auf einmal passiert ist. Ich ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...