Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SBS2011 zweiter DC Probleme mit Exchange

Frage Microsoft Windows Server

Mitglied: walexi

walexi (Level 1) - Jetzt verbinden

07.09.2012 um 17:16 Uhr, 7508 Aufrufe, 8 Kommentare

Guten Tag,
da ich neu hier bin, darf ich mich zunächst kurz vorstellen. Meine (kleine) Firma erstellt Software für fehlertolerante HP NonStop Server (große Kisten, proprietäres OS). Für interne Zwecke betreiben wir ein Windows Netzwerk mit einem SBS2011 als DC und Email Server (Exchange). Da das Administrieren dieser Umgebung nicht unser Hauptgeschäft ist, sind meine Kenntnisse in diesem Umfeld - hmm, sagen wir: begrenzt. Man verzeihe mir daher, wenn ich vielleicht Anfängerfehler gemacht habe.

Da der SBS2011 auch DNS spielt, wollte ich einen zweiten DC ins Netz stellen, damit zumindest Anmeldungen und Internet Recherchen für die Mitarbeiter auch funktionieren, wenn der SBS2011 mal ausgeschaltet ist. Laut diverser Recherchen sollte das eigentlich funktionieren. Ich habe dann einen Windows Server 2008 R2 aufgesetzt und mit dcpromo zum DC (nicht RODC) gemacht. Das hat auch funktioniert, das AD wurde anscheinend korrekt repliziert.

Als ich dann den SBS2011 wegen Umbauarbeiten im Rack tatsächlich herunterfahren musste, gab es beim Wiederanlauf leider erhebliche Probleme mit Exchange. Eine Anmeldung mit Outlook war nicht möglich - die Verbindung blieb einfach getrennt. Auch IMAP funktionierte nicht (iPhone bekam keinen Kontakt) und der OWA Zugang ebenfalls nicht. Nach der ersten Panik (Email ist leider wichtig) stellte ich fest, dass einige notwendige Dienste (RPC, IMAP) nicht liefen. Zum Glück ließen sich die Dienste manuell starten und dann lief es vorerst wieder. Da mich so etwas aber extrem beunruhigt, habe ich diverse Versuche gemacht und Stunden in Google verbracht - leider keine Lösung. Bevor ich einen der wertvollen Calls bei Microsoft opfere, wollte ich mein Glück jetzt zunächst hier suchen - vielleicht kann ja jemand helfen.

Hier ein paar Details (habe unsere Domäne durch XXXXX ersetzt):

1. Ist der zweite DC (der kein SBS, sondern nur ein Server 2008 R2 ist) ausgeschaltet und man fährt den SBS2011 hoch, kommt es u.a. (habe nur die Meldungen hier eingefügt, die mir für das Problem wichtig schienen) zu folgenden Fehlermeldungen:

System:

Zeitüberschreitung bei der Namensauflösung für den Namen _ldap._tcp.Default-First-Site-Name._sites.dc._msdcs.XXXXX.local, nachdem keiner der konfigurierten DNS-Server geantwortet hat.
Zeitüberschreitung bei der Namensauflösung für den Namen XXXXX.local, nachdem keiner der konfigurierten DNS-Server geantwortet hat.
Der Dienst "Formularbasierter Microsoft Exchange-Authentifizierungsdienst" wurde mit folgendem dienstspezifischem Fehler beendet: %%-2147467259.
Der Dienst "Microsoft Exchange-Informationsspeicher" wurde mit folgendem dienstspezifischem Fehler beendet: %%2415.

Anwendung:

Prozess MSEXCHANGEADTOPOLOGY (PID=2536). Fehler beim Abrufen der SID für Konto '<WKGUID=1A9E39D35ABE5747B979FFC0C6E5EA26,CN=Microsoft Exchange,CN=Services,CN=Configuration,...>' durch Exchange während des Initialisierens eines RPCs (Remote Procedure Call) an den Microsoft Exchange Active Directory-Topologiedienst - Fehlercode=80040a01.
Prozess MSEXCHANGEADTOPOLOGY (PID=2536). Die Standortmonitor-API konnte nicht überprüfen den Standortnamens für diesen Exchange-Computer - Anruf=HrSearch Fehlercode=80040a01. Überprüfen Sie, ob der Exchange-Server ordnungsgemäß beim DNS-Server registriert ist.
Prozess MSEXCHANGEADTOPOLOGY (PID=2536). Fehler beim Abrufen der Sicherheitsbeschreibung für das Exchange-Serverobjekt 'SERVER2011' durch Microsoft Exchange während des Aktualisierens der Sicherheit für einen RPC-Zugriff (Remote Procedure Call) für den Exchange Active Directory-Topologiedienst - Fehlercode=80040a01.
Fehler '0x96f' beim Verbinden mit Active Directory.

Als DNS Server ist überall der SBS2011 selbst eingetragen (und nur dieser). dcdiag und dcdiag /test:dns zeigen keine Auffälligkeiten. Die Exchange Server verfügen über das Recht "Verwalten von Überwachungs- und Sicherheitsprotokollen" (zumindest zeigt RSOP.msc XXXXX\Exchange Enterprise Servers und XXXXX\Exchange Servers.

2. Wenn der 2. DC eingeschaltet ist und der SBS2011 neu gestartet wird, fällt auch der Information Store auf die Nase, kommt aber letztlich (nach sehr langer Zeit) hoch. Die Fehlermeldungen sind gleich.

Eigentlich hatte ich mehr Robustheit mit dem zweiten DC erhofft. Jetzt ist vorerst alles leider nur schlechter geworden.

Bin für jede Hilfe sehr dankbar. Vor der Einführung des 2. DC lief alles gut - und jetzt das.

Gruß
W.Alexi
Mitglied: Epixc0re
07.09.2012 um 17:19 Uhr
Hi W.Alexi,

wenn du etwas erfährst lass es uns bitte wissen, ich habe hier das gleiche Problem,
jedoch nicht mit SBS sondern mit 4 Win2008R2 + 2x Exchange 2010 Servern ...

lg
Bitte warten ..
Mitglied: Onitnarat
07.09.2012 um 17:30 Uhr
Hallo,
habt Ihr mal versucht die DNS-Server kreuzweise einzutragen? Also den SBS als primären DNS auf dem DC und den DC als primären DNS auf dem SBS.
So sollte die Domäne bei einem Neustart auf jeden Fall verfügbar sein!

Nächste Frage: Du hast die FSMO-Rollen aber auf dem SBS belassen, oder?

Gruß
Marcus
Bitte warten ..
Mitglied: walexi
07.09.2012 um 17:48 Uhr
Tja,
das mit den kreuzweisen DNS Servern scheint mir nicht die beste Idee zu sein, da ja dann gerade in dem Fall, dass einer der DCs down ist, aus Sicht des Überlebenden der primäre DNS Server weg ist und das ist nicht gut. Ich denke, es ist besser, wenn generell der SBS primärer DNS Server ist und der zweite DC dann der zweite DNS. Nur beim zweiten DC könnte man das andersherum machen. Das ist aber hier nicht relevant, weil ja die unangenehmste Situation (Exchange nicht verfügbar) genau dann entsteht, wenn der zweite DC gar nicht läuft.

Leider bin ich bei den Rollen überfragt. Ich selbst habe damit jedenfalls gar nichts gemacht, sondern nur den dcpromo Assistenten verwendet. Wie kann ich das prüfen?

Nett, dass so schnell Antworten kommen. Gut ist auch, dass auch sonst jemand das Problem hat. Wenn ich in absehbarer Zeit keine Lösung dafür bekomme, werde ich den Microsoft Support bemühen. Zumindest verspreche ich, dass ich die Lösung in dem Fall hier posten werde. Prinzipiell haben wir mit dem Microsoft Support ganz gute Erfahrungen. Das Problem ist meistens, dass man eine "Gemengelage" hat: die Auswirkung ist der Exchange Fehlschlag, die Ursache vermutlich ein DNS Problem (nicht wahrscheinlich, habe das gut geprüft) oder etwas mit Gruppenrichtlinien (eine unendliche Geschichte) oder ein AD Problem oder Timingproblem und Dienstabhängigkeiten oder ... Die Eventmeldungen sind leider oft nicht hilfreich.
Gruß
W. Alexi
Bitte warten ..
Mitglied: JensMander
12.09.2012 um 17:54 Uhr
Ich habe den gleichen Fehler. Ich weiss zumindest wo er herkommt.
Mein Server ist DNS, AD und Exchange in einem. Er nutzt sich selbst als DNS-Server. Beim Hochfahren ist der DNS-Service anscheinend noch nicht schnell genug gestartet, dass ihn die Dienste verwenden können.
Irgendwie müsste ich einen Timeout hinbekommen (beim Boot DNS-starten, Timout 2min, danach soll er erst alle Exchange-Dienste starten.
Wenn der Server dann hochgefahren ist und ich starte die Dienste dann manuell nach funktioniert der Start bei mir problemlos, da DNS zu der Zeit ja auch schon wunderbar arbeitet - ich denke Du hast das gleiche Verhalten(?!).

Ich habe jetzt zum Test mal einen anderen Server zum Backupdomaincontroller gemacht und ihm DNS mit verpasst. Nutze ich diesen Server als zweiten DNS-Server fährt der Server auch mit den Exchange-Diensten hoch. Ich möchte aus bestimmten Gründen trotzdem nur einen AD-Server und DNS, daher würde mich interessieren, wie Du das mit MS gelöst hast.

Wäre sehr nett, wenn Du postest was der Microsoft-Support dazu gesagt hat.
Bitte warten ..
Mitglied: JensMander
12.09.2012 um 19:45 Uhr
Ich glaube ich habe die Lösung für Dich gefunden. Ich habe alle betroffenen Dienste auf "Automatisch (verzögert)" gestellt und siehe da, es klappt. Beim Booten werden plötzlich alle Dienste normal (auch ohne Fehler im Log) gestartet.

Perfekt - lag ich wohl richtig damit, dass DNS noch nicht so richtig da war...

P.S: Ich habe vorher noch in die hosts-Datei den Exchangeserver eingetragen. Ich denke das war unnötig, da es ja erst mit dem verzögerten Start so richtig geklappt hat - wenn es bei Dir aber nicht klappt mach das einfach auch. Ich lass das mal eingetragen.
Bitte warten ..
Mitglied: walexi
13.09.2012 um 08:20 Uhr
Guten Tag,
witzigerweise bin ich gestern auch auf die Idee gekommen, die Exchange Dienste auf "Automatisch (verzögert)" zu stellen. Das hat auch bei mir geholfen. Exchange läuft jetzt sauber hoch. Es gibt zwar noch ein paar Fehler im Eventlog (nicht von Exchange Diensten), ich nehme aber an, dass die normal sind. Ich habe den Fall allerdings noch in einem MS Supportforum (nicht öffentlich zugänglich) stehen, vielleicht hat man dort noch eine andere (bessere?) Idee.
Vorerst vielen Dank bei allen, die zumindest mal über das Problem nachgedacht haben. Wenn von MS noch etwas kommt, werde ich es mitteilen.
Gruß
Werner Alexi
Bitte warten ..
Mitglied: JensMander
13.09.2012 um 10:20 Uhr
Ich hatte auch noch -wie Du- andere Fehler im Eventlog (z.B. Gruppenrichtlinien konnte nicht übernommen bzw. gelesen werden). Die sind aber weggegangen als ich den Eintrag des Servers (das er sich selbst auflösen kann ohne dass der DNS-Server schon verfügbar ist) in der Host Datei gemacht habe.
Zu den nicht-Exchangefehlern stand auch meist drin, dass es an der Namensauflösung liegen kann / wird.

Ich weiss, dass die Lösung mit dem verzögerten Start nicht die sauberste ist, aber Sie funktioniert für mich. Ich denke mal den Fehler werden alle Leute haben, die eine Standalone-Umgebung bzw. SBS Server haben. Wird Microsoft sicher in einem Update mal nachbessern. Für mich funktioniert es so aber prächtig. Ob die Exchange-Dienste ein paar Sekunden später nach dem Boot zur Verfügung stehen oder sofort ist mir persönlich egal. Die Hauptsache ist, das sie fehlerfrei starten.
Bitte warten ..
Mitglied: Ausserwoeger
25.04.2013 um 11:02 Uhr
Hi Leute

Super ich hab den selben sch

Dienste auf Verzögert gestellt hilft erstmal.

Microsoft sollte sich die situation mal anschauen hat einer von euch einen Call eröffnet ?

LG Andy
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
Nach Migration des DC, Probleme mit Exchange (2)

Frage von StephanS zum Thema Exchange Server ...

Exchange Server
Zertifikat Probleme Exchange (13)

Frage von meeeen zum Thema Exchange Server ...

Exchange Server
gelöst Probleme Exchange 2010 (5)

Frage von windowsboy zum Thema Exchange Server ...

Exchange Server
gelöst SBS2011 - im Exchange mobile Geräte löschen (4)

Frage von MiSt zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...