Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SCA SCSI Raid HDD an Adaptec ausgefallen. Contoller integriert neue HDD nicht.

Frage Hardware Festplatten, SSD, Raid

Mitglied: yaguza

yaguza (Level 1) - Jetzt verbinden

12.01.2007, aktualisiert 15.01.2007, 9323 Aufrufe, 4 Kommentare

2 HDD defekt mit Status Dead. Austausch HDD optimal aber nicht im Raid.

Hallo Forúmianer,
stehe etwas unter Druck, da mir ein Datenbank-Server, Probleme macht.
Mainboard ist ein Tyan mit "On Board SCSI", dazu ein zero channel Adaptec 2010S raid controller. Die beiden Backplane's sind von Fantec mit jeweils 5 Einschüben. Die Konfig wurde vom Softwarelieferanten (sitzt auf Oracle) so vorgegeben. Es gibt die Partitionen c:, d:, e: f: g: mit 18 GB IBM SCSI IC35L018UCPR15-0 die jeweils im Raid 1 laufen.

Habe vor ein paar Tagen festgestellt, das 2 Hdd's den Status "Dead" haben. Wegen der hohen Priorität habe ich dann 2 Stck 36 GB Fujitsu SCA organisiert weil 18 GB scheinbar nur noch in Litauen über ebay zu beziehen sind! :---)
Dachte ich könnte die einfach austauschen, ein rebuild anschmeissen und fertig, aber die neuen Platten werden vom Controller jeweils als neue Platten (LSU/HBA) aufgeführt mit dem Status "redirected" geführt und im Storage Manager haben die entnommenen Platten den Status " Zur Zeit nicht vorhanden"
Formatieren kann ich beide Platten ohne Probleme.
Wichtig ist natürlich, dass die Partition (wegen DB Transaktion, Idex, Logfiles...) auf der funktionierenden Platte erhalten bleiben.

Hat jemand eine Idee wie ich die beiden neuen Platten dazu bringe sich in das jeweilige Raid 1 zu integrieren? Das geht bestimmt ganz einfach, aber wie? :---)
Ich hoffe ich liege richtig in der Annahme, das die Zuordnung der ID etc durch SCA und der Backplane automatisch abgestimmt wird.
Bin im Controllerbios als auch Adaptec Storage Manager nicht fündig geworden.

Für jeden Tipp dankbar

Gruss
Yaguza
Mitglied: Rafiki
13.01.2007 um 11:37 Uhr
Adaptec 2010S
http://www.adaptec.com/en-US/support/raid/scsi_raid/ASR-2010S/
-> Documentation.

Wenn es möglich ist den Server herunter zufahren, dann würde ich das auch machen. Ein Rebuild während die Oracle Datenbank läuft ist möglich, aber die Performance der Datenbank ist deutlich schlechter als normal und das Rebuild dauert länger. Wenn die Datenbank weiterlaufen muss, dann würde ich im Storage Manger, Options, Background Task Priority auf 50% stellen, damit Windows und das Rebuild sich die Leistung von dem RAID Controller teilen.

Nach dem die defekten Festplatten ausgetauscht wurden kann das Rebuild beginnen.
In der Windows Software (Adaptec Storage Manager) oder in dem BIOS vom Controller (während der Server bootet Strg A drücken) in den logical view wechseln und das degraded (beschädigt) logische Laufwerk auswählen. Dann ein Rebuild für das Laufwerk beginnen. Es kann sehr lange dauern. Ich weiß nicht ob es möglich ist die beiden logische Laufwerke gleichzeitig zu reduilden.

Gruß Rafki
Bitte warten ..
Mitglied: yaguza
14.01.2007 um 13:37 Uhr
Hallo Rafki,
danke für deine Antwort.
Vermutlich habe ich nicht ausreichend genug deutlich gemacht wo das eigentliche Problem liegt.
Den prinzipiellen Ablauf des Austauschs von defekten HDDs kenne ich, mehr oder weniger.
Im vorliegenden Fall liegt das Problem darin, dass die neuen Platten in der Backplane vom Controller erkannt werden und dann den Status OPTIMAL erhalten. Leider werden diese jeweils nur als einzelne Platten erkannt und NICHT dem jeweiligen RAID 1 zugeordnet wie es laut Adaptec passieren soll.
In diesem Status habe ich keine Möglichkeit das REBUILD zu initiieren. Der Menuepunkt ist grau hinterlegt! Zum Glück, denn wer was der Controller dann machen würde.
Er scheint nicht zu wissen, wo die neu eingebauten HDDs eingebunden werden sollen.

Hoffe das ich es hiermit etwas deutlicher beschrieben habe.

Gruss

Yaguza
Bitte warten ..
Mitglied: kipker
15.01.2007 um 13:31 Uhr
hallo yaguza, versuchen Sie doch mal folgende Vorgehensweise, die bei mir in einem ähnlichen System funktioniert hatte.

System komplett sichern (Backup + Image) und zwar so, dass man es nacher wieder herstellen kann. Das ist die absolute Bedinung!!
System runter fahren, auch wenn die Backplane hotswap Funktionalität hat.
Die defekten Festplatten austauschen.
System starten und mit crtl + A das BIOS des SCSI Controller starten.
Jetzt werden die neuen Festplatten angezeigt. Wie Sie schrieben ohne Zuordnung.
Wählen Sie zunächst eine Festplatte aus und markieren diese.
Dann mit ALT + A (action) definieren Sie diese über das Menue als HOTSPARE.
Achtung, das muss die richtige sein, weil alle DAten auf der Harddisk verloren gehen.
Jetzt über das Datei Menue die Einstellungen speichern.
Es erscheint ein + an den neuen Festplatten die signalisieren, das diese Festplatten als HOTSPARE definiert sind.

Starten Sie das System neu und rufen Sie den Adaptec Storage Manager auf.
Schalten Sie die logische Ansicht ein.
Wählen Sie das degradierte Raid aus und starten das REBUILD.
Wenn es funktioniert, die ganze Sache mit der zweiten HDD wiederholen.

Im Prinzip fehlte Ihnen nur der Hinweis , die Festplatten vorher als hotspare zu definieren!

Viel Glück

www.kipker.com

Für die oben beschriebene Vorgehensweise übernehme ich natürlich keine Verantwortung oder Haftung. Alles was Sie machen geschieht auf eigene Verantwortung.
Bitte warten ..
Mitglied: yaguza
15.01.2007 um 20:47 Uhr
Das hat genau so geklappt wie beschrieben.
Da haben Sie einen dicken Brocken weggeräumt.
LG Yaguza
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
SSD im Raid ausgefallen - kurzzeitig mit HDD ersetzen?
gelöst Frage von cymodeServer-Hardware10 Kommentare

Hi, Scenario: Wir haben 4x Seagate Pulsar.2 mit je 200GB (SAS) in einem hardware Raid 10 laufen. Controller ist ...

Server-Hardware
Ideen für günstiges Hot-Swap-Fähiges SCA Raid?
Frage von HacklerServer-Hardware1 Kommentar

Hallo Liebes Forum! Ich habe mich hier angemeldet um mich von euch vorerst 'mal zu einer speziellen Frage inspirieren ...

Festplatten, SSD, Raid
Raid Controller wechsel von Adaptec auf MegaRaid
Frage von geforce28Festplatten, SSD, Raid9 Kommentare

Hallo Leute, ich habe vor einen bestehenden Raid, der mit einem Adaptec Controller erstellt wurde auf einen neuen Raid ...

Festplatten, SSD, Raid
Adaptec 6805 Raid Controller - defekt?
gelöst Frage von Axel90Festplatten, SSD, Raid15 Kommentare

Hi! ich habe gerade einen gebrauchten Adaptec 6805 in meinen Server eingebaut. Wenn ich den Server starte, leuchten alle ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 3 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...