Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Schaum vorm Mund wegen Postgres installation

Frage Linux

Mitglied: coredump

coredump (Level 1) - Jetzt verbinden

19.01.2006, aktualisiert 14:18 Uhr, 4685 Aufrufe, 10 Kommentare

Hallo Leute. Ich verzweifle gerade an einer Postgersinstallation.
Das Betribessystem ist Opensuse10 und Postgres ist in der Version 8.1.2 installiert

Wenn ich den Postgres Server starten möchte, geht das lediglich mit der -D Option.

Dabei habe ich eine profile.local wie folgt angelegt.:

LD_LIBRARY_PATH=/usr/local/pgsql/lib
PGDATA=/usr/local/pgsql/data
PATH=/usr/local/pgsql/bin:$PATH
MANPATH=/usr/local/pgsql/man:$MANPATH

export LD_LIBRARY_PATH PGDATA PATH MANPATH

Will ich die Datenbank mit "postmaster" starten, bekomme ich den Hinweis, dass ich doch mal den PGDATA Pfad setzen möchte.....
Nachdem ich mich nun schon wundgegoogelt habe, mag ich nicht mehr.
Kann mir bitte jemand weiterhelfen??? Ich brauch nen guten Denkanstoss

Gruss und schonmal Danke im Vorraus
Core
Mitglied: netstorm
19.01.2006 um 11:01 Uhr
Hallo,

also ich hab letztens noch ein Postgres auf suse10 installiert. Allerdings hatte ich keine wirklich großen Probleme. Ich hab das Package, das dabei war installiert. Danach solltest Du postgres mit "/etc/init.d/postgres start" starten können. Allerdings ist ein connect zu der Datenbank dann nur bedingt möglich. Aber probier das erstmal aus.

CIAO Thorsten
Bitte warten ..
Mitglied: coredump
19.01.2006 um 11:27 Uhr
hi thorsten.

ich habe die allererste versio vom opensuse10...und da war kein postgres dabei.
ich hab den server nun auch schon installiert und läuft hervorragend.

das problem ist ja nur dieser pgdata pfad.

gruss
lars
Bitte warten ..
Mitglied: netstorm
19.01.2006 um 11:36 Uhr
Mhh,

hab mich eben mal ein wenig umgeschaut. Opensuse scheint etwas anders zu sein als die "richtige" Suse.
Sehe ich das richtig, daß Du dir die Datenbank direkt bei Postgres auf der Seite runtergeladen und compiliert hast?
Hast Du die Installationsanleitung von Postgres durchgearbeitet?

http://www.postgres.de/install.html

CIAO Thorsten
Bitte warten ..
Mitglied: coredump
19.01.2006 um 11:52 Uhr
Jau Thorsten..

Die Quellen hab ich von postgres downgeloaded und durchgequrilt. Alles strickt nach Anleitung, die dabei war. Es hat ja auch alles bis auf das genannte Problem bestens funktioniert.

DAnn hab ich ein bissl gegoogelt und zum Thema PGDATA noch ne anleitung für eine ältere SuSe gefunden, in der der Pfad folgendermassen lautet:
PGDATA=$PGDATA/usr/local/pgsql/data

Den hatte ich dann auch noch ausprobiert....funktioniert aber genausowenig.
Mit dem Befehl "env" kann die ich eingetragenen Pfade auch sehen. Echt ne doofe Nummer.

Gruss
Lars
Bitte warten ..
Mitglied: netstorm
19.01.2006 um 11:56 Uhr
DAnn hab ich ein bissl gegoogelt und zum
Thema PGDATA noch ne anleitung für eine
ältere SuSe gefunden, in der der Pfad
folgendermassen lautet:
PGDATA=$PGDATA/usr/local/pgsql/data

Der Pfad sieht mir etwas komisch aus. Sinnvoller wäre:
export PGDATA=$PGDATA:/usr/local/pgsql/data/

Aber nochmal, daß ich das richtig verstanden habe:
Du kannst die DB mit "postmaster -D /usr/local/pgsql/data" starten?
Wenn ja, kannst du auch "postmaster -D $PGDATA" ?

Thorsten
Bitte warten ..
Mitglied: coredump
19.01.2006 um 12:42 Uhr
Hey Thosten.

Vielen Dank für Deine Mühe und Unterstützung.

Es funktioniert jetzt aber ich habe keine Ahnung warum.
Ich habe nichts an der profiles.local verändert seit meinem letzten versuch.

Manchmal isses doch echt zum verzweifeln.

Gruss
Lars
Bitte warten ..
Mitglied: netstorm
19.01.2006 um 13:23 Uhr
Hallo,

hast Du dich nachdem Du die Änderungen gemacht hast mal neu eingeloggt? Die profile-Datei wird nämlich immer nur beim neuen anmelden einer shell neu geladen.

CIAO Thorsten
Bitte warten ..
Mitglied: coredump
19.01.2006 um 13:53 Uhr
Hey Thorsten.

Das wird es gewesen sein. Zuerst hab ich es immer mit nem Neustart versucht. Das wurde mir dann aber zu doof, weil es zu lange dauert. Dann hab ich nur noch die profile.local editiert und ausgeführt.

Eben hatte ich nochmal nen Neustart durchgeführt.

Vielen Dank
Lars
Bitte warten ..
Mitglied: netstorm
19.01.2006 um 14:11 Uhr
Nochmal für die Zukunft. Neustarten mußt Du nicht unbedingt. Aber wenn Du solche Änderungen machst, mußt Du dich neu einloggen oder eine neue Shell starten, damit die Änderungen aktiv werden. Da bin ich auch schon oft drauf reingefallen

CIAO Thorsten
Bitte warten ..
Mitglied: coredump
19.01.2006 um 14:18 Uhr
Hi Thorsten.

Ich versuche auch immer dieses Windows verhalten zu vermeiden. Aber ich wusste nicht, wann die profile.local abgearbeitet wird.
Aber nu weiss ich et ja

Gruss
lars
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
SAN, NAS, DAS
NetApp FAS3240 + DS14MK4 + DS14MK2 Fibre Channel - Installation (3)

Frage von sunny-ko zum Thema SAN, NAS, DAS ...

Linux
SW-Verteilung und unattended OS Installation

Frage von winlin zum Thema Linux ...

Video & Streaming
Beamer-Installation neben Klimagerät (3)

Frage von inno-it zum Thema Video & Streaming ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...