Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Schema-Update hängt? Erneut ausführen? (EX2003 zu EX2010 im 2003er AD)

Frage Microsoft Windows Server

Mitglied: AdminKnecht

AdminKnecht (Level 1) - Jetzt verbinden

25.11.2011, aktualisiert 10:03 Uhr, 5504 Aufrufe, 1 Kommentar

setup /prepareschema bei EX2010 hängt, erneut ausführen?

Hallo,

ich möchte unseren bestehenden Exchange2003 zu Exchange2010 migrieren ("swing-by-update" lt. der genialen Anleitung von Stephan Mey unter http://www.faq-o-matic.net/2011/05/30/whitepaper-migration-von-exchange ... )

Ausgangsbasis ist eine Domäne in einer Gesamtstruktur an einem Standort, die D2003er Domäne im einheitlichen Modus, Gesamtstruktur. und Domänenfunktionsebene sind im "Windows Server 2003 Modus", die Exchange-Org ist ausserdem im "einheitlichen Modus (keine Ex-Server vor 2003)", zwei Domänencontroller DC1 und DC2, die gegeneinander replizieren und AD, DNS, DHCP etc, hosten ----so weit, so gut, Exchange kommt auf einen neuen Memberserver mit 2008R2

In einer Testumgebung habe ich das alles durchgespielt, funktionierte einwandfrei!

Gestern Abend wollte ich schon mal die Vorbereitungen in unserer echten Domäne duchführen (setup /prepareschema, setup /preparead /organizationsname:FIRMA , setup /preparelegacyexchangepermissions, setup /preparedomain), vorher beide DCs frisch "geupdated" und durchgebootet, und mit REPLMON und DSASTAT -LOGLEVEL:INFO geprüft, ob auf beiden DCs der gleiche AD-Stand ist, alles perfekt!

Leider gab es dann gleich beim ersten Schritt (SETUP /PREPARESCHEMA) Probleme, denn nach dem erfolgreichen "Die Setupdateien werden kopiert" -> abgeschlossen und "Die Voraussetzungen für Microsoft-Exchange Server werden überprüft" -> abgeschlossen hängt die Installation nun mit der Meldung "Das Active Directory Schema wird erweitert 39%" , seitdem (ca. 14 Stunden) tut sich nichts mehr, der Server ist aber nicht abgestürzt o.ä. ...

Im EXCHANGE SETUP.LOG lauten die letzten Zeilen

[11.24.2011 18:48:11.0485] [2] Die Active Directory-Sitzungseinstellungen für 'Install-ExchangeSchema' lauten: Vollständige Gesamtstruktur anzeigen: 'True', Konfigurationsdomänencontroller: 'dc1.firma.ads', Bevorzugter globaler Katalog: 'dc1.firma.ads',
Bevorzugte Domänencontroller: '{ dc1.firma.ads }'
[11.24.2011 18:48:11.0485] [2] Beginning processing install-ExchangeSchema -LdapFileName:'Setup\Data\PostExchange2003_schema35.ldf'
[11.24.2011 18:48:11.0485] [2] Running <C:\Windows\system32\ldifde.exe> with arguments <-i -s "dc1.firma.ads" -f "C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema35.ldf" -j "C:\Users\Adminmeister\AppData\Local\Temp" -
c "<SchemaContainerDN>" "CN=Schema,CN=Configuration,DC=firma,DC=ads">.
[11.24.2011 18:48:48.0392] [2] Process C:\Windows\system32\ldifde.exe finished with exit code 0.
[11.24.2011 18:48:48.0392] [2] Ending processing install-ExchangeSchema
[11.24.2011 18:48:48.0392] [1] Executing:
install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema36.ldf")

[11.24.2011 18:48:48.0392] [2] Die Active Directory-Sitzungseinstellungen für 'Install-ExchangeSchema' lauten: Vollständige Gesamtstruktur anzeigen: 'True', Konfigurationsdomänencontroller: 'dc1.firma.ads', Bevorzugter globaler Katalog: 'dc1.firma.ads', > Bevorzugte Domänencontroller: '{ dc1.firma.ads }'
[11.24.2011 18:48:48.0392] [2] Beginning processing install-ExchangeSchema -LdapFileName:'Setup\Data\PostExchange2003_schema36.ldf'
[11.24.2011 18:48:48.0407] [2] Running <C:\Windows\system32\ldifde.exe> with arguments <-i -s "dc1.firma.ads" -f "C:\Windows\Temp\ExchangeSetup\Setup\Data\PostExchange2003_schema36.ldf" -j "C:\Users\Adminmeister\AppData\Local\Temp" ->
c "<SchemaContainerDN>" "CN=Schema,CN=Configuration,DC=firma,DC=ads">.
[11.24.2011 18:49:28.0486] [2] Process C:\Windows\system32\ldifde.exe finished with exit code 0.
[11.24.2011 18:49:28.0486] [2] Ending processing install-ExchangeSchema

Im selben Log der Testumgebung kommen da noch zig Einträge (bis schema99.ldf....)

Eine Fehlermeldung wird aber, wie man sieht nicht geloggt, das Skript scheint noch irgendwie weiter zu laufen ...?!?!?

Ein Blick in das Ereignisprotokoll am Domänencontroller DC2 (im DC1 steht nichts dergleichen!) ergab, das etwas später, nachdem das prepareschema gestartet wurde, mehrere Warnungen NTDS GENERAL 1153 "DS-Schema" stehen mit dem Text "Die folgende Schemaklasse hat eine ungültige Superklasse" , google führte mich hierhin http://support.microsoft.com/kb/307323/en-us , evtl. hat das was zu tun mit dem gleichzeitig im Log vermerkten Neuaufbau von einige Indizes im AD....

Hat jemand eine Idee, was zu tun ist? Kann ich das "setup /prepareschema" gefahrlos abbrechen, und erneut ausführen? Oder zerhaue ich mir damit komplett mein AD?

Schon mal vielen Dank für eure Tipps,

AdminKnecht
Mitglied: AdminKnecht
25.11.2011 um 17:05 Uhr
OK, danke den Lesern für's lesen, aber ich habe etwas recherchiert und dabei mehrmals den Hinweis gelesen, das z.B. ein abgebrochenes /ADPREP problemlos (?) zu wiederholen ist...

Das habe ich dann auch gemacht, und siehe da------- nun sind die setup /prepareXYZ-Geschichten erledigt und der Installation des EX2010 am Wochenende steht nichts mehr im Wege!

Der AdminKnecht
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Notebook & Zubehör
Laptop hängt nach Windows 10 Update (1)

Frage von Markowitsch zum Thema Notebook & Zubehör ...

Server-Hardware
gelöst Supermicro 813-4 Server - hängt bei Neustarts (4)

Frage von NetzwerkDude zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...