Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Schlechte Netzwerkperformance unter Virtual Server 2005

Frage Microsoft Windows Server

Mitglied: 2P

2P (Level 2) - Jetzt verbinden

18.01.2009, aktualisiert 14:36 Uhr, 4428 Aufrufe, 9 Kommentare

Hallo,

ich experimentiere zur Zeit mit MS Virtual Server herum.
Dabei ist mir die extrem schlechte Netzwerkperformance aufgefallen.
Auf den Hostrechnern sind jeweils Gigabit Netzwerkkarten installiert.
Zwischen beliebigen PC´s und den Hostrechnern erreiche ich auch Transferraten von 50-60 MByte/s - völlig akzeptabel.
Zu den darauf laufenden virtuellen Rechnern erreiche ich allerdings lediglich Transferraten von 7-9 MByte/s - das ist ziemlich inakzeptabel.
Ist das normal oder hab ich irgend etwas übersehen?

MfG

2P
Mitglied: DerWoWusste
18.01.2009 um 16:07 Uhr
Ins Blaue geraten: Du verwendest für die Messung eine große Datei, die Du auf die virtuelle Installation schiebst. Gleichzeitig ist die Festplatte der virtuellen Installation nicht vorallokiert, also deren Performance deutlich vermindert - kann das angehen? Das würde zumindest eine niedrigere Übertragungsrate erklären, vielleicht nicht so niedrig, aber deutlich geringer als 50-60 MB.
Oder: wie wurde denn die virtuelle Netzwerkkarte erkannt? als 100 MBit? Dann wären 7-9 MB im grünen Bereich. Auch wenn Gigabit: bei einem ungünstigen virtuellen Treiber kann kann man so schlechte Raten haben, bei Gigabit hab ich schonmal 13 MB/s gesehen, und da bremsten nicht die Platten.
Falls beides nicht hilft, miss noch einmal mit diesem netio hier, das misst nur den Netzwerkverkehr, ohne eine Festplatte zu benutzen. http://www.ars.de/ars/ars.nsf/docs/netio
Bitte warten ..
Mitglied: wiesi200
18.01.2009 um 16:10 Uhr
Ja, denn Virtual Server verwendet ja nicht die echte Hardware sondern eine Virtuelle und soweit ich weiß wird nur eine 10Mbit karte emuliert.
Bitte warten ..
Mitglied: DerWoWusste
18.01.2009 um 16:12 Uhr
Huihui, und die schafft dann 7-9 MB/s? Sehr sportlich für 10 MBit.
Bitte warten ..
Mitglied: DerWoWusste
18.01.2009 um 16:16 Uhr
Es kann auch ganz simpel sein, dass Du eine Datei verschiebst und die Platte nicht hinterherkommt, denn sie muss von der selben Platte (falls die VMs auf der selben Platte liegen) lesen und gleichzeitig schreiben, da sind solche Werte durchaus möglich. Dies ist ja anders, wenn Du übers echte Netzwerk schreibst, da wird nicht gleichzeitig gelesen und geschrieben.
Bitte warten ..
Mitglied: 2P
18.01.2009 um 16:26 Uhr
Hi,

erst einmal besten Dank für die Antworten.
Die Übertragungsrate habe ich mit netio und jperf ermittelt.
Meines Wissens nach emuliert VS zwar eine virtuelle 100MBit Netzwerkkarte nutzt aber tatsächlich die lokal vorhandene. Diese Info ist allerdings "Hörensagen" - konnte bisher noch nicht eruiert werden.
Bei VMWare verhält es sich zumindest auch so. Dort wird eine 10MBit Karte emuliert aber man erreicht dennoch annährend die Transferraten der Hostkarte.
Ich kopiere auch keine Daten auf der selben Platte.
Die VM´s laufen auf einem eigenen Plattenverbund und ich greife von gänzlich anderen Clientrechnern auf die VM´s zu.

Wie sieht das denn bei euch aus? Sind die Transferraten da genauso niedrig?

MfG

p.s. Zum besseren Verständnis. Ich arbeite mit einem tatsächlich physisch vorhandenem Netzwerk. Nur die Server sind virtualisiert. Wobei die Hostrechner noch lang nicht ausgelastet sind.
Bitte warten ..
Mitglied: DerWoWusste
18.01.2009 um 16:36 Uhr
Was VS 2005 emuliert, kannst Du doch leicht ablesen. Sind es 100 MBit, ist das ziemlich normal. Die Gigaitkarte wird dann nicht schneller angesprochen. Nebenbei: wo wird in vmware eine 10-MBit-Karte emuliert? Nicht bei mir, da ist es Gigabit.
Bitte warten ..
Mitglied: 2P
18.01.2009 um 16:40 Uhr
Ältere VMWare Version - ohne den aktuelleren vmxnet-Treibern.
Bitte warten ..
Mitglied: DerWoWusste
18.01.2009 um 16:51 Uhr
Schon klar, aber ich bestreite Deine Aussage
Dort wird eine 10MBit Karte emuliert aber man erreicht dennoch annährend die Transferraten der Hostkarte
Bestimmt nicht. Die Rate wird die einer 10er sein.
Somit scheint mir, Deine virtuelle Karte ist schlicht eine 100er und das ist es.

Ich kann Dir leider keinen Vergleich bieten ohne VS.
Bitte warten ..
Mitglied: 2P
18.01.2009 um 17:23 Uhr
Nö - ist schon mittelmäßiges Gigabit (25MByte/s).

Trotzdem besten Dank.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Hyper-V
gelöst Virtual Lab Windows Server 2012 R2 Hyper-V (3)

Frage von DaPedda zum Thema Hyper-V ...

Windows Server
gelöst Update von sql server express 2005 sp4 auf 2008 klappt nicht (11)

Frage von jhaustein zum Thema Windows Server ...

Windows Server
DHCP-Server vor Änderung schützen (1)

Frage von cuilster zum Thema Windows Server ...

Windows Server
"Do you trust this printer" bei jedem Druck von Citrix via Server 2k8 R2 (2)

Frage von diematrix125 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...