Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SCSI Raid Treiber für Windows-XP Installation auf IBM e-Server xSeries 346 8840-01Y

Frage Linux

Mitglied: CKbeats

CKbeats (Level 1) - Jetzt verbinden

24.02.2011, aktualisiert 22:18 Uhr, 7378 Aufrufe, 11 Kommentare

Kann Windows XP Professional nicht installieren, da XP Installation den SCSI Treiber nicht integriert hat und Treiberintegration fehlschlägt.

Hallo zusammen,

habe ein riesengroßes Problem mit dem ich seit Stunden nicht voran komme.

Möchte bei uns den alten Dell Server durch einen IBM e-Server xSeries 346 8840-01Y ersetzen.
Da das Domaincontrolling, Filserver und Mailserver durch ein anderes System bereitgestellt wird muss dieser Server kein Serverbetriebssystem haben.

Die zu installierende Datenbanksoftware (Borland Interbase) und Key-Dienste können problemlos auf XP laufen. Den Server könnte ich dann sogar in die Domain integrieren.

Problem ist, dass ich kein Betriebssystem zum Laufen bekomme.
Der Treiber für den Adaptec SCSI / RAID Controller liefert XP nicht mit.

RAID ist voll konfiguriert und einsatzbereit.
XP Installation meldet aber, dass keine Festplatte erkannt werden konnte.

Die Installation eines SCSI Treibers von einem Drittanbieter klappt auch nicht, da ich kein Diskettenlaufwerk habe.

Nun wollte ich per XP-Iso-Builder den Treiber integrieren.
Problem ist, dass bei der ISO-Imageerstellung eine Fehlermeldung kommt, dass Verzeichnisse und Dateien nicht gefunden werden können.
Anscheinend verweist die txtsetup.oem der heruntergeladenen Treiber von IBM auf nicht vorhandene Dateien.

Wenn ich das erstellte Image booten lasse lädt das Setup bis genau an die Stelle, an der die Dateien fehlen.
Das Setup bricht ab.

Ich bin total am verzweifeln. Keine Ahnung mehr, wie ich die Maschine noch zum Laufen bringen soll.

Vielleicht weiß jemand einen guten Rat!
Dafür bin ich unendlich dankbar.

Dachte in einer Stunde bin ich fertig und kann die Betriebssoftware installieren.
Aber nichts da - ich habe noch nicht einmal ein lutschiges XP aufgespielt.
Mitglied: loonydeluxe
24.02.2011 um 23:28 Uhr
Hallo CKbeats,

am einfachsten ginge ein USB-Diskettenlaufwerk (falls sich so was finden lässt). Oder klau einem älteren Rechner das Floppy Im Prinzip kannst du das aber auch mit nLite machen (beachte bitte eventuelle Probleme, die durch nLite auftreten können, z. B. dass einige Pfade verbogen werden, wenn es z. B. ans syspreppen geht).

Ich glaube, ich hatte mal einen xSeries 346 in Händen, bei dem die Maschine von VMWare aufs Blech gezogen werden sollte und wo ebenfalls die txtsetup.oem fehlerhaft war (ich lege mich aber nicht aufs genau xSeries Modell fest).
Such dir mal die txtsetup.oem und die eigentliche .inf raus. In einem der ersten Abschnitte beider Dateien stehen die jeweils benötigten Dateien. Such dir diese Dateien aus dem entpackten Archiv zusammen, schau im Netz nach eventuell fehlenden Dateien und werfe alle Dateien in ein Verzeichnis. Falls eine Datei nur falsch benannt sein sollte (nur bei offensichtlichen Fehlern!), benenne die Datei entsprechend um. Entferne aus der .inf und der txtsetup.oem die Pfade, so dass die Dateien im aktuellen Verzeichnis der inf/oem gesucht werden. Danach sollte der Treiber sowohl mit nLite integrierbar als auch von Diskette verwendbar sein.

Falls du kannst, kannst du das OS auch erstmal auf eine ATA-Platte mit Standard-IDE-Treiber installieren. Anschließend kannst du im laufenden OS den Storage-Treiber installieren und dann mit Ghost, ImageX oder was da ist die Platte imagen bzw. direkt auf dein RAID klonen. Falls du den Treiber lieber offline integrieren möchtest, kannst du mit einem WinPE/ERDCommander, DriverInjection (und zugehörig language.ini und devcon.exe) versuchen, den Treiber ins Offline-System zu integrieren und dann zu klonen.

Grüße, loonydeluxe

edit: Schreib am Besten mal, welchen Controller du tatsächlich einsetzen willst (Hersteller, Modell, sowie Hersteller- und Geräte-ID, wenn du hast) und welches Treiberpaket du heruntergeladen hast, damit das nachvollzogen werden kann.
Bitte warten ..
Mitglied: vossi31
25.02.2011 um 09:20 Uhr
Hallo CKbeats,

mag ja sein, dass man das irgendwie hinkriegt, aber laut dieser Info können auf der Maschine ja nur Server-Betriebsysteme laufen.

http://www.ws-datenservice.de/media/files/Produkte/IBM%20Broschueren/IB ...

Gruß
Bitte warten ..
Mitglied: CKbeats
25.02.2011 um 10:20 Uhr
Hallo vossi31,
vielen Dank für den Hinweis.
Ich habe noch eine alte Win2k Server-CD herum liegen. Auch hier ist der Treiber nicht implementiert.
Ich hoffe, dass Du unrecht hast. Sonst sehe ich alt aus
Lt. IBM-Supportsite sind auch viele Treiber für diese Maschine unter WinXP 32- und 64-bit Version erhältlich.
Habe keinen direkten Hinweis gefunden, ob das System nur mit Serverbetriebssystemen funktioniert.

Werde heute Abend mal in aller Ruhe die Vorschläge von loonydeluxe ausprobieren.
Mal schauen, irgendwo ist noch ein USB Diskettenlaufwerk. Dann brauche ich nur noch ein paar Disketten
Ansonsten danke für den Tip mit der Pfadänderung der txtsetup.oem.
Das probiere ich doch gleich mal aus, ob ich die nicht verbieten kann.

Melde mich wieder und gebe auch die genauen RAID-Controllerdaten durch!

Euch allen vielen Dank für die schnelle und kompetente Hilfe!

Grüße
Constantin
Bitte warten ..
Mitglied: Jochem
25.02.2011 um 11:03 Uhr
Moin,
also laut Serial-Number 346 8840-01Y kannst Du auf dem System u.a. Windows ab NT installieren (siehe Support-Seite für xSeries 346)

Und Hier findest Du die zu dem System und XP passenden Treiber. Demnach sollte ein Adaptec Ultra320 SCSI-Controller verbaut sein. Und den Support für das Raid-System findest Du ebenfalls dort.

Laut Users Guide gibt es für das Gerät sogar ein Slimline-Floppy ,welches über dem (Slimline) CD-ROM Laufwerk eingebaut werden kann.

Gruß J chem
Bitte warten ..
Mitglied: CKbeats
25.02.2011 um 18:43 Uhr
Hi Jochem,
danke für die Info. Das Slimline Flopppy und ein Slimline DVD-Rom sind verbaut.
Bloß muss ich ja die Daten zuerst auf so eine miese kleine Disk bringen
Habe nun ein USB-Floppy.
Jetzt brauche ich nur noch eine Disk selbst.
Die, die ich aus der Versenkung holte waren so alt, dass sie nicht mehr bespielbar waren.
Bis morgen habe ich welche da, dann geht's ran!

Dir auch vielen Dank für den Support!
Hoffe, dass ich nun weiter komme!
Wenn XP läuft gibt's ein riesengroßes Dankeschön an alle!
Bitte warten ..
Mitglied: loonydeluxe
25.02.2011 um 20:28 Uhr
Welchen Servicepack-Stand hat eigentlich deine XP-CD?
Bitte warten ..
Mitglied: CKbeats
25.02.2011 um 20:58 Uhr
Die eine CD hat Service Pack 3, die andere SP1a.
Leider hat die mit SP3 einen Kratzer, daher werde ich wohl die mit SP1 nehmen müssen.
Warum?
Bitte warten ..
Mitglied: loonydeluxe
25.02.2011 um 21:07 Uhr
Beim SP2 gabs nochmal Verbesserung bei der Unterstützung von Speichergeräten. Du kannst das SP2 oder SP3 in eine beliebige Windows-CD integrieren (entweder über die Kommandozeile oder mit nLite - es wird jeweils nur das SP-Setup mit Parametern aufgerufen), dann hast du eine aktuelle CD.
Weitere Updatepacks solltest du nur im Ausnahmefall integrieren (etwa .NET-Updatepacks, IE-Updates, ...), da dadurch spätere Updates fehlschlagen können. Installiere die Updates hinterher über das Windows Update/WSUS.
Bitte warten ..
Mitglied: CKbeats
03.03.2011 um 15:11 Uhr
Hallo zusammen,

möchte noch schnell meine positive Rückmeldung abgeben und mich für die schnelle Hilfe bedanken.
System läuft nun, habe es wie loonydeluxe vorschlug gemacht.
Treiber für den SCSI Adapter auf Diskette, in die XP Installation manuell geladen und siehe da - die SCSI Platten wurden erkannt.
Leider klappte das erst, nachdem ich die Array-Konfiguration wieder herunter genommen habe.
Das habe ich einfach nicht hinbekommen, dass er bei einer RAID-0 Config die Platte erkennt.

Nach der Installation von SP2 wurden auch die letzten unbekannten Geräte vollständig installiert und vom System erkannt.
Nun sind alle Updates drauf, System rennt ohne Vergleich. Die beiden 2-kernigen Prozessoren "rupfen die Wurst vom Brot"!
Datenbank läuft so was von schnell.
Beim Starten dauert es etwas länger, da das System anscheinend - dank des großzügigen RAM's - die komplette Database in den Speicher lädt. Aber dann... wenn's mal läuft...

Überlege nun irgendwann 2 weitere Platten zu kaufen, um jeweils über den RAID-Controller jede Platte für sich einzeln zu spiegeln.
Bin mir noch nicht sicher wegen der Umsetzung, da ich mit RAID wenig Erfahrung habe.

Vielleicht darf ich dann wieder auf Eure Hilfe zurück kommen?!

So long!
Grüße
Constantin
Bitte warten ..
Mitglied: loonydeluxe
03.03.2011 um 19:31 Uhr
Hallo,

RAID 0 würd ich dir für ein Produktiv-System nicht empfehlen, weil: wenn 1 Platte stirbt, ist das ganze System hin.

Konsultier vor dem Umstellen auf ein RAID 1+0/10 unbedingt das Manual ob das auch nachträglich noch geht. Du solltest *unbedingt* vor einem solchen Eingriff ein Komplettbackup (--> ntbackup) erstellen. Da nicht jede DB einen VSS-Provider bietet, solltest du die entsprechenden DB-Dienste vor dem Backup beenden, damit die Datendateien fehlerfrei gesichert werden.
Erstell in NTBackup noch eine ASR-Disk (Extras --> Assistent für die automatische Systemwiederherstellung) für eine evt. Neuinstallation des Betriebssystems. Dafür brauchst du wieder einmal ein Floppy-Laufwerk.

Grüße, loonydeluxe
Bitte warten ..
Mitglied: CKbeats
04.03.2011 um 09:50 Uhr
Guten Morgen!
Danke für die Infos!
Bei diesem System ist mir eine Redundanz eher zweitrangig.
Über CMD-Skripte wird jede Nacht der Datenbankdienst beendet, die komplette Datenbank auf den Sicherungsserver geschaufelt und von dessen Platten auf Band gesichert.
Sollte wirklich das System absterben oder eine der Platten hops gehen wäre das nicht schlimm, da ich ja noch den alten voll konfigurierten Server dastehen habe.
Die Borland Datenbank lässt sich, wenn die Dienste offline sind, einfach überschreiben. Nach dem Dienststart läuft er dann mit der neuen Datenbank.
Daher ist mir das noch nicht "so" wichtig.
Aber den Hinweis mit der nachträglichen Erstellung eines Raid 1 werde ich auf jeden Fall beachten!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Installation
gelöst Fehlermeldung bei Installation mit Windows XP (7)

Frage von bestelitt zum Thema Windows Installation ...

Hyper-V
gelöst Bestehende XP-Installation mit Hyper-V virtualisieren (30)

Frage von fox14ch zum Thema Hyper-V ...

Windows XP
gelöst WPA2 unter Windows XP SP1 nutzen? (10)

Frage von bestelitt zum Thema Windows XP ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...