Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Diese Seite enthält ein nicht genauer spezifiziertes, mögliches Sicherheitsrisiko

Frage Microsoft

Mitglied: ako673de

ako673de (Level 1) - Jetzt verbinden

16.10.2010 um 12:12 Uhr, 8267 Aufrufe, 3 Kommentare

Vorweg: Nach Mapping eines Shares meiner NAS (und geeigneten Konfigurationsmassnahmen in den Sicherheitseinstellungen der "Interneteinstellungen") sehe ich im Explorer von WinXP-SP3 (rechts unten in der Statusleiste), dass der Inhalt dieses Netzlaufwerks in der Intranet-Zone liegt.

Also alles super? Nein! Denn jetzt biege ich die "Eigenen Dateien" auf das Verzeichnis "Eigene Dateien" auf dem gerade verbundenen Netzlaufwerk um (danach immer noch alles super: "Eigene Dateien" sind noch in der Intranet-Zone) und starte den Rechner neu.

Nach dem Neustart kommt jetzt beim ersten Öffnen von "Eigene Dateien" die im Betreff genannte Meldung. Egal, wie ich die wegklicke, kommt sie nur dieses eine mal pro Neustart, aber permanent bleibt, dass "Eigene Dateien" immer als in der Internet-Zone befindlich angezeigt wird. Und nicht nur "Eigene Dateien" sondern auch alle anderen Inhalte dieses Shares! Ich habe zwei Shares auf der NAS, und beiden ist ein Netzlaufwerk zugeordnet, aber nur der Share mit den "Eigenen Dateien" ist betroffen.

Biege ich "Eigene Dateien" wieder zurück und starte neu ist das Problem wieder verschwunden.

Workaround: Das Problem tritt gar nicht erst auf, wenn beim Umbiegen von "Eigene Dateien" anstatt des Netzlaufwerkbuchstabens der Sharename angegeben wird. Das bringt aber andere Probleme mit sich:
- Keine Möglichkeit sich unter anderem Namen an der NAS anzumelden (die NAS kann keine Blanks im Usernamen )
- Manche Programme (wohl unsauber programmiert) akzeptieren keine "\\" im Pfadnamen von "Eigene Dateien" und legen ihre Daten dann im besten Fall unkontrollierbar irgendwo ab oder stürzen einfach ab

=> Das ist keine Lösung!

Ich wäre sehr dankbar, wenn der Mist irgendwie abgeschaltet werden könnte (ich habe noch einen anderen XP-Rechner, der das Problem nicht zeigt, wohl weil da seit SP3 keine Updates mehr drauf gekommen sind) oder jemand eine Lösung kennt.

Grüsse
ako673de
Mitglied: 60730
16.10.2010 um 14:01 Uhr
Zitat von ako673de:
Vorweg:

Ein Hallo oder Guude wie schadet keinem, außer dem der es wegläßt.

- Keine Möglichkeit sich unter anderem Namen an der NAS anzumelden (die NAS kann keine Blanks im Usernamen )
  • wtf blankt im Usernamen?
- Manche Programme (wohl unsauber programmiert) akzeptieren keine "\\" im Pfadnamen von "Eigene Dateien" und
legen ihre Daten dann im besten Fall unkontrollierbar irgendwo ab oder stürzen einfach ab

=> Das ist keine Lösung!

So sehe ich deinen Ansatz auch!

Ich wäre sehr dankbar, wenn der Mist irgendwie abgeschaltet werden könnte (ich habe noch einen anderen XP-Rechner, der
das Problem nicht zeigt, wohl weil da seit SP3 keine Updates mehr drauf gekommen sind) oder jemand eine Lösung kennt.

Den "Mist" hast du dir doch selber eingebrockt - manches - was früher nur Insidern bekannt war, wurde von fiesen Insidern missbraucht und deswegen wurden diese "Lücken" durch Flickenteppiche aus Redmont wieder ausgebügelt.

Hat du eine klitschkokleine Idee, welche Funktion sich eigentlich hinter "eigene Dateien umbiegen" verbirgt?
Mach dich erstmal schlau darüber und dann motze über den Mist weiter

Einfach nur ein zeitgesteuertes Backup der eigenen Dateien auf das Nas ist 1.0001 * Sinniger, die Ordernerstruktur eigene Dateien überhaupt nicht zu nutzen 1.0002* schlauer.

Gruß
Bitte warten ..
Mitglied: ako673de
17.10.2010 um 12:13 Uhr
Guten Tag verehrte Gemeinde, ich mag zwar die Anrede vergessen haben, aber bitte seht davon ab solch unproduktive Kommentare zu verfassen, da dadurch ein aus meiner Sicht durchaus wertvoller Thread nur zu einem Haufen Müll verkommen würde.

Ich glaube nicht, dass ich jemanden, der mich fragt, warum sein Auto nicht fährt, als erstes fragen würde, warum er fahren will. Mehr will ich dazu gar nicht sagen.

Aber noch einmal zum Kern des Themas (falls das nicht 100% rüber gekommen ist): Redmont mag Sicherheitslücken geschlossen haben mit der Eingruppierung in unterschiedliche Zonen, aber das ist doch gar nicht das Thema! Ich kann schliesslich das Verzeichnis "Eigene Dateien" per *übrigens völlig legaler* Umleitung (Desktopsymbol von "Eigene Dateien" -> Eigenschaften -> Ziel -> Verschieben -> Übernehmen) versetzen, ohne dabei aus der Intranetzone zu fliegen. Ich darf als Ziel für diese Umleitung allerdings keinen Netzwerklaufwerksbuchstaben verwenden (z.B. "F:\Eigene Dateien") sondern nur UNC-Pfade (z.B. "\\nas\share\Eigene Dateien").

Und genau das ist für mich definitiv ein Bug! Das hat nichts mit Sicherheit zu tun, denn der hinter dem Laufwerksbuchstaben stehende Share ist ja per Definition schon in der Intranetzone, warum sollte es also der vorangestellte Laufwerksbuchstabe nicht mehr sein?

Verzeiht mir daher bitte, dass ich diesen "Mist" abschalten will, der offenbar kaputt gebugfixt worden ist seit dem Original-Release des SP3.

Zitat von 60730:
Hat du eine klitschkokleine Idee, welche Funktion sich eigentlich hinter "eigene Dateien umbiegen" verbirgt?
Was genau meinst Du? Wozu muss ich was über Details einer Funktion wissen, die dokumentiert ist und sich bis auf diesen einen Fall auch korrekt verhält?
...die Ordernerstruktur eigene Dateien überhaupt nicht zu nutzen 1.0002* schlauer.
Was genau meinst Du damit?

Grüsse
ako673de
Bitte warten ..
Mitglied: ako673de
20.10.2010 um 21:51 Uhr
Ich hab zufällig eine Lösung gefunden! (ich musste nämlich das Öffnen meiner Arbeitsplatzfenster scripten, da es Probleme gibt, wenn die beim Hochfahren automatisch geöffnet werden sollen, während noch keine Netzwerkverbindung besteht):

Nochmal das Verhalten ohne: Wenn das erste Öffnen eines Arbeitsplatz-Fensters über das "Computer"-Symbol auf dem Desktop (oder in meinem Fall eine Verknüpfung darauf, die sich im Autostart-Ordner befindet) stattfindet, dann landet (der umgeleitete) "Eigene Dateien"-Ordner und das gesamte Netzwerklaufwerk, das "Eigene Dateien" beherbergt, in der Internetzone.

Wenn ich aber das erste Öffnen des Arbeitsplatzfensters durch eine Verknüpfung realisiere, die %WinDir%\explorer.exe /n, ::{20D04FE0-3AEA-1069-A2D8-08002B30309D} ausführt (was eigentlich exakt das Gleiche macht wie das Klicken auf das "Computer"-Symbol auf dem Desktop!), dann haben dieses und alle später geöffneten Arbeitsplatzfenster das Internetzone-Problem nicht mehr!

Für mich ist das erst einmal eine zufriedenstellende Lösung, aber ihr müsst doch zugeben, dass da definitv ein Windows-Bug dahinter steckt.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...