Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

seltsames Verhalten beim Routen mit Suse10.1

Frage Linux Suse

Mitglied: 15187

15187 (Level 2)

14.01.2007, aktualisiert 18:41 Uhr, 2971 Aufrufe, 1 Kommentar

tracen ohne Ergebnis, aber ping und restliches Netzwerk geht - wie das?

Hallo,

mein Suse10.1 hat die Aufgabe, Router zu sein. Dafür gibt es 3 Netzwerkkarten:

1. DEV_EXT -> feste 195er IP
2. DEV_INT -> 192.168.100.1
3. DEV_DMZ -> 10.0.0.1 (noch ohne Funktion)

hinter diesem Router hängt ein ipcop, der mit seiner ROTEN Karte auf die 192.168.100.2 hört. DEV_INT und ROT sind per Crossover-Kabel verbunden.

Ursprünglich basiert die Frage auf dem Problem, dass ich den Router nicht dahingehend konfiguriert bekomme, dass VPN (egal, ob PPTP oder L2TP) reingeroutet wird. Zunächst wollte ich PPTP, aber alle Versuche, GRE geroutet zu bekommen, scheiterten. Daher wollte ich nun L2TP probieren, da hier "nur" UDP-Pakete geroutet werden müssen, die Konfig der SuseFirewall2 das also einfach ermöglichen sollte. Auch das scheiterte.

Nun das Problem, welches ich dahinter vermute, oder sehe:
Wenn ich von Suse aus den ipcop anpinge, erhalte ich Antwort. Trace ich das ganze, seh ich nur Sternchen. Wie kann das denn sein?
Müßte ich nicht in der Ablaufverfolgung wenigstens den einen Eintrag (192.168.100.2) sehen?

Hier mal die Route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.1 * 255.255.255.255 UH 0 0 0 wlan0
195.243.14.128 * 255.255.255.128 U 0 0 0 wlan0
192.168.100.0 * 255.255.255.0 U 0 0 0 eth0
link-local * 255.255.0.0 U 0 0 0 eth0
10.0.0.0 * 255.0.0.0 U 0 0 0 eth1
loopback * 255.0.0.0 U 0 0 0 lo
default 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0


Das merkwürdigste daran ist, route ich Port 80 per Masqerade rein, komme ich auf den entsprechenden test-webserver in meinem LAN.
Daher dachte ich zuerst an das Problem, dass GRE-Routing nicht funktioniert.
Jetzt geht aber L2TP auch nicht (UDP 500 und 1701).
Und dass tracing nun auch nicht will, macht mich stutzig... hat jemand mal nen guten Tipp für mich?

Danke schonmal vorab
Gruß, tc

EDIT 1: Bevor es irritiert: wlan0 ist mein Internetzugang per Richtfunk, und mein für's Internet benötigter GW ist tatsächlich 192.168.1.1
Fragt bitte nicht, es ist halt so... ich kann ja auch nix dafür... Übrigens kann ich mich mit nem Laptop an der DEV_DMZ 10.0.0.1 anklemmen, diese auf DEV_EXT umstellen und das Verhalten der Suse-Kiste so testen, als käme ich von außen.
Mitglied: 15187
14.01.2007 um 18:41 Uhr
Lösung zum tracerouten: Port 33434 UDP auf ipcop freigeschaltet - damit gehts erst mal

VPN weiterhin unklar...
Bitte warten ..
Ähnliche Inhalte
Drucker und Scanner
Ein Druckserver verhält sich seltsam?! (7)

Frage von Y3shix zum Thema Drucker und Scanner ...

SAN, NAS, DAS
gelöst Seltsames Verhalten zwischen Qnap und Veeam (6)

Frage von FFSephiroth zum Thema SAN, NAS, DAS ...

CPU, RAM, Mainboards
gelöst Seltsames Verhalten vom Netzteil (14)

Frage von FFSephiroth zum Thema CPU, RAM, Mainboards ...

Windows 10
Win10-Server2008 Offlinedateien seltsames Verhalten

Frage von Elgered zum Thema Windows 10 ...

Neue Wissensbeiträge
Sicherheit

How I hacked hundreds of companies through their helpdesk

Information von SeaStorm zum Thema Sicherheit ...

Erkennung und -Abwehr

Ccleaner-Angriff war nur auf große Unternehmen gemünzt

(10)

Information von Lochkartenstanzer zum Thema Erkennung und -Abwehr ...

Sicherheit

Eventuell neue Lücke in Intels ME

Information von sabines zum Thema Sicherheit ...

Heiß diskutierte Inhalte
Humor (lol)
Freidach Beitrag (32)

Frage von Penny.Cilin zum Thema Humor (lol) ...

Lizenzierung
Programm soll in verschiedenen Versionen lizenziert sein (20)

Frage von Yanmai zum Thema Lizenzierung ...

Windows 7
SSD - Win7 Lags (19)

Frage von ph5555 zum Thema Windows 7 ...

Humor (lol)
Wo ist der Fehler auf dem Bild? (17)

Information von the-buccaneer zum Thema Humor (lol) ...