Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sendkey in einer CMD ist fehlerhaft, brauche einen Rat!

Frage Entwicklung Batch & Shell

Mitglied: cyprian

cyprian (Level 1) - Jetzt verbinden

02.09.2011, aktualisiert 15:47 Uhr, 4188 Aufrufe, 6 Kommentare

Hallo,

ich möchte eine cmd schreiben, mit der ich eine partition formatiere und den befehl "enter" mit sendkey realisiere...

anschließend soll der remount J: H: ausgeführt werden:

Format J: /FS:FAT32 /Q /V:Extern
sendkey #VK_RETURN
remount J: H:

nach der ersten Zeile kommt folgendes:

C:\>Format J: /FS:FAT32 /Q /V:Extern
Legen Sie eine neue Diskette in Laufwerk J: ein,
und drücken Sie die EINGABETASTE.

Der Befehl sendkey #VK_RETURN wird übersprungen...ich muss die ENTER Taste drücken, damit es weitergeht....

Der Typ des Dateisystems ist FAT32.
Formatieren mit Schnellformatierung 3819 MB
Die Dateizuordnungstabelle (FAT) wird initialisiert...
Formatieren beendet.

3.997.700.096 Bytes Speicherplatz auf dem Datenträger insgesamt
3.997.696.000 Bytes auf dem Datenträger verfügbar

4.096 Bytes in jeder Zuordnungseinheit
976.000 Zuordnungseinheiten auf dem Datenträger verfügbar

32 Bits in jedem FAT-Datensatz.

Volumenummer: 742E-54C7

C:\>sendkey #VK_RETURN

C:\>remount J: H:
ReMount V1.3.1 (Win32) - remounts a volume from one mount point to another
Freeware by Uwe Sieber - www.uwe-sieber.de
ReMount J:\ ->H:\
success

Kann mir jemand helfen, die syntax wird sicherlich falsch sein...

lg cyprian

p.s. sendkey.exe und die remount.exe befindet sich im %windir%
Mitglied: 60730
02.09.2011 um 15:52 Uhr
moin,

eigentlich macht man(n) das ja so...
01.
echo j|Format J: /FS:FAT32 /Q /V:Extern
Nur was du mit dem Remount hast?
Das war eine Frage, die eine Antwort nett findet
Bitte warten ..
Mitglied: cyprian
02.09.2011 um 15:57 Uhr
alles klar, funktioniert
remount: Laufwerksbuchstabe soll umbenannt werden...

diese cmd soll in eine unattended winxp integriert werden...
Bitte warten ..
Mitglied: cyprian
02.09.2011 um 19:40 Uhr
hallo,


hab noch eine frage...
wenn ich cmd über start/ausführen/ starte und die fertige format.cmd mit folgenden Inhalt per drag & drop reinschiebe, dann funktioniert es...

echo j|Format D: /FS:FAT32 /V:Daten

Wenn ich aber die format.cmd per doppelklick starte, dann öffnet sich zwar die konsole, läuft aber in einer endlosschleife...
wo ist der fehler??

cyprian
Bitte warten ..
Mitglied: Biber
02.09.2011 um 20:13 Uhr
Moin cyprian,

du kommst allein auf den Fehler, wenn ich dich mal zitiere:
wenn ich cmd über start/ausführen/ starte und die fertige format.cmd mit folgenden Inhalt per drag & drop reinschiebe, dann funktioniert es...
echo j|Format D: /FS:FAT32 /V:Daten


Entweder du schreibst in den Aufruf "echo j|Format.exe D: /FS:FAT32 /V:Daten oder/und benennst die Format.cmd in mein4mat.cmd oder zumindest einen anderen Namen als bestehende CMD-Befehle.

Grüße
Biber
Bitte warten ..
Mitglied: cyprian
02.09.2011 um 20:48 Uhr
ohh man...danke, darauf wäre ich wohl nicht drauf gekommen
Bitte warten ..
Mitglied: 60730
03.09.2011 um 21:35 Uhr
Servus,

geh ich recht in der Annahme, das wir wieder einen Haken in Almond Green mehr in der Datenbank erwarten können?

Gruß
Bitte warten ..
Ähnliche Inhalte
Exchange Server
gelöst Exchange Server 2010 Emails aufbewahren? Brauche einen Rat (5)

Frage von phantasist zum Thema Exchange Server ...

Windows Installation
MDT 2013 Images Fehlerhaft

Frage von SebastianH zum Thema Windows Installation ...

Windows Server
Rat zu externen Dienstleister gesucht (8)

Frage von rocco61 zum Thema Windows Server ...

Batch & Shell
Mit ISO Datei CMD Befehle ausführen (15)

Frage von Alexsus zum Thema Batch & Shell ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (50)

Frage von sabines zum Thema Internet ...

Netzwerke
LAN2LAN Verbindung sehr langsam flaschenhals gesucht (27)

Frage von PixL86 zum Thema Netzwerke ...

Router & Routing
PFsense - Netzverbindung steht, aber kein Internet vorhanden (24)

Frage von aschmid zum Thema Router & Routing ...

Windows Server
gelöst Windows 2016 Hyper-V und VHDS (19)

Frage von emeriks zum Thema Windows Server ...