Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

sendusing -Konfigurationswert ist ungültig, finde das Problem nicht

Frage Entwicklung VB for Applications

Mitglied: CapitainC

CapitainC (Level 1) - Jetzt verbinden

13.05.2009, aktualisiert 15:31 Uhr, 8575 Aufrufe, 4 Kommentare

Danke für Eure HIlfe

Hallo,

möchte gern mit eine vbs Skript E-mails versenden.

Dim objEMail, body

Const sender = "lisa@server.de"
Const receiver = "empfaenger@server.de"
Const subject = "E-Mail-Versand ohne Client"
Const server = "smtp_mail.server.de"
Const user = "lisa@server.de"
Const password = "12345lisa"
Const schema = "http://schemas.microsoft.com/cdo/configuration/"

body = "Das ist der Text der E-Mail."

On Error Resume Next

Set objEMail = CreateObject("CDO.Message")
With objEMail
.From = sender
.To = receiver
.subject = subject
.Textbody = body
.AddAttachment "d:\test\blabla.doc"
With .Configuration.Fields
.Item(schema & "sendusing") = 2
.Item(schema & "smtpserver") = server
.Item(schema & "smtpserverport") = 25
.Item(schema & "smtpauthenticate") = 1
.Item(schema & "sendusername") = user
.Item(schema & "sendpassword") = password
End With
.Configuration.Fields.Update
.Send
End With

Set objEMail = Nothing
If Err.Number <> 0 Then
MsgBox Err.Number & vbCrLf & Err.Description
Else
MsgBox "Mail wurde erfolgreich versendet."
End If

On Error GoTo 0


Werte habe ich natürlich passend eingetragen, smtp Server kann ich mit einem normal E-mail Client auch normal benutzen.
Wenn ich diese Skript laufen lassen kommt leider immer immer der Fehler -21477220960 Der "sendunsing" -Konfigurationswert ist ungültig
Wie gesagt der SMTP Server ist erreichbar und kann auch mit einem E-mail Client normal genutzt. Bin ein bischen ratlos.

Danke für jeden HInweis.

Gruß Claus
Mitglied: LotPings
13.05.2009 um 16:26 Uhr
Hallo CapitainC,

es liegt nicht am Script (funktioniert hier an Hamster und Strato Accounts),
sondern an deinen Konfigurationsdaten.

Vielleicht braucht dein Smtp Server noch ein:
.Item (schema & "smtpusessl") = False ' oder true

Gruß
LotPings
Bitte warten ..
Mitglied: CapitainC
13.05.2009 um 18:05 Uhr
Zitat von LotPings:

Vielleicht braucht dein Smtp Server noch ein:
.Item (schema & "smtpusessl") = False '
oder true



Hallo,

habe true und false ausprobiert, auch mit anderem SMTP Server, gleicher Effekt, Fehler immer noch da
Bitte warten ..
Mitglied: CapitainC
13.05.2009 um 22:32 Uhr
Bin der Sache glaube ich ein bischen auf der Spur, ich glaube dass das Schema Const schema = "http://schemas.microsoft.com/cdo/configur" ...; nicht erkannt wird. Kann mir da einer helfen?

Danke und Gruß
Bitte warten ..
Mitglied: LotPings
13.05.2009 um 22:40 Uhr
In deiner Originalfrage oben steht es doch komplett drin und funktioniert auch so.
Hab ich so auch schon seit Jahren in Benutzung.

Die Darstellung wird wohl von der Forensoftware verkürzt.

Gruß
LotPings
Bitte warten ..
Ähnliche Inhalte
Windows Update
WSUS Problem, einige Clients ziehen keine Updates mehr (7)

Frage von Leo-le zum Thema Windows Update ...

LAN, WAN, Wireless
Problem mit W-LAN Einbindung bei UniFi AP-AC-Mesh (1)

Frage von mayli01 zum Thema LAN, WAN, Wireless ...

Windows 10
gelöst WLAN-Problem mit W10 (Home) 1703 15063.332 und Intel wireless AC-7260 (8)

Frage von keine-ahnung zum Thema Windows 10 ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Update
MS: Update-Server-Adressen OHNE Wildcards (16)

Frage von mrserious73 zum Thema Windows Update ...

Microsoft Office
+1.000 Ordner in Outlook: Wie besser? (10)

Frage von Matsushita zum Thema Microsoft Office ...

Router & Routing
gelöst Netzwerk am einfachsten trennen (8)

Frage von geheimagent zum Thema Router & Routing ...