Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Serverüberprüfung mit Kix - Pseudologonscript

Frage Entwicklung KiXtart

Mitglied: photographix

photographix (Level 1) - Jetzt verbinden

19.01.2009, aktualisiert 17:17 Uhr, 4883 Aufrufe, 4 Kommentare

Erstellung eines Systemweiten Logonscriptes OHNE eine Domäne

Hallo Leute,

da unsere Domäne noch eine ganze Weile auf sich warten lassen wird muss ich mir selbst ein paar Gedanken zu Deploy und Gruppenverwaltungsscripten machen.

Meine Idee war dahingehend das ich dies per KIX regeln will (kann ich ja dann in der Domäne auch nutzen).

Gedanke1:

Lokales "Pre" Script was abprüft ob der "Logonserver" mit dem Logonscript verfügbar ist.
Wenn Ja call logon.kix wenn nein bringe Meldung.

Konkret sieht das so aus bei mir:

01.
Break OFF 
02.
SetConsole("Hide") 
03.
FlushKB 
04.
 
05.
 
06.
 
07.
$kix="\logon.kix" 
08.
Use * /DELETE 
09.
Use Z: "\\server1\personal" /USER:Gast /Password:"" 
10.
?@RESULT 
11.
If Exist(@RESULT+$kix) = 1 
12.
	Call @result+$kix 
13.
Else 
14.
MessageBox( 
15.
"-----------------------------------------------------------------------------------------------------"+CHR(10)+CHR(10) + 
16.
"Der Anmeldeserver ist nicht erreichbar!"+ CHR(10) + 
17.
"Die Verarbeitung von Netzwerkscripten wird abgebrochen." +CHR(10)+ 
18.
"Es wurden keine Netzlaufwerke oder Netzwerkdrucker bereitgestellt." + CHR(10) +CHR(10) + 
19.
"Bitte die Verbindung zum internen Netzwerk prüfen."+CHR(10) + CHR(10) + 
20.
"Netzwerkkabel angeschlossen?    Neustart versucht?" + CHR(10) + CHR(10) + 
21.
"Sollte sich das Problem nicht lösen lassen bitte zeitnah an den Support wenden."+ CHR(10) + CHR(10) + 
22.
"-----------------------------------------------------------------------------------------------------" 
23.
,"Status Information - Logon Fehler - Der Anmeldeserver ist nicht erreichbar!",48,0)
Leider scheitere ich bei der Überprüfung des Servers. Wenn ich schon einmal am Server angemeldet war funktioniert es problemlos. Mit nur Userrechten komme ich nach einem frischen Neustart nicht auf den Server. Per Explorer lässt sich das Laufwerk problemlos mappen - dann funktioniert auch das Script.
Es ist ein Odner mit den Rechten "Jeder" darf alles ohne Passwort.

Jemand Ideen zu meinem Script - oder gibt es andere möglichkeiten dies umzusetzen?

LG
Mitglied: seTTembrinY
19.01.2009 um 17:14 Uhr
Hi,

mach die Connection zu Deinem Server vielleicht mal über DOS, also eine
shell 'cmd /c net use \\server\freigabe /user:xxx password'
Aber du kriegst auf jeden Fall ein Problem, wenn der DC dann da ist. Weil Du hast zu dem Server ja schon einen Share offen mit anderen Credentials.
Also würd ich ich Credential-Sache gleich rauslassen.
Und versuch dann nicht zu mappen, sondern machen nen "if file exist" auf irgendwas was in dem Share liegt...

HTH,
Sven
Bitte warten ..
Mitglied: 60730
19.01.2009 um 17:25 Uhr
Servus,

auf gar keinen Fall das Mappen via Explorer benutzen, damit sorgst du für zukünftige Probleme!

So, wie ich es sehe - liegt es daran, dass du einen Account ohne Passwort benutzt.

Benutze für das Kix mal einen Benutzer mit Passwort und sehe nach, ob ich nicht daneben liege.

Und in Batch sähe dein Preloginscript ungefähr so aus:

01.
if exist "\\server1\personal" call kix.exe logon.kix
Bitte warten ..
Mitglied: photographix
20.01.2009 um 16:36 Uhr
Hallo Timo,

ich bin nun über den Schritt 1 hinweg.

Das Script sieht nun so aus - sicher quick n dirty aber es geht so.

01.
if not exist "\\server1\personal" call %windir%\KIX32.EXE "c:\pre.kix" 
02.
if exist "\\server1\personal" call %windir%\KIX32.EXE "\\server1\personal\logon.kix"
Nun werte ich im Logonscript die Arbeitsgruppen aus da ich ja keine Domäne habe.
Das klappt auch aber die passende zuweisung von Laufwerksbuchstaben will mir nicht gelingen.

01.
Case @DOMAIN = "ADMIN" And @WUSERID = "Administrator" 
02.
		Use * /DELETE 
03.
		Use O: "\\Server1\c" /user:Administrator /Password:123456 
04.
		$mapping = @result 
05.
		Use Y: "\\server1\personal" /User:Gast /Password : "" 
06.
		$mapping = $mapping + "  " + @result 
07.
		;Use Z: "\\live.sysinternals.com\tools" 
08.
		;$mapping=$mapping+"  "+@result
Liegt es daran das ich hier wenn ich das Script ausführe auch schon als Admin am Rechner bin aber ein anderes Passwort habe? Über die Anmeldung via Explorer klappt es aber problemlos....

LG
Bitte warten ..
Mitglied: photographix
20.01.2009 um 16:46 Uhr
Das Schnipsel

01.
Use O: "\\Server1\c" /user:Administrator /Password:123456 
02.
?@RESULT
Liefert mir leider keinen Fehler und auch keinen anderen Status im Debug Mode zurück.
@Result bleibt einfach leer.

Server ist ein Windows 2008er
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...