Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Server 2003 IP nachträglich ändern

Frage Microsoft Windows Server

Mitglied: northern

northern (Level 1) - Jetzt verbinden

05.06.2009, aktualisiert 23:59 Uhr, 6004 Aufrufe, 5 Kommentare

Ich habe mir unter Virtual Box eine Grüne Wiese eingerichtet unter der ein Server 2003 R2 läuft um zu lernen wie ein Client-Server-Netz aufgebaut und administriert wird.

Hallo!

Ich habe einen Server 2003 mit Active-Directory, DHCP und DNS aufgesetzt.
Server IP 192.168.13.201
SUB 255.255.255.0
SG 192.168.13.20
DNS 80.69.100.174

Das Standardgateway ist mein Dlink-Router. Dieser ist mit einem Kabelmodem verbunden.

Server-DHCP-Pool 192.168.13.211 - 192.168.13.220
Scope-Options (Router: 192.168.13.20)
(DNS-Server: 192.168.13.201)

DNS-Reverse Lookup Zones - Forwarders: DNS - Adresse meines Providers 80.69.100.174

Soweit funktioniert alles. Ich kann mich mit einem Client (der auch unter V-Box läuft) an der Domäne anmelden. Der Client erhält
eine IP von Server und kann auch ins Internet.
Bis hier hin komme ich klar.

Nun habe ich mir die schöne Anleitung zum Routen mit 2 Netzwerkkarten von aqui
http://www.administrator.de/index.php?content=56073 angeschaut
(vielen Dank dafür!! Sehr sehr aufschlussreich!) und wollte das jetzt so umsetzen.

Meine obige Konfig ist mit einem billigen Dlink-Router aufgesetzt (der keine statischen Routen kann).

Ich habe ich also folgendes gemacht:

In den Server (also auf dem XP-Rechner auf dem Virtual box MS-Server-2003 emuliert) eine zweite Netzwerkkarte rein. Diese mit einem Netgear verbunden (der statische Routen kann). Diesem Router die IP 192.168.15.20 gegeben (restliche Einstellungen wie oben, allerdings jetzt als 192.168.15-Netz).
Die IP des Server 2003 habe ich dann entsprechend geändert,
192.168.15.201
SG 192.168.15.20
DNS 80.69.100.174

Der Dlink-Router (192.168.13.20) fungiert auf der grünen Wiese nur als Switch und verbindet die Clients die sich an der Domäne anmelden sollen mit dem Server.

Das habe ich also so umgesetzt und wollte dann die zweite Netzwerkkarte im Server aktivieren und dann kam nur noch "Schwerwiegender Ausnahmefehler" (Vbox-Meldung) und nichts ging mehr. Auch neu starten half nichts. Auch die IPs wieder so einzutragen wie sie vorher war hatte keinen Erfolg.
In "weiser" Vorausschau habe ich vorher noch ein Snapshot von der VM gemacht und jetzt alles wieder in den ursprünglichen Zustand zurückversetzt.

Meine Frage ist jetzt: Wie mache ich das richtig? Anscheinend kann ich nicht einfach nach belieben die IP des Servers ändern. Muss ich vielleicht vorher den DHCP-Server
die Autorisierung wegnehmen? Oder den DNS-Server bearbeiten? Ich bin sicher das es damit zusammenhängt.
Kann mir bitte dazu jemand mal etwas sagen?

Vielen Dank schon mal.

northern
Mitglied: Dirmhirn
05.06.2009 um 23:28 Uhr
Hi

ich glaube eher du hast einfach ein virtuelles Hardware Problem.

An der IP kann es ja nicht liegen, wenn er schon abstürtzt wenn du die Netzwerkkarte aktivierst.
Welchen Netzwerkkartentyp verwendest du denn in Vbox? je nachdem liegt ja dann noch die IP des Hosts "zwischen" VM und HW-Routern.
Oder hast du eine 2. HW-Netzwerkkarte im Host installiert?

DHCP-Server ist egal, sobald du die IPs statisch vergibst, fragt ihn die Karte ja nicht mehr ab. DNS-Server ebenso, kann nur bisschen dauern bis er aktuell ist.

sg Dirm
Bitte warten ..
Mitglied: northern
05.06.2009 um 23:42 Uhr
Hi!
Danke für Deine Antwort.
Ich habe eine zweite HW-Netzwerkkarte im Host installiert. Diese habe ich dann in den Settings der
VM als zweite Netzwerkkarte aktiviert und zwar als Bridged-Adapter und bei beiden den Adaptertyp PCnet-FAST III (AM79C973) festgelegt. Auf meinem Host laufen beide Karte parallel ohne Probleme.
Woran kann es denn noch liegen?
Bitte warten ..
Mitglied: Dirmhirn
06.06.2009 um 00:37 Uhr
Ich glaube es liegt an Vbox.

hast du sicher beide Netzwerkkarten ausgewählt? nicht eine für beide?
Probier halt einmal eine virtuelle Intel karte oder die PCnet-PCI.
Hast du die Karte aktiviert bevor du die VM gestartet hast?

Vbox hast du die aktuelle Version 2.2.4?

Bei der Fehlermeldung wird ja eine ID oä stehen - schau einmal ins Vbox-Forum.

sg Dirm
Bitte warten ..
Mitglied: northern
06.06.2009 um 17:30 Uhr
Hurra. Alles läuft wie es soll! )

Unter Virtual Box sind die Netzwerkkarten jeweils gebridged. Dabei ist es anscheinend egal welche Karte man emuliert.
Ich habe den Server noch mal aufgesetzt. Erst mal mit nur einer Netzwerkkarte. Dann habe ich AD und somit auch DNS eingerichtet. Dieser Link hat mir dabei sehr geholfen http://www.wintotal.de/Artikel/w2003server3/w2003server3.php

Dann habe ich den Server runtergefahren, die zweite Netzwerkkarte unter VirtualBox aktiviert (gebrückt), den Server neu gestartet, der neuen Netzwerkkarte die IP des Internet-Routers zugeteilt und in selbigem eine statische Route auf den Server (der ja Router ist) gesetzt, wie es aqui in seiner Anleitung beschrieben hat.
Jetzt können die Segmente untereinander kommunizieren.
Ich bin ausser mir vor Freude.
Durch das rumprobieren habe ich festgestellt, dass wenn man RAS (also nicht nur das Lan-Routing) aktiviert, der RAS-Server sich direkt 10 IP's vom DHCP-Server reserviert. Deshalb ist es wichtig, je nach Vorhaben, den DHCP-Server mit einem entsprechen grossen Adress-Pool aufzusetzen.
Wunderbar. Jetzt kommt der nächste Schritt: Remote-Usern den Zugriff auf mein Lan über VPN zu ermöglichen. Es könnte sein dass ich dazu noch die eine oder andere Frage oder auch mehrere auf einmal stellen werden. Bis dann und schönes Wochenende!!!

northern
Bitte warten ..
Mitglied: Dirmhirn
06.06.2009 um 18:37 Uhr
na sehr gut.

DIe 10 IPs sind glaube ich für die VPN Verbindungen reserviert.

sg Dirm
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Server
gelöst Client bei Windows Server 2003 ändern (5)

Frage von Therealcookie zum Thema Server ...

Windows Server
Small Business Server 2o11 IP ändern? (4)

Frage von Zoom78 zum Thema Windows Server ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...