Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server 2003 - Problem mit Winsock

Frage Microsoft Windows Server

Mitglied: marcoglatz

marcoglatz (Level 1) - Jetzt verbinden

06.06.2012 um 11:43 Uhr, 2388 Aufrufe, 4 Kommentare, 1 Danke

Hallo,

unsere Leitrechner-Software lief bisher auf irgendwelchen Win2000/WinXP Kisten. Ein Kunde hat möchte das aber unbedingt auf einem Server mit Server 2003.

Auf der Kiste läuft einmal Apache/PHP mit einer selbstgeschriebenen Extension. Zusätzlich läuft ein kleines Progrämmchen was die eigentlich Kommunikation mit den Maschinen übernimmt. Die PHP-Extension kommuniziert per Winsock2/UDP mit dem Kommunikations-Programm. Und eben das geht jetzt nicht mehr. In den Logs taucht nichts auf.

Ich hab bis jetzt die Firewall deaktiviert, wieder aktiviert mit Ausnahmen für Apache, PHP, die DLL. Dann Dienst-Konto für Apache auf Administrator geändert, hilft alles nichts. Ich bin kein Windows-Server-Experte, welche Einstellungen kann ich noch ausprobieren?


Gruß,
Marco
Mitglied: chfr77
06.06.2012 um 12:02 Uhr
Das kann ganz viele Ursachen haben. z.B.:
- Domänenweite IPSec Einstellungen die UDP teilweise oder ganz unterbinden
- Das Tool nutzt scheinbar den Loopback, es kann sein, dass UDP hierfür deaktiviert ist
- Nicht genug Nutzerrechte

War das auf Win2000/XP wirklich winsock 2? Schau mal ob diese Tools ws2_32.lib oder winsock.lib verlinken.

Ein Lösungsansatz ist, wenn Du Network Monitor installierst und einfach alles an den betreffenden Ports mitschneidest. Dann können Eure Entwickler das besser eingrenzen.

http://www.microsoft.com/en-us/download/details.aspx?id=4865
Bitte warten ..
Mitglied: marcoglatz
06.06.2012 um 12:13 Uhr
Ich bin selber der Entwickler bzw. einer davon

Der Witz an der Sache: Auf der Kiste läuft eine zweite .exe, die über die Kommunikations-Exe zyklische Daten abholt für die Protokollierung, das funktioniert fehlerfrei.

Wenn ich im eigentlichen Leitrechner-Programm Daten von den Maschinen abholen will, das geht nicht, da mault eben die DLL rum nö keine UDP-Verbindung.

Werd wohl nicht drum rum kommen in einer VM mir einen Server 2003 aufzusetzen mit Debugger und das mal genauer ansehen. Ich hatte gehofft das wäre nur eine versteckte Sicherheitsrichtlinie die ich aktivieren muss.
Bitte warten ..
Mitglied: chfr77
06.06.2012 um 12:20 Uhr
Das sieht mir dann aber so aus als wäre das Webserver-Dienstkonto nicht mit genug Nutzerrechten versehen. Ich kenne das nur als Problem bei dem UDP-Listener und BC-Sender auf dem ganzen System nicht funktionieren.
Bitte warten ..
Mitglied: marcoglatz
06.06.2012 um 12:47 Uhr
Ich hatte das Konto auch schon umgestellt, brachte aber nichts. Auch probiert PHP einmal als Modul einmal als CGI ausführen lassen, auch nichts gebracht.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...

Exchange Server
Verteilerlisten Exchange Server 2003 (5)

Frage von MultiStorm zum Thema Exchange Server ...

Heiß diskutierte Inhalte
DSL, VDSL
gelöst DSL 200m verlängern (15)

Frage von Angela44 zum Thema DSL, VDSL ...

LAN, WAN, Wireless
Per Script auf UniFi-controller zugreifen und WPA2-Key ändern (11)

Frage von Winfried-HH zum Thema LAN, WAN, Wireless ...

Windows Server
SBS 2011 Standard virtualisieren (11)

Frage von HeinrichM zum Thema Windows Server ...

Exchange Server
gelöst DHCP Sever MS Server 2012 Problem (10)

Frage von Florian86 zum Thema Exchange Server ...