Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Server 2003 R2 plus W-LAN-Router als DHCP ... und DNS?!?

Frage Microsoft Windows Server

Mitglied: dr-perry-cox

dr-perry-cox (Level 1) - Jetzt verbinden

09.08.2011, aktualisiert 18.10.2012, 5180 Aufrufe, 11 Kommentare

Ich bin gerade dabei, auf Basis eines IBM System x3650 einen Windows Server 2003 R2 hochzuziehen ... und dabei stolpere ich über einige Fragen, zu denen mich Eure Meinung interessiert hätte.

Zunächst aber zur Infrastruktur:

Der Server hat die Grundinstallation hinter sich (Betriebssystem, Treiber, Service Packs, Updates, etc.). Serverfunktionen wie DHCP, DNS oder AD sind noch nicht installiert. Der Server hat 2 NICs, eine davon trägt die IP 192.168.011.001, die andere ist derzeit deaktiviert.

Dazu gibt es einen W-LAN-Router D-Link DIR-635. Dieser hat die IP 192.168.011.254 und stellt die Verbindung zum Internet dar.

Was für mich nun Fragen aufwirft ist folgendes Szenario: Es wird einerseits 15 Desktop-Clients geben, die "ganz normal" Mitglied der Domäne sind und über Netzwerkkabel angebunden sind. Dann wird es ca. 4-5 Mitarbeiter-Notebooks geben, die auch auf den Server und seine Dienste zugreifen möchten. Und schließlich gibt es immer wieder mal noch Gäste, die über das W-LAN Zugang zum Internet haben sollen, aber nicht an den Server rankommen sollen.

2 DHCPs in einem Netz gehen ja logischerweise nicht. Mein erster Gedanke war aslo, den DHCP auf dem Router zu nutzen. Aber wie sieht es dann in Sachen DNS aus? Hänge ich den Server mit einer NIC an der Router und leite DNS-Anfrage an diesen weiter, wenn der Server sie nicht beantworten kann? Oder zieht man für Mitarbeiter und Gäste unterschiedliche W-LANs auf? Oder ... ja, oder???

Und in welcher Reihenfolge installiere und konfiguriere ich eigentlich die Serverdienste? Als ich zu ersten mal den Server-Installations-Assistenten startete (mit 2 aktiven NICs), hat er bei Routing und RAS anschließend die Konfigurationen der Karten abgefragt. Aber das habe ich abgebrochen und eine der beiden Karten deaktiviert. Jetzt bietet er mir nur noch eine Liste der Serverkomponenten, um diese manuell nacheinander zu installieren. Da wäre es sehr hilfreich, die Reihenfolge zu kennen.

Vielleicht hat jemand von Euch eine Erfahrung mit einem ähnlichen Szenario. Über einen Tipp und etwas Beistand würde ich mich sehr sehr freuen.

Herzlichen Dank schon mal im Voraus ...
Mitglied: winf-hst
09.08.2011 um 15:39 Uhr
Hallo perry,

ist denn noch andere netzwerkhardware vorhanden (switche etc.)?
Wenn du gästen den zugang zum internet, nicht aber zum internen netzwerk ermöglichen willst, solltest du schon zwei netze bilden und diese entweder physikalisch oder per vlan trennen.
bei vlan ist dann eben die frage ob die switche dies unterstützen?
soll der w2k3 nur als dc genutzt werden oder noch andere rollen übernehmen?
wie sieht es mit einer firewall aus? der dlink ist ja nun "nur" ein konsumer gerät und nicht gerade die profi lösung.

gruß
Bitte warten ..
Mitglied: dr-perry-cox
09.08.2011 um 17:04 Uhr
Hi win-hst,

es gibt noch einen 48-Port Gigabit-Switch, ebenfalls von D-Link, der müsste VLAN können.

Der W2k3 soll DC, Internet-Gateway, File- und Printserver sein.

Der Haken in meinem Kopf ist die W-LAN-Anbindung: Ein Mitarbeiter X sitzt mit seinem Notebook im Büro und hat es über Netzwerk-Kabel ans LAN angebunden. Ein DHCP hat eine IP zugeteilt und alles ist schön. Dann geht der Mitarbeiter X eine Stunde später ein Stockwerk höher in den Besprechungsraum und muss über W-LAN auf den Server und das Internet zugreifen ...
Bitte warten ..
Mitglied: winf-hst
09.08.2011 um 17:17 Uhr
hallo,

in diesem fall brauchst du nicht wirklich einen router sonder lediglich einen access point (kann auch ein weiterer router sein) der am internen netzwerk hängt und nicht als dhcp oder dns server fungiert sonder nur eine wlan verbindung bereit stellt.
das würde ich an deiner stelle auch so machen um das gast wlan wie bereits gesagt physisch vom internen wlan zu trennen.
der dlink stellt dann die inet verbindung her und spannt ein "gast" wlan mit eigenem ipadressbreich und dhcp und dein w2k3 ist dann eben dc und dhcp für das interne netzwerk mit einem zweiten adressbereich.
und über einen ap am internen switch können dann deine mitarbeiter ins wlan und bekommen vom w2k3 die ip per dhcp.
du solltest dir aber auch unbedingt gedanken über eine firewall-lösung machen um dein netzwerk zu sichern!
die interne firewall des dlink ist ja wie erwähnt keine wirklich professionelle lösung.

gruß
Bitte warten ..
Mitglied: dr-perry-cox
17.08.2011 um 12:15 Uhr
Hi,

die Sache mit dem Accesspoint ist eine sehr gute Idee - so mache ich das

Das Firewall-Thema ist natürlich auch sehr wichtig, dass muss ich mir zu gegebenener Zeit Gedanken machen. Jetzt muss ich aber erstmal den DNS und den DHCP sauber ans laufen kriegen

Vielen herzlichen Dank für Deine Hilfe.
Bitte warten ..
Mitglied: dr-perry-cox
22.08.2011, aktualisiert 18.10.2012
Hallo nochmal,

so nun hab ich hier einen D-LINK DAP-1353 Wireless N Access Point und versuche über diesen, meine W-LAN Clients sowohl auf die Serverfreigaben zugreifen zu lassen als auch ins Netz zu kriegen. Allerdins scheitere ich dabei bisher souverän.

Die jetzigeNetzwerkkonfiguration sieht folgendermaßen aus:

- Server 2003 R2 SP2 mit allen Updates Installiert, Serverdienste DNS / DHCP / Routing und RAS installiert

- Netzwerkkarte 1 (LAN - verbunden mit Switch): IP-Adresse: 192.168.11.1 / Subnetmask: 255.255.255.0 / Standardgateway: - / Primärer DNS-Server: 192.168.11.1 / Alternativer DNS-Server: -
- Netzwerkkarte 1 (WAN - verbunden mit Router): IP-Adresse: 192.168.0.1 / Subnetmask: 255.255.255.0 / Standardgateway: 192.168.0.254 / Primärer DNS-Server: - / Alternativer DNS-Server: -

Die DNS-Konfiguration habe ich gemäß der Anleitung http://www.administrator.de/wissen/probleme-mit-multihomed-dcs-vermeide ... (Probleme mit Multihomed DCs vermeiden) konfiguriert. nslookup tut - soweit es sich auf das 192.168.11.x - Subnetz bezieht wunderbar; alle anderen Anfragen werden an den Router mit der IP 192.168.0.254 weitergeleitet. Der DHCP vergibt IP-Adressen von 192.168.11.100 - .199. Soweit also auch alles paletti, aber ...

Nun möchte ich einen D-LINK DAP-1353 Wireless N Access Point anschließen, um einigen Mitarbeitern zur ermöglichen, mit ihren Notebook via W-LAN auf die Domäne zuzugreifen. Sie sollen auf Freigaben und Drucker zugreifen können und natürlich auch auf´s Internet.

Im Moment hat der AccessPoint die IP 192.168.0.2. Wenn ich einen Client über W-LAN mit dem AccessPoint verbinde, bekommt der auch ´ne IP, zum Beispiel die 192.168.11.101. Ein Zugriff auf eine Freigabe auf dem Server funktioniert auch, allerdings nur über \\192.168.11.1\Testfreigabe. Die DNS-Auflösung der Serversnamens findet nicht statt - möglicherweise wegen dem Verfahren nach der Anleitung "Probleme mit Multihomed DCs vermeiden"?!?

Der Client bekommt auch keine Gateway-IP zugewiesen. Ich habe im Accesspoint die IP des Routers (192.168.0.254) als Gateway hinterlegt - aber das hat nichts gebracht. Den AccessPoint in das 192.168.11.x-Subnetz einzubinden hat auch keine Erfolg.

Ich hab das Gefühl, da ist ein großer gordischer Knoten im DNS/DHCP ... obwohl abgesehen vom AccessPoint alles wunderbar geht. Vielleicht kannst Du - oder jemand von euch, der das liest - helfen, dass ganze zu entwirren ...

Ein ganz herzliches Dankeschön schon mal im Voraus.
Bitte warten ..
Mitglied: winf-hst
22.08.2011 um 13:59 Uhr
Hallo Perry,

versuchen wir mal dich zu entknoten ;)
Als erstes würde ich den AP in dein internes Netz nehmen, sofern über diesen auch nur die internen Systeme laufen sollen.
Dann hat der AP z.B. die IP 192.168.11.2.
Kannst du aus dem kabelgebundenen Netz denn über den Freigabenamen auf die Freigabe zugreifen?
Wenn du wie in der Anleitung beschrieben die Registrierung der DNS Namen deaktiviert hast, kannst du natürlich keine Namensauflösung mehr nutzen.
Das Netz steht ja wie du sagst, du kommst also über die IP Adresse auf deine Freigaben. Das weist ja schon auf ein DNS Problem hin.
Die Adressen, wie das Gateway, bekommen deine Clients nicht von dem AP sondern von deinem DHCP Server, also dem 2k3.
Bitte überprüfe auch dies mal an deinen kabelgebundenen Systemen, ob hier die IP Einstellungen korrekt vom DHCP übergeben werden.

Gruß
Bitte warten ..
Mitglied: aqui
22.08.2011 um 16:16 Uhr
Deine DHCP Konfiguration ist totaler Murks ! Hättest du dem WLAN Client einmal richtigerweise einen statische IP im .0.0er netz gegeben hättest du gesehen das alles sauber funktioniert !
Wenn der AP im 192.168.0.0er Segement angeschlossen ist können die WLAN Clients niemals eine .11.0er IP darüber bekommen.
Dann würdest du ja mit .11.0er Endgeräte IPs auf dem .0.0er IP Segment arbeiten. Das wäre dann totaler IP Tohuwabohu und jeder Erstklässler würde wissen das das so niemals funktionieren kann.
Du musst also zwingend den DHCP auf dem AP ausschalten sofern du die IPs zentral vom Windows Server per DHCP vergibst !
Dann musst du auf dem Windows DHCP einen 2ten Scope eintragen im 0.0er Netz. (Den Scope aus dem .11.0er Netz hat er ja vermutlich schon ?)
Du musst zwingend einen DHCP Relay Agent aktivieren auf dem Server, damit jedes Segment auch seine richtigen IPs bekommt:
http://technet.microsoft.com/de-de/library/cc781416%28WS.10%29.aspx
und
http://www.computerperformance.co.uk/w2k3/services/DHCP_Relay_Agent.htm
WLAN Clients im .0.0er Netzwerk (der AP ist ja in diesem Netz !) müssen logischerweise ja auch eine .0.0er IP Adresse bekommen, denn der WLAN Acesspoint arbeitet nur als dumme Bridge auf Basis der Mac Adressen auf dem OSI Layer 2 !!
Bitte warten ..
Mitglied: dr-perry-cox
22.08.2011 um 17:45 Uhr
Zitat von aqui:
Deine DHCP Konfiguration ist totaler Murks ! Hättest du dem WLAN Client einmal richtigerweise einen statische IP im
.0.0er netz gegeben hättest du gesehen das alles sauber funktioniert !

Ich darf freundlich darauf hinweisen, dass der AP am Anfang meiner Bemühungen die IP 192.168.0.2 hatte (stand auch in meinem Beschreibungstext) und damit im "0.0er netz" war. Es funktionierte aber wie beschrieben trotzdem nicht - unabhängig davon in welchem Subnetz ich den AP integrierte. Ich hab´s eben einmal mit ´ner statischen 0.0er-IP und einmalmit ´ner statischen 11.0er-IP versucht. Beides hatte das gleiche Ergebnis.

Wenn der AP im 192.168.0.0er Segement angeschlossen ist können die WLAN Clients niemals eine .11.0er IP darüber
bekommen.
Dann würdest du ja mit .11.0er Endgeräte IPs auf dem .0.0er IP Segment arbeiten. Das wäre dann totaler IP
Tohuwabohu und jeder Erstklässler würde wissen das das so niemals funktionieren kann.

Ich habe führende Erstklässler befragt und sie stimmen dir zu Aber im Ernst: Der DHCP am AP ist abgeschaltet, DHCP macht der Server (192.168.11.100 - .199). Unabhängig davon, welches IP-Subnetz ich versuchte, haben meine Clients jedoch immer eine IP aus dem 11.0er Netz erhalten. Was aber kein Client erhält - weder über Kabel noch über W-LAN, sind DNS-Server bzw. Gateway-Adressen.

Du musst also zwingend den DHCP auf dem AP ausschalten sofern du die IPs zentral vom Windows Server per DHCP vergibst !

War und ist aus!

Dann musst du auf dem Windows DHCP einen 2ten Scope eintragen im 0.0er Netz. (Den Scope aus dem .11.0er Netz hat er ja vermutlich
schon ?)

Du musst zwingend einen DHCP Relay Agent aktivieren auf dem Server, damit jedes Segment auch seine richtigen IPs bekommt:
http://technet.microsoft.com/de-de/library/cc781416%28WS.10%29.aspx
und
http://www.computerperformance.co.uk/w2k3/services/DHCP_Relay_Agent.htm
WLAN Clients im .0.0er Netzwerk (der AP ist ja in diesem Netz !) müssen logischerweise ja auch eine .0.0er IP Adresse
bekommen, denn der WLAN Acesspoint arbeitet nur als dumme Bridge auf Basis der Mac Adressen auf dem OSI Layer 2 !!


Also - nochmal auf Anfang: Ich habe die Änderungen nach der Anleitung "Probleme mit Multihomed DCs vermeiden" zunächst einmal wieder rückgängig gemacht und den Server neu gestartet.

Ein Blick in die Management-Konsole zeigt mir beim DNS und Forward-Lookupzone und in der Reverse-Lookupzone den Server mit den IPs 192.168.11.1 (interne IP zum Switch) und 192.168.0.1(externe IP zum Router mit der IP 192.168.0.254). In der Reversed-Lookupzone sehe ich zwei Subnetze - 0.x und 11.x. Der Server taucht in beiden mit der jeweiligen IP auf. Der DHCP behauptet, er habe die IP 192.168.11.1 und vergebe IPs von 192.168.11.100 - .199. So weit, so gut.

nslookup liefert den Namen des Servers korrekt zurück als meinserver.local, allerdings "nur" mit der 192.168.11.1 als IP. Namensauflösungen lokal und auf Internetadressen, z.b. nslookup www.heise.de liefern sauber und direkt IPs zurück und mein Server wird auch als DNS ausgewiesen.

Clients erhalten aber nach wie vor keine Gateway oder DNS-Angaben. Bereichsoptionen im DHCP? Serveroptionen im DHCP? und müsste nslookup nun wieder beide Server-Ips anzeigen, nachdem ich die vormaligen Änderungen zurückgenommen habe.

Und abschließend die Frage: Wie wäre es, dem Ap ´ne statische 11er-Adresse zu geben. Dann wäre er doch von Haus aus im gleichen IP-Subnetz wie die Clients und wie der DNS und der DHCP. Das müsste doch einiges vereinfachen, oder ...?!?

Ich habe hier einen alten Server, auf dem ist im DNS nur ein Bereich in der Reversed-Lookupzone sichtbar (der interne Bereich), obwohl der auch zwei Netzwerkkarten hatte. Aber jetzt wird´s glaub´ ich zu konfus. Ich bin jedenfalls für jeden Tipp dankbar.

Herzliche Grüße und vielen Dank euch allen.
Bitte warten ..
Mitglied: aqui
22.08.2011 um 18:10 Uhr
Nochmals da du es scheinbar noch immer nicht verstanden hast:
Die IP Adresse des AP dient einzig und allein NUR für das Management des APs ! NICHT für die Kommunikation der Clients !
Der Accesspoint arbeitet als simple Netzwerk Bridge auf Basis der Mac Adressen !!
WLAN Clients befinden sich also immer im gleichen IP Segment indem auch der Accesspoint ist...logisch. Bei dir also das IP Segment 192.168.0.0 /24 wenn du den AP nicht ins 2te Segment mit der .11.0 /24 verlegt hast.
DHCP Broadcast Requests von den WLAN Clients werden also transparent in das LAN Segement des Accesspoints übertragen und gelangen so zum Server.

Der Client muss doch erstmal überhaupt eine korrekte IP Adressierung bekommen bevor man überhaupt erst über DNS nachdenken kann. Vergiss doch deshalb also erstmal die DNS Thematik, denn bei dir scheitert es ja schon grundsätzlich an der korrekten DHCP IP Adressvergabe der Clients.
Das ist also der erste Schritt den du fixen musst !!
Trage also den entsprechenden 2ten Scope im DHCP Server nach inkl. der Gateway IPs (IP des Servers in diesem Segment) und auch der DNS Adresse (Server).
Zwingend erforderlich ist der DHCP Relay Agent sofern du in beiden Segmenten vom Server per DHCP IPs vergibst. Ist das nicht der Fall kann das natürlich entfallen, genauso wie der 2te Scope !!

Halte dich also an die strategische Reihenfolge das zum Fliegen zu bringen und versuche nicht sinnlos mit DNS Troubleshooting ein DHCP Problem zu fixen. Das das Unsinn ist leuchtet vermutlich auch dir ein, oder?!
Bitte warten ..
Mitglied: winf-hst
22.08.2011 um 19:05 Uhr
Hallo,

also so wie ich es bis hier her verstehe ist die IP-Adressierung soweit OK?!
Du solltest zwar den AP lieber an dein Switch ins "interne" Netz hängen um Problemen mit der IP-Vergabe aus dem Weg zu gehen.

Wenn dann jetzt die einzige Problematik darin besteht das du ein DNS Problem hast, sprich keine Namensauflösung, solltest du dir die Konfiguration vom DNS Server erneut vornehmen. wie ich bereits geschrieben habe hast du ja die Namensauflösung deaktiviert. Dies könnte schon dein Problem sein.
Du brauchst in deiner Konfiguration den DNS nicht unbedingt nach der Anleitung die du genommen hast einrichten. Ein "normale" Konfiguration dürfte schon ausreichen.

Gruß
Bitte warten ..
Mitglied: dr-perry-cox
05.09.2011 um 11:17 Uhr
Hallo nochmal an alle,

ich war ein paar Tage unterwegs - aber am Wochenende hab´ ich mich der Sache nochmal angenommen und jetzt funktioniert alles wie ich es wollte und und wie es soll. Wie schon geschrieben habe ich alle Änderungen am DNS aus der Anleitung zurückgenommen und den AccessPoint nach einem Reset mit einer statischen IP ins 11er-Netz (intern) gehängt und schon passt alles - also im wesentlichen den Weg den winf-hst beschrieben hat.

Also vielen Dank für die Hilfe euch allen
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst Keine DNS-Einträge vom DHCP-Server im Windows Server 2012 R2 (8)

Frage von jeschero zum Thema Windows Server ...

Microsoft
Server 2012 Wake on Lan Pakete an alle Geräte im DHCP Lease senden (1)

Frage von thomasreischer zum Thema Microsoft ...

Windows Server
gelöst DHCP Server 2012 R2 umziehen (3)

Frage von oce zum Thema Windows Server ...

Windows Netzwerk
Windows Server 2008 R2 mit 2 DHCP, 1 MAC-Filter (11)

Frage von Nathenn zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (23)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (19)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...