Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server 2003: Startscripte werden nicht immer ausgeführt

Frage Microsoft Windows Server

Mitglied: Popeye

Popeye (Level 1) - Jetzt verbinden

15.08.2006, aktualisiert 16.08.2006, 3585 Aufrufe, 3 Kommentare

Hallo Experten,

ich habe gestern einen Server 2003 nach einem Hardwaredefekt neu installieren müssen. Backup war zwar da, aber die Installation war eh etwas vermurkst, also habe ich in den sauren Apfel gebissen...

Funktioniert mittlerweile auch ganz gut, nur mit den Startscripten der User habe ich ein Problem. Ich konnte mich bei der Installation nicht recht erinnern, wo die eigentlich hingehören (sysvol irgendwo), also habe ich sie in ein Verzeichnis "Scripte" direkt unter c: gelegt und dies Verzeichnis freigegeben. Das ist insofern nicht sicher, weil nun jeder darauf greifen kann und auch Scripte ausführen, die nicht für ihn sind, also werde ich das noch ändern müssen... Ist aber nicht so dringend, weil da nichts schlimmes passieren kann.

Allerdings habe ich jetzt den Effekt, daß die Scripte nach der Anmeldung der User gelegentlich nicht ausgeführt werden, ich könnte mir denken daß die Anmeldung "zu schnell" geht und das Scriptverzeichnis in dem Moment noch nicht zu sehen ist. Ist das so? Sind die Scripte, wenn sie am richtigen Ort liegen, besser im Zugriff? Falls ja, muß ich das wohl doch etwas früher ändern als geplant. Oder kan es einen anderen Grund geben, warum das nicht so klappt wie es soll?
Mitglied: gemini
15.08.2006 um 18:56 Uhr
Hallo Popeye,

wo die Loginscripten liegen hängt davon ab wie du sie zugewiesen hast.
Erfolgt die Zuweisung:
a) in den Eigenschaften des Users, dann müssen die Scripten in der Freigabe NETLOGON (lokaler Pfad: SYSVOL\sysvol\Domänenname\Scripts) auf dem Server liegen. In den Usereigenschaften darf dann NUR der Name des Scripts ohne Pfad stehen
b) über Gruppenrichtlinien, dann liegen die Scripten in SYSVOL\sysvol\Domänenname\Policies\GUID der Policy\User\Scripts\Logon.

Wenn die Speicherorte der Scripten nicht stimmen kann ich mir schwerlich vorstellen, dass sie _gelegentlich_ nicht ausgeführt werden, dann werden sie _gar nicht_ ausgeführt.

BTW die Benutzer müssen auf die Scripten mind. das Recht Lesen und Ausführen haben, da die Anmeldescripte ja mit den Rechten des Benutzers ausgeführt werden.
Ob die verhindern kannst, dass manche mit den Scripten spielen weiß ich nicht, hab ich ehrlich gesagt auch noch nie gebraucht.
Du könntest versuchen der entspr. Benutzergruppe das Recht Ordnerinhalt auflisten NUR FÜR DIESEN ORDNER zu entziehen. Ist aber nur ein Gedanke und ungetestet!

Gruß
gemini
Bitte warten ..
Mitglied: Popeye
15.08.2006 um 23:28 Uhr
Danke für die Antwort, und du hast natürlich Recht! Die Scripte wurden in Wirklichkeit gar nicht ausgeführt. Da bin ich nur bei der Probiererei durcheinandergekommen, weil einige Freigaben auf den User-PCs zwar verbunden waren, aber eben nicht wegen der Scripte...

Tja, man sollte wenn etwas nicht geht erstmal überlegen statt hektisch irgendwas zu versuchen.

Ich verspreche, mich zu bessern!
Bitte warten ..
Mitglied: Biber
16.08.2006 um 00:24 Uhr
Ich verspreche, mich zu bessern!
Auch wenn ich nur stiller Mitleser war - für dieses Versprechen gebe ich 5 Punkte!

Gruss
Biber
P.S. *winkzzzzz @gemini
Schön, Dich zu lesen!
Bitte warten ..
Ähnliche Inhalte
Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
Windows Server
gelöst Exchange HyperV Prozessorlast (19)

Frage von theoberlin zum Thema Windows Server ...

Hardware
16-20 Port POE Switch mit VLAN (19)

Frage von thomasreischer zum Thema Hardware ...

Windows Server
Server mit Netzwerkaussetzern (17)

Frage von SarekHL zum Thema Windows Server ...

LAN, WAN, Wireless
gelöst Batchdatei um einen Proxy einzustellen (14)

Frage von CrystalFlake zum Thema LAN, WAN, Wireless ...