Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server 2003: Startscripte werden nicht immer ausgeführt

Frage Microsoft Windows Server

Mitglied: Popeye

Popeye (Level 1) - Jetzt verbinden

15.08.2006, aktualisiert 16.08.2006, 3603 Aufrufe, 3 Kommentare

Hallo Experten,

ich habe gestern einen Server 2003 nach einem Hardwaredefekt neu installieren müssen. Backup war zwar da, aber die Installation war eh etwas vermurkst, also habe ich in den sauren Apfel gebissen...

Funktioniert mittlerweile auch ganz gut, nur mit den Startscripten der User habe ich ein Problem. Ich konnte mich bei der Installation nicht recht erinnern, wo die eigentlich hingehören (sysvol irgendwo), also habe ich sie in ein Verzeichnis "Scripte" direkt unter c: gelegt und dies Verzeichnis freigegeben. Das ist insofern nicht sicher, weil nun jeder darauf greifen kann und auch Scripte ausführen, die nicht für ihn sind, also werde ich das noch ändern müssen... Ist aber nicht so dringend, weil da nichts schlimmes passieren kann.

Allerdings habe ich jetzt den Effekt, daß die Scripte nach der Anmeldung der User gelegentlich nicht ausgeführt werden, ich könnte mir denken daß die Anmeldung "zu schnell" geht und das Scriptverzeichnis in dem Moment noch nicht zu sehen ist. Ist das so? Sind die Scripte, wenn sie am richtigen Ort liegen, besser im Zugriff? Falls ja, muß ich das wohl doch etwas früher ändern als geplant. Oder kan es einen anderen Grund geben, warum das nicht so klappt wie es soll?
Mitglied: gemini
15.08.2006 um 18:56 Uhr
Hallo Popeye,

wo die Loginscripten liegen hängt davon ab wie du sie zugewiesen hast.
Erfolgt die Zuweisung:
a) in den Eigenschaften des Users, dann müssen die Scripten in der Freigabe NETLOGON (lokaler Pfad: SYSVOL\sysvol\Domänenname\Scripts) auf dem Server liegen. In den Usereigenschaften darf dann NUR der Name des Scripts ohne Pfad stehen
b) über Gruppenrichtlinien, dann liegen die Scripten in SYSVOL\sysvol\Domänenname\Policies\GUID der Policy\User\Scripts\Logon.

Wenn die Speicherorte der Scripten nicht stimmen kann ich mir schwerlich vorstellen, dass sie _gelegentlich_ nicht ausgeführt werden, dann werden sie _gar nicht_ ausgeführt.

BTW die Benutzer müssen auf die Scripten mind. das Recht Lesen und Ausführen haben, da die Anmeldescripte ja mit den Rechten des Benutzers ausgeführt werden.
Ob die verhindern kannst, dass manche mit den Scripten spielen weiß ich nicht, hab ich ehrlich gesagt auch noch nie gebraucht.
Du könntest versuchen der entspr. Benutzergruppe das Recht Ordnerinhalt auflisten NUR FÜR DIESEN ORDNER zu entziehen. Ist aber nur ein Gedanke und ungetestet!

Gruß
gemini
Bitte warten ..
Mitglied: Popeye
15.08.2006 um 23:28 Uhr
Danke für die Antwort, und du hast natürlich Recht! Die Scripte wurden in Wirklichkeit gar nicht ausgeführt. Da bin ich nur bei der Probiererei durcheinandergekommen, weil einige Freigaben auf den User-PCs zwar verbunden waren, aber eben nicht wegen der Scripte...

Tja, man sollte wenn etwas nicht geht erstmal überlegen statt hektisch irgendwas zu versuchen.

Ich verspreche, mich zu bessern!
Bitte warten ..
Mitglied: Biber
16.08.2006 um 00:24 Uhr
Ich verspreche, mich zu bessern!
Auch wenn ich nur stiller Mitleser war - für dieses Versprechen gebe ich 5 Punkte!

Gruss
Biber
P.S. *winkzzzzz @gemini
Schön, Dich zu lesen!
Bitte warten ..
Ähnliche Inhalte
Windows Server
Startscript wird nicht überall ausgeführt
Frage von Thor01Windows Server5 Kommentare

Hallo, habe einer bestehenden Domäne einige neue PCs hinzugefügt und diese in die passenden OUs gesteckt. Verwunderlich ist jetzt, ...

Linux
Startscript PID statt PPID
gelöst Frage von schneerunzelLinux5 Kommentare

Hallo zusammen, ich habe auf Grundlage des Beispiels ein Startscript für Java Applikation geschrieben nun habe ich folgendes Problem ...

Windows Server
Gruppenrichtlinie wird nur bei Anmeldung am Server, aber nicht am Client ausgeführt
gelöst Frage von klanaxWindows Server3 Kommentare

Hallo an alle! Wir haben einen Windows Server 2011 SBS (also eigentlich Windows Server 2008 R2) als Domain-Controller und ...

Batch & Shell
Batch läuft als Startscript auf Fehler, aber nur an einem pc
gelöst Frage von ChrisDynamiteBatch & Shell1 Kommentar

Guten Morgen, eine Batch, welche bei Systemstart läuft, bringt eine MSGBox und läuft zwangsweise auf einen Fehler. Manchmal ist ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter wieder installieren auf einer frischen Windows-Installation

Tipp von Lochkartenstanzer vor 12 StundenMicrosoft Office

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 14 StundenDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 15 StundenSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 18 StundenMicrosoft Office1 Kommentar

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Server-Hardware
Veeam Backup Server stürzt alle paar Tage ab
Frage von Leo-leServer-Hardware11 Kommentare

Hallo Forum, ich habe momentan folgendes Problem. Veeam Backup and Replication 9.5 u2 auf voll gepatchten DL 380 G7 ...

Windows 10
Win10 Laptop findet keine Netzwerkgeräte und Freigaben mehr
Frage von CoolzeroWindows 1010 Kommentare

Hi, seit ein paar Tagen habe ich das Problem das mein Windows 10 Laptop keine Geräte mehr in der ...

Batch & Shell
Dateien verschieben mit batch
gelöst Frage von michi-ffmBatch & Shell10 Kommentare

Hallo Zusammen hat jemand evtl eine Idee? Zunächst hier das Skript: Leider werden keine UNC-Pfade unterstüzt, kann mir jemand ...