Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Server 2008 R2 Hyper-V Guest Server 2008 32Bit Integrationsdienste lassen sich nicht installieren

Frage Virtualisierung Hyper-V

Mitglied: goscho

goscho (Level 4) - Jetzt verbinden

17.07.2013 um 11:55 Uhr, 2955 Aufrufe, 9 Kommentare

Tach Leute,

Ich habe folgendes Problem:

In einer SBS2003 Domäne mit zusätzlichem Server 2008 32Bit DC (anderer Standort) steht eine Migration zu SBS2011 an.

Diese möchte ich vorher gern virtuell testen.

Dazu habe ich einen W2K8 R2 mit aktivierter Hyper-V-Rolle.
Vom SBS habe ich ein BESR-Backup beider Partitionen, ebenso vom 2. DC.
Diese werden in MS VHDs gewandelt (Funktion in BESR).

Den SBS habe ich als Virtuelle Maschine laufen, alles funktioniert so wie es soll.
Den Server 2008 habe ich ebenso als Virtuelle Maschine laufen. Leider bekomme ich dort die Integrationsdienste nicht installiert.
Diese lassen sich zwar installieren, jedoch habe ich weiterhin keine Netzwerkkarten, etc.
Das manuelle Hinzufügen einer Legacy-Netzwerkkarte scheitert auch, weil ich nicht den passenden Treiber finde bzw. hinzufügen kann.

Ich habe auch schon mehrfach diverse Geräte aus dem Gerätemanager entfernt und die Integrationsdienste neuinstallieren lassen, hat aber nichts bewirkt.

Es ist schon verwunderlich, dass nach der Reparatur/Installation der Integrationsdienste kein Neustart angefordert wird.

Jetzt weiß ich nicht mehr weiter und bitte euch um Hilfe.

Grüße aus dem sonnigen Eichsfeld
Goscho
Mitglied: manuel1985
17.07.2013 um 12:14 Uhr
hi,

hab die Woche nen SBS 2003 R2 zu Testzwecken (ebenfalls Migration) installiert. Hast du alle Service Packs auf dem Ding? Bei mir wollte er erst die Integrationsdienste installieren, nachdem ich Server 2003 SP2 installiert habe. Da gibt's nen KB-Artikel, finde den auf die schnelle nicht, der die Updates auflistet, die du brauchst. SBS SP1, Server 2003 SP2, Exchange SP1 und noch was für SQL und SharePoint.
Im Link sind die aber auch aufgelistet. Installier die mal und versuchs dann nochmal mit den Integrationsdiensten.


http://technet.microsoft.com/de-de/library/cc527563%28v=ws.10%29.aspx
Bitte warten ..
Mitglied: goscho
17.07.2013 um 12:50 Uhr
Hi Manuel,

der SBS ist nicht das Problem. Ja, da waren alle SPs installiert.

Auf dem W2K8 sind auch alle SPs (aktuell SP2) installiert und viele weitere Windows-Updates.
Wie soll ich diesem Server aber sonstige Windows-Updates zukommen lassen, wenn ich keine Netzwerkkarte installiert bekomme?
Bitte warten ..
Mitglied: DerWoWusste
17.07.2013 um 12:52 Uhr
Hi.

Beschreib doch noch mal, wofür das "etc." aus "jedoch habe ich weiterhin keine Netzwerkkarten, etc." steht. Zudem sag mal genauer, wieso Du eine Legacynetzwerkkarte hinzufügen willst und wie überhaupt das NIC-Setup des Gastes in Hyper-V konfiguriert ist. Selber virtueller Switch wie die anderen Gäste, die laufen?
Bitte warten ..
Mitglied: goscho
17.07.2013 um 13:04 Uhr
Zitat von DerWoWusste:
Hi.
Hi DWW
Beschreib doch noch mal, wofür das "etc." aus "jedoch habe ich weiterhin keine Netzwerkkarten, etc."
Im Gerätemanager ist ein Gerät namens "Bus des virtuellen Computers", welches nicht nutzbar ist.
Bei RDP-Verbindung zum Hyper-V Host ist keine Mausnutzung in der VM möglich.
Beim lokalen Arbeiten wird der Mauszeiger zum Punkt, sobald man die VM überquert.
Also eigentlich die Dinge, die durch die Integrationsdienste ermöglicht werden.
steht. Zudem sag mal genauer, wieso Du eine Legacynetzwerkkarte hinzufügen willst und wie überhaupt das NIC-Setup des
Gastes in Hyper-V konfiguriert ist. Selber virtueller Switch wie die anderen Gäste, die laufen?
Die VM ist dem selben virtuellen Switch (intern) zugeordnet, wie der SBS.
Es ist keine Netzwerkkarte verfügbar.
Wenn ich jetzt versuche, eine Legacy-Netzwerkkarte zu installieren, benötige ich einen passenden Treiber.
Woher soll ich diesen nehmen?

BTW: Bin Anfänger in Hyper-V.
Bitte warten ..
Mitglied: DerWoWusste
17.07.2013, aktualisiert um 13:20 Uhr
Ich wäre vorsichtig mit BESR, auch wenn es gehen sollte, halte ich es für die Ursache. ich habe schon viele Systeme mit anderen Imageprogrammen virtualisiert, die an der Hardware gar nichts machen a la "universal restore" und hatte nicht deratige probleme.
Jedenfalls wird das nichts mit der Legacykarte, so ist das nicht gedacht.

Ich würde ein Systemstateimage des DCs in die VM spielen, das wird klappen.
Bitte warten ..
Mitglied: goscho
17.07.2013 um 13:42 Uhr
Zitat von DerWoWusste:
Ich wäre vorsichtig mit BESR, auch wenn es gehen sollte, halte ich es für die Ursache. ich habe schon viele Systeme mit
anderen Imageprogrammen virtualisiert, die an der Hardware gar nichts machen a la "universal restore" und hatte nicht
deratige probleme.
Ich gehe nicht davon aus, dass es daran liegt.
Beim Umwandeln mittels BESR in eine VHD gibt es die Option, das Windows-Minisetup ausführen zu lassen.
Wenn ich dies allerdings mache, so kann ich mich genau einmal an der VM anmelden, werde anschließend abgemeldet und kann mich anschließend nicht mehr anmelden, da das PW falsch sein soll.

Man kann die Funktion mit dem Minisetup auch weglassen. Dann startet die VM normal, es werden auch die Integrationsdienste installiert, jedoch bekomme ich keinen Netzwerkadapter zum Laufen.
Es gibt keinen Nezwerkadapter, unter ausgeblendete sind auch nur der "asynchrone RAS-Adapter" und der "Teredo Tunnel Provider" vorhanden.
Jedenfalls wird das nichts mit der Legacykarte, so ist das nicht gedacht.
Das war auch nur für den Notafll, um überhaupt eine Netzwerkkarte installiert zu bekommen
Ich würde ein Systemstateimage des DCs in die VM spielen, das wird klappen.
Habe ich nicht, komme ich auch nicht so schnell ran, weil weit entfernt und kleine Bandbreite.
Bitte warten ..
Mitglied: DerWoWusste
17.07.2013 um 14:18 Uhr
Habe ich nicht, komme ich auch nicht so schnell ran
Dann spiel das BESR-image auf ein Blech zurück und erzeug dort ein Systemstate-image.
Bitte warten ..
Mitglied: goscho
17.07.2013 um 14:30 Uhr
Upgrade:

Habe jetzt über "ältere Netzwerkkarte hinzufügen" in den Einstellungen der VM eine Netzwerkverbindung mit dem virtuellen Switch zustande bekommen.

Die Integrationsdienste laufen aber weiterhin nicht, weshalb bspw. das Wechseln von VM zu VM umständlich ist.
Das Gerät "Bus des virtuellen Computers" steht nach wie vor mit Ausrufungszeichen im Gerätemanager.
Jetzt kann ich aber wenigstens die Replikation der beiden DCs wieder in Gang bringen.
Bitte warten ..
Mitglied: goscho
05.09.2013, aktualisiert um 14:31 Uhr
Ich glaube, ich stelle den Beitrag mal auf gelöst.

Ich habe das ganz noch zwimal durchgeführt, einmal virtuell und einmal auf Blech.
Beide Male hat es funktioniert. Der Unterscheid waren ein paar Windows-Updates, die die Server mehr hatten als vorher.
Denke wohl, dass es daran gelegen hat.

BTW: Habe immer mit BESR gesichert und restored.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Netzwerk
gelöst VLAN-IDs in Hyper-V (Server 2008 R2) (3)

Frage von honeybee zum Thema Windows Netzwerk ...

Windows Server
gelöst NTP Server auf einem Windows Server 2008 R2 DC standardmäßig schon drauf? (11)

Frage von M.Marz zum Thema Windows Server ...

Windows Server
Windows Server 2008 R2 Aero-Design auf Remote Desktop geht nicht (3)

Frage von Motherboard33 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...