Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server nicht über Hostnamen erreichbar bei VPN-Verbindung

Frage Netzwerke

Mitglied: ischbindebaetmaen

ischbindebaetmaen (Level 1) - Jetzt verbinden

01.05.2012, aktualisiert 18.10.2012, 16659 Aufrufe, 26 Kommentare

Hallo Leude,

habe folgende Frage:

Habe in mein Büro eine VPN-Verbindung aufgebaut. Jetzt erreiche ich den Server aber nicht über den Hostenamen Server, sondern nur über IP-Adresse. Ping geht natürlich auch.

Warum funktioniert das nicht über den Hostnamen. TCP/IP und Netbios sind am Server aktiviert und für den VPN-Benutzer der im Router eingrichtet ist, wurde ebenfalls TCP/IP und Netbios aktiviert. Die VPN Einwahl erfolgt über PPTP/PPP Protokoll.

Kann mir jemand sagen, was da korrigiert werden muss, damit der Server auch über den Hostnamen gefunden wird und erreichbar ist.

Freu mich auf Euren Rat.

Greetz
De Baetmaen
26 Antworten
Mitglied: catachan
01.05.2012 um 17:20 Uhr
Hi

ich denke es handelt sich hier um ein DNS Problem. Schau mal mit ipconfig /all welchen DNS Server du bekommen hast.
Wenn du den richtigen (aus deinem Büro) bekommen hast, dann kannst du die Funktion mittels nslookup in der Kommandozeile testen

LG
Bitte warten ..
Mitglied: ischbindebaetmaen
01.05.2012 um 17:34 Uhr
ja, habe ich gerade probiert. Habe tatsächlich den falschen DNS Server bekommen, nämlich den Router.

Wie korrigiere ich das? Zur Info. Der VPN Benutzer ist nur auf dem Router eingerichtet, nicht als Windows VPN-Wizard am Server. der Server hat als 1. DNS den Router und als zweiten DNS sich selbst eingetragen...
Bitte warten ..
Mitglied: transocean
01.05.2012 um 17:37 Uhr
Moin,

das Problem habe ich gerade Dank eines sehr kompetenten Users hier gelöst.

Du must auf dem Server in den DNS Einstellungen eine Weiterleitung auf den Router einstellen.

Gruß

Uwe
Bitte warten ..
Mitglied: ischbindebaetmaen
01.05.2012 um 17:51 Uhr
alles klar, hört sich gut an. Bist Du so nett und sagst mir gleich mit, wie genau du das gemacht hast? Ist mein erster Server

Kann ich leider erst morgen machen, da der Server gerade bei der Verbindungsassistenten abgestürzt ist und ich nicht merh per Remote druff komm...
Bitte warten ..
Mitglied: transocean
01.05.2012 um 18:02 Uhr
Da Du leider nicht schreibst welches Server OS Du verwendest, hier der Weg für 2008 R2:

Start---Verwaltung---DNS--rechte Maustaste und als Administrator ausführen---auf den Servernamen mit rechter Maustaste---Eigenschaften---Weiterleitungen.

Gruß

Uwe
Bitte warten ..
Mitglied: ischbindebaetmaen
01.05.2012 um 18:06 Uhr
klingt schaffbar Das Server OS ist Windows 2003 R2 Standart
Bitte warten ..
Mitglied: transocean
01.05.2012 um 18:11 Uhr
Das Server OS ist Windows 2003 R2 Standart

Sollte in der groben Richtung ähnlich sein.

Viel Glück.

Uwe
Bitte warten ..
Mitglied: ischbindebaetmaen
01.05.2012 um 18:13 Uhr
na dann herzlichen Dank soweit, ich sach morgen Bescheid ob es funktioniert hat.
Bitte warten ..
Mitglied: Pjordorf
02.05.2012 um 16:57 Uhr
Hallo,

Zitat von ischbindebaetmaen:
Habe tatsächlich den falschen DNS Server bekommen, nämlich den Router.
OK.

Wie korrigiere ich das? Der VPN Benutzer ist nur auf dem Router eingerichtet, nicht als Windows VPN-Wizard am Server.
In deinem uns unbekannten Router dafür sorgen das dieser bei Ausgabe der IP für die VPN Sitzung auch den korrekten DNS mitgibt. Das wäre ja dann bei dir die IP von deinem Server 2003 wo ja dein DNS drauf läuft.

der Server hat als 1. DNS den Router und als zweiten DNS sich selbst eingetragen...
Auch das ist falsch. Der Server (DC ?) hat immer sich selbst als ersten DNS eingetragen mit seiner eigene IP (nicht localhost oder 127.0.0.1). Eine zweiten DNS braucht es nur wenn dieser DNS nicht läuft (da es der Server ist, wenn der nicht läuft hast du ehj andere Probleme) und du aber einen DNS abfragen musst. Hier macht der Zweite DNS Eintrag auch keinen Sinn, da dein uns unbekannter Router bestimmt nicht die namen deines Netzes auflöst (sonst hättest du ja auch nicht das problem bei der VPN verbindung). Dann im DNS selbst den Router als Weiterleitung eintragen. So wirds gemacht. Hast du noch einen weiteren DNS am laufen , dann kann dieser als zweiter DNS in den Netzwerkeinstellungen des Servers eingetragen werden (setzt mindestens 2 getrennte DNS (Server) plus Router vorraus).

Gruß,
Peter
Bitte warten ..
Mitglied: ischbindebaetmaen
02.05.2012 um 19:46 Uhr
Also, der Euch unbekannte Router wäre ein Lancom.

Ich habe heute, wie mir geraten wurde, die DNS-Einträge wie Verwaltung-DNS usw. auf den Router weitergeleitet.

Bei Windows 2003 Server bin ich wie folgt vorgegangen:

- Verwaltung
- DNS
- Server
- Eigenschaften
- Weiterleitungen- alle anderen Domänen
- hier dann die Router-Ip eingetragen

ich bekomme bei Einwahl jetzt aber immer noch den falschen DNS zugewiesen, habe allerdings den Server noch nicht neugestartet.

Habe jetzt noch in den TCP-eigenschfaten des Servers die Server-IP als ersten DNS-server eingetragen und werde den Server gleich mal neustarten.

Dann sollten das doch funktionieren oder?
Bitte warten ..
Mitglied: Pjordorf
02.05.2012 um 20:02 Uhr
Hallo,

Zitat von ischbindebaetmaen:
Also, der Euch unbekannte Router wäre ein Lancom.
Und Lancom hat auch nur ein einziges Modell

ich bekomme bei Einwahl jetzt aber immer noch den falschen DNS zugewiesen
Klar. Dein Lancom ist der VPN Server / Endpunckt. Dieser vergibt per DHCP dir die IP und alle anderen Einstellungen. Du musst also dein Lancom dazu bringen die IP deines Server wo dein DNS läuft als DNS bei der VPN Verbindung an den VPN Client auszugeben.

habe allerdings den Server noch nicht neugestartet.
Ist für Änderungen am DNS nicht nötig. Und hilft dir bei der Vergabe der VPN Einstellung von deinem Router aus auch nicht.

Habe jetzt noch in den TCP-eigenschfaten des Servers die Server-IP als ersten DNS-server eingetragen und werde den Server gleich mal neustarten.
Auch das ist hierbei nicht nötig. Mach mal ein IPConfig /all und du wirst sehen das dein Server die neuen Einstellungen schon hat.

Dann sollten das doch funktionieren oder?
Wie gesagt, dein VPN Server (Lancom) musst du es (auch) richtig beibringen.

Gruß,
Peter
Bitte warten ..
Mitglied: ischbindebaetmaen
02.05.2012 um 20:22 Uhr
ja, ja ich versteh schon, mach endlich konkrte Angaben über den Router . also es ist ein LANCOM 1781AW.

Also war der Schritt DNS -Weiterleiten falsch? Wie macht man das dann?
Bitte warten ..
Mitglied: Pjordorf
02.05.2012 um 20:32 Uhr
Hallo,

Zitat von ischbindebaetmaen:
ja, ja ich versteh schon, mach endlich konkrte Angaben über den Router
Na also. geht doch

es ist ein LANCOM 1781AW.
OK,

Also war der Schritt DNS -Weiterleiten falsch?
Nein, das war vollkommen richtig.

Wie macht man das dann?
Was kannst du im Setup (GUI / CLI) im Lancom für das VPN alles Einstellen? (Ich habe keinen Lancom) Aber vielleicht hilft dir dies hier weiter http://www2.lancom.de/kb.nsf/0/1f3a4eb3ce2b90aac1256eee0029e2f8?OpenDoc ... Dort mal im Erster DNS die IP von deinem DNS Server eintragen?

Gruß,
Peter
Bitte warten ..
Mitglied: ischbindebaetmaen
02.05.2012 um 21:09 Uhr
also, interessant, hab jetzt in den TCP/IP-Einstellungen des Routers die DNS Einstellungen hinterlegt, neu eingewählt.

Jetzt bekomme ich zwar den richtigen DNS-Server zugewiesen, kann den Server aber noch immer nicht über den Hostnamen erreichen...

Kann es sein, dass der WINS-Server auch der Server sein muss. Da habe ich nämlich die IP Vom router zugewiesen bekommen?

ipconfig /all siehts so aus:

IP-Adresse: 192.168.1.130
DNS-Server: 192.168.1.60 (Server)
WINS-Server: 192.168.1.1 (Router)
Bitte warten ..
Mitglied: aqui
03.05.2012 um 12:01 Uhr
WINS gibt es gar nicht mehr, das ist Steinzeit. Sofern du das aber noch betreiben solltest dann muss logischerweise der DNS Server auch der WINs Server sein.
Ein Router versteht gar kein WINS Protokoll, das ist also ziemlicher Blödsinn wenn dort die Router IP steht !!
Kommt man eigentlich auch von selber drauf wenn man mal bedenkt das ein Router nur IP Adressen kennt um Pakete von A nach B zu schicken ihm aber NetBios DNS Funktionen herzlich egal sind !
Bitte warten ..
Mitglied: Pjordorf
03.05.2012 um 15:35 Uhr
Hallo,

Zitat von ischbindebaetmaen:
Jetzt bekomme ich zwar den richtigen DNS-Server zugewiesen, kann den Server aber noch immer nicht über den Hostnamen erreichen...
Da stellt sich doch die Frage nach welchen Name soll denn aufgelöst werden?
Client mit VPN verbinden
DNS cache am Client löschen
ping name
ping name.domäne.deineendung
ping name.workgroup
ping ip
dann mal im DNS cache geschaut was dort steht
Und wenn du es genauer haben willst, lass mal den MS Netzwerkmonitor oder Wireshark mitlaufen und schau nach an wen die DNS Anfragen gehen und was zurückkommt.

Kann es sein, dass der WINS-Server auch der Server sein muss
Wenn du keinen WINS am laufen hast und auch sonst keinen brauchst, nein. Ausserdem ist wie aqui schon schrieb WINS nicht routing fähig. Und wenn es nicht anders geht, lass dir von Lancom mal deine VPN Konfiguration auf korrektheit prüfen (Kostet). Du kannst diese aber auch hier reinstellen denn auch hier gibt es exzellente Lancom kenner.

Gruß,
Peter
Bitte warten ..
Mitglied: ischbindebaetmaen
03.05.2012 um 16:08 Uhr
na ja, das ist ziemlich einfach erklärt. Ich bin exact nach dieser Anleitung vorgegangen:

http://www2.lancom.de/kb.nsf/1275/6BD3FBFF671A9013C125743A0040A83E?Open ...

und habe dann noch den DNS-Server auf den Router weitergeleitet.


Vielleicht sollte ich einen Post aufmachen, speziell an alle Lancom-Kenner...
Bitte warten ..
Mitglied: aqui
03.05.2012 um 19:19 Uhr
wenn du bei aktiver VPN Verbindung mal ein ipconfig -all bzw. nslookup machst WAS bekommst du denn für eine DNS Server IP am Client ???
Bitte warten ..
Mitglied: ischbindebaetmaen
03.05.2012 um 19:54 Uhr
bei nslookup bekomme ich:

Standardserver: server.intern
Adress: 192.168.1.60 (ist der Server/DNS-Server)

bei ipconfig /all:

ip-Adresse: 192.168.1.134 (bevorzugt)
Subnetzmaske: 255.255.255.255
Standartgateway 0.0.0.0
DNS Server: 192.168.1.60 (Server)
Netbios über TCP/IP aktiviert

wenn ich jetzt aber in der Eingabeauforderung

\\Server eingebe bei Windowss 7 kann man ja nicht merh über Netzerkumgebung Computer suchen, kommt die Meldung:

\\Server auf Server konnte nicht zugegriffen werden.

Bei Windows XP und Computer suchen: Server kommt einfach nur kein Suchergebniss...

Versteh ich also nicht, da ja anscheinend der DNS jetzt korrekt zugewiesen wird...
Bitte warten ..
Mitglied: aqui
06.05.2012, aktualisiert 18.10.2012
Beziehen sich die o.a. Angaben auch wirklich auf das VPN Interface ?? Oder hast du hier einfach nur die LAN IPs gepostet ??
Wenn ja und es das VPN Interface ist, kannst du dann den Server bzw. DNS 192.168.1.60 anpingen bei aktiver VPN Verbindung ??
Nochwas wichtiges solltest du unbedingt lesen:
http://www.administrator.de/wissen/vpns-einrichten-mit-pptp-117700.html ...
Bei deiner Verwendung auch dieser Banal IP Adresse lässt das die Befürchtung aufkommen das da ggf. auch ein Problem lauert...??!
Bitte warten ..
Mitglied: wescraven07
06.05.2012 um 16:00 Uhr
die Angaben beziehen sich definitiv auf das vpn interface. ich kann den server anpingen und auch auch die laufwerke zugreifen mit

Eingabe \\192.168.1.60

Ich kann auch arbeiten, aber eben NUR unter Verwendung der IP-Adresse des Servers. Wenn ich den Hostenamen "Server" anpinge funktioniert nicht mit Befehl \\Server bekomme ich Fehlermeldung und wenn ich mit Windows XP Computer "server" suche, bekomme ich kein Suchergebniss.
Bitte warten ..
Mitglied: Pjordorf
06.05.2012 um 21:17 Uhr
Hallo,
Äh ?!?
Zitat von wescraven07:
Du bist auch ischbindebaetmaen oder wie kommt es das du so antwortest?!? Etwas irritiert.

die Angaben beziehen sich definitiv auf das vpn interface. ich kann den server anpingen und auch auch die laufwerke zugreifen mit
Ein IPConfig /all mal hier reinstellen klärt das sofort, und auch welche Domäne dein Client angehört. Und dann bitte ein IPConfiag /all vom Server. Dann sehen wir welche Domänen etc.

Eingabe \\192.168.1.60
Klar, über die IP.

Wenn ich den Hostenamen "Server"
Da wir dich schon gebeten hatte mal die Ergebnisse diese Ping an xxxx uns mitzuteilen, können wir hier nur fröhlich weiter raten udn unsere Glasmurmeln bemühen. Deine Server hört doch sicherlich nicht nur auf den Namen Server. Komm schon, du verheimlichst etwas

nslookup server liefert was?
nslookup server.deine.domäne.wasweisich liefert? (Nein, nicht von deiner Domäne im Internet.

Lies mal unsere Antworten und beantworte mal unsere Fragen. Dann hättest du das schon letzte Woche am laufen gehabt

Gruß,
Peter
Bitte warten ..
Mitglied: ischbindebaetmaen
06.05.2012 um 22:14 Uhr
Ja, hatte mal vor ner Weile nen anderen Account eingerichtet, lange geschichte. sorry jetzt wieder mit richtigem Account .

Also @ Pjordorf, Eure fragen hatte ich zwei Posts über Deinem beantwortet, siehe:


bei nslookup bekomme ich:

Standardserver: server.intern
Adress: 192.168.1.60 (ist der Server/DNS-Server)

bei ipconfig /all:

ip-Adresse: 192.168.1.134 (bevorzugt)
Subnetzmaske: 255.255.255.255
Standartgateway 0.0.0.0
DNS Server: 192.168.1.60 (Server)
Netbios über TCP/IP aktiviert
Bitte warten ..
Mitglied: Pjordorf
07.05.2012 um 03:35 Uhr
Hallo,

Zitat von ischbindebaetmaen:
Also @ Pjordorf, Eure fragen hatte ich zwei Posts über Deinem beantwortet, siehe:
Sorry, teils überlesen.

> Standardserver: server.intern
OK. Dann sag uns doch was ein ping server.intern liefert und was liefert die Eingabe von \\server.intern bei Win 7 und bei XP? Der Name Server ist wohl nicht in deinem DNS eingetargen, WINS hast du wohl keinen wo evtl. der Netbios Name server aufgelöst werden würde.... Mach es uns mit deinem Problem doch nicht so schwer. Wir sind keine Nasenpuhler

> bei ipconfig /all:
Du hast doch nicht nur die eine Schnittstelle, nämlich die VPN. Da ist noch mehr.

Gruß,
Peter
Bitte warten ..
Mitglied: wescraven07
12.05.2012 um 10:29 Uhr
also:

der ping server.intern. liefert mir die ip des (DNS) Servers 192.168.1.60

Eingabe "\\server.intern" öffnet mir die freigegebenen Serververzeichnisse, so wie es eigentlich bei der Eingabe "\\Server" sein sollte. Bei Eingabe "\\server" erhlate ich nach wie vor die fehlemeldung...
Bitte warten ..
Mitglied: Pjordorf
12.05.2012 um 11:35 Uhr
Hallo,

Zitat von wescraven07:
Schon wieder falsches Konto?

der ping server.intern. liefert mir die ip des (DNS) Servers 192.168.1.60
OK.

Eingabe "\\server.intern" öffnet mir die freigegebenen Serververzeichnisse,
OK.

Bei Eingabe "\\server" erhlate ich nach wie vor die fehlemeldung...
Nein, keine Fehlermeldung. Das ist wohl so zu 100% korrekt. Warum? Weil dieser Name "Server" nirgends bei dir aufgelöst wird (DNS, WINS, NETBIOS usw.). Und bitte, falls du wirklich Hilfe von uns willst, dann beantworte unsere Fragen bitte endlich wenigstens einmal vollständig. (Die Meldung das ein Name nicht aufgelöst werden kann ist kein Fehler).

1. IPConfiag /all von deinem Server hier vollständig reinstellen
2. IPConfig /all von deinem Client hire vollständig reinstellen
3. Läuft ein DNS? Wenn ja welcher?
4. Läuft ein WINS? Wenn ja, wo?
5. Welche Optionen vergibt dein Lancom zusammen mit der Vergabe der VPN IP?
6. Was steht in der Client HOSTS Datei?
7. Was steht in der Client LMHOSTS Datei?
8. Darf die Firewall auf deinen Server Anfragen vom VPN Netz durchlassen?
9. Dein DNS hat als weiterleitung deinen Lancom eingetragen oder auch noch andere?
10. Welche Namen werden in deinem DNS aufgelöst?
11. Falls WINS, welche Namen werrden dort aufgelöst?
12. Läuft ein DHCP auf dein Server?
Die Externe IP kannst du ja gerne verschleiern. Die sollte aber nicht mit deinen Netzen (mindestens 3) in Konflickt stehen (z.B. UMTS usw).

Gruß,
Peter
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Router & Routing
TP-Link Router VPN Verbindung Router Oberfläche nicht erreichbar (3)

Frage von D46505Pl zum Thema Router & Routing ...

Windows Server
Server 2012 R2 VPN steht, jedoch keine Verbindung zum Server! (7)

Frage von moinmoin2016 zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 - VPN Verbindung nach Update nicht mehr möglich (1)

Frage von ruNN0r zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...