Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server kann ins Internet. Die LAN-PCs nicht

Frage Netzwerke Router & Routing

Mitglied: Fred-HB

Fred-HB (Level 1) - Jetzt verbinden

08.12.2004, aktualisiert 13.12.2004, 11427 Aufrufe, 14 Kommentare

Hallo.

Ich habe einen Hardwarerouter Draytek Vigor 2200E an einen Win2003-Server gehängt. Der
Server soll für ein paar Domänen-PCs den Internetzugriff ermöglichen, und der Server soll
auch von Homearbeitsplätzen per VPN erreichbar sein.

Die Komponenten:
Der Server hat 2 Netzwerkkarten. Die LAN-seitige ist mit einem Switch verbunden. An dem
Switch hängen auch die LAN-PCs. Die WAN-seitige Netzkarte geht zum Hardwarerouter. Die
beiden NICs im Server sind in 2 Netzen. Routing und RAS ist eingerichtet. Mit dem Server
komme ich auch ins Internet. Aber die LAN-PCs haben keinen Zugang zum Internet.

Vom Server aus kann ich den Hardware-Pouter anpingen. Von den LAN-PCs nicht. Die LAN-PCs haben auch keine Route zum Hardware-Router. Der DHCP-Server hat den LAN-PCs den Router als Standard-Gateway mitgeteilt und die IP des Servers als DNS-Server. In DNS ist eine
Weiterleitung auf die IP des Routers eingetragen.

Ich schätze, dass ich in Routing und RAS noch etwas einstellen muss. Aber wo? Hat jemand
noch einen Tipp, an welcher Schraube ich drehen muss?

Im voraus schon einmal vielen Dank für die Hilfe!
Fred
Mitglied: 6035
08.12.2004 um 10:26 Uhr
versuchs mal mit 'tracert', dann siehst du wo es hakt und welche Route du noch eventuell anhängen musst
Bitte warten ..
Mitglied: 7217
08.12.2004 um 10:27 Uhr
Das Problem ist, dass du dem Router auch sagen musst, wie er den Weg zurück zu deinen Clients findet. In der Regel ist es so, dass die meisten Router irgendwo ein Menü haben, wo man einstellen kann, dass an der LAN-Schnittstelle noch weitere Netze mit der und der Netzmaske und so weiter sitzen... Musst du mal die Doku und das Gerät an sich genauer unter die Lupe nehmen.

Gruß, Mupfel
Bitte warten ..
Mitglied: 6035
08.12.2004 um 10:29 Uhr
vergessen: wenn es mit dem Befehl Tracert beim Switch endet, musst du ihn Konfigurieren, beim Server musst du routing/ras einstellen und wenns beim Router hakt musst du die eventuell vorhandene Firewall konfigurieren
Bitte warten ..
Mitglied: Herbert
08.12.2004 um 11:23 Uhr
Hallo Fred,

da schießt Du Dich doch selbst ins Bein.

Du hast einen Server mit zwei Netzwerkkarten und zwei durch diesen Server getrennte Netze.

Das eine ist das WAN-Netz, das andere ist das nomale LAN.
Wenn der Server ins Internet kann, ist offensichtlich auf der WAN-Seite alles ok.

Deine Clients im LAN wissen aber nichts von diesem Teilnetz, weil der Server nicht in dieses Netz routet.

Du kannst jetzt entweder den Server zum Router machen oder die Clients mit ins WAN-Netz hängen (bzw. den Draytek mit geänderter IP-Adresse gleich in dieses Netz hängen).

Da der Draytek-Router eine gute Firewall hat, sehe ich da auch kein Problem.
Außerdem entlastet es den Server vom Routing-Traffic.

Die zweite Netzwerkkarte im Server ist dann allerdings überflüssig.

Ich hoffe, das hilft.

Herbert
Bitte warten ..
Mitglied: Fred-HB
08.12.2004 um 20:16 Uhr
Schönen Dank für die schnellen Antworten.

TraceRoute ist eigentlich keine schlechte Idee, hier ist aber im Prinzip klar, wo es hakt; -
nämlich höchstwahrscheinlich beim Routing im Server. Auf der LAN-Seite arbeiten die PCs
prima mit dem Server zusammen und der Switch macht dabei auch keine Probleme. Auf der
WAN-Seite klappt der Internetzugriff im Server auch gut. Aber eben nur im Server. Der Server
will partout nich routen.

Auf dem Server ist der Routing und RAS-Dienst installiert, und wie das grüne Symbol anzeigt,
scheint er auch zu arbeiten. In der Routing und RAS-Konsole kann ich auch die beiden Server-NICs sehen. Was muss man denn nun noch machen, damit zwischen den beiden Netzen auch
geroutet wird? Oder muß man doch händisch Routen eintragen?

Schöne Grüße
Fred
Bitte warten ..
Mitglied: 7217
09.12.2004 um 09:13 Uhr
Auf dem Server ist der Routing und
RAS-Dienst installiert, und wie das
grüne Symbol anzeigt,
scheint er auch zu arbeiten. In der Routing
und RAS-Konsole kann ich auch die beiden
Server-NICs sehen. Was muss man denn nun
noch machen, damit zwischen den beiden
Netzen auch
geroutet wird? Oder muß man doch
händisch Routen eintragen?

Ich wiederhole mich nur ungerne:

du musst dem ROUTER (also nicht dem Server, sondern deinem DSL-Router) sagen, wie er in dein 2. Subnetz kommt (sprich eine Rückroute in diesem Gerät eintragen).

Dein Windows-Server sieht ja schonmal gut aus. Du kannst ja mal testhalber statt des DSL-Routers eine normale Workstation mit der IP-Adresse des Routers hängen und dort mal als Defaultroute den Server eintragen und einen Ping ins andere Subnet machen. Das sollte nämlich funktionieren dann.

Was dem Router fehlt, ist das Wissen, wie er halt in dein 2. Subnet kommt.

Er bekommt zwar höchstwahrscheinlich die Pakete vom Server zugeliefert, findet aber selbständig nicht den Weg zurück.

Gruß, Mupfel
Bitte warten ..
Mitglied: Fred-HB
09.12.2004 um 10:12 Uhr
Okay, jetzt habe ich verstanden, was Du meinst ;) Leider komme ich heute nicht mehr dazu, aber morgen teste ich gleich mal, ob der DSL-Router tatsächlich nicht den Rückweg zu den LAN-PCs kennt. Ich glaube der Draytek Router kennt in seinen Config-Menüs so etwas wie RIP-Datenaustausch. Schauen wir mal, ob ich bisher auf der falschen Baustelle zugange war. Ich melde mich auf jeden Fall wieder, wenn ich getestet habe.
Bis dahin erst einmal schönen Dank und schöne Grüße
Fred
Bitte warten ..
Mitglied: Fred-HB
10.12.2004 um 20:38 Uhr
Hallo Admins

Mein Problem, dass zwar der Server, nicht aber die LAN-PCs ins Internet können habe ich leider noch nicht lösen können. Ich habe noch nicht testen können, ob der Router nicht den Weg zurück zu den LAN-PCs kennt. Aber zumindest die Routen habe ich mir schon einmal ausdrucken lassen.

LAN-seitiger NIC im Server - 192.168.168.1/24
WAN-seitiger NIC im Server - 192.168.169.1/24
Draytec Router - 192.168.169.2/24

Routen des Server
IPv4-Routentabelle
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x2 ...00 0d 61 76 8a 32 ...... Intel(R) PRO/100 VE Network Connection - Paketplaner-Miniport
0x3 ...00 02 b3 45 d3 27 ...... Intel(R) PRO/100 S-Desktopadapter - Paketplaner-Miniport
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Metrik
0.0.0.0 0.0.0.0 192.168.169.2 192.168.169.1 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.168.0 255.255.255.0 192.168.168.1 192.168.168.1 20
192.168.168.1 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.168.255 255.255.255.255 192.168.168.1 192.168.168.1 20
192.168.169.0 255.255.255.0 192.168.169.1 192.168.169.1 20
192.168.169.1 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.169.255 255.255.255.255 192.168.169.1 192.168.169.1 20
224.0.0.0 240.0.0.0 192.168.168.1 192.168.168.1 20
224.0.0.0 240.0.0.0 192.168.169.1 192.168.169.1 20
255.255.255.255 255.255.255.255 192.168.168.1 192.168.168.1 1
255.255.255.255 255.255.255.255 192.168.169.1 192.168.169.1 1
Standardgateway: 192.168.169.2
St?ndige Routen:
Keine



Routen der LAN-PCs
Schnittstellenliste
0x1 ........................... MS TCP Loopback interface
0x10003 ...00 00 39 6b b4 2b ...... Intel 8255x-basierter PCI-Ethernetadapter (10/100) - Paketplaner-Miniport
Aktive Routen:
Netzwerkziel Netzwerkmaske Gateway Schnittstelle Anzahl
0.0.0.0 0.0.0.0 192.168.169.2 192.168.168.20 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.168.0 255.255.255.0 192.168.168.20 192.168.168.20 20
192.168.168.20 255.255.255.255 127.0.0.1 127.0.0.1 20
192.168.168.255 255.255.255.255 192.168.168.20 192.168.168.20 20
224.0.0.0 240.0.0.0 192.168.168.20 192.168.168.20 20
255.255.255.255 255.255.255.255 192.168.168.20 192.168.168.20 1
Standardgateway: 192.168.169.2
St?ndige Routen:
Keine

Vielleicht hat ja jemand einen Tipp.
Zunächst einmal schönen Dank
Fred
Bitte warten ..
Mitglied: 7217
10.12.2004 um 21:46 Uhr
Du hast, wie es scheint, bei den PCs als Default-GW den WLAN-Router angegeben und nicht deinen Windows2000-Server. Da der Server jedoch für die Clients als Default-Router fungiert, musst du diesen eintragen.

Wichtig ist auch, dass du auf dem WLAN-Router die Rückroute auf das Netz der Clients einträgst! (Darauf wies ich schon mehrfach hin).

Gruß, Mupfel
Bitte warten ..
Mitglied: 7217
10.12.2004 um 21:50 Uhr
Um das ganze nochmal deutlicher zu machen:

das Standardgateway ist IMMER ein Knoten im EIGENEN Netz, der als Schnittstelle zu einem Fremdnetz dient.

Deine Clients haben als Schnittstelle in ein Fremdnetz den Server, also muss der auch Defaultgateway sein.

Der Server an sich sieht soweit sauber konfiguriert aus, da er unterscheiden kann, wohin er welche Pakete schicken soll und wenn er nicht selbst weiss, wohin damit, fragt er den Router (der dann idR. ja weiss, dass es ab ins Internet soll).

Der Router muss jetzt jedoch eine statische Route zu 192.168.168.0/24 verbrutzelt bekommen und zwar mit dem Gateway 192.168.168.1 (dein Windowsserver), weil der ja die beiden Netze, das Lan 192.168.168.0/24 und dein "Brückennetz" 192.168.169.0/24 verbindet.

Ich hoffe, ich habe das jetzt deutlich erklärt, wenn nicht, frag einfach nochmal nach und sage mir, was du nicht verstanden hast ich werde so gut es geht helfen

Gruß, Mupfel
Bitte warten ..
Mitglied: Fred-HB
11.12.2004 um 16:25 Uhr
Hallo Mupfel

Mittlerweile bin ich einen Schritt weiter, aber noch nicht am Ziel. Jetzt kann ich von den LAN-PCs den DSL-Router anpingen und ich kann von den LAN-PCs aus mit dem Internet-Browser in
das Konfigurationsmenü des DSL-Routers. Nslookup vom LAN-PC aus ins Internet geht auch und gibt korrekte Namen und IPs zurück. Traceroot von den LAN-PCs aus zeigt genau wie erwartet 2 Hops bis zum DSL-Router. Nur ins Internet komme ich nach wie vor nicht.

Folgendes habe ich gemacht:
Zunächst einmal lasse ich jetzt vom DHCP-Server das richtige Gateway verteilen. Schönen Dank für den wichtigen Tipp!
Dann habe ich im DSL-Router eine statische Route in das LAN angegeben.
Der dedizierte LAN-seitige NIC des Servers hat kein Standardgateway mehr.
Der dedizierte WAN-seitige NIC des Servers hat als Standardgateway die IP des DSL-Routers
und als DNS-Server einen Nameserver der Telekom (194.25.2.129).
Testweise habe ich auch einmal eine zweite Reverse Lookupzone in das Brückennetz eingerichtet.

Wie gesagt, komme ich von den LAN-PC in das Konfig-Menü des DSL-Routers. Anpingen geht,
Nslookup geht, Tracert gibt die erwarteten Werte, nur die bunten Bilder aus dem Internet sind an den LAN-PCs noch nicht zu sehen. Hast Du einen Tipp wo jetzt die richtige Baustelle
sein könnte? - DNS? Routing und RAS? Der DSL-Router?

Schöne Grüße
Fred
Bitte warten ..
Mitglied: 7217
11.12.2004 um 19:05 Uhr
Folgendes habe ich gemacht:
Zunächst einmal lasse ich jetzt vom
DHCP-Server das richtige Gateway verteilen.

Fein, so stell ich mir das auch vor.
Schönen Dank für den wichtigen
Tipp!

Bitteschön, gerne geschehen - ist ja nicht so, als hätte ich Ahnung von dem, was ich erzähle *lach*

Dann habe ich im DSL-Router eine statische
Route in das LAN angegeben.

Fein

Der dedizierte LAN-seitige NIC des Servers
hat kein Standardgateway mehr.
Der dedizierte WAN-seitige NIC des Servers
hat als Standardgateway die IP des
DSL-Routers

so siehts gut aus.

und als DNS-Server einen Nameserver der
Telekom (194.25.2.129).

Ah, fein.

Testweise habe ich auch einmal eine zweite
Reverse Lookupzone in das Brückennetz
eingerichtet.

Wie gesagt, komme ich von den LAN-PC in das
Konfig-Menü des DSL-Routers. Anpingen
geht,
Nslookup geht, Tracert gibt die erwarteten
Werte, nur die bunten Bilder aus dem
Internet sind an den LAN-PCs noch nicht zu
sehen. Hast Du einen Tipp wo jetzt die
richtige Baustelle
sein könnte? - DNS? Routing und RAS?
Der DSL-Router?

Ping auf eine IP-Adresse ausserhalb deines Netzes (also ins Internet) funktioniert oder funktioniert nicht?

Der Server an sich routet ja fantastisch, daran kanns ja jetzt nicht liegen. Wenn deine Clients zum DSL-Router kommen, ist der WINDOWS-Router soweit durch.

Du könntest mal ein Tracert auf eine IP-Adresse im Internet versuchen und mal schauen, wo der Trace abbricht.

Kommt er durch, vermute ich noch als Quelle des Übels irgendwie eine Fehlkonfiguration im Browser.

Gruß, Mupfel
Bitte warten ..
Mitglied: Fred-HB
13.12.2004 um 10:05 Uhr
Es ist vollbracht! Die LAN-PCs kommen ins Internet.
Und was war die letzte Hürde?
Ein zusätzlich gesetztes Häkchen im Router Konfigurationsmenü. In Draytek Routern kann man das Routing ins LAN in zwei unterschiedlichen Menüpunkten beeinflussen. Einmal im Menüpunkt Ethernet. Dort kann man ein zweites Netz angeben und zusätzlich RIP einschalten. Zum Anderen kann man im Menüpunkt Static Route eine statische Route eingeben. Zuletzt waren beim Herumexperimentieren beide Menüpunkte aktiv. Das Ausschalten des Routing im Menüpunkt Ethernet hat den Erfolg gebracht. Alles läuft richtig schnell und zuverlässig. Eigentlich habe ich nach diesem Akt ein wenig Angst als nächsten Punkt nun VPN anzugehen. Aber wie sagt man hier in Norddeutschland: Wat mut dat mut!
Besten Dank für Eure Hilfe. Besonders bei Mupfel. Wahrscheinlich brauche ich dann für VPN noch einmal Hilfe. Dann mache ich auf jeden Fall hier bei Euch einen Thread auf.
Bitte warten ..
Mitglied: 7217
13.12.2004 um 15:10 Uhr
Das ist doch mal ein Feedback, wie man es sich wünscht Danke für die Lösung, ich hoffe, die Nachwelt wird diesen Thread zu würdigen wissen

Gruß, Mupfel
Bitte warten ..
Neuester Wissensbeitrag
Batch & Shell

Batch Script Editor - Programmvorstellung des Entwicklers

(7)

Tipp von wowItsDoge zum Thema Batch & Shell ...

Ähnliche Inhalte
Microsoft
Server 2012 Wake on Lan Pakete an alle Geräte im DHCP Lease senden (1)

Frage von thomasreischer zum Thema Microsoft ...

Windows Server
gelöst Windows Server 2012R2 mit 2 Nics - Clients bekommen keine Internet Verbindung (15)

Frage von GoForIt zum Thema Windows Server ...

Webbrowser
Internet Explorer für Terminal Server einschränken (4)

Frage von FlashOver zum Thema Webbrowser ...

Router & Routing
gelöst OpenVPN Server - Kein Zugriff auf Server LAN (2)

Frage von PeterH96 zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Batch & Shell
gelöst PowerShell Transpose Objects und Memoryleak (11)

Frage von agowa338 zum Thema Batch & Shell ...

Windows Server
Anmeldung an neuen Windows Domäne Client nicht möglich (11)

Frage von FlorianN zum Thema Windows Server ...

Exchange Server
MX Eintrag für Exchange-Server , habe aber nur feste IP (9)

Frage von Mausbiber zum Thema Exchange Server ...

Netzwerkprotokolle
Kurze Frage: AnyConnect woher beziehen? (8)

Frage von PharIT zum Thema Netzwerkprotokolle ...