Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Server im Netzwerk abfragen

Frage Netzwerke

Mitglied: bjoern.schrammen

bjoern.schrammen (Level 1) - Jetzt verbinden

13.04.2011 um 12:44 Uhr, 3482 Aufrufe, 7 Kommentare

Hallo,

ich würde gerne Server im Netzwerk per Batch abfragen.
Net view ist mir bekannt aber dort bekomme ich immer eine Auflistung aller im Netzwerk vorhanden Systeme (Server + Workstations). Ich hätte aber gerne eine Liste mit nur bestimmten Servern.
Bei uns ist es so das alle Workstations mit "W-" und alle Server mit "S-" anfangen. Gibt es die Mölichkeit dies bei Net View anzugeben so das ich auch wirklich nur eine Liste mit Servern hab?

Für Hilfe bin ich sehr dankbar!

Mit freundlichen Grüßen Bjoern.Schrammen
Mitglied: bastla
13.04.2011 um 12:55 Uhr
Hallo bjoern.schrammen!

Etwa so:
net view|findstr /i "S-"
Grüße
bastla
Bitte warten ..
Mitglied: 99045
13.04.2011 um 12:56 Uhr
Hi,

versuche es so in der Konsole:
for /f %a in ('net view ^|find "\\S-"') do @echo %a
Gruß


Edit: x mal geändert und immer noch falsch. Ein Hoch auf den Programmierer der Forensoftware.
Bitte warten ..
Mitglied: bastla
13.04.2011 um 13:05 Uhr
@99045
Wenn schon Schleife, dann aber vielleicht besser (wenn es wirklich eine Liste der Workstations werden soll):
for /f "delims=\ " %a in ('net view ^|find "\\W-"') do @echo %a
Grüße
bastla
Bitte warten ..
Mitglied: bjoern.schrammen
13.04.2011 um 13:17 Uhr
Zitat von bastla:
@99045
Wenn schon Schleife, dann aber vielleicht besser (wenn es wirklich eine Liste der Workstations werden soll):
for /f "delims=\ " %a in ('net view ^|find "\\W-"') do @echo %a 
> 
Grüße
bastla

Hallo Ihr zwei, vielen dank für eure Hilfe! Die Schleife funktioniert super.
mein Problem wäre damit auch schon gelöst :D

DANKE!
Bitte warten ..
Mitglied: 99045
13.04.2011 um 13:25 Uhr
@bastla
Wenn schon Schleife, dann aber vielleicht besser (wenn es wirklich eine Liste der Workstations werden soll):

Ich hasse diese kaputte und zusammengefrickelte Forensoftware wie die Pest.

Den Kommentar hatte ich geändert auf \\S-, weil er ja eigentlich die Server haben wollte Ohne 100maligem STRG-RELOAD kommt da jedes Mal ein anderes Ergebnis, und im Kommentarfenster stand vor dem Senden "\\S-"

Gruß


.
Bitte warten ..
Mitglied: Pjordorf
13.04.2011 um 13:58 Uhr
Hallo,

[OT]
Zitat von 99045:
Ich hasse diese kaputte und zusammengefrickelte Forensoftware wie die Pest.
Nun, liegt es nicht daran das du die richtigen Werte einträgst?

Dein Aufruf mit
<code test=plain>

liefert doch ganz was anderes als
<code type="plain">

oder irre ich mich hier. So schlecht finde ich die Forensoftware nun nicht.
[/OT]

Gruß,
Peter
Bitte warten ..
Mitglied: 99045
13.04.2011 um 14:05 Uhr
Nein, daran liegt nicht, denn den Fehler hatte ich selbst bereits bei der Änderung von "\\W-" zu "\\S-" bemerkt und geändert, aber jetzt beim Edit nicht mehr daran gedacht. Aber danke für den Hinweis.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Netzwerk
Client-Server-Netzwerk einrichten (5)

Frage von Elduderino zum Thema Windows Netzwerk ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...